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Overview: Guided Tour 
This tutorial contains four major examples to guide you through the operation of KaleidaGraph. We 
recommend that you try and complete all four at one sitting, however you can always come back and 
complete the examples at a later time. 
  
Example 1 - Generating a Sample Data Set 

Enter some data, change the column titles and data format, sort the data, and calculate simple 
statistics for the data. 
  

Example 2 - Creating a Scatter Plot 
Create and modify a Scatter plot of the data from the first example. This example shows how to 
change the display of the variable, use a few plot tools, and add a curve fit and error bars. 
  

Example 3 - Creating a Column Plot 
Create a Column plot from a saved data set. This example shows how to modify the axes, 
change the display of the axis labels, and add value labels above the columns. 
  

Example 4 - Laying out Plots for Printing 
Display the plots from the preceding examples on the same page using the layout window. 
  

A number of additional tutorials are also provided. Some of the topics include using Formula Entry, applying 
a General curve fit, and performing Student t-tests and ANOVA on data sets. 
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Example 1 - Generating a 
Sample Data Set 

This example takes you through the process of typing data into the data window, changing the column titles 
and data format, sorting the data, and calculating statistics on the raw data. This example is divided into the 
following topics: 

• Entering Data 

• Editing Column Titles 

• Changing Data Format 

• Sorting the Data 

• Calculating Statistics 

Entering Data 
The first step is to type some data into the data window. By default, the cell at row 0, column 0 is the active 
cell. 

1. Type 4.3 into this cell. 
2. Press the Return (Mac), Enter (Windows), or Down Arrow key to move down to the next 

cell. 
3. Type the values 2.9, 4.8, 3.2, 3.9, 3.5, and 2.3 into the first column. After each value is 

entered, press the Return (Mac), Enter (Windows), or Down Arrow key to move down a 
row. 

4. Click the cell in the first row of the second column (row 0, column 1). 
5. Use the same method to type the data values 8.0, 6.2, 9.0, 5.7, 8.8, 7.2, and 4.9 into this 

column. 

Editing Column Titles 
The next step will be to change the titles of the first two data columns. 

1. Double-click the column title of the first data column. The name of the current column (A) 
will be selected. 

2. Type Time for the new column title. 
3. Press Tab to edit the title of the second column. 
4. Type Test 1 for the new column title. 

Changing Data Format 
The following steps change the display of the data so that each value only has one decimal place. 

1. Select the first two columns in the data window (Time and Test 1). 
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2. Choose Data > Column Formatting or click  in the data window to display the Column 
Formatting palette. This palette can be used to change many of the attributes associated 
with the data window, such as font, color, font size, column width, and format of the data. 

3. In the Number Type and Formatting portion of the palette, choose Fixed from the Format 
pop-up menu. 

4. Set the Decimals to 1. 
5. Click Apply to update the selected columns. The data window should resemble the one 

below: 
  

 

Sorting the Data 
Now we will sort the data in the first column to get the values in ascending order (from low to high). 

1. If they are not already selected, select the first two columns in the data window (Time and 
Test 1). 

2. Choose Functions > Ascending Sort or click  in the data window to display the Sort 
dialog. 

3. Click OK to sort the data. The data in the second column will be arranged according to the 
rows in the first column. 

Calculating Statistics 
The final step is to calculate a number of standard statistics on one of the data columns. 

1. Click the Test 1 label in the data window to select the entire column. 

2. Choose Functions > Statistics or click  in the data window to display the statistics for 
the Test 1 data. The Statistics dialog provides a Copy to Clipboard button to export the 
results for use in a data, plot, or layout window. 

3. Click OK. 
  
At this point, you can proceed to the next example to create a plot from this data. 
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Example 2 - Creating a Scatter 
Plot 

This example uses the data from the preceding example to create a Scatter plot. This example shows how 
to change marker type and size, use the Identify and Data Selection tools, apply a Linear curve fit, display 
the curve fit equation, and add error bars. This example is divided into the following topics: 

• Creating a Scatter Plot 

• Changing Variable Settings 

• Using the Identify Tool 

• Applying a Linear Curve Fit 

• Exporting the Results of the Curve Fit 

• Using the Data Selection Tool 

• Adding Error Bars 

Creating a Scatter Plot 
Now, let’s create a plot using the example data entered in the previous exercise. 

1. Choose Gallery > Linear > Scatter. The Variable Selection dialog is displayed. Notice that 
the name of the data file and its column titles are displayed in this dialog. 

2. Select Time as the X variable and Test 1 as the Y variable by clicking the appropriate 
check boxes, as shown in the dialog below: 

  

 
  

3. Click Plot to create a Scatter plot. 
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Changing Variable Settings 
Now that the graph has been created, it can be modified very easily. For example, let's change how the data 
is represented on the plot. You will use the Variable Settings dialog to change the marker type and size. 

1. Triple-click the marker displayed in the legend (or choose Plot > Variable Settings). 
2. Select a different marker from the Marker pop-up menu to represent the variable on the 

plot. The first six markers in the left column are transparent; all of the others are opaque. 
3. Select 18 from the Marker Size pop-up menu. 
4. Click OK and the plot will be redrawn to reflect the changes that have been made. 

Using the Identify Tool 

Now we will use the Identify tool ( ) on the toolbox to display the coordinates of the data. 
1. Select the Identify tool by either clicking it or pressing I on your keyboard. 
2. Once the tool is selected, click one of the data points. The X and Y coordinates are 

displayed in the upper-left corner of the plot window. 
  
It is also possible to leave the coordinates directly on the plot. To do this: 

• Press Option (Mac) or Alt (Windows) as you release the mouse button. This places a label 
containing the coordinates to the right of the point. 

Applying a Linear Curve Fit 
You can quickly and easily fit a curve to a set of data points. To add a curve fit to the plot: 

1. Choose Curve Fit > Linear. This displays the Curve Fit Selections dialog to select which 
variables to fit with the Least Squares Error method. 

2. Select a variable to be fit (in this case Test 1) by clicking its check box. 
3. Click OK. The curve fit is calculated and the curve fit line is drawn on the plot. By default, 

the curve fit results will also be displayed on the plot. If the equation is not displayed, turn 
on Display Equation in the Plot menu. 

  
The position of the equation can be changed using the Selection Arrow. 

1. Click the Selection Arrow ( ) on the toolbox. 
2. Drag the equation to a new position. 
3. When the move is complete, click anywhere else in the window and the object handles 

disappear. 
4. You can use the same technique to move the legend. At this point, the plot should be 

similar to the one below: 
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Exporting the Results of the Curve Fit 
Once a curve fit is applied, you can copy the values of the curve fit line to the data window. These values 
are appended after the existing data in your data window. The first column will be a series of X values. The 
number of X values will be equal to the number of curve fit points specified in the Curve Fit Options dialog 
(Curve Fit menu). The second column will contain the values from the curve fit at each of these locations. 

1. Reselect Linear from the Curve Fit menu. The Curve Fit Selections dialog appears with a 
drop-down arrow under View. 

2. Click the drop-down arrow and choose Copy Curve Fit to Data Window from the pop-up 
menu. 

3. Click OK to return to the plot window. 

Using the Data Selection Tool 

Now we will use the Data Selection tool ( ) to graphically remove a point from the plot. The Data 
Selection tool operates by enclosing a region of the plot in a polygon. Any data points outside the polygon 
are temporarily removed from the plot. By pressing Option (Mac) or Alt (Windows) as you make the 
polygon, the data inside the polygon can be eliminated. 

1. Select the Data Selection tool by either clicking it or pressing S on your keyboard. 
2. Once the tool is selected, press Option (Mac) or Alt (Windows) and create a polygon 

around the data point in the lower-left corner of the plot window. Once the polygon is 
complete, the point is removed from the plot and the curve fit is recalculated. 

3. Double-click the Data Selection tool to return the plot to its original state. 
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Adding Error Bars 
The last modification to the plot will be the addition of error bars. Error bars illustrate the amount of error for 
the plotted data. 

1. Choose Plot > Error Bars to display the Error Bar Variables dialog. 
2. Click the check box in the Y Err column to add vertical error bars. The Error Bar Settings 

dialog is displayed to choose the type of error. 
3. From the pop-up menu, choose Standard Error for the error type. The dialog should look 

like the following: 
  

 
  

4. Click OK to return to the Error Bar Variables dialog. 
5. Click OK to add the error bars to the plot. The error bars represent the standard error of the 

entire data column. 
  

You have just created a customized plot, as shown below: 
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You can continue on to the next example which takes you through the process of creating and customizing a 
Column plot. 
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Example 3 - Creating a Column 
Plot 

This example uses a Column plot to show how to adjust major and minor ticks, axis labels, plot color, fill 
patterns, column spacing, and label rotation, in addition to displaying values above the columns. This 
example is divided into the following topics: 

• Opening a Saved Data File 

• Creating a Column Plot 

• Changing Axis Options 

• Changing the Fill Pattern 

• Increasing Column Offset 

• Editing Text Labels 

• Adding Value Labels 

Opening a Saved Data File 
We will begin this example by opening a saved data set. 

1. Choose File > Open. 
2. Locate and open the Data folder, which is located in the Examples folder. 
3. Double-click the Housing Starts file. 

Creating a Column Plot 
Now, let’s create a plot using this data. 

1. Choose Gallery > Bar > Column. The Variable Selection dialog is displayed. 
2. Select Month as the X variable and 1966(K) as the Y variable by clicking the appropriate 

check boxes. 
3. Click Plot to create a Column plot. 

Changing Axis Options 
The first set of changes will be made in the Axis Options dialog. This dialog contains the majority of the 
settings for the axes, tick marks, grid lines, and axis labels. 
  
The first change is to remove the grid lines and tick marks along the X axis. 

1. Triple-click the X axis (or choose Plot > Axis Options). 
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2. Click Ticks & Grids. The dialog changes to show the options that can be selected for the 
major and minor tick marks and grid lines. 

3. In the Major Interval portion of the dialog, choose None from the Display Tick and 
Display Grid pop-up menus. 

  
The next change also involves the tick marks, but this time on the Y axis. 

1. Click the Y tab at the top of the dialog. 
2. Choose Out from both of the Display Tick pop-up menus. 

  
The next step is to change the maximum Y axis limit from 140 to 160. 

1. Click Limits. The dialog changes to show the options that can be selected for the limits. 
2. Change the Maximum value from 140 to 160. 

  
The last step is to add some color to the interior of the plot. By default, plots are created without interior and 
background colors. To select an interior color: 

1. Click the All tab at the top of the dialog. 
2. If it is not already selected, click Colors and then choose one of the lighter colors from the 

Interior pop-up menu. 
3. Click OK to update the plot with all of the changes that were made while in the Axis Options 

dialog. 

Changing the Fill Pattern 
Now you can change the fill pattern for the columns using the Variable Settings dialog. 

1. Triple-click the small square in the legend, which is filled with the same pattern as the 
columns (or choose Plot > Variable Settings). 

2. Select a different fill pattern from the Fill Pattern pop-up menu. 
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3. Click OK. 

Increasing Column Offset 
The next step is to increase the amount of space between the columns. 

1. Choose Plot > Plot Options. 
2. If it is not already selected, click Bar to display the options available for Bar and Column 

plots. 
3. Change the Column Offset percentage from 20 to 40%. 
4. Click OK to update the plot. 

Editing Text Labels 
The following steps remove the X axis title, resize the Y axis title, and rotate the X axis labels. 

1. Click the X axis title, Month, and press Delete (Mac) or Backspace (Windows). 
2. Click the Y axis title, 1966 (K). Drag any one of the four object handles to increase the font 

size of the label. It is also possible to change the font size by double-clicking the text label. 
3. Double-click one of the X axis labels. Notice that this dialog has its own set of controls. 
4. Choose 90° from the pop-up menu. 
5. Click the right justification button so that the rotated labels line up evenly. 
6. Click OK to return to the plot window. 
7. Drag the X axis labels closer to the axis. You can also use the arrow keys to move selected 

objects one pixel at a time in the specified direction (10 pixels if you press Shift while using 
the arrow keys). 

Adding Value Labels 
The last step is to display the values of each column. To do this: 

• Turn on Add Values in the Plot menu. 
  
The values are placed at the top of each column. The values can be moved as a group by dragging them to 
a new location. 
  
The Column plot is now complete. A sample plot is shown below. 
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Example 4 - Laying out Plots for 
Printing 

This example shows how to use the layout window to place the plots created in the previous examples on a 
single page. 
  

Note:  The following topics assume the two plots from the previous examples are still available. If 
you do not have them any longer, you can open any two plots from the Plots folder in the 
Examples folder. 

  
This example is divided into the following topics: 

• Placing Plots in the Layout 

• Arranging Plots in the Layout 

• Modifying and Printing the Layout 

Placing Plots in the Layout 
To place plots into the layout window: 

1. Choose Windows > Show Layout > KG Layout. If no layout has been created previously, 
an empty layout window is displayed. 

2. Use the Select Plot command (Layout menu) to select the two plots that were created in 
the previous examples. At this point, do not worry about their overall placement. 

Arranging Plots in the Layout 
To arrange the plots in the layout window: 

1. Choose Layout > Arrange Layout. The Arrange Layout dialog allows you to enter the 
number of rows and columns to divide the layout window into equal sections. 

2. The default settings (two rows and one column) are sufficient for this example, so click OK. 
  
Notice that the layout window is divided into two equal sections and the plots are automatically resized and 
placed into these sections. 

Modifying and Printing the Layout 
It is possible to display more than just plots in the layout window. The plot tools are available, enabling you 
to add text and other objects to the layout. Various graphic images can be imported into the layout window. 
Also, a background pattern and frame can be added to the layout using the Set Background command 
(Layout menu). 

  
The following steps explain how to add a text label to the layout window: 

1. Select the Text tool ( ) from the toolbox. You can select this tool by either clicking it or 
pressing T on your keyboard. 
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2. Click anywhere in the layout window. The Edit String dialog will appear. 
3. Enter some text into this dialog. KaleidaGraph supports fully-stylized text, so feel free to 

highlight various portions of the text string you have entered and make changes to the font, 
font size, style, and color. Any changes you make only affect the selected portion of the text 
string. 

4. Once you are finished making changes, click OK to add the text label to the layout window. 
You can move the label to a new position using either the Text tool or the Selection Arrow. 

  
Feel free to print the layout by choosing File > Print Layout. To close the layout window, choose File > 
Close. 
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Additional Tutorials 
Editing the Legend 
This example shows how to edit the legend frame and text. The attributes of the legend frame are controlled 
by the bottom three icons on the toolbox. The steps in this example use the last icon in the toolbox, which is 
divided into two sections: a Line Style icon on the left and a Line Width icon on the right. 
  

              
Line Style pop-up menu      Line Width pop-up menu 

  
The first step is to open a saved plot. 

• Open the Sample Plot file, which is located in the Plots folder in the Examples folder. 

Editing the Legend Frame 
1. Click the legend to select it. 
2. From the toolbox, click the Line Width icon (the up and down arrows) and choose Hairline 

from the pop-up menu. Notice that the legend frame changes from a shadow box to a 
hairline width line. 

3. Now click the Line Style icon (the line to the left of the up and down arrows) and select one 
of the dashed lines from the pop-up menu. Notice that the line surrounding the legend now 
contains the dashed pattern you selected. 

4. Finally, choose None from the Line Style pop-up menu. This removes the legend frame 
completely. 

Editing the Legend Text 
1. Select the Text tool ( ) from the toolbox. You can select this tool by either clicking it or 

pressing T on your keyboard. 
2. Double-click any of the three labels inside the legend. The Edit String dialog is displayed to 

modify the text. 
3. Delete the text in this dialog and type any information you like. Feel free to change the font, 

size, and style as well. 
4. Click OK to return to the plot and see the change. 

The changes you made only affect this one label. If you use the Selection Arrow instead of the Text tool, you 
can change the attributes of all legend items at once. However, you cannot edit the text with the Selection 
Arrow. 
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Using Formula Entry 
This example shows how to use the Formula Entry window to operate on the data window. Details on 
executing a multi-line formula are also included. This example is divided into the following topics: 

• Formula Entry Overview 

• Executing Individual Formulas 

• Executing Multi-line Formulas 

Formula Entry Overview 
The Formula Entry window, shown below,  is a very powerful tool for data analysis. Use Formula Entry to 
enter equations (functions) that generate and manipulate data in the frontmost data window. The results of a 
formula can be placed in a data column, a single cell, or a memory location. 
  

 
  
Memory locations and column numbers can be used in formulas. Memory locations range from 0 to 99 and 
need to be preceded by an m when used in a formula (m15, m35, and so on). 
  
Column numbers range from 0 to 999 and need to be preceded by a c when used in a formula (c10, c55, 

and so on). To display the column numbers, click the Expand/Collapse button  in the data window. Please 
note that when a selection is made in the data window, the first column in the selection becomes column 0. 
  
The following are a few examples of basic formulas along with a description of each: 

c2=c0+c1; Adds the first two columns together and stores the results in column 2. 
c1=c0/1000; Divides column 0 by 1000 and stores the results in column 1. 
c2=cos(c0); Calculates the cosine of column 0 and stores the results in column 2. 

Executing Individual Formulas 
Let’s get started by running a few formulas and seeing their effects on the data window: 
  

Note: In the steps that follow, you can press Enter on the numeric keypad instead of clicking Run. 
  

1. Choose File > New to display an empty data window. 
2. Choose Windows > Formula Entry. By default, the F1 button is selected. The F1-F8 

buttons can be used to store common formulas, however, we recommend that you leave F1 
for general use and store your formulas in F2-F8. 

3. Click F2, type c0=index() + 1, and click Run. This creates a series from 1 to 100 in column 
0. 

4. Click F3, type c1=log(c0), and click Run. This function calculates the logarithm of each 
value in column 0 and stores the results in column 1. 

5. Click F4, type c2=c1^2, and click Run. This formula squares each value in column 1 and 
stores the results in column 2. 
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6. Click F5, type cell(0,3)=csum(c2), and click Run. This formula calculates the total sum of 
the values in column 2 and stores the result in the cell at row 0, column 3. 

Executing Multi-line Formulas 
It is not necessary to enter and execute each formula individually. KaleidaGraph has a method to enter 
multiple formulas and execute them all at once. 
  

To the left of the F1 button is a Posted Note button . Clicking this button displays a text editor. You can 
enter multiple formulas into the editor and run them all at once by clicking Run. The formulas must be on 
separate lines and each must be terminated with a semicolon. 
  
Let’s try using the same formulas from before, but this time executing them using the Posted Note window: 

1. Choose File > New to display an empty data window. 
2. Choose Windows > Formula Entry. 
3. Click the Posted Note button in the Formula Entry window to display a text editor. 
4. Type the following formulas into the Posted Note window. Note that each formula ends with 

a semicolon and appears on a separate line. 
 
c0=index() + 1; 
c1=log(c0); 
c2=c1^2; 
cell(0,3)=csum(c2); 

5. After the formulas are entered, click Run to execute all of the formulas at once. 
  
As you can see, this is a very convenient method to execute multiple formulas at once. Using this method, 
you can save the formulas as a text file that can be opened at a later time within the Posted Note dialog. 

Performing a One Way ANOVA 
This example walks you through the process of performing a one way ANOVA on one of the example data 
files. Use this test when you want to see if the means of three or more different groups are affected by a 
single factor. This test is the same as the unpaired t-test, except that more than two groups can be 
compared. 

  
As part of the results, KaleidaGraph calculates F and P values: 

• F value - This value is the ratio of the groups’ mean square over the error mean square. If 
this value is close to 1.0, you can conclude that there are no significant differences between 
the groups. If this value is large, you can conclude that one or more of the samples was 
drawn from a different population. To determine which groups are different, use one of the 
post hoc tests. 

• P value - This value determines if there is a statistically significant difference between the 
groups. If this value is below a certain level (usually 0.05), the conclusion is that there is a 
difference between the groups. 

  
This example is divided into the following topics: 

• Opening a Saved Data File 

• Performing the One Way ANOVA 

• Running a Post Hoc Test 
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Opening a Saved Data File 
We will begin this example by opening a saved data set. 

1. Choose File > Open. 
2. Locate and open the Data folder, which is located in the Examples folder. 
3. Double-click the ANOVA data file. 

  
The first five columns in the data window (Sample 1 through Sample 5) will be used in this example. 

Performing the One Way ANOVA 
1. Choose Functions > ANOVA to display the ANOVA dialog. 
2. Assign Sample 1 through Sample 5 to the Dependent(s) list by selecting these variables 

and clicking the Add button. You can assign each one individually or you can select all five 
and assign them at once. 

3. Click Calculate. The results of the test are displayed in the bottom half of the dialog, as 
shown below. This test produces a P value of 0.04325, indicating that there is a significant 
difference between the groups.  

  

 

Running a Post Hoc Test 
To determine which groups are different and the size of the difference, you can use one of the post hoc 
tests. 

1. Choose Tukey HSD from the Post Hoc Test pop-up menu. 
2. Click Calculate. The results of the post hoc test appear below the ANOVA results. By 

comparing the P values that are calculated, it appears that Sample 4 differs significantly 
from the other samples. 
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3. The results can be copied to the Clipboard or printed by pressing the appropriate button in 
the dialog. 

4. Click OK to return to the data window. 

Applying a General (user-defined) Curve Fit 
This example takes you through the process of opening a saved plot and applying a user-defined curve fit. 
KaleidaGraph’s General curve fit is based on the Levenberg-Marquardt algorithm. You can solve up to nine 
unknown parameters during the fitting process. This example is divided into the following topics: 

• Opening a Saved Plot 

• Applying a General Curve Fit 

• Changing Appearance of the Curve Fit Line 

• Loading Curve Fit Definitions from KaleidaGraph's Fit Library 

Opening a Saved Plot 
We will start by opening a saved plot. 

1. Choose File > Open. 
2. Locate and open the Plots folder, which is located in the Examples folder. 
3. Double-click the Inhibition Plot file. 

Applying a General Curve Fit 
The steps below will take you through the process of applying a Sigmoidal curve fit to the data. The equation 
used is of the form y = a+(b-a) / (1+(x/c)^d). 

1. Choose Curve Fit > General > fit1. This will display the Curve Fit Selections dialog. 
2. Click Define Function to display the General Curve Fit Definition dialog. 
3. Type m1+(m2-m1) / (1+(x/m3)^m4);m1=1;m2=100;m3=1;m4=1 into the field provided and 

click OK. The information that appears after the curve fit definition represents the initial 
guesses for the unknown parameters in the equation. 

  

 
  

4. Click the check box in front of % Inhibition. This indicates to KaleidaGraph that you want to 
apply a curve fit to this variable. 

5. Click OK and the curve fit is calculated and displayed on the plot. 
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6. A table should appear containing the results of the fit. If it is not displayed automatically, 
turn on Display Equation in the Plot menu. The table lists the values of the unknown 
parameters along with the standard error of these values. It should be read as the 
parameter value +/- the standard error. The Chi Square and R values are also displayed as 
part of the curve fit results. 

7. Feel free to move the table to a new location using the Selection Arrow. If you would prefer 
to hide the table, turn off Display Equation in the Plot menu. 

Changing Appearance of the Curve Fit Line 
The final step will be to change the line style and width of the curve fit line. 

1. Choose Plot > Variable Settings. 
2. Click the Curve Fit Settings tab. This will allow you to change the appearance of the curve 

fit line. 
3. Using the appropriate pop-up menus, select a different line style and line width for the curve 

fit. 
4. Click OK to apply the changes. 

  
Note: Depending on the line width selected, you may not notice a difference on the screen. 

However, you will notice a difference when the plot is printed. 

Loading Curve Fit Definitions from KaleidaGraph's Fit 
Library 
KaleidaGraph includes over 100 curve fit definitions that are divided into several categories (Polynomial, 
Logarithmic, Sigmoidal, and so on). Each curve fit definition is stored as a text file in the Curve Fits folder 
(within the Examples folder). 

  
The following steps show you how to load a predefined curve fit definition. The equation used in this 
example is the same as the one used in the previous example. 
  

1. Choose Curve Fit > General > fit1. This will display the Curve Fit Selections dialog. 
2. Click Define Function to display the General Curve Fit Definition dialog. 
3. Click File to display a text editor. 
4. Click Open. 
5. Locate and open the dosersplgst file. This file is in the Sigmoidal folder (in the Curve Fits 

folder). The definition and initial guesses for the parameters will be displayed in the editor. 
All of the initial guesses in the predefined definitions are set equal to 1. You may need to 
modify one or more of the initial guesses to allow the fit to converge on a reasonable 
solution. 

6. Click OK to display the curve fit equation in the General Curve Fit Definition dialog. 
7. Change the initial guess for the m2 parameter from 1 to 100. 
8. Click OK to exit the General Curve Fit Definition dialog. 
9. If it is not already selected, click the check box in front of % Inhibition. 
10. Click OK and the curve fit is calculated and displayed on the plot. 

  
This process cannot be used to edit the curve fits stored in your master curve fit list. For information on how 
to add curve fits to your master list, refer to either the electronic manual or the online help. 
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Modifying Data in a Saved Plot 
This example shows how to modify a data point in a saved plot and have the plot and any curve fits 
automatically updated. This example is divided into the following topics: 

• Extracting the Data 

• Changing the Data and Updating the Plot 

• Changing Multiple Data Points 

Extracting the Data 
To get started, we need to open a saved plot and extract the data. To do this: 

1. Choose File > Open and open the Sample Plot file (located in the Plots folder, within the 
Examples folder). 

2. With the plot frontmost, choose Plot > Extract Data. The original data used to create the 
plot is displayed.  

  
The title of the window begins with the same name as the original data file. Additionally, a date and time 
stamp is appended to the name, identifying when the data was archived in the plot. 

Changing the Data and Updating the Plot 
Now we can make changes to the data and have the plot updated. 

1. Turn on Auto Link in the Plot menu. When this command is active, you can make changes 
to the data and have the plot automatically updated after each individual change. 

2. Delete the first value in the second column (78.5) and type 100 into this cell. 
3. Click another cell to activate the Auto Link feature. The plot and curve fit are automatically 

updated to reflect the modified data value. 

Changing Multiple Data Points 
If you need to add or modify multiple data points, it may be more efficient to use the Update Plot command 
(Plot menu) because Auto Link causes the plot to update after each change. In this case, turn off Auto 
Link, make any changes to the data, and either choose Update Plot or click  in the data window. The 
plot will be updated to reflect all of the changes at once. 
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Generating Similar Plots 
If you routinely create the same types of plots in KaleidaGraph, it helps to set some defaults or templates so 
that most of the work can be done automatically. KaleidaGraph provides several features that can be used 
to generate similar plots. 
  
The following topics provide a general idea of when to use each to achieve a consistent look for your plots: 

• Style Files - This feature is useful for setting program defaults like font information, plot 
characteristics, colors, and so on. This information is used any time a new plot is created. It 
is possible to export separate Style files so that you can load different settings as needed. 

• Template Plots - This feature is useful when you have an existing plot and want to replace 
the data, keeping the appearance of the plot intact. If the original plot contains curve fits or 
error bars, the resulting plot will also have these applied. The plot and axis titles will remain 
the same; however, the legend will reflect the names of the new variables. 

• Plot Scripts - This feature is useful when you need to generate several identical plots at one 
time from different data sets. If the script is pointed at a plot that contains curve fits or error 
bars, each resulting plot will also have these applied. Other features include the option to 
automatically save or print each plot and the ability to set the titles and legend information 
for each plot. 

• Formula Scripts - This feature is useful for automating the process of creating plots. Using a 
formula script, it is possible to open saved data files, manipulate the data with Formula 
Entry, and create plots. 
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Contact Information 
If you have any questions concerning KaleidaGraph, please contact us at: 
  
Synergy Software 
2457 Perkiomen Avenue 
Reading, PA 19606 
  
Tel: 610-779-0522 
Fax: 610-370-0548 
  
Internet addresses: 
Sales/Upgrades: orders@synergy.com 
Technical Support: support@synergy.com 
  
Website: www.kaleidagraph.com 

www.synergy.com 
  

Please take the time to register your program during installation to receive free technical support and 
upgrade information. You can also register by accessing the registration page on our website. 
  
Please feel free to check our website periodically for: 

• Product descriptions 

• Technical notes 

• Frequently asked questions 

• New release information 

• Maintenance updates 

• And other topics of interest 
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