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System Requirements
To run KaleidaGraph on a Mac, you need the following:

OS 10.14 or later.
150 MB free hard disk space.

 
To run KaleidaGraph under Windows, you need the following:

A 64-bit version of Windows 10 or later.
150 MB free hard disk space.

 

Installing KaleidaGraph
The installer creates a new folder on your hard disk containing the KaleidaGraph software. If you are upgrading from an 
earlier version, your existing KaleidaGraph files are not affected.
 

Mac Version
To install KaleidaGraph on your computer:

Make sure you are logged in as the administrator of the computer.
Drag the KaleidaGraph 5.0 folder to the Applications folder.
After installing, please visit our website and  submit your registration information. By registering the software, you 

will receive free technical support and upgrade information.

 

Windows Version
To install KaleidaGraph on your computer:

Make sure you are logged in as the administrator of the computer.
Launch the KaleidaGraph installer and proceed through the various screens.
Once all of the program files have been installed, click Finish to exit the installer. A second installer may also run in 

the background to install the Visual C++ Redistributable file.
After installing, please visit our website and  submit your registration information. By registering the software, you 

will receive free technical support and upgrade information.

 

Network Installation
To have KaleidaGraph installed on a server and not ask each user to personalize the software:

Make sure you are logged in as the administrator of the computer.
Install KaleidaGraph on the server.
Launch the KaleidaGraph application from the server and personalize the software.
Quit out of KaleidaGraph.
Mac version: Move UserInfoV5.xml from the Macintosh HD > Users > (user) > Library > Application Support > 

Synergy Software > KaleidaGraph5.0 folder and KG50License from the Macintosh HD > Users > (user) > 
Library > Preferences > KaleidaGraph Preferences folder and place them in the same folder as the 
KaleidaGraph application.

Windows version: Move UserInfoV5.xml and KG50License from the \Users\(user)\AppData\Local\Synergy 
Software\KaleidaGraph5.0 directory and place them in the same directory as the KaleidaGraph application.

 

Uninstalling KaleidaGraph
To remove the KaleidaGraph software from your computer:

Mac version: Drag the KaleidaGraph 5.0 folder to the Trash and empty the trash.
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Windows version: Choose Settings from the Start menu and open Apps. Choose KaleidaGraph and click 
Uninstall.

 

Features Added in v5.0
 
 Version 5.0 includes the following changes:

Added a Bubble plot.
Added ability to open .csv and .dat files and export .csv files.
Modified the date structure to allow for dates well beyond the year 2040.
Added support for Unicode text and longer text strings.
Added support for drag and drop text editing in dialogs that support multiple lines of text, such as the Edit String 

and Posted Note dialogs.
Added support for multiple undos. The History window displays a list of any unsaved operations for the current 

data, plot, or layout window. The Undo command can be used to undo the last operation or you can click in 
the list to return to a previous state. The Undo command is more limited in the plot window as the list will reset 
any time the plot needs to be redrawn. The various text editors also make use of an Undo stack, however their 
operations are not listed in the History window.

Added a new settings file (KG Prefs) that is saved automatically on exit. This file contains many of the settings that 
were previously saved in the Style file. The Style file now focuses on settings that affect the appearance of a 
plot.

Increased the maximum number of data windows to 200.
Increased the maximum number of plot windows to 50. The layout window also supports 50 plots as well.
Increased the maximum number of General curve fits to 30.
If a syntax error is detected in a General curve fit definition, the error dialog will display a portion of the function 

that caused the error.
Increased the maximum number of program steps in a macro to 2000 and increased the stack size to 24.
Rounded rectangles, ovals, and arcs can now have dashed lines.
Added support for exporting SVG and PDF files.
Added support for transparent backgrounds when exporting PNG and TIFF files.
Improved the appearance of fill patterns when exported at higher resolutions.
Added support for error bars in Dot plots.
Added support for the Add Values command in Histogram plots.
Saving a plot script that uses a template saves everything in a single file.
Increased the number of files stored in the Recent Files list to 20.
Added support for long file names in the Mac version.
Added support for Command-clicking the window title to see where the file is located in the Mac version.
Added support for the Set the default open file type to "All Files" option in the Mac version.
Increased the maximum resolution for exported images in the Windows version to 1400 dpi.
Added support for enhanced Metafiles when exporting plots and layouts from the Windows version.

 

Command and Dialog Changes
 
New Commands

Added Find and Find Again to the Edit menu.
Added Overlay Markers to the Plot menu. This can be used to overlay the markers from a Dot plot on Box, 

Percentile, and Summary Column plots.
Added Set Plot View to the Plot menu. This provides an alternate way to change the view of the plot or layout 

window.
Added Show Plot Tools/Hide Plot Tools to the Plot menu.
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Added a History command to the Windows menu.
Added Clear History commands to the Recent Files and Show Layout submenus.
Added Auto Resize, Add Rows, and Add Columns commands to the Edit menu in the Edit Table dialog.

 
Preferences Dialog

Added Show plot rulers and Show plot grids options to control the default state of these items for new plot 
windows.

Added the Limit plot size to the paper boundary option which can be used to restrict the size of the plot when 
dragging to resize it.

Added the Use Locale Aware Sorting option which determines whether text is sorted based on your location or 
the Unicode value.

Added Font and Text Size settings that control the appearance of text in the various text editors and Formula 
Entry.

Added a Show Row Numbers in Editors option that globally determines if row numbers are shown in the various 
editors.

Moved the Default File Location setting from the General tab to the File Settings tab.
Added settings to the File Settings tab to specify the default text encoding to use when importing/saving text files.
Added a Column Title pop-up menu to the Column tab that can be used to set the default font for column titles.
Moved the settings for assigning menu shortcuts into this dialog.

 
Text File Input Format Dialog

Added Comma as a default delimiter type.
Added a pop-up menu that allows you to choose the encoding of the text file.
Added options to show the control characters (tabs, spaces, returns, etc.) and line numbers when previewing the 

text file.
Added a Save to file button when using the Special delimiter, and the Import from file button displays the Open 

dialog instead of a text editor.

 
Set Plot Size Dialog

Added Portrait and Landscape settings to this dialog to provide another location to change the orientation.

 
Formula Entry Window

Now supports multiple lines in the main section of the window, using the same syntax as multi-line formulas in the 
Posted Note. Because of this change, the Enter key on the numeric keypad is now the only keyboard shortcut 
to execute the formula.

It is now possible to run multi-line formulas and formula scripts without closing the Posted Note.
If a syntax error is detected, the error dialog will display a portion of the function that caused the error.
When Formula Entry is the active window, typing the F1-F9 function keys on the keyboard will activate the various 

function buttons. F9 activates the Posted Note window.
The table() function can now be used on data columns that have masked or missing values.

 
Edit String Dialog

The menus were replaced by graphical controls.
Added support for overline and strikethrough font styles.
Added the ability to resize the dialog.
Editing functions are available via keyboard shortcuts and the shortcut menu.
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Added support for multiple undos, but not through the History window.

 

Interface Changes

Changed the default data type from Float to Double.
Process for adding and removing splits in the data window has changed. Insert a split by clicking the split icon and 

remove a split by double-clicking the split area.
As you drag to make a selection in the data window, the coordinates in the lower-left corner update to show the 

current location as you drag.
The Posted Note now appears as a panel in the data window instead of being displayed as a separate dialog. 

Printing and editing commands are available from the File and Edit menus when the Posted Note panel is the 
active section.

The various text editors temporarily replace the original window instead of being displayed as an additional dialog. 
All of the editors contain Open and Save As buttons and an option to show the row numbers. The editors for 
the Posted Note and Edit Program support normal printing and editing commands via the File and Edit
menus. The other editors provide a Print button while normal editing commands are supported via keyboard 
shortcuts and right-clicking within the dialog. The editors also support multiple undos, but not through the 
History window.

If a file gets edited, it is noted by a black dot in the Close box (Mac) or a * behind the name (Windows).
Due to adding support for Unicode, typing a Latin character in the Edit String dialog on the Mac and converting it to 

the Symbol font will not immediately display the Greek character. It will be displayed when you exit the dialog. 
It is possible to see the character immediately if you copy it from the Font Book application and paste it into 
the Edit String dialog.

Changed the default resolution to 4X Screen when exporting plots or layouts.
The Copy OLE Object command must now be used to copy a plot as an OLE object in the Windows version.
Added a Defaults button to the Plot Options and Text Options dialogs.
Added a Select All button to the Curve Fit Selections dialog.
The plot tools are no longer on a floating palette and are now part of the plot and layout window.
The total number of fill patterns available has increased to 24, which includes 8 gradient patterns, and are identical 

for both platforms. Because the fill patterns have changed, you may see some of the patterns change when 
opening older plots.

Added more options for changing the magnification level for the plot and layout windows.
Up and down arrow buttons were added to the Variable Selection dialog to change the order of selected plot 

groups.
Names of hidden windows are no longer displayed in italic. Names of hidden windows now show two dashes 

before the name in the Show Data and Show Plot submenus.
Any functions that include a path must now use "/" to separate directories in the path instead of ":" or "\" that were 

used in earlier versions.

 

Features that were removed

Removed the ability to save data and plot files in a v3.5 format.
Removed support for importing and exporting GIF images. PNG would be a good alternative and has the added 

advantage of supporting transparent backgrounds.
Removed ability to insert a column by pressing Option (Mac) or Alt (Windows) and clicking a column. There is 

now a keyboard shortcut for the Insert Column command.
Removed the Auto Refresh command from the Plot menu.
Removed the View Text button from the Text File Input Format dialog since scrolling is enabled and the dialog can 

be resized.
The PICT format is no longer supported for exporting images. This format was deprecated by Apple in 2013. SVG 

and PDF are both vector formats that could be used instead.
The CMYK option for TIFF images is not currently supported.
Removed the Only use built-in sizes option from Text Options.
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AppleScript is not currently supported in the Mac version.
The Open dialog in the Mac version no longer supports Macintosh file types, as these were deprecated in the Mac 

OS. All files need a file name extension or they will be treated as text files.
Outline, Shadow, Condense, and Extend text styles are no longer available in the Edit String dialog in the Mac 

version.
Removed support for Dynamic Data Exchange (DDE) in the Windows version.
Removed the Use Windows Fill Patterns option from the Preferences dialog in the Windows version.

 

Launching KaleidaGraph for the First Time
The first time the program is started, a dialog is displayed to personalize your copy of KaleidaGraph and enter your serial 
number and authorization code. Make sure you are logged in as the administrator of the computer.
 
The serial number and authorization code can be found in the order confirmation that was sent via e-mail. If this is an 
update from an earlier version, use your original serial number. The serial number is a number; it does not contain any 
letters.
 
The OK button will not activate until a valid authorization code is entered. Some common issues that prevent the OK 
button from being active include:

Typing the letter O instead of a zero. None of the codes use the letter O.
Typing the wrong character by accident (for example, K for X or A for 4).
Using an authorization code from an earlier version of the software.

 

Data Window Overview
The data window, shown below, contains a worksheet used to enter and store data for plotting and analysis. It consists of 
a number of cells organized in columns. A data window can contain a maximum of 1000 columns and 1 million rows, 
subject to memory limitations.
 

 
The various elements of the data window are described below:

Toolbar - The buttons in the toolbar provide shortcuts to commonly used commands.
Home button - Clicking this button returns the data window to its origin (row 0, column 0).
Vertical and Horizontal splits - These controls are used to split the data window into multiple panes. This allows 

you to view two sections of the data window simultaneously.
Current position - This area of the data window shows the row and column number of the current cell.
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Expand/Collapse button - Clicking this button allows you to expand or collapse the column headers to display or 
hide the column numbers. The column numbers are used when writing formulas in Formula Entry. To display 
the column numbers by default, select the Show Column Numbers check box in the Preferences dialog.

Column titles - This area of the dialog contains the title of each data column. By default, the column titles are A, 
B, C, and so on for a new data window. The titles can be edited directly in the data window.

 

Plot Window Overview
Plots are created by entering data into the data window and choosing a plot type from the Gallery menu. After selecting 
the data columns to be plotted, the plot is generated and displayed in the plot window.

 

 
The various elements of the plot window are described below:

Toolbox - The plot tools are located on a movable palette. The tools are used to create, modify, and enhance 
objects in the plot window.

Axis title - The axis titles are taken from the column names of the data being plotted. If more than one variable is 
plotted on the same axis, the title is taken from the first column being plotted on that axis.

Minor ticks - Minor ticks display the divisions between major tick marks.
Zoom setting - This pop-up menu can be used to change the view of the active plot window.
Hide/Show Plot Tools button - This button can be used to hide/show the plot tools.
Extract button - Clicking this button displays any data windows referenced by the plot.
Legend - The legend consists of a frame, the plot symbols, and the labels used to identify each variable in the 

plot. By default, the labels are taken from the names of the columns in the data window. The variables are 
listed in the order they are selected for plotting.

Plot title - The plot title is the name of the graph. By default, the plot title is taken from the name of the data 
window.

Grid lines - The grid lines allow you to display a horizontal or vertical line at each of the major and minor tick 
marks in the plot.

Major ticks - The major tick marks are used to identify the major divisions along the axis.
Axis labels - The axis labels display the values associated with each of the major tick marks on the plot.
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Opening KaleidaGraph Files
The Open command (File menu) can be used to open files previously saved from KaleidaGraph. This command can also 
be used to open Excel files, text files, and any graphic images that you want to include in the plot or layout window. The 
Import command can be used to import Style, Macro, and Program Text files. Multiple files can be opened at once by 
pressing Shift, Command (Mac), or Ctrl (Windows) and clicking the file names.
 
Note: If you have files that were created in the Mac version prior to OS X, the files will not have any file name extensions. 

They can be added manually or you can try to use the AppleScript converter available on our website. If the file 
name extension is not added, it will be treated as a text file.

 
The File menu contains a Recent Files command that lists the last 20 files that have been opened or saved in 
KaleidaGraph. You can open one of the files in the list by choosing its file name from the submenu.
 

Setting Defaults
Data Window Defaults
The Preferences dialog provides several options that can be used to change the defaults used for the data window.
 

Default Column Format
The options in the Column tab of the Preferences dialog can be used to set the default column format used for any new 
data windows. The options available range from being able to set the default font for column titles and data, font size, and 
color to specifying the default column width and row height. You can also use the options in this tab to set the default data 
type and format for the data.
 

Other Data Window Settings
The General tab of the Preferences dialog also contains a few options that affect the data window. This includes things 
like the default date format and decimal separator. You can also choose whether or not to show the tools or the column 
numbers in the data window.
 

Plot Window Defaults
KaleidaGraph provides several commands that can be used to set the defaults for some of the elements in the plot 
window.
 

Plot Layouts
The Define Layout command (Plot menu) can be used to save the layout of the current plot. Each of the plots in the 
Gallery menu can have its own layout. The layout remembers the default style for the legend, the position of the axis 
titles, plot title, axes, and legend, and the size of the axes, frame, and legend.
 

Text Defaults
The Text Options command (Plot menu) can be used to set the default font attributes for each of the label types available 
in the plot window. This command can also be used to set the settings associated with subscripts and superscripts, and to 
choose an alternate font.
 

Other Plot Window Settings
The General tab of the Preferences dialog contains a few settings that affect the behavior of the plot window, including 
what happens when you exceed the maximum number of open plot windows.
 
Attributes for shapes drawn in the plot or layout window are controlled using the icons below the tools in the toolbox. If no 
objects are selected in the window, you can set default attributes. These attributes are applied to any new shapes created 
in KaleidaGraph.
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File Settings Defaults
The File Settings tab of the Preferences dialog contains pop-up menus that control what happens to each of the different 
file types when quitting the program. For data and plot files, you can choose to Always save changes or to display a 
Prompt if there are any unsaved windows. If a data or plot window has not been saved previously, a Save dialog is 
displayed. For the remaining types of files (Layout, Macros, Script, and Style), you can choose whether to display the 
Prompt dialog if any changes have occurred, Always save, or Never save the changes.
 

Sharing Files Across Platforms
KaleidaGraph has the ability to share files between the Mac and Windows platforms. Both platforms make use of the file 
name extensions to identify the type of file. The following table lists the file name extensions:
 

Kind of File File Name Extension
Data file .QDA
Plot file .QPC

Macro file .EQN
Layout file .QPL
Script file .QSC
Style file .QST

 
If you have files that were created in the Mac version prior to OS X, the files will not have any file name extensions. They 
can be added manually or you can try to use the AppleScript converter available on our website.  If the file name 
extension is not added, it will be treated as a text file.
 
If you run into problems, check which version of KaleidaGraph is installed. Version 5.0 can open files from any version of 
KaleidaGraph, but older versions can only open files created by v5.0 if they were exported in an older file format using the 
Save As command.
 

Saving Files in an Older File Format
KaleidaGraph allows you to save the data, plot, and layout windows in a v4.x file format so that these files can be opened 
in an earlier version of KaleidaGraph. It is not possible to save these files in a v3.x format.
 
To save a file in an older file format:

Choose Save Data As, Save Graph As, or Save Layout As from the File menu.
Select the appropriate file format from the pop-up menu in the Save dialog.
Specify the location and file name for the file and click Save.

 

Getting Help
If you have a question that is not covered in the Quick Start guide or want more information on a particular topic, here are 
several places you can reference for information:
 

Context Sensitive Help
To get online Help, do any of the following:

Choose Help > KaleidaGraph Help
Click Help in any dialog that contains a Help button.
Click the ? button on the toolbar. (Windows version)

 
The Help dialog contains a table of contents for the topics available in the KaleidaGraph program. Click the topic and the 
dialog displays the information available for the selected topic. If you are unable to locate the desired information from the 
table of contents page, you can use the Index or search the entire Help system for a particular term.
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PDF Manual
A PDF version of the manual is available by choosing Help > Manual from within the KaleidaGraph application.
 

Synergy Website
The Support area on our website (www.synergy.com) has a Knowledge Base section for FAQs and answers to other 
technical questions.
 

Email
Assistance is available by sending email to support@synergy.com. Most messages are answered within 24 hours Monday 
- Friday.
 

Phone
If the above options are not helpful, call Synergy Software at 610-779-0522.
 

Quitting KaleidaGraph
To close the KaleidaGraph program and return to the desktop, choose KaleidaGraph > Quit KaleidaGraph (Mac) or File
> Exit (Windows). KaleidaGraph saves any changes to the default Style, Macros, Script, and Layout files, depending on 
what is specified in the File Settings tab of the Preferences dialog.
 
If Prompt is selected for any of the items in the Preferences dialog and changes have occurred to those particular items, a 
dialog will be displayed and give you a chance to save changes to the various files.
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Creating a New Data Window
A blank data window can be created by choosing File > New. Any defaults that have been set using the Preferences
command are used to create the new window. By default, data windows are created 10 columns by 100 rows in size and 
named Data 1, Data 2, and so on. A maximum of 200 data windows can be open at any one time.
 

Hiding, Displaying, and Closing Data Windows
You can view a list of all open data windows by choosing Windows > Show Data.  Names of hidden data windows show 
two dashes before the name. A maximum of 200 data windows can be open at any one time.
 

Changing the Active Window
To make a data window active, click anywhere in the desired data window or choose Windows > Show Data and select 
its name.
 

Hiding Data Windows
A data window can be hidden by choosing Windows > Hide Window and selecting its name. The next window in the list 
becomes active.
 

Displaying Data Windows
A hidden data window can be displayed using the Show Data command (Windows menu). Select the name of the 
desired data window and it is brought to the front.
 

Closing Data Windows
You can use the Close All Data command (Windows menu) to close all of the open data windows at once. Individual data 
windows can be closed by choosing File > Close or clicking the close box of each window. A dialog may be displayed, 
asking if you want to save the data window before closing.
 
Note: If you do not want to save the data, this dialog can be avoided by pressing Shift while either clicking the close box 

or choosing File > Close/NoSave.
 

Moving Around in the Data Window
You can move around the data window using the scroll bars or the following keys:
 
Key Direction
Left/Right Arrow Move one cell left/right.
Up/Down Arrow Move one cell up/down.
Tab Move one cell to the right.
Shift+Tab Move one cell to the left.
Return (Mac)
Enter (Windows)

Move down one cell.

Shift+Return (Mac)
Shift+Enter (Windows)

Move up one cell.

Enter (keypad) Move one cell in the same direction as the last move.
Page Up/Down Move one window view up/down.
Home Move to row 0, column 0.
End Move to the last cell in the last column.
 
If you are editing the contents of a cell, the left and right arrow keys can be used to change the position of the insertion 

point. You can also click the Home button  in the data window to return the window to its origin (row 0, column 0).
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Going to a Cell
The Go To Cell command (Data menu) can be used to view a specific cell in the data window. Choosing this command 
displays a dialog to enter the row and column numbers of the desired cell. When you click OK, the data window 
automatically scrolls to make the cell position visible.
 

Making Selections
Selecting Rows
A single row can be selected by clicking its row number.
 
To select a range of rows, do one of the following:

Click the number of the first or last row that you want and drag to complete the selection.
Click the first row to be included, press Shift, and click the last row. You can use the scroll bars to move to the last 

row.

 

Selecting Columns
A single column can be selected by clicking the column title.
 
To select a range of columns, do one of the following:

Click the column title of the first or last column and drag to complete the selection.
Click the first column to be included, press Shift, and click the last column. You can use the scroll bars to move to 

the last column.

 

Selecting a Range of Cells
To select a range of cells, drag the mouse until all of the cells you want are selected. If some of the cells are not visible, 
keep dragging and the data window will scroll automatically.
 
To select a large block of data, click the first cell of the block, press Shift, and click the cell in the opposite corner of the 
block. You can use the scroll bars to move to the second cell.
 

Selecting the Entire Window
To select all of the cells in the data window, choose Edit > Select All.
 
Note:  It is not possible to select nonadjacent columns in the data window.
 

Adding, Inserting, and Deleting Rows and Columns
Adding Rows

To add more rows to the data window, choose Data > Add Rows or click  in the data window. This command displays 
a dialog to enter the number of rows to be added to the data window. The number entered is rounded up to the next 
multiple of 100.
 
Note: If the active cell is in the last row of the data window, pressing the Down Arrow, Return (Mac), or Enter (Windows) 

key automatically adds 100 rows to the data window.
 

Adding Columns
To add more columns to the data window, do one of the following:

Choose Data > Append Columns or click  in the data window and enter the number of columns to be 
appended to the data window.

Press the Right Arrow key (if the active cell is in the last column of the data window).
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Inserting Rows
Rows can be inserted anywhere in the data window. A row can be inserted in a single column or in a range of columns.
 
To insert a row:

Make a selection in the data window. The row is inserted above the selection.

Choose Data > Insert Row or click  in the data window. A row of blank cells is inserted into the data window.

 

Inserting Columns
To insert a column in the data window:

Select a column in the data window.

Choose Data > Insert Column or click  in the data window. A blank column is inserted before the selected 
column in the data window.

 

Deleting Rows
To delete a row or group of rows:

Select one or more rows to be deleted.
Choose Data > Delete Row. The selection is deleted and the remaining data shifts up to take the place of the 

deleted data.

 

Deleting Columns
To delete a column or a range of columns:

Select one or more columns to be deleted.
Choose Data > Delete Column. The selection is deleted and the remaining columns shift over to take the place of 

the deleted selection.

 

Overview: Formatting Data Columns
KaleidaGraph provides a Column Formatting palette, shown below, that can be used to change many of the attributes 
associated with the data window, such as font, color, font size, column width, and format of the data.
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The Column Formatting palette can be displayed by either choosing Data > Column Formatting or clicking  in the 
data window. The same methods used to display the Column Formatting palette can also be used to close it.
 
Any changes made in the first two sections of the dialog (Font and Alignment, Color and Width) are applied immediately 
to any selected columns. Any changes to the Number Type and Formatting do not take effect until you click Apply.
 
As you move from one column to another, the palette updates to display the current settings for that column.
 
Refer to the following topics to learn how to use the Column Formatting palette to change the attributes of the data 
window:

Changing the Column Width
Changing the Font, Color, Size, and Style
Changing the Background Color
Changing the Number Type and Formatting

 

Changing the Column Width
KaleidaGraph allows you to control the width of each individual column in the data window. If multiple columns are 
selected, the new column width is applied to each column in the selection.
 
You can use either of the following methods to change the width of the columns:
 
To change the width of a column by dragging:

If you want to change the width of multiple columns, make a selection in the data window.
Position the pointer on the line that separates the column titles.

When the pointer changes to a double-headed arrow  drag the boundary on the right side of the column until 
the column is the desired width.

 
To change the width of a column using the Column Formatting palette:

Select one or more columns in the data window.

Choose Data > Column Formatting or click  in the data window to display the Column Formatting palette.
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Click the up and down arrows to the right of the Column Width to increase or decrease the width (in pixels) of the 
selected columns.

If you want the column width to be based on the length of the strings in each column, click the Auto button.

 

Changing the Row Height
KaleidaGraph allows you to control the height of each individual row in the data window. If multiple rows are selected, the 
new row height is applied to each row in the selection.
 
To change the height of a row:

If you want to change the height of multiple rows, make a selection in the data window.
Position the pointer on the line that separates the row numbers.

When the pointer changes to a double-headed arrow  drag the lower boundary until the row is the desired 
height.

 

Changing the Font, Color, Size, and Style
The Column Formatting palette allows you to change the font, color, font size, and style used to display data in each 
column of the data window. If multiple columns are selected, the current settings are applied to all of the columns in the 
selection. The data window updates as soon as you make a change to any one of these settings.
 
To change the font, color, font size, or style of a column:

Select one or more columns in the data window.

Choose Data > Column Formatting or click  in the data window to display the Column Formatting palette.
Use the settings in the Font portion of the palette to change the font, size, color, and style used for the data in the 

selected columns.

Use the Justification setting  in the Alignment, Color and Width portion of the palette to control whether 
the values are left, center, or right justified in the column.

 

Changing the Background Color
The Column Formatting palette allows you to change the background color for each column in the data window. If multiple 
columns are selected, the current background color is applied to all of the columns in the selection.
 
To change the background color of a column:

Select one or more columns in the data window.

Choose Data > Column Formatting or click  in the data window to display the Column Formatting palette.
Click the Color control in the Alignment, Color and Width portion of the palette.
Select a new background color and click OK.

 

Changing the Default Data Window Settings
The Preferences command can be used to select default settings for most of the attributes associated with a data 
window, including column title and data fonts, color, font size, column width and row height. You can also select the default 
data type and format for the data values.
 
To change the defaults for the data window:

Choose KaleidaGraph > Preferences (Mac) or File > Preferences (Windows) to display the Preferences dialog.
Click the Column tab.
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Select your new defaults for the various options and pop-up menus.
Click OK. Any changes take effect the next time you display a new data window, except for the font used for 

column titles which changes immediately.

Note: If you want to reset these settings to KaleidaGraph’s default settings, click the Defaults button.
 

Displaying the Column Numbers
Each column in the data window is assigned a column number. The column numbers range from 0 to 999 and are used to 
identify columns within Formula Entry functions.
 

To display the column numbers, click the Expand/Collapse button  in the data window. To make this the default, select 
the Show Column Numbers check box in the Preferences dialog.
 
Please note that when a selection is made in the data window, the first column in the selection becomes column 0.
 

Splitting the Data Window
KaleidaGraph provides two controls in the data window that can be used to split the data window into multiple panes. This 
allows you to view two sections of the data window simultaneously.
 
To split the data window into multiple panes:

Click one of the split boxes  in the data window. The split boxes are located above the vertical scroll bar and to 
the left of the horizontal scroll bar.

The data window will get divided into two equal panes. Each pane will have its own set of scroll bars. The position 
of the split can be adjusted by dragging.

 
To remove a split from the data window, double-click the split area.
 

Making Notes about the Data
Each data window in KaleidaGraph can display a panel where you can make notes about the data set. This panel is 

displayed by either choosing Data > Show Posted Note or clicking the Posted Note button  in the data window. The 
Posted Note contains Open and Save As buttons and an option to show the row numbers, while other commands are 
available from the File and Edit menus when the Posted Note panel has focus. It also supports multiple undos, but not 
through the History window.
 
The information in the Posted Note is unique for each data window and is saved as part of the data file.
 
If any lines are skipped when importing a text file, the skipped lines are automatically placed in the Posted Note.
 
The Posted Note panel can be hidden by either choosing Data > Hide Posted Note or clicking the Posted Note button in 
the data window.
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Switching Between Overwrite and Insert Mode
KaleidaGraph provides two commands, Overwrite Mode and Insert Mode, that control what happens when you select a 
cell and begin typing. The active mode is preceded by a check mark in the Data menu.
 
If Overwrite Mode is active, clicking a cell and typing replaces any existing data.
 
If Insert Mode is active, clicking a cell and typing appends the information to the current value.
 

Entering Numeric Data
The Column Formatting palette provides three data types for displaying numeric data. They are:

Float - Accurate for numbers containing up to seven digits.
Double - Accurate for numbers containing up to 16 digits.
Integer - Displays the numbers as integers.

 
To enter numeric data in the data window:

Click a cell in the data window.

Choose Data > Column Formatting or click  in the data window to display the Column Formatting palette.
Verify that the correct data type (Float, Double, or Integer) and format are selected for the column.
Type the data value. If you make a mistake, press Delete (Mac) or Backspace (Windows) to remove incorrect 

characters. To enter numbers in scientific notation, enter the number, followed by an e and the power (for 
example, 1.23e-4).

Press the Return (Mac), Enter (Windows), or the Down Arrow key to move down one row.
Repeat steps 4 and 5 until all of the data is entered.

Note: If KaleidaGraph detects any characters that are not associated with the selected data type, a beep sounds when 
you move to the next cell. Examples of incorrect characters for numeric data include: text, multiple decimal 
points, and separators for date and time numbers. If the data values contain more than seven digits, make sure 
the column format is set to Double or round-off errors will occur.

 

Entering Date or Time Data
To enter date or time data:

Click a cell in the data window.

Choose Data > Column Formatting or click  in the data window to display the Column Formatting palette.
Choose either Date or Time from the Type pop-up menu.
Choose the desired format from the Format pop-up menu and click Apply.
Type the date or time data. If you make a mistake, press Delete (Mac) or Backspace (Windows) to remove 

incorrect characters.
Press Return (Mac), Enter (Windows), or the Down Arrow key to move down one row.
Repeat steps 5 and 6 until all of the data is entered.

 
If you import date or time data from a file, the format must closely match the actual format shown to enable KaleidaGraph 
to recognize the column properly. However, if you are typing the data or pasting the data from the Clipboard (to a column 
that has been set to a date or time format), variations from the exact format are allowed. Valid separators for the date and 
time formats include: slashes (/), colons (:), commas, and spaces.
 
Note: Dates and times in Excel that include h:m should use a Custom format that includes the seconds, otherwise the h:m 

data will be treated as m:s.
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When importing dates from another program, the Default Date Format setting in the General tab of the Preferences 
dialog determines how the dates are interpreted by KaleidaGraph.
 
When entering two digit years less than 40, the Promote 2 digit dates less than 40 option in the General tab of the 
Preferences dialog determines whether the dates are displayed as 19xx or 20xx.
 

Entering Text Data
To enter text data:

Click a cell in the data window.

Choose Data > Column Formatting or click  in the data window to display the Column Formatting palette.
Choose Text from the Type pop-up menu and click Apply.
Enter the text data. A maximum of 50 characters can be entered for each text label. If you make a mistake, press 

Delete (Mac) or Backspace (Windows) to remove incorrect characters.
Press the Return (Mac), Enter (Windows), or the Down Arrow key to move down one row.
Repeat steps 4 and 5 until all of the data is entered.

 

Missing Values
There may be times when data values are missing in a series of data. In the data window, KaleidaGraph represents a 
missing data value with an empty cell, regardless of the data type.
 
When plotting, if the independent variable (X) contains missing values, KaleidaGraph searches for the first and last cells 
that contain data and plots all values in between, ignoring any empty cells. If the dependent variable (Y) contains missing 
values, the empty cells are ignored when plotting.
 
There is an option in the General portion of the Plot Options dialog (Plot menu) that controls how missing values are 
treated in Line, Double Y, Double X, Double XY, High/Low, Step, X-Y Probability, and Polar plots. When Missing Data 
Breaks is selected, a missing data point in an X or Y variable causes a break in the line being plotted. Otherwise, the line 
is continuous and the missing data points are ignored.
 

Generating a Series
There are several methods that can be used to generate a series of data. Some of the default macros that come with 
KaleidaGraph can be used to create a data series. The Formula Entry window contains commands which can also be 
used to place a series into a column. The only problem is these methods do not give you very much control over the type 
of series that is generated.
 
The one method that does give you complete control is the Create Series command from the Functions menu. This 
command allows you to specify an initial value, an increment, a multiplier, and a final value for the series.
 
You can create a numeric series in any column that contains a Float, Double, or Integer data format. A date or time series 
can be created in any column that contains a Date or Time format.
 
Note: It is not possible to generate a series in a Text column.
 
To create a series:

Select a column or a range of columns in the data window.
Choose Functions > Create Series.
Enter the initial value, increment, multiplier, and final value into the appropriate fields of the Create Series dialog.
Click OK to generate the series.
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Generating Random Numbers
There are two methods available to fill a column with random numbers.
 
The first method is to use the Random# macro from the Macros menu. Choosing this macro allows you to fill a column in 
the data window with random numbers between the limits that you specify.
 
The second method is to use the ran() function in Formula Entry. This function generates a random number between zero 
and one, but this value can be multiplied by a constant to obtain random numbers over a wider range.
 

Opening a KaleidaGraph Data File
To open a KaleidaGraph data file:

Choose File > Open. To open the file into an existing data window, use the Merge command. When you choose 
one of these commands, the standard Open dialog appears.

Change the drive and directory as needed, select the file to be opened, and either click Open or double-click the 
file name. Multiple files can be opened at once by pressing Shift, Command (Mac), or Ctrl (Windows) and 
clicking the file name.

Note: If you open a text file, the Text File Input Format dialog appears. Use this dialog to specify the format of the text file.
 

Opening Microsoft Excel Files
KaleidaGraph can directly open files created in Microsoft Excel.
 
To open a Microsoft Excel file:

Choose File > Open.
Change the drive and directory as needed and select the file to be opened.
Click Open or double-click the file name.

If the Excel file contains extraneous information or if the file does not import as desired, you can either copy the data and 
paste it into KaleidaGraph or export the data in a text format and import the text file into KaleidaGraph.
 
If you are copying and pasting and the first row in the Excel file contains column titles, press the Shift key when pasting. 
This performs a Paste w/Titles so that the first row automatically gets used as the column titles in KaleidaGraph.
 
Note: If the data values contain more than seven digits, make sure your default column format is set to Double or round-

off errors will occur.
 

Importing Text Files
KaleidaGraph can open text files that are formatted in a number of different ways. This allows you to read data created in 
another program and use that data in KaleidaGraph. The only requirements are that the data must be saved as a text file 
and the information must be arranged in a repeating pattern.
 
To open a text file:

Choose File > Open. To open the file into an existing data window, use the Merge command. When you choose 
either of these commands, the standard Open dialog appears.

Change the drive and directory as needed, select the file to be opened, and either click Open or double-click the 
file name. The Text File Input Format dialog, shown below, appears.
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This dialog allows you to

Preview the text file, including whether or not to show the control characters.
Select the delimiter.
Indicate the number of delimiters between columns.
Specify the number of lines to skip at the beginning of a file.
Select whether or not to read titles into the data window.
Select the encoding to use when importing the text file.

Click OK to open the file into a new data window.

Please note the following:

KaleidaGraph will look for text files that have a .txt, .csv, or .dat  file name extension. For text files with some other 
extension, you need to choose All Documents from the pop-up menu in the Open dialog.

If the text appears garbled or as question marks or boxes, KaleidaGraph may not have accurately guessed the 
encoding used in the file. You can specify the encoding standard to be used in the File Settings tab of the 
Preferences dialog.

If the data values contain more than seven digits, make sure your default column format is set to Double or round-
off errors will occur.

 

Importing Missing Data Points
Missing data points can be entered from text files. If =1 is selected for the Number setting in the Text File Input Format 
dialog, whenever KaleidaGraph detects two consecutive delimiters, an empty cell is placed in the data window.
 
A period can also be used to represent an empty data cell. There is a mainframe program called SAS that uses the period 
as a default character for empty data cells.
 

Using the Special Format
If the delimiter is set to Special, the Text File Input Format dialog expands, as shown below. The Special format requires 
that you define the format of the text file by specifying which fields to read and which fields to skip.
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The settings in the Text File Input Format dialog related to the Special format are discussed below:
 
Help...
Clicking Help displays the definitions for the special format control characters. These characters are used in the Title 
Format and Data Format fields.
 
Some of these definitions display a lowercase letter and an uppercase letter enclosed in parentheses. The lowercase 
letter should be used to read that type of value. The uppercase letter should be used to skip that type of value.
 
Import from file...
Use this button to open a text file containing a previously saved title and data format.
 
Save to file...
Use this button to save the title format and data format to a text file.
 
Title Format:
The Title Format field specifies which labels are to be skipped or read into the data window. It is only necessary to enter a 
format in this field if Read Titles is selected. The title format does not have to be the same as the data format; however, 
you must read one title for each column being imported.
 
Data Format:
This field defines which data is to be skipped or read into the data window.
 

Special Format Control Strings
The following table lists the control strings that can be used to specify the Title and Data Formats when using the Special 
delimiter.
 
Note: White space characters include: <Space>, <Tab>, <Return>, and <Form Feed>.
 
s Skip a single character.
w Skip white space.
c Skip to the next line.
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ux Redefine white space to be the character x.
\ Do not flush the input buffer after each control line.
n(...) Repeat the pattern enclosed by parentheses n times
   
f (F) Read (Skip) a fixed width right justified number:
  f12 is a 12 character number.
v (V) Read (Skip) a number, separated by white space.
b (B) Read (Skip) a double, separated by white space.
l (L) Read (Skip) an integer, separated by white space.
   
a (A) Read (Skip) a label, separated by white space.
t (T) Read (Skip) a label, separated by <Tab>, <Return>, or <FF>.
   
y (Y) Read (Skip) a date in m/d/yy format.
d (D) Read (Skip) a date in d-m-yy format.
q (Q) Read (Skip) a date in y/m/d format.
e (E) Read (Skip) a date in y/month/d format.
k (K) Read (Skip) a date in m/d/yy h:m:s format.
p (P) Read (Skip) a date in d-m-yy h:m:s format.
r (R) Read (Skip) a date in y/m/d h:m:s format.
i (I) Read (Skip) a date in y/month/d h:m:s format.
h (H) Read (Skip) a time number in h:mm:ss.ss format.
m (M) Read (Skip) a time number in mm:ss.ss format.
 
 

Special Format Examples
The following table shows some example data format strings that can be used with the Special format. To see all of the 
available format strings, click the Help button in the Text File Input Format dialog.
 

Data Format Effect
w v v v Skips any white space at the beginning of each row before 

reading three variable width numbers.
v v v c Reads the first three columns of variable width numbers 

and skips everything else on the line.
v V v c Reads the first and third columns of variable width 

numbers and skips everything else on the line.
4(v) c 4(v) Takes a data set with four columns and places it into eight 

columns in the data window.
v v v \ Takes a data set with any number of columns and places it 

into three columns in the data window.
3(y f6 b b b) Repeats the pattern in parentheses three times. After 

executing this format, the data window would contain 12 
columns.

u, 8(v) Reads eight comma-separated columns containing 
variable width numbers.
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Editing Column Titles
The column titles are used to identify each of the data columns in the data window. These titles are used when selecting 
data columns for plotting or curve fitting. They are also used to label the plot legend and axes.
 
If the title is too long to fit inside the cell, KaleidaGraph will show ... in the middle of the title. You can mouse-over the 
column title to display the full name in a tool tip.
 
To change the title of a column:

Double-click the title of the column. The name of the current column will be selected.
Type a new column title.
Press Tab to edit the next column title.

 

Changing the Number Type and Formatting
Each column in the data window can contain numeric, date, time, or text data. KaleidaGraph supports six different data 
types: Float, Double, Integer, Date, Time, and Text. Most of these data types also have several formats available for 
displaying the data.
 
Note: Caution should be used when changing data types. Significant digits may be lost when applying a data type with 

less precision.
 
To change the format of the data in a column:

Select one or more columns in the data window.

Choose Data > Column Formatting or click  in the data window to display the Column Formatting palette.
Use the settings in the Number Type and Formatting portion of the palette to change the data type, format, and 

number of significant digits. You can also select whether or not to display the thousands separator and any 
trailing zeros.

Click Apply to update the selected columns.

 

Cutting, Copying, Pasting, and Clearing Data
There are several commands in the Edit menu that can be used to edit the contents of the data window. Using these 
commands, you can cut, copy, paste, and clear data selections.
 

Binary Mode/Text Mode Setting
This command controls whether the Cut and Copy commands use binary or text format to copy large amounts of data to 
the Clipboard. When copying 10,000 cells or less, a binary and text representation of the data are copied to the Clipboard. 
This occurs regardless of the current setting.
 
Text Mode should be used if you need to copy more than 10,000 cells and paste them into another application. The Edit
menu lists the active mode. Selecting the current mode will toggle to the other mode.
 

Cutting Data
Choose Edit > Cut to remove the data selection from the window and place it on the Clipboard, replacing the previous 
contents, if any.
 

Copying Data
Choose Edit > Copy to place a copy of the data selection on the Clipboard, replacing the previous contents, if any.
 

Pasting Data
Choose Edit > Paste to place the Clipboard’s contents into the data window. You can also paste data into the plot window, 
layout window, or another program.
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Clearing Data
Choose Edit > Clear to delete all of the cells in the selection without disturbing the contents of the Clipboard. To clear a 
cell’s contents without deleting the cell,click the Delete (Mac) or Backspace (Windows) key, or use the Clear Data
command.
 

Including Column Titles when Editing Data
To include the column titles when editing, press Shift while choosing the Cut, Copy, Paste, or Clear command from the 
Edit menu.
 

Sorting Data
KaleidaGraph can perform ascending and descending sorts on a column, a range of columns, or any data selection. Sorts 
can be applied to selections that contain any data format. If a column contains text, the state of the Use Locale Aware 
Sorting option in the Preferences dialog determines whether the text is sorted based on your location or the Unicode 
value.
 
To sort a range of data:

Select the data to be sorted. The selection can contain a few cells, columns, or the entire data window.

Choose Ascending Sort or Descending Sort from the Functions menu or click  or  in the data window. 
The Sort dialog appears, with the names of any selected columns already highlighted. The first column in the 
selection is automatically assigned as Sort Key 1.

To perform a multi-level sort, click the name of the column to be used as the second sort key, click the Sort Key 2
section, and click Add Key. Repeat these steps for Sort Key 3, if necessary.

Select all of the columns to be sorted.

To select individual columns, press Shift, Command (Mac), or Ctrl (Windows) and click the column name.
To select a range of columns, drag with the mouse.
To select every column in the data window, click All.
To deselect a column, press Command (Mac) or Ctrl (Windows) and click the column name.

Click OK to perform the sort.

 

Transposing Data
You can exchange rows and columns in the data window. When you use the Transpose command, the columns are 
converted to rows and the rows to columns. For example, if a selection contains four columns and 128 rows, it contains 
128 columns and four rows after transposing the data.
 
To switch rows and columns:

Make a selection in the data window.
Choose Functions > Transpose. The selected data is transposed and displayed in the data window.

 
 An error message is displayed if either of the following occurs:

You attempt to transpose a selection containing text data.
Your selection contains more than 1000 rows, because the data window is limited to a maximum of 1000 columns.

 

Masking Data
Masking data provides a way to leave data in the data window but not have it used in any calculations, curve fits, or plots. 
Any cells that are masked have a red frame in the data window, as shown in the data window below.
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Data can be masked using any of the following: the Mask command (Functions menu), the Data Selection tool, macros, 
and Formula Entry.
 
The Unmask command (Functions menu) can be used to unmask selected data cells. The Invert Mask command 
(Functions menu) can be used to mask unmasked cells and unmask masked cells.
 

The , , and  buttons in the data window can be used to perform the mask, unmask, and invert mask functions, 
respectively.
 
Note: If a Formula Entry function or macro overwrites an existing column containing masked cells, the masking will be 

removed in that column.
 
To mask data with the Mask command:

Select the cells to be masked.
Choose Functions > Mask. A red frame is drawn around each of the masked cells.

 

Executing Macros
Macros can be used to perform a variety of data operations, including those required for data analysis. KaleidaGraph 
contains several default macros in the Macros menu. Some of these macros are used to create data series and others 
are used to manipulate and analyze data.
 
To execute a macro:

Open the data window to be operated on by the macro.
Choose a macro from the Macros menu. Choosing a macro from the menu automatically causes it to be executed. 

Some macros may prompt for specific information during execution.
Type the appropriate values into any dialogs that appear. Click OK to continue execution or Cancel to stop the 

macro.

 

Saving Data
To save the data, choose Save Data or Save Data As from the File menu when the data window is active. If the Save 
Data command is used on a window that has not been saved before, a Save dialog appears, allowing you to specify the 
location and file name.
 
To save the data in a text format:

Choose File > Save Data As.
Select the type of text file to be saved from the pop-up menu in the Save dialog.
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3. Specify the location and file name for the text file and click Save.

Note: You can specify the encoding standard to be used in the File Settings tab of the Preferences dialog.
 
 

Printing Data
To print the current data set, choose File > Print. To print a subset of the data, make a selection in the data window before 
printing or edit the page range in the Print dialog.
 
The options available in the Print dialog depend on the printer and operating system.
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Viewing Column Statistics
KaleidaGraph provides 12 different statistics to help analyze data. These statistics are automatically calculated for each 
column in the data window.
 
To view statistics on a data set:

Select the data for which you want the statistics calculated. If you do not make a selection, the statistics are 
calculated for each column in the data window.

Choose Functions > Statistics or click  in the data window. The Statistics dialog has a split-screen display so 
that any two columns can be compared.

Click Copy to Clipboard if you want to paste this information into a data, plot, or layout window. You can also 
select the Transposed check box so that when the data is copied, each statistic becomes a column and the 
different variables become rows.

When you are finished, click OK.

 

Binning Data
Binning data involves counting the number of data points that fall within a certain range. The binned data distribution can 
be exported in any one of three formats for plotting or for annotating a plot.
 

Binning the Data
To bin the data:

Select one or more columns containing the variables to be binned.
Choose Functions > Bin Data to display the Bin Data dialog.
Bin the variables by specifying the minimum and maximum values, number of bins, Y units, and where to show the 

counts. If you make any changes to the minimum, maximum, or number of bins, click Recalculate to update 
the count.

Select the appropriate Export Format for the type of plot to be created.
Click Copy to Clipboard.
Click OK.

Pasting Results from the Bin Data dialog
Once the data is binned, it can be pasted into a new data window.

Choose File > New to create a blank data window.
Choose Edit > Paste to place the results into the data window.

Creating the Plot

Choose the proper plot type from the Gallery menu.

Histogram - For a single variable, choose Gallery > Bar > Column. For multiple variables, choose Gallery > 
Bar > Stack Column.

Step Plot - Choose Gallery > Linear > Line.
Spike Plot - Choose Gallery > Linear > High/Low.

Select the variables to be plotted.

Histogram - Select Histogram X for the X variable and one or more binned columns for the Y variables.
Step Plot - Select Step X for the X variable and one or more binned columns for the Y variables.
Spike Plot - Select Spike X for the X variable, plus a binned column and Zero for the Y variables.

Click Plot.
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The following three figures show the different plot types that can be created. All three were generated from the same 
original data set, using the same settings in the Bin Data dialog. The only difference was the Export Format.
 

         

    

Histogram Step Plot Spike Plot

Reorganizing Grouped Data
Often times when collecting data you will have one or more data columns in addition to the X and Y data that identify 
factors about the data (such as sex, drug, observation, etc.). The Slice Data command in the Functions menu can be 
used to reorganize the Y data using up to three different factor columns. This allows you to easily analyze or plot the 
various subsets independently.
 
To reorganize the data:

Select the column that you want to reorganize.
Choose Functions > Slice Data to display the Slice Data dialog.
Double-click the name of the column to be used as the first factor. You can also click the name of the column and 

click the 1st Factor button. You can use the same method to assign any additional factors.
Make any changes to the output options at the bottom of the dialog.
Click OK. The reorganized data will be appended to the current data window. The Y data will remain in the same 

row; it will just be copied over into the new columns.

 
The dialog below shows an example data set after using the Slice Data command. The level column contains the original 
Y data and the drug column was selected as the only factor column. Three columns were appended to the data window; 
one for the summary data and two for the types of drugs in the factor column. Now that the data has been reorganized, it 
would be possible to analyze the two groups independently.
 

 

Choosing a Statistical Test
KaleidaGraph can be used to perform a variety of statistical tests. The type of test to use depends on the number of 
samples and the nature of the data.

Use a single sample test to analyze one sample to a known or hypothesized value.
Use a group comparison test to analyze two or more different samples for statistically significant differences.
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Use a repeated measures test to analyze the differences in two or more matched samples (such as the same 
individuals before and after one or more treatments).

 
The table below shows the proper test to use for each experiment and the type of data collected.
 

Type of Experiment Type of Data
Numeric (normally distributed with 
equal variances)

Rank, score, or numeric (not normally 
distributed with equal variances)

Compare one sample to a 
hypothetical value

One sample t-test Wilcoxon signed rank test

Compare two paired samples Paired t-test Wilcoxon matched pairs test
Compare two unpaired samples Unpaired t-test Wilcoxon-Mann-Whitney test
Compare three or more matched 
samples

One way or Two way repeated 
measures ANOVA

Friedman test

Compare three or more unmatched 
samples

One way or Two way ANOVA Kruskal-Wallis test

 

Parametric and Nonparametric Tests
The statistical tests in KaleidaGraph can be divided into two categories: parametric and nonparametric.

Parametric Tests
Parametric tests assume the samples are drawn from a population that is normally distributed with equal variances. 
Examples of parametric tests include the t-test and analysis of variance (ANOVA).
 
In general, you should use a parametric test if you are confident that the samples are drawn from a normally distributed 
population.

Nonparametric Tests
Nonparametric tests (or distribution-free tests) do not make any assumptions about the distribution of the data. These 
tests rank the data from low to high and analyze the rank. Examples of nonparametric tests include the Wilcoxon, Kruskal-
Wallis, and Friedman tests.
 
In general, you should use a nonparametric test if the data represents a rank or score, or if the measurements are drawn 
from a population that is not normally distributed.
 

Overview: Analyzing One Sample
KaleidaGraph provides two tests that can be used to determine whether the mean or median of a single sample differs 
significantly from a hypothetical value. The two tests are listed below:

Use a single sample t-test if the sample was taken from a normally distributed population. This is a parametric test 
that compares the mean of a single sample to a known or hypothesized value.

Use a Wilcoxon signed rank test if the sample was taken from a non-normally distributed population or if the data 
consists of ranks or scores. This is a nonparametric test that compares the median of a single sample to a 
known or hypothesized value.

 

Entering Data for One Sample Tests
The single sample t-test and the Wilcoxon signed rank test both require that the observations for the sample be entered 
into a single data column. If the data includes a grouping variable, it can be included. However, the grouping variable will 
not be used in either of these analyses.
 

Performing a Single Sample t-Test
Use this test when you want to compare the mean of a sample to a known or hypothesized value.
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To perform a single sample t-test:

Choose Functions > Student t to display the Student t-Test dialog.
Click the single group button.
Select the column to be tested by either clicking the column name and pressing Group 1 or double-clicking the 

column name.
Enter the known or hypothesized value in the Test Value field.
Verify Show group information is selected to have the group statistics displayed.
Click Calculate. The results of the test are displayed on the right side of the dialog.
To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout 

window.
To print the results, click the Print Results button.
Click OK to return to the data window.

 

Results of a Single Sample t-Test
The following values are calculated when performing a single sample t-test:

mean difference - This value indicates the difference between the mean and the test value.
degrees of freedom - This is a measure of the sample size.
t value - The Student’s t statistic, which is calculated using the following formula:

        

t probability - This value (also known as P) determines if there is a statistically significant difference between the 
mean of the sample and the hypothetical mean. If this value is below a certain level (usually 0.05), the 
conclusion is that there is a difference between the two.

 
In the formula above, = mean of the data.
 

Performing a Wilcoxon Signed Rank Test
Use this test to compare the median of a single sample to a known or hypothesized value.
 
This is a nonparametric test that does not require that the samples be drawn from a normally distributed population. If you 
know that the sample is normally distributed, use a single sample t-test instead.
 
To perform a Wilcoxon signed rank test:

Choose Functions > Wilcoxon to display the Wilcoxon Test dialog.
Click the single group button.
Select the column to be tested by either clicking the column name and pressing Group 1 or double-clicking the 

column name.
Enter the known or hypothesized value in the Test Value field.
Click Calculate. The results of the test are displayed on the right side of the dialog.
To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout 

window.
To print the results, click the Print Results button.
Click OK to return to the data window.
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Results of a Wilcoxon Signed Rank Test
The following values are provided after performing a Wilcoxon signed rank test:

median difference - This value indicates the difference between the median and the test value.
sum of positive ranks - This value represents the sum of the ranks for values that are greater than the test value.
sum of negative ranks - This value represents the sum of the ranks for values that are less than the test value.
P value - This value determines if there is a statistically significant difference between the median of the sample 

and the hypothetical median. If this value is below a certain level (usually 0.05), the conclusion is that there is 
a difference between the two.

P value method - This indicates how the P value was calculated in KaleidaGraph.

 

Overview: Analyzing Two or More Groups
KaleidaGraph provides five tests that can be used to analyze two or more different samples for a significant difference in 
the mean or median values. The proper test to use depends on the number of samples and the distribution of the data.

Comparing Two Groups
If data was collected from two different groups of subjects (for example, male and female manatees), use one of the 
following group comparison tests:

Use the unpaired t-test if the samples were taken from normally distributed populations with equal variances. This 
is a parametric test that compares the sample data directly.

Use the Wilcoxon-Mann-Whitney test if the samples were taken from non-normally distributed populations or if the 
data consists of ranks or scores. This is a nonparametric test that ranks the data, and analyzes the ranks 
instead of the raw data.

Comparing Three or More Groups
If the samples were taken from normally distributed populations with equal variances, use one of the following group 
comparison tests:

Use a one way ANOVA to compare the effect of a single factor on the mean of three or more groups (for example, 
the effect of three drugs on a group of test animals).

Use a two way ANOVA to compare the effect of two different factors on the mean of three or more groups (for 
example, the effect of three drugs given at different times during the day to a group of test animals).

 
If the samples were taken from non-normally distributed populations or if the data consists of ranks or scores, use the 
Kruskal-Wallis test.
 
Note: If you find a statistically significant difference using the one way ANOVA, you can use one of the post hoc tests to 

determine which groups are different.
 

Entering Data for Group Comparison Tests
The group comparison tests in KaleidaGraph require that the data be entered in one of two ways:

as raw data, where the data for each group is entered into a separate column (see examples).
as indexed data, where one of the columns is a factor column or grouping variable, with the corresponding data 

points in one or more columns (see examples).

 
You can use raw data for all of the tests except the two way ANOVA. The two way ANOVA requires one or two factor 
columns and one or more data columns.
 
Note: The groups do not have to be the same size, unless you are using the two way ANOVA. The two way ANOVA 

assumes you are using balanced data. Any rows containing masked or empty cells are ignored.
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Raw Data Examples - Group Comparisons
unpaired t-test and Wilcoxon-Mann-Whitney test
 

 

one way ANOVA and Kruskal-Wallis test
 

 

Indexed Data Examples - Group Comparisons
unpaired t-test and Wilcoxon-Mann-Whitney test
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one way ANOVA and Kruskal-Wallis test
 

 

two way ANOVA
 

(one factor column and four columns containing the data values)
 

(two factor columns and one column containing the data values)
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Performing an Unpaired t-Test
Use this test to compare the means of two independent samples. This test can be performed on columns of different 
length, since no relationship is assumed between the samples. As a special case, if Group 1 is assigned a Text column, it 
is used as a grouping variable (for example, gender) to separate the data in the second column into two groups.
 
To perform an unpaired t-test:

Choose Functions > Student t to display the Student t-Test dialog.
Click the unpaired data with equal variance or unpaired data with unequal variance button.
Select the columns to be tested by either clicking the column name and pressing a Group button or double-clicking 

the column names. If you are using a Text column as a grouping variable, it must be assigned to Group 1.
Verify F Test and Show group information are selected to have the F, F probability, and group statistics 

displayed.
Click Calculate. The results of the test are displayed on the right side of the dialog.
To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout 

window.
To print the results, click the Print Results button.
Click OK to return to the data window.

 

Results of an Unpaired t-Test
The following values are calculated when performing an unpaired t-test:

mean difference - This value indicates the difference between the two means.
degrees of freedom - This is a measure of the sample size.
t value - The Student’s t statistic, which is calculated using one of the following formulas:

        unpaired data with equal variance

        
        unpaired data with unequal variance

        

t probability - This value (also known as P) determines if there is a statistically significant difference between the 
two means. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference 
between the two group means.

F value - This value is the ratio of the larger variance over the smaller one.
F probability - This value determines if the two groups have different variances. A small F probability value 

(usually less than 0.05) indicates that the two groups have significantly different variances.

 
In the formulas above,
N = number of data points

 = mean of the data

 = current data value (from 1 to N)
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Performing a Wilcoxon-Mann-Whitney Test
Use this test to see if two different samples have been drawn from the same population. This test can be performed on 
columns of different length, since no relationship is assumed between the samples. As a special case, if Group 1 is 
assigned a Text column, it is used as a grouping variable (for example, gender) to separate the data in the second column 
into two groups.
 
This test assumes the samples are not normally distributed with the same variances. If you know that the samples are 
normally distributed, use an unpaired t-test instead. If there are more than two samples to compare, use the Kruskal-
Wallis test.
 
To perform a Wilcoxon-Mann-Whitney test:

Choose Functions > Wilcoxon to display the Wilcoxon Test dialog.
Click the unpaired data button.
Select the columns to be tested by either clicking the column name and pressing a Group button or double-clicking 

the column names. If you are using a Text column as a grouping variable, it must be assigned to Group 1.
Click Calculate. The results of the test are displayed on the right side of the dialog.
To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout 

window.
To print the results, click the Print Results button.
Click OK to return to the data window.

 

Results of a Wilcoxon-Mann-Whitney Test
The following values are calculated when performing a Wilcoxon-Mann-Whitney test:

median difference - This value indicates the difference between the medians of the two groups.
sum of Group 1 ranks - This value represents the sum of the ranks for the values in Group 1.
sum of Group 2 ranks - This value represents the sum of the ranks for the values in Group 2.
Group1 U - This value represents the Wilcoxon-Mann-Whitney statistic (U) for Group 1, which is calculated using 

the following formula:

        

Group2 U - This value represents the Wilcoxon-Mann-Whitney statistic (U′) for Group 2, which is calculated using 
the following formula:

        

P value - This value determines if there is a statistically significant difference between the medians of the two 
groups. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between 
the two.

P value method - This indicates how the P value was calculated in KaleidaGraph.

 
In the formulas above,

 and  are the number of observations in Groups 1 and 2, respectively

 is the sum of the Group 1 ranks
 

Performing a One Way ANOVA
Use this test when you want to see if the means of three or more different groups are affected by a single factor. This test 
is the same as the unpaired t-test, except that more than two groups can be compared.
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This is a parametric test that assumes the samples are drawn from normally distributed populations with equal variances. 
If you know that the samples are not normally distributed, use the Kruskal-Wallis test. If there are only two samples to 
compare, use an unpaired t-test.
 
To perform a one way ANOVA:

Choose Functions > ANOVA to display the ANOVA dialog.
Assign the data columns containing the measured values to the Dependent(s) list.
If you are using indexed data, assign the factor column to the Factor(s) list. In this case, only one dependent 

column should be used. If you assign multiple columns to the Dependent(s) list, a two way ANOVA will be 
performed.

Click Calculate. The results of the test are displayed in the bottom half of the dialog.
If you find a statistically significant difference, you can use one of the post hoc tests to determine which groups are 

different and the size of the difference.
To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout 

window.
To print the results, click the Print Results button.
Click OK to return to the data window.

 

Results of a One Way ANOVA
The following values are calculated when performing a one way ANOVA. Please refer to the references cited for the 
equations used to calculate the degrees of freedom, sum of squares, and mean square values.
 
DF (degrees of freedom) - Three degrees of freedom values are reported in this column of the results table:

The total degrees of freedom equals the total sample size minus 1.
The groups’ degrees of freedom equals the number of groups minus 1.
The error degrees of freedom equals the total sample size minus the number of groups.

 
SS (sum of squares) - Three sum of squares values are reported in this column of the results table:

The total sum of squares measures the total variability of the samples in relation to the grand mean (the overall 
mean of the samples).

The groups’ sum of squares measures the variability between group means.
The error sum of squares measures the variability of the individual samples.

 
MS (mean square) - Three mean square values are reported in this column of the results table:

The total mean square is the ratio of the total sum of squares over the total degrees of freedom.
The groups’ mean square is the ratio of the groups’ sum of squares over the groups’ degrees of freedom.
The error mean square is the ratio of the error sum of squares over the error degrees of freedom.

 
F value - This value is the ratio of the groups’ mean square over the error mean square. If this value is close to 1.0, you 
can conclude that there are no significant differences between the groups. If this value is large, you can conclude that one 
or more of the samples was drawn from a different population. To determine which groups are different, use one of the 
post hoc tests.
 
P value - This value determines if there is a statistically significant difference between the groups. If this value is below a 
certain level (usually 0.05), the conclusion is that there is a difference between the groups.
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Performing a Two Way ANOVA
Use this test when you want to see if the means of three or more different groups are affected by two factors. A two way 
ANOVA tests three hypotheses:

There is no difference among the levels of the first factor.
There is no difference among the levels of the second factor.
There is no interaction between the factors.

 
This is a parametric test that assumes the samples are drawn from normally distributed populations with equal variances. 
If you want to see the effect of only one factor on your data, use a one way ANOVA. KaleidaGraph does not have a 
nonparametric equivalent to the two way ANOVA.
 
Note: The two way ANOVA ignores any rows that contain masked or empty cells. Each of the factors must have an equal 

number of observations.
 
To perform a two way ANOVA:

Choose Functions > ANOVA to display the ANOVA dialog.
Assign the data columns containing the measured values to the Dependent(s) list.
Assign one or two factor columns to the Factor(s) list. If two factor columns are assigned, only one dependent 

column may be used.
Click Calculate. The results of the test are displayed in the bottom half of the dialog.
To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout 

window.
To print the results, click the Print Results button.
Click OK to return to the data window.

 

Results of a Two Way ANOVA
The following values are calculated when performing a two way ANOVA. Please refer to the references cited for the 
equations used to calculate the degrees of freedom, sum of squares, and mean square values.
 
DF (degrees of freedom) - Five degrees of freedom values are reported in this column of the results table:

The total degrees of freedom equals the total sample size minus 1.
The degrees of freedom for each factor equals the number of levels in the factor minus 1.
The interaction degrees of freedom equals the product of the degrees of freedom of factors A and B.
The error degrees of freedom equals the total degrees of freedom minus the factors and interaction degrees of 

freedom.

 
SS (sum of squares) - Five sum of squares values are reported in this column of the results table:

The total sum of squares measures the total variability of the data.
The sum of squares for each factor measures the variability among the levels of each factor.
The interaction sum of squares provides a gauge of the interaction between the factors.
The error sum of squares measures the random variation in the data.

 
MS (mean square) - Five mean square values are reported in this column of the results table:

The total mean square is the ratio of the total sum of squares over the total degrees of freedom.
The mean square of each factor is the ratio of the sum of squares for the factor over the degrees of freedom for 

the factor.
The interaction mean square is the ratio of the interaction sum of squares over the interaction degrees of freedom.
The error mean square is the ratio of the error sum of squares over the error degrees of freedom.
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F value - The F value is calculated for each of the factors and the interaction. For each factor, this value is the ratio of the 
mean square of the factor over the error mean square. For the interaction, it is the ratio of the interaction mean square 
over the error mean square.
 
If the F value is close to 1.0, you can conclude that there are no significant differences between the factor levels or that 
there is no interaction between the factors. If this value is large, you can conclude that one or more of the samples for that 
factor or combination of factors was drawn from a different population.
 
P value - This value determines if there is a statistically significant difference between the groups. If this value is below a 
certain level (usually 0.05), the conclusion is that there is a difference between the groups.
 

Performing a Kruskal-Wallis Test
Use this test when you want to see if three or more groups are affected by a single factor.
 
This is a nonparametric test that does not require that the samples be drawn from a normally distributed population. If you 
know that the samples are normally distributed, use the one way ANOVA. If there are only two samples to compare, use 
the Wilcoxon-Mann-Whitney test.
 
To perform a Kruskal-Wallis test:

Choose Functions > Kruskal-Wallis to display the Kruskal-Wallis dialog.
Assign the data columns containing the measured values to the Dependent(s) list.
If you are using indexed data, assign the factor column to the Factor(s) list. In this case, only one dependent 

column may be used.
Click Calculate. The results of the test are displayed in the bottom half of the dialog.
To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout 

window.
To print the results, click the Print Results button.
Click OK to return to the data window.

 

Results of a Kruskal-Wallis Test
The following values are calculated when performing a Kruskal-Wallis test:

Kruskal-Wallis statistic - This value represents the Kruskal-Wallis test statistic (H), which is calculated using the 
following formula:

        .

P value - This value represents the P value that corresponds to the Kruskal-Wallis statistic. It determines if there is 
a statistically significant difference between the medians of the groups. If this value is below a certain level 
(usually 0.05), the conclusion is that there is a difference between the groups.

Method - This indicates how the P value was calculated in KaleidaGraph.

 
In the formula above,

is the number of groups

 is the number of observations in group i

is the total number of observations in all k groups

 is the sum of the ranks of the n(i) observations in group i
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Overview: Analyzing Repeated Measurements
KaleidaGraph provides five tests that can be used to analyze two or more matched samples for a significant difference in 
the mean or median values. The proper test to use depends on the number of samples and the distribution of the data.

Comparing Two Groups
If data was collected from the same group of subjects (for example, the gas mileage for a number of cars before and after 
receiving a tune-up), use one of the following repeated measures tests:

Use the paired t-test if the samples were taken from normally distributed populations with equal variances. This is 
a parametric test that compares the sample data directly.

Use the Wilcoxon matched pairs test if the samples were taken from non-normally distributed populations or if the 
data consists of ranks or scores. This is a nonparametric test that ranks the data, and analyzes the ranks 
instead of the raw data.

Comparing Three or More Groups
To compare data collected from three or more matched groups, use the one way repeated measures ANOVA, two way 
repeated measures ANOVA, or Friedman test.
 
If the samples were taken from normally distributed populations with equal variances, use the one way or two way 
repeated measures ANOVA.

Use a one way repeated measures ANOVA to compare the effect of a single factor on the mean of three or more 
matched groups (for example, comparing the effects of a drug on a group of subjects before, during, and after 
the treatment).

Use a two way repeated measures ANOVA to compare the effect of two different factors on the mean of three or 
more matched groups (for example, comparing the effects of a drug on males and females before, during, and 
after the treatment).).

 
If the samples were taken from non-normally distributed populations or if the data consists of ranks or scores, use the 
Friedman test.
 
Note: If you find a statistically significant difference using the one way repeated measures ANOVA, you can use one of the 

post hoc tests to determine which groups are different.
 

Entering Data for Repeated Measurements
The repeated measurement tests in KaleidaGraph require that the data be entered as raw data, where the data for each 
treatment is entered into a separate column (see examples).
 
The only exception is the two way repeated measures ANOVA, which requires indexed data. In this case, one of the 
columns is a factor column or grouping variable, with the corresponding data points in two or more columns (see 
examples).
 
Note: Each group being analyzed must have the same number of observations.
 

Data Examples - Repeated Measurements
paired t-test and Wilcoxon matched pairs test
 



KaleidaGraph 5.0 User Guide

Page 54

 

one way repeated measures ANOVA and Friedman test
 

 

two way repeated measures ANOVA
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Performing a Paired t-Test
Use this test to compare means on the same or related subjects over time or under different conditions. This test requires 
columns of equal length. Any missing or extra values are skipped when running this test.
 
To perform a paired t-test:

Choose Functions > Student t to display the Student t-Test dialog.
Click the paired data button.
Select the columns to be tested by either clicking the column name and pressing a Group button or double-clicking 

the column names.
Verify Correlation and Show group information are selected to have the correlation, correlation probability, and 

group statistics displayed.
Click Calculate. The results of the test are displayed on the right side of the dialog.
To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout 

window.
To print the results, click the Print Results button.
Click OK to return to the data window.

 

Results of a Paired t-Test
The following values are calculated when performing a paired t-test:

mean difference - This value indicates the difference between the two means.
degrees of freedom - This is a measure of the sample size.
t value - The Student’s t statistic, which is calculated using the following formula:

        

t probability - This value (also known as P) determines if there is a statistically significant difference between the 
two means. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference 
between the two group means.

correlation - This value represents the linear correlation coefficient between the two groups. The closer this value 
is to 1.0, the closer they are correlated. The correlation is calculated using the following formula:

        

correlation probability - This value determines if there is a correlation between the two groups. A small 
correlation probability (usually less than 0.05) indicates that the two groups are significantly correlated.

 
In the formulas above,
N = number of data points

 = mean of the data
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 = current data value (from 1 to N)
 

Performing a Wilcoxon Matched Pairs Test
Use this test to compare the median values on the same or related subjects over time or under different conditions. This 
test requires columns of equal length. Any missing or extra values are skipped when running this test.
 
This test assumes the samples are not normally distributed with the same variances. If you know that the samples are 
normally distributed, use a paired t-test instead. If there are more than two samples to compare, use the Friedman test.
 
To perform a Wilcoxon matched pairs test:

Choose Functions > Wilcoxon to display the Wilcoxon Test dialog.
Click the paired data button.
Select the columns to be tested by either clicking the column name and pressing a Group button or double-clicking 

the column names.
Click Calculate. The results of the test are displayed on the right side of the dialog.
To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout 

window.
To print the results, click the Print Results button.
Click OK to return to the data window.

 

Results of a Wilcoxon Matched Pairs Test
The following values are provided after performing a Wilcoxon matched pairs test:

median difference - This value indicates the difference between the medians of the two groups.
sum of positive ranks - After calculating the differences between the two groups, this value represents the sum of 

the ranks for the differences where Group 1 was higher (positive ranks).
sum of negative ranks - After calculating the differences between the two groups, this value represents the sum 

of the ranks for the differences where Group 2 was higher (negative ranks).
P value - This value determines if there is a statistically significant difference between the medians of the two 

groups. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between 
the two.

P value method - This indicates how the P value was calculated in KaleidaGraph.

 

Performing a One Way Repeated Measures ANOVA
Use this test when you want to see if the same group of individuals is affected by a single factor. This test is the same as 
the paired t-test, except that more than two treatments can be compared.
 
This is a parametric test that assumes the samples are drawn from normally distributed populations with equal variances. 
If you know that the samples are not normally distributed, use the Friedman test. If there are only two samples to 
compare, use a paired t-test.
 
Note: This test requires columns of equal length. If any missing or extra values are found, a one way ANOVA is performed 

on the data. You cannot use a Factor column with this test.
 
To perform a one way repeated measures ANOVA:

Choose Functions > ANOVA to display the ANOVA dialog.
Assign the data columns containing the measured values to the Dependent(s) list.
Click the Repeated Measures check box.
Enter a label in the Repeating Factor Name field. This label will appear in the ANOVA results.
Click Calculate. The results of the test are displayed in the bottom half of the dialog.
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If you find a statistically significant difference, you can use one of the post hoc tests to determine which groups are 
different and the size of the difference.

To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout 
window.

To print the results, click the Print Results button.
Click OK to return to the data window.

 

Results of a One Way Repeated Measures ANOVA
The following values are calculated when performing a one way repeated measures ANOVA. Please refer to the 
references cited for the equations used to calculate the degrees of freedom, sum of squares, and mean square values.
 
DF (degrees of freedom) - Four degrees of freedom values are reported in this column of the results table:

The total degrees of freedom equals the total sample size minus 1.
The treatment degrees of freedom equals the number of treatments (columns) minus 1.
The subject degrees of freedom equals the number of subjects (rows) minus 1.
The error degrees of freedom equals the total sample size minus the sum of the treatment and subject degrees of 

freedom.

 
SS (sum of squares) - Four sum of squares values are reported in this column of the results table:

The total sum of squares measures the total variability of the data.
The treatment sum of squares measures the variability of the mean treatment responses within the subjects.
The subject sum of squares measures the variability of the average responses of each subject.
The error sum of squares measures the variability of the data after accounting for the differences between 

subjects.

 
MS (mean square) - Four mean square values are reported in this column of the results table:

The total mean square is the ratio of the total sum of squares over the total degrees of freedom.
The treatment mean square is the ratio of the treatment sum of squares over the treatment degrees of freedom.
The subject mean square is the ratio of the subject sum of squares over the subject degrees of freedom.
The error mean square is the ratio of the error sum of squares over the error degrees of freedom.

 
F value - The F value is calculated for both the treatment and the subject. For the treatment, this value is the ratio of the 
treatment mean square over the error mean square. For the subject, it is the ratio of the subject mean square over the 
error mean square.
 
If this value is close to 1.0, you can conclude that there are no significant differences among treatments. If this value is 
large, you can conclude that the treatments have different effects. To determine which treatments are different, use one of 
the post hoc tests.
 
P value - This value determines if there is a statistically significant difference between the treatments. If this value is below 
a certain level (usually 0.05), the conclusion is that there is a difference between the treatments.
 

Performing a Two Way Repeated Measures ANOVA
Use this test when you want to see if the same group of individuals is affected by two factors. At least one of these factors 
is a repeated treatment on the same group of individuals. A two way repeated measures ANOVA tests three hypotheses:

There is no difference among the levels or treatments of the first factor.
There is no difference among the levels or treatments of the second factor.
There is no interaction between the factors.
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This is a parametric test that assumes the samples are drawn from normally distributed populations with equal variances. 
If you want to see the effect of only one factor on your groups, use a one way repeated measures ANOVA. KaleidaGraph 
does not have a nonparametric equivalent to the two way repeated measures ANOVA.
 
Note: Each group must have the same number of observations for this test.
 
To perform a two way repeated measures ANOVA:

Choose Functions > ANOVA to display the ANOVA dialog.
Assign the data columns containing the measured values to the Dependent(s) list.
Assign a factor column to the Factor(s) list.
Click the Repeated Measures check box.
Enter a label in the Repeating Factor Name field. This label will appear in the ANOVA results.
Click Calculate. The results of the test are displayed in the bottom half of the dialog.
To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout 

window.
To print the results, click the Print Results button.
Click OK to return to the data window.

 

Results of a Two Way Repeated Measures ANOVA
The following values are calculated when performing a two way repeated measures ANOVA. Please refer to the 
references cited for the equations used to calculate the degrees of freedom, sum of squares, and mean square values.
 
DF (degrees of freedom) - Six degrees of freedom values are reported in this column of the results table:

The total degrees of freedom equals the total sample size minus 1.
The degrees of freedom for each factor equals the number of levels in the factor minus 1.
The interaction degrees of freedom equals the product of the degrees of freedom of factors A and B.
The subject degrees of freedom is a measure of the number of subjects (rows).
The error degrees of freedom equals the total degrees of freedom minus the factors, interaction, and subject 

degrees of freedom.

 
SS (sum of squares) - Six sum of squares values are reported in this column of the results table:

The total sum of squares measures the total variability of the data.
The sum of squares for each factor measures the variability of treatments in each factor.
The interaction sum of squares measures the variability of treatments for both factors.
The subject sum of squares measures the variability of all subjects.
The error sum of squares measures the underlying variation of the data.

 
MS (mean square) - Six mean square values are reported in this column of the results table:

The total mean square is the ratio of the total sum of squares over the total degrees of freedom.
The mean square of each factor is the ratio of the sum of squares for the factor over the degrees of freedom for 

the factor.
The interaction mean square is the ratio of the interaction sum of squares over the interaction degrees of freedom.
The subject mean square is the ratio of the subject sum of squares over the subject degrees of freedom.
The error mean square is the ratio of the error sum of squares over the error degrees of freedom.
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F value - The F value is calculated for each of the factors, the interaction, and the subjects. If this value is close to 1.0, 
you can conclude that there are no significant differences among treatments. If this value is large, you can conclude that 
the treatments have different effects.

For the first factor, this value is the ratio of the factor mean square over the subject mean square.
For the second factor, it is the ratio of the factor mean square over the error mean square.
For the interaction, it is the ratio of the interaction mean square over the error mean square.
For the subjects, it is the ratio of the subject mean square over the error mean square.

 
P value - This value determines if there is a statistically significant difference between the treatments. If this value is below 
a certain level (usually 0.05), the conclusion is that there is a difference between the treatments.
 

Performing a Friedman Test
Use this test when you want to see if a single group of individuals is affected by a series of three or more treatments.
 
This is a nonparametric test that does not require that the samples be drawn from a normally distributed population. If you 
know that the samples are normally distributed, use the one way repeated measures ANOVA. If there are only two 
samples to compare, use the Wilcoxon matched pairs test.
 
Note: This test requires columns of equal length.
 
To perform a Friedman test:

Choose Functions > Friedman to display the Friedman Test dialog.
Assign the data columns containing the measured values to the Dependent(s) list.
Click Calculate. The results of the test are displayed in the bottom half of the dialog.
To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout 

window.
To print the results, click the Print Results button.
Click OK to return to the data window.

 

Results of a Friedman Test
The following values are calculated when performing a Friedman test:

Friedman statistic - This value represents the Friedman chi-square statistic ( ), which is calculated using the 
following formula:

        

P value - This value represents the P value that corresponds to the Friedman chi-square statistic. It determines if 
there is a statistically significant difference between the groups. If this value is below a certain level (usually 
0.05), the conclusion is that there is a difference between the groups.

Method - This indicates how the P value was calculated in KaleidaGraph.

F F statistic - This value represents the Friedman test statistic ( ), which is distributed according to the F-
distribution. This form of the Friedman test is often known as the Iman-Davenport correction of the Friedman 
test. It is calculated using the following formula:
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F F P value - This value represents the P value that corresponds to the Friedman test statistic. It determines if 
there is a statistically significant difference between the groups. If this value is below a certain level (usually 
0.05), the conclusion is that there is a difference between the groups.

DF - This value indicates the degrees of freedom.
Kendall’s Concordance - This value represents Kendall’s coefficient of concordance (W). The value of W will 

range from zero (where there is no association between the groups) to one (where there is complete 
agreement among the rankings of the groups). This value is calculated using the following formula:

        
 
In the formulas above,

is the number of groups

 is the number of rows (blocks)

 is the sum of the ranks within each group

 is the Friedman test statistic
 

Choosing a Post Hoc Test
Once you have performed a one way or one way repeated measures ANOVA and found a statistically significant 
difference, you can use one of the following post hoc tests to determine which groups are different:

Use the Tukey HSD, Student-Newman-Keuls, Bonferroni, Holm, Scheffe, or Fisher's LSD test to compare all 
possible combinations of group pairs.

Use the Dunnett test if one column represents control data, and you want to compare all other columns to the 
control column (but not to each other).

 
As you can see, there are a number of different post hoc tests available. However, there is no consensus as to which test 
is the best.
 
The Tukey HSD and Student-Newman-Keuls tests are widely accepted and more commonly used than some of the other 
tests. Some favor Fisher’s LSD test because it is one of the least conservative tests. If you do not know which test to use, 
you may want to experiment with two or three tests to get different viewpoints.
 
To perform a post hoc test:

Verify that One Way ANOVA or One Way ANOVA – Repeated Measures is listed on the first line in the ANOVA 
results. The post hoc tests cannot be used with the two way or two way repeated measures ANOVA.

Select the desired test from the Post Hoc Test pop-up menu.
If necessary, select a different significance level using the Alpha pop-up menu.
Click Calculate. The post hoc test results will appear below the ANOVA results.

 

Tukey HSD Test
The Tukey HSD (honestly significant difference) test is a pairwise comparison of every combination of group pairs. This 
test calculates the mean difference for each treatment or group pair, calculates a q test statistic for each pair, and displays 
the P value for that comparison. This test is more conservative than the Student-Newman-Keuls test because the Tukey 
HSD test controls the errors of all comparisons simultaneously.
 
To perform a Tukey HSD post hoc test:
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Verify that One Way ANOVA or One Way ANOVA – Repeated Measures is listed on the first line in the ANOVA 
results. The post hoc tests cannot be used with the two way or two way repeated measures ANOVA.

Select Tukey HSD from the Post Hoc Test pop-up menu.
If necessary, select a different significance level using the Alpha pop-up menu.
Click Calculate. The post hoc test results will appear below the ANOVA results.

 
The following values are calculated when performing a Tukey HSD post hoc test. Please refer to the references cited for 
the equations used to calculate the mean difference, q, and confidence limits.

Mean Difference - This value represents the difference between the means of the groups or treatments being 
compared.

|q| - This value is the q test statistic. Large values of q indicate that the difference of the two treatments or groups 
being compared is statistically significant.

P value - This value represents the P value that corresponds to the q test statistic. It determines if there is a 
statistically significant difference between the treatments or groups being compared. If this value is below a 
certain level (usually 0.05), the conclusion is that there is a difference between the groups.

95% CL - These values represent the confidence limits for the differences between all possible pairs of treatment 
or group means. Depending on the Alpha value selected, this will be listed as 90%, 95%, or 99% CL.

 

Student-Newman-Keuls Test
The Student-Newman-Keuls test is a pairwise comparison of every combination of group pairs. This test calculates the 
mean difference for each treatment or group pair, calculates a q test statistic for each pair, and displays the P value for 
that comparison.
 
This test is calculated in the same manner as the Tukey HSD test, except in the calculation of the q test statistic. This test 
is less conservative than the Tukey HSD test and is more likely to determine that a given difference is statistically 
significant.
 
To perform a Student-Newman-Keuls post hoc test:

Verify that One Way ANOVA or One Way ANOVA – Repeated Measures is listed on the first line in the ANOVA 
results. The post hoc tests cannot be used with the two way or two way repeated measures ANOVA.

Select Student-Newman-Keuls from the Post Hoc Test pop-up menu.
If necessary, select a different significance level using the Alpha pop-up menu.
Click Calculate. The post hoc test results will appear below the ANOVA results.

 
The following values are calculated when performing a Student-Newman-Keuls post hoc test. Please refer to the 
references cited for the equations used to calculate the mean difference and q values.

Mean Difference - This value represents the difference between the means of the groups or treatments being 
compared.

|q| - This value is the q test statistic. Large values of q indicate that the difference of the two treatments or groups 
being compared is statistically significant.

P value - This value represents the P value that corresponds to the q test statistic. It determines if there is a 
statistically significant difference between the treatments or groups being compared. If this value is below a 
certain level (usually 0.05), the conclusion is that there is a difference between the groups.

 

Bonferroni Test
The Bonferroni test is a pairwise comparison of every combination of group pairs. This test calculates the mean difference 
for each treatment or group pair, calculates a t test statistic for each pair, and displays the P value for that comparison. 
This test is more conservative than the Tukey HSD and Student-Newman-Keuls tests.
 
To perform a Bonferroni post hoc test:
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Verify that One Way ANOVA or One Way ANOVA – Repeated Measures is listed on the first line in the ANOVA 
results. The post hoc tests cannot be used with the two way or two way repeated measures ANOVA.

Select Bonferroni from the Post Hoc Test pop-up menu.
If necessary, select a different significance level using the Alpha pop-up menu.
Click Calculate. The post hoc test results will appear below the ANOVA results.

 
The following values are calculated when performing a Bonferroni post hoc test. Please refer to the references cited for 
the equations used to calculate the mean difference, t, and confidence limits.

Mean Difference - This value represents the difference between the means of the groups or treatments being 
compared.

|t| - This value is the t test statistic. Large values of t indicate that the difference of the two treatments or groups 
being compared is statistically significant.

P value - This value represents the P value that corresponds to the t test statistic. It determines if there is a 
statistically significant difference between the treatments or groups being compared. If this value is below a 
certain level (usually 0.05), the conclusion is that there is a difference between the groups.

95% CL - These values represent the confidence limits for the differences between all possible pairs of treatment 
or group means. Depending on the Alpha value selected, this will be listed as 90%, 95%, or 99% CL.

 

Holm Test
The Holm test is a pairwise comparison of every combination of group pairs. This test calculates the mean difference for 
each treatment or group pair, calculates a t test statistic for each pair, and displays the two-sided P value for that 
comparison.
 
The smallest P value is compared to the adjusted Alpha value. If the P value is greater than or equal to the adjusted 
Alpha, you can conclude that there is no significant difference for this test and any remaining comparisons. If the P value 
is less than the adjusted Alpha, there is a statistically significant difference for this test. A new adjusted Alpha value is 
calculated, and the tests continue with the next smallest P value.
 
This test is a refinement of the Bonferroni test. The Holm test may find a statistically significant difference when the 
Bonferroni test does not. One disadvantage of this test is that, unlike the Bonferroni test, the Holm test does not report any 
confidence intervals.
 
To perform a Holm post hoc test:

Verify that One Way ANOVA or One Way ANOVA – Repeated Measures is listed on the first line in the ANOVA 
results. The post hoc tests cannot be used with the two way or two way repeated measures ANOVA.

Select Holm from the Post Hoc Test pop-up menu.
If necessary, select a different significance level using the Alpha pop-up menu.
Click Calculate. The post hoc test results will appear below the ANOVA results.

 
The following values are calculated when performing a Holm post hoc test. Please refer to the references cited for the 
equations used to calculate the mean difference, t, and adjusted Alpha values.

Mean Difference - This value represents the difference between the means of the groups or treatments being 
compared.

|t| - This value is the t test statistic.
2-P - This value represents the two-sided P value that corresponds to the t test statistic.
adjusted Alpha - This value is used to determine if there is a statistically significant difference in the treatments or 

groups. It is based on the Alpha value, the rank of the two-sided P value, and the number of tests that need to 
be performed.

Significant? - If the two-sided P value is less than the adjusted Alpha value, there is a statistically significant 
difference between the two treatments or groups being compared.
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Scheffe Test
The Scheffe test is a pairwise comparison of every combination of group pairs. This test calculates the mean difference for 
each treatment or group pair, calculates an S test statistic for each pair, and displays the P value for that comparison.
 
Scheffe’s test is more conservative than the other post hoc tests, meaning that a larger difference between means is 
required for significance. Because it is more conservative, this test has less statistical power than the Tukey HSD or 
Student-Newman-Keuls tests.
 
To perform a Scheffe post hoc test:

Verify that One Way ANOVA or One Way ANOVA – Repeated Measures is listed on the first line in the ANOVA 
results. The post hoc tests cannot be used with the two way or two way repeated measures ANOVA.

Select Scheffe from the Post Hoc Test pop-up menu.
If necessary, select a different significance level using the Alpha pop-up menu.
Click Calculate. The post hoc test results will appear below the ANOVA results.

 
The following values are calculated when performing a Scheffe post hoc test. Please refer to the references cited for the 
equations used to calculate the mean difference, S, and confidence limits.

Mean Difference - This value represents the difference between the means of the groups or treatments being 
compared.

|S| - This value is the S test statistic. Large values of S indicate that the difference of the two treatments or groups 
being compared is statistically significant.

P value - This value represents the P value that corresponds to the S test statistic. It determines if there is a 
statistically significant difference between the treatments or groups being compared. If this value is below a 
certain level (usually 0.05), the conclusion is that there is a difference between the groups.

95% CL - These values represent the confidence limits for the differences between all possible pairs of treatment 
or group means. Depending on the Alpha value selected, this will be listed as 90%, 95%, or 99% CL.

 

Fisher's LSD Test
Fisher’s LSD (least significant difference) test is a pairwise comparison of every combination of group pairs. This test 
calculates the mean difference for each treatment or group pair, calculates a t test statistic for each pair, and displays the 
P value for that comparison.
 
Fisher’s LSD test is equivalent to multiple t-tests between all treatments or groups. This is the least conservative post hoc 
test because no adjustment is made based on the number of tests performed.
 
To perform Fisher’s LSD post hoc test:

Verify that One Way ANOVA or One Way ANOVA – Repeated Measures is listed on the first line in the ANOVA 
results. The post hoc tests cannot be used with the two way or two way repeated measures ANOVA.

Select Fisher’s LSD from the Post Hoc Test pop-up menu.
If necessary, select a different significance level using the Alpha pop-up menu.
Click Calculate. The post hoc test results will appear below the ANOVA results.

 
The following values are calculated when performing Fisher’s LSD post hoc test. Please refer to the references cited for 
the equations used to calculate the mean difference and t values.

Mean Difference - This value represents the difference between the means of the groups or treatments being 
compared.

|t| - This value is the t test statistic. Large values of t indicate that the difference of the two treatments or groups 
being compared is statistically significant.

P value - This value represents the P value that corresponds to the t test statistic. It determines if there is a 
statistically significant difference between the treatments or groups being compared. If this value is below a 
certain level (usually 0.05), the conclusion is that there is a difference between the groups.
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Dunnett Test
The Dunnett test is used to determine if the mean of one group, designated as a control, differs significantly from each of 
the means of the other groups.
 
To perform a Dunnett post hoc test:

Verify that One Way ANOVA or One Way ANOVA – Repeated Measures is listed on the first line in the ANOVA 
results. The post hoc tests cannot be used with the two way or two way repeated measures ANOVA.

Select Dunnett from the Post Hoc Test pop-up menu.
If necessary, select a different significance level using the Alpha pop-up menu.
Click Calculate. The post hoc test results will appear below the ANOVA results.

 
The following values are calculated when performing a Dunnett post hoc test. Please refer to the references cited for the 
equations used to calculate the mean difference, q, and confidence limits.

Mean Difference - This value represents the difference between the means of the groups or treatments being 
compared.

|q| - This value is the q test statistic. Large values of q indicate that there is a statistically significant difference 
between the control and the group being compared.

P value - This value represents the P value that corresponds to the q test statistic. It determines if there is a 
statistically significant difference between the control and the group being compared. If this value is below a 
certain level (usually 0.05), the conclusion is that there is a difference between the groups.

95% CL - These values represent the confidence limits for the differences between the control mean and each of 
the other group means. Depending on the Alpha value selected, this will be listed as 90%, 95%, or 99% CL.
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Overview: Formula Entry Basics
The Formula Entry window, shown below, is a very powerful tool for data analysis. This window can be displayed by 
choosing Windows > Formula Entry.
 

 
Use this window to enter formulas that generate and manipulate data in the active data window. The results of a formula 
can be placed in a data column, a single cell, or a memory location.
 
Note: The results of a formula are based on the data at the time the formula is executed. Changing the data does not 

cause the results to automatically recalculate. To update the results, the formula must be executed again.
 
To execute a formula from the Formula Entry window, a data window must be open. Otherwise, the Run button is 
unavailable.
 
The last section of this chapter includes descriptions, syntax, and examples for all of the operators and functions that are 
available for use in the Formula Entry window.
 
Refer to the following topics to learn how to write a formula:

Formula Structure
Referencing Columns and Memory Registers in a Formula
Using Specific Cells in Formulas

 

Formula Structure
A formula calculates new values from existing data in the data window. A formula can be a simple mathematical operation, 
such as multiplying a column by a constant, or a more complex operation, such as calculating the root mean square of a 
specific group of data.
 
Formulas are created using a combination of column references, operators, and functions. Memory locations and 
constants can also be used in a formula. Formulas are usually constructed with the destination to the left of the equal sign 
(=) and the calculation to the right of the equal sign. One exception is the name function, which specifies the output 
column as one of the parameters.
 
The results of a formula can be stored in another column, a cell, or a memory register. If a destination is not specified, the 
results are displayed in a dialog similar to the one below. This is useful for formulas that result in a single value, such as 
the commands located in the Statistics menu.
 

 
Some example formulas are shown below:
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c1 = c0 / 1000;
c5 = (c1 + c2) * (c3 - c4);
c2 = 5 * cos(c1);
c4 = (c1 + m0 * (2 * sin(c3))) / c2;
c5 = table(c2,c3,c4);
c6 = exp(-(c0 - c1));
 

Referencing Columns and Memory Registers in a Formula
Column numbers range from 0 to 999 and need to be preceded by a c when used in a formula (c10, c55, and so on). To 

display the column numbers, click the Expand/Collapse button  in the data window. The Show Column Numbers option 
in the Preferences dialog can be used to automatically show the column numbers in all new data windows.
 
Note: When a selection is made in the data window, the first column in the selection becomes column 0.
 
Calculations involving columns are performed on a row-by-row basis. If two or more columns are used in a calculation, 
corresponding cells in the same row are used to determine the results. If empty or masked cells are encountered during 
the calculation, the corresponding cell in the destination column is left empty.
 
Memory registers range from 0 to 99 and need to be preceded by an m when used in a formula (m15, m35, and so on). 
Memory registers are useful in calculations that result in a single value. The value can be stored in a memory register and 
used at a later time in other calculations.
 

Using Specific Cells in Formulas
The cell function can be used in formulas to read or store values in specific cells in the data window. The syntax of this 
function is cell(row#, col#).
 
Some example formulas are shown below:
cell(0,1) = csum(c0); Stores the result in row 0 of column 1.
cell(0,5) = cell(0,4) * 5;
c3 = c2 - cell(0,1);
 

Entering and Executing a Formula
To enter and execute a formula:

Open the data window to be operated on by the formula.
Click the Formula Entry window or choose Windows > Formula Entry.
Enter the formula into the text field of Formula Entry. You can either type the operators and functions or choose 

them from the appropriate menus in the Formula Entry window.
Multiple formulas can be entered on a single-line by separating each formula with a semicolon, or by placing each 

formula on a separate line and terminating the individual formulas with a semicolon.
Click Run or press the Enter key on the numeric keypad to execute the formula.

 
If a syntax error is found during the execution of the formula, a dialog similar to the following is displayed to show the 
portion of the formula that triggered the error.
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If the values calculated by the formula are incorrect, check to see if any of the columns referenced in the formula are 
formatted as Text. Use the Column Formatting command to apply the correct format to the data column(s) and run the 
formula again.
 
Note: The results of a formula are based on the data at the time the formula is executed. Changing the data does not 

cause the results to automatically recalculate. To update the results, the formula must be executed again.
 

Storing Formulas
You can store formulas in any of the eight function buttons in Formula Entry. Any formulas that are assigned to these 
buttons are saved in the Macros file. It is recommended that you store frequently-used formulas in F2-F8 and leave F1 for 
entering general formulas that do not need to be saved.
 
To assign a formula to a particular function button:

Select the appropriate function button in Formula Entry using one of the following methods:

Click the button in the Formula Entry window.
Press the corresponding function key on the keyboard.

Enter the formula into the text field of Formula Entry.

If you want to store the formulas with the data, copy each of the formulas and paste them into the Posted Note of the data 
window. This information is saved as part of the data file. When you re-open the data file, you could copy the formulas 
from the data window Posted Note and paste them into the Formula Entry Posted Note and execute them as a multi-line 
formula.
 

Calculating Statistics with Formula Entry
KaleidaGraph provides 12 commands in the Statistics menu to help you analyze data. The statistics can be calculated on 
individual columns or a specific range of data.
 

Individual Column Statistics
Statistics are calculated on individual columns by entering the column number within the statistics function. This function 
results in a single data value, which can be displayed in a dialog or stored in a column, cell, or memory register.
 
For example:
mean(c12); Finds the mean of column 12 and displays the result in a dialog.
c4 = stderr(c3); Determines the standard error for column 3 and places the result in column 4.
cell(0,5) = std(c15); Finds the standard deviation of column 15 and stores the result in row 0, column 5.
m2 = cmin(c11); Determines the minimum value in column 11 and stores the result in memory register 2.
 

Statistics on a Specific Group of Data
Statistics can also be calculated on a range of data. This is accomplished using the statistics commands and the matrix 
operator, [ ]. This operator enables you to define a range of rows and columns (around the current row or column index) to 
use in the calculation. The syntax for the matrix operator is:
 
[starting row:ending row, starting column:ending column]
 
It is not necessary to enter starting and ending values if you want to use all of the rows or columns in the calculation. If the 
starting and ending values are missing, the entire range of rows or columns is used to determine the result.
 
For example:
[ , ] Operate on the entire data window.
[ , 1:3] Operate on all rows in columns 1 through 3.
[0:25, ] Operate on rows 0 through 25 in all columns.
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Statistics on a Row-By-Row Basis
The statistics commands support two formats for calculating statistics on a row-by-row basis. It is valid to either specify a 
range of columns or to use the matrix operator and enter zero for both the starting and ending row.
 
For example, both of the following formulas calculate the mean for each individual row in columns 1 through 4 and store 
the results in column 5:
 
c5=mean(1:4)
c5 = mean([0:0, 1:4])
 

Masking Data with Formula Entry
KaleidaGraph supports two functions (mask and filter) that can be used to mask data via a formula. An unmask function 
is also provided to return the data to normal. Some example uses of these commands are listed below.
 
mask(c0 < 0, c0); Masks any negative values in c0.
mask(c1 < c2, c2); Masks any cells in c2 whose value is greater than the corresponding cell in c1.
filter(-1, 1, c0); Masks all cells in c0 that are less than -1 or greater than 1.
unmask(c0 > 0, c3); Unmasks any cells in c3 if the corresponding value in c0 is positive.
 

Interpolating Data
KaleidaGraph is able to perform linear interpolation through the use of the table function in Formula Entry. The table 
command performs a linear approximation of a number (x) based on the data in two columns. The syntax for this 
command is table(x, x col#, y col#), such that for a given x value, this function returns an estimate for y.
 
Note: This function has the constraint that y col# = f(x col#) may only describe a single value function, meaning that you 

cannot have the same Y value for multiple X values.
 
The following data window shows an example use of the table function. The first two columns contain X-Y data points. 
Column 2 contains a new set of X values for which you want to find the corresponding Y values. The Y values in column 3 
were found by executing the formula c3=table(c2, c0, c1) in Formula Entry.
 

 

Performing Date and Time Calculations
It is possible to perform calculations on columns containing dates and times. Internally, dates are stored as the total 
number of seconds since Jan. 1, 1904 and times are stored as a relative number of seconds. This allows you to perform 
calculations on date and time data just as you would with any other kind of data. The easiest way to illustrate this is to use 
the Column Formatting command (Data menu) to change the format of a column containing dates or times to the 
Double format. The column now shows the total number of seconds.
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Note: You do not have to change the format of the column before using it in a calculation. This is because KaleidaGraph 
automatically stores the values as a total number of seconds.

 

Advanced Formulas
This section provides examples of some advanced formulas that can be executed from within Formula Entry. More 
formulas can also be found in the FAQ’s and Technical Notes portion of our web site.
 
To calculate a statistic on blocks of data (e.g. the mean of every 5 rows) use a formula like:

cell(index() * n + offset, ocol) = stat([index() * (n-1):index() * (n-1) + (n-1), icol: icol])
 
where n is the number of rows in the block, offset is the number of rows down where the final result will be stored, 
stat is the appropriate command from the Statistics menu, ocol is the output column number, and icol is the input 
column number.
 
The formula cell(index() * 5, 1) = mean([index() * 4:index() * 4 + 4, 0: 0]) finds the mean for every five rows in 
column 0 and stores the results in column 1. Since there is no offset, the results are placed at the beginning of 
each block being evaluated.

 
To have a statistic calculated from the beginning of the column down to the current row, use a formula like:

ocol = stat([-index() :0, icol:icol])
 
where stat is the appropriate command from the Statistics menu, ocol is the output column, and icol is the input 
column number.
 
The formula c2 = mean([-index() :0, 1:1]) finds the mean of column 1, from the beginning of the column to the 
current row, and stores the results in column 2.

 
To invert the data in one column and place it in another column, use a formula like:

ocol = cell(n - index(), icol)
 
where n is the last row number in the data window, ocol is the output column, and icol is the input column 
number. Any empty rows at the bottom of the original data are placed at the top of the output column. These can 
be selected and deleted using the Cut command.
 
The formula c1 = cell(99 - index(), 0) inverts column 0 and stores the results in column 1.

 
To take an input column and have every n rows stored in a separate column, use one of the following formulas:

cell(index(), int(index()/n) + (icol + 1)) = cell(index(), icol)
or
cell(index() % n, int(index()/n) + (icol + 1)) = cell(index(), icol)
 
where n is the number of rows in each group and icol is the input column number. Using the first formula, the data 
remains in the same row as the original data; in the second the data is placed at the top of the data window.
 
The formula cell(index() % 10, int(index()/10) + 4) = cell(index(), 3) moves every 10 rows from column 3 and stores 
them in different data columns, starting at column 4. The data is placed at the top of each output column.
 

Multi-line Formulas
With the use of the Posted Note in Formula Entry, you can string formulas together and have them executed sequentially. 
Each formula should be entered on a separate line and end with a semicolon.
 
To enter and execute a multi-line formula:

Open the data window to be operated on by the formula.
Click the Formula Entry window or choose Windows > Formula Entry.
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Click the Posted Note button  to display the text editor.
Enter the individual formulas into the Posted Note. Each formula must be entered on a separate line and end with 

a semicolon.
When you are finished entering the formulas, click Run to execute the formulas in the Posted Note.

The following dialog shows a multi-line formula entered in the text editor. Notice that each formula is entered on a 
separate line and is terminated by a semicolon.
 

 

Adding Comments
Comments can be added to a multi-line formula in the Posted Note window. Comments are used to make the formula 
more readable by describing the purpose of the program and the use of each individual formula.
 
Comments can be added anywhere in the Posted Note with the use of a semicolon. Anything after the semicolon to the 
first occurrence of a carriage return is treated as a comment. Some example formulas with comments are shown below:
 
c0 = (-0.5 + ran()) * 10; Fill c0 with random numbers between -5 and 5.
macro("Invert Mask"); Execute the Invert Mask macro from the Macros menu.
name("Values", c0); Change the title of c0 to "Values"
 

Saving Multi-line Formulas
Multi-line formulas can be saved as a text file by clicking Save As in the Posted Note window. This text file can be 
reopened at a later time by clicking the Posted Note button in Formula Entry and clicking Open.
 

Overview: Function Description and Syntax
The menus in Formula Entry contain all of the commands and operators that are available for use. You have the option of 
choosing the commands from the menu or typing them into the window.
 
The following can be used to write functions in the Formula Entry window:

Operators
Variables
Math Functions
Statistics Functions
Curve Fit Functions
Special Functions
Library Functions

 

Operators
Formula operators in order of precedence:
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!  factorial
-----------------------------------------------------------
^  raise to a power
-----------------------------------------------------------
*  multiply
/  divide
%  modulo
-----------------------------------------------------------
+  add
-  subtract
-----------------------------------------------------------
<  less than
<=  less than or equal to
>  greater than
>=  greater than or equal to
==  equal to (used for comparisons)
!=  not equal to
-----------------------------------------------------------
&&  logical and
||  logical or
?:  conditional
( )  left and right parentheses
=  equal (used to store results)
[ ]  matrix
 
Note: Grouped items have the same precedence.
 
( )
The parentheses are used with almost every formula to enclose the variable being used in the calculation. They are also 
used to set the priority order for calculations.
Example: c3 = (cos(c2) * sin(c1)) + ((2 * tan(c0)) / sqrt(pi))
 
^
This operator raises the preceding value to the specified power.
Examples: 5^2, c3 = c1^(1/c0)
 
*
This operator multiplies two values together.
Examples: 23 * m0, c3 = .9087 * c5
 
/
This operator is used for division.
Examples: c4 = c0 / 12.234, c12 = (c8 + c5) / c2
 
+
This operator is used for addition.
Examples: c3 = (c2 + c1 + c0) / 3, c12 = 198 + c10
 
-
This operator is used for subtraction.
Examples: c9 = c8- c6, c19 = (c12 - c3) / c5
 
%
This operator performs the mod function.
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Examples: c9 = c8 % 4, c13 = c12 % c3
 
!
This operator calculates the factorial of a number.
Examples: 7!, c13 = c10!
 
<
This operator compares two values to see if one is less than the other.
Examples: mask(c1 < 3, c1), unmask(c2 < -12, c3)
 
<=
This operator compares two values to see if one is less than or equal to the other.
Examples: mask(c4 <= c5, c6), unmask(c2 <= 23, c12)
 
>
This operator compares two values to see if one is greater than the other.
Examples: mask(c1>1, c0), unmask(c4 > c3), c5)
 
>=
This operator compares two values to see if one is greater than or equal to the other.
Examples: mask(c12 >= 12.34, c12), unmask(c11 >= -5, c11)
 
==
This operator compares two values to see if they are equal to each other.
Examples: mask(c1 == 4, c1), unmask(c3 == c2, c1)
 
!=
This operator compares two values to see if they are unequal.
Examples: mask(c2 != c4, c2), unmask(c3 != 2, c3)
 
&&
This operator performs a logical and on two Boolean expressions. The result of both expressions must be true (non-zero) 
for the logical and to be true.
Examples: c3 = (c0>1 && c0<15) ? c0 : .5, c1 = (c2>3 && c2<11) ? c2 : 0
 
||
This operator performs a logical or on two Boolean expressions. The result of one expression must be true (non-zero) for 
the logical or to be true.
Examples: c1 = (c2>1 || c3>1) ? c1 : c4, c2 = (c1<0 || c1 == .5) ? 0 : c1
 
?:
This operator performs a conditional test on a Boolean expression. This operator can be expressed in one of two ways:

if (Boolean) expression 1 else expression 2
(Boolean) ? expression 1 : expression 2

If the result of the Boolean is true (non-zero), return expression 1; if it is false, return expression 2.
Examples: c9 = (c2>.5 || c3>.1) ? c11 : c4, c1 = (c2>1 && c2<10) ? c2 : .1
 
=
This operator is used to place the result of a calculation into a column, cell, or memory location.
Examples: m0 = 12 * m1, c1 = sqrt(c0), c2 = cos(c0), cell(0,5) = cmin(c0)
 
[ ]
The matrix operator is used to specify a range of data for use in a statistical calculation. The syntax of the operator is: 
[starting row:ending row, starting column:ending column]. It is not necessary to enter starting and ending values to use all 
of the rows or columns in the calculation. If the starting and ending values are missing, the entire range of rows or 
columns is used to determine the result.
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Examples: cmax([ 0:23 , 3:10]), c18 = median([ , 12:14 ])
 

Variables
Variables:
Column vectors

c0 through c999
 
Memory registers

m0 through m99
 
Default Library Definitions
Variable Definitions:

x = m0;
a = m1;
b = m2;
c = m3;
d = m4;

 
Constant Definitions:

e = exp(1);
 

Math Functions
abs(x)
Determines the absolute value of a number.
Examples: abs(-5), abs(m3), c3 = abs(c2)
 
cell(row#, col#)
Gets or sets the value of a specific cell.
Example: cell(0, 2) = 5.5 * cell(1, 3), cell(10, 13) = sqrt(cell(15, 11))
 
corr(col#, col#)
Determines the linear correlation between two columns of numbers. To use this function, the two columns being compared 
must have the same number of data points.
Examples: corr(c5, c7), m1 = corr(c9, c12), cell(10, 13) = corr(c2, c3)
 
cos(x)
Determines the cosine of a number. The number is in radians or degrees, based on the setting in the Formula Entry 
window.
Examples: cos(30), cos(m8), c4 = cos(c2)
 
diff(x)
Calculates the difference between each value and the one that follows it.
Examples: c5 = diff(c2), c11 = diff(c10)
 
erf(x)
Calculates the error function of a value. This function has the following limiting values: erf(0) = 0, erf(∞) = 1, and erf(-x) = 
-erf(x).
Examples: erf(2), c10 = erf(c9)
 
erfc(x)
Calculates the complementary error function of a value. This function has the following limiting values: erfc(0) = 1, erfc(∞) 
= 0, and erfc(-x) = 2-erfc(x).
Examples: erfc(.5), c20 = erfc(c19)
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exp(x)
Calculates the value of e (2.7182...) raised to a power.
Examples: exp(3), exp(m1), c10 = exp(c2)
 
fract(x)
Returns the fractional portion of a number.
Examples: fract(2.83), c12 = fract(c9)
 
index()
Returns the current row number (starting at 0).
Example: c5 = index() * .5, c11 = index() - 64
 
inorm(x)
Determines the inverse of the normal distribution for a number between zero and 100% (using a built-in mean value of 0 
and a standard deviation of 1).
Examples: inorm(25), inorm(m2), c10 = inorm(c9)
 
int(x)
Returns the integer portion of a number.
Examples: int(2.83), c12 = int(c9)
 
invcos(x)
Determines the inverse cosine of a number. The number is in radians or degrees, based on the setting in the Formula 
Entry window.
Examples: invcos(.5), invcos(m3), c6 = invcos(c5)
 
invsin(x)
Determines the inverse sine of a number. The number is in radians or degrees, based on the setting in the Formula Entry 
window.
Examples: invsin(.219), invsin(m0), c15 = invsin(c10)
 
invtan(x)
Determines the inverse tangent of a number. The number is in radians or degrees, based on the setting in the Formula 
Entry window.
Examples: invtan(1), invtan(m2), c9 = invtan(c8)
 
ln(x)
Calculates the natural logarithm (base e) of a number.
Examples: ln(8), ln(m5), c12 = ln(c9)
 
log(x)
Calculates the common logarithm (base 10) of a number.
Examples: log(20), log(m10), c18 = log(c15)
 
norm(x)
Determines the normal distribution of a number between zero and 100% (using a built-in mean value of 0 and a standard 
deviation of 1).
Examples: norm(23), norm(m5), c7 = norm(c5)
 
pi
Represents the value of π (3.1415926...).
Example: c10 = pi * c9, c11 = 3 * pi * c9
 
ran()
Generates a random number between zero and one.
Examples: c15 = ran(), c9 = c8 * ran()
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rsum(col#)
Computes the running sum of a column.
Example: c3 = rsum(c2), c10 = rsum(c9)
 
sin(x)
Determines the sine of a number. The number is in radians or degrees, based on the setting in the Formula Entry window.
Examples: sin(45), sin(m6), c11 = sin(c10)
 
sqrt(x)
Calculates the square root of a number.
Examples: sqrt(192), sqrt(m9), c6 = sqrt(c5)
 
table(x, x col#, y col#)
The table command performs a linear approximation of a number (x) based on the data in two columns. The result is that 
for a given x, this function returns an estimate for y. The order of the columns determines what value is returned. This 
function has the constraint that y col# = f(x col#) may only describe a single value function, meaning that you cannot have 
the same Y value for multiple X values.
Examples: table(2.5, c0, c1), c4 = table(c3, c0, c1)
 
tan(x)
Determines the tangent of a number. The number is in radians or degrees, based on the setting in the Formula Entry 
window.
Examples: tan(68), tan(m10), c5 = tan(c4)
 

Statistics Functions
cmin(x)
Determines the minimum value within the specified data.
Examples: cmin(c5), cmin([ , 0:10]), c6 = cmin(0:5)
 
cmax(x)
Determines the maximum value within the specified data.
Examples: cmax(c15), cmax([ 0:23 , 3:10]), c13 = cmax([ , 0:12 ])
 
csum(x)
Calculates the sum of the data values.
Examples: csum(c9), csum([ , 0:3 ]), c12 = csum([ 0:50 , 3:8 ])
 
kurtosis(x)
Calculates the kurtosis of the specified data using the formula for excess kurtosis.
Examples: kurtosis(c12), kurtosis([ 0:5 , ]), c5 = kurtosis(0:4)
 
mean(x)
Calculates the mean of the data.
Examples: mean(c0), mean([ , 2:3 ]), c11 = mean(1:10)
 
median(x)
Calculates the median of the data range.
Examples: median(c3), median([ 2:10 , 0:1 ]), c17 = median(12:14)
 
npts(x)
Determines the number of points within the specified data range.
Examples: npts(c1), npts([ , 0:5 ]), c10 = npts([ , ])
 
rms(x)
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Calculates the RMS (root mean square) of the data range.
Examples: rms(c3), rms([ , 1:1 ]), c5 = rms(12:21])
 
skew(x)
Calculates the skewness of the data range.
Examples: skew(c15), skew([ , 3:10 ]), c13 = skew([ -10:10 , 2:2 ])
 
std(x)
Calculates the standard deviation of the data range.
Examples: std(c10), std([ 12:120 , ]), c13 = std(8:12)
 
stderr(x)
Calculates the standard error of the data.
Examples: stderr(c4), stderr([ -5:5 , 15:19 ]), c10 = stderr(5:9)
 
var(x)
Calculates the variance of the specified data range.
Examples: var(c6), var([ 0:25, ]), c3 = var([ , ])
 

Curve Fit Functions
expr(x, col#)
Given an x value and a column that has an Exponential curve fit applied, this function determines the value from the fit at 
the x point.
Examples: expr(105, c10), c11 = expr(c8,c9)
 
gen(" ", x, col#)
Given the name of a General curve fit, an x value, and a column that has the fit applied, this function determines the value 
at the x point. If no name is given, the first General fit that is found in the column is used.
Examples: gen("fit1", 22, c1), c5 = gen(c0, c1), c11 = ("gaussian", c8, c9)
 
interp(x, col#)
Given an x value and a column that has an Interpolate curve fit applied, this function determines the value from the fit at 
the x point.
Examples: interp(11.95, c2), c19 = interp(c15, c18)
 
lin(x, col#)
Given an x value and a column that has a Linear curve fit applied, this function determines the value from the fit at the x 
point.
Examples: lin(-12.5, c1), c10 = lin(c9, c5)
 
logr(x, col#)
Given an x value and a column that has a Logarithmic curve fit applied, this function determines the value from the fit at 
the x point.
Examples: logr(1300, c8), c12 = logr(c3, c4)
 
poly(x, col#)
Given an x value and a column that has a Polynomial curve fit applied, this function determines the value from the fit at the 
x point.
Examples: poly(.0034, c15), c14 = poly(c12, c1)
 
pow(x, col#)
Given an x value and a column that has a Power curve fit applied, this function determines the value from the fit at the x 
point.
Examples: pow(119, c10), c3 = pow(c0, c2)
 
smooth(x, col#)
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Given an x value and a column that has a Smooth curve fit applied, this function determines the value from the fit at the x 
point.
Examples: smooth(11.15, c2), c4 = smooth(c2, c3)
 
spline(x, col#)
Given an x value and a column that has a Cubic Spline curve fit applied, this function determines the value from the fit at 
the x point.
Examples: spline(-23.098, c17), c4 = spline(c3, c8)
 
wgt(x, col#)
Given an x value and a column that has a Weighted curve fit applied, this function determines the value from the fit at the 
x point.
Examples: wgt(15.657, c2), c9 = wgt(c10, c11)
 

Special Functions
Note: File paths must use "/" to separate directories in the path instead of ":" or "\" that were used in earlier versions.
 
execute("filename")
This function loads a formula or formula script and executes it.
Examples: execute ("Documents/Sample script.txt"), execute ("quad formula.txt")
 
macro(" ")
This function executes a macro by name.
Examples: macro("Simplify"), macro("Invert Mask")
 
mask(logical expression, col#)
Masks the cells in the specified column if the expression is true.
Examples: mask(c4 > 1.25, c6), mask(c9 != c11, c14)
 
name(" ", col#)
This command uses the text string given to name the specified column.
Examples: name("Y-Error", c2), name("Residuals", c11)
 
script("filename")
This function loads and runs the specified Script file. If no name is given, the current plot script is executed.
Examples: script("Documents/Scatter Plot Script.qsc"), script("Temperature.qsc"), script()
 
unmask(logical expression, col#)
Unmasks the cells in the specified column if the expression is true.
Examples: unmask(c2 == c4, c5), unmask(c2 < 4, c3)
 

Library Functions
The Library menu lists all of the definitions that are present in the current library. If the library is empty, this menu is also 
empty.
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Line Plot
Use a Line plot to represent trends in different data sets over a period of time. Each line in the plot represents a separate 
data column. The data is displayed as a series of X-Y pairs, connected to the next point by a line. The data does not have 
to be sorted, but it is important to note that the points are connected in the order they appear in the data window.
 
Line plots give you a great deal of flexibility in how the data is displayed. You can specify the number of markers, line 
style, and line thickness for each variable. You can also hide the line and display only the markers. All of these 
characteristics are controlled in the Variable Settings dialog.
 

                 
Example Line Plots

 
To create a Line plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Linear > Line to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables. A range of data 

columns can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name 
of the last column, and clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

Scatter Plot
Use a Scatter plot to compare large sets of data. Scatter plots are similar to Line plots, except the points are not 
connected by lines. Each X-Y pair is represented by a unique marker on the plot. Each column of data is represented by a 
different marker.
 
It is not possible to display a partial set of markers or a line between the points (although you can apply curve fits to the 
data). If you want this kind of flexibility, plot the data as a Line plot.

 

                 
Example Scatter Plots

 
To create a Scatter plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Linear > Scatter to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables. A range of data 

columns can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name 
of the last column, and clicking one of the check boxes in the Y column.
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Click Plot to generate a plot based on your selections.

 

Double Y Plot
Use a Double Y plot to display two groups of data, each with its own vertical scale. Each line in the plot represents a 
separate data column. The data is displayed as a series of X-Y pairs, connected to the next point by a line. The data does 
not have to be sorted, but it is important to note that the points are connected in the order they appear in the data window.
 
The Double Y plot gives you the same amount of control over the display of the data as the Line plot, but with the added 
capability of having separate scales on the vertical axes. This plot is useful when you are plotting two dependent (Y) 
groups that share a common independent (X) variable.

 

                 
Example Double Y Plots

 
To create a Double Y plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Linear > Double Y to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y1 and Y2) variables. A range of 

data columns can be selected for Y or Y2 by clicking the name of the first column, pressing Shift and 
selecting the name of the last column, and clicking one of the check boxes in the Y or Y2 column.

Click Plot to generate a plot based on your selections.

 

Double X Plot
Use a Double X plot to display two groups of data, each with its own horizontal scale. Each line in the plot represents a 
separate data column. The data is displayed as a series of X-Y pairs, connected to the next point by a line. The data does 
not have to be sorted, but it is important to note that the points are connected in the order they appear in the data window.
 
The Double X plot gives you the same amount of control over the display of the data as the Line plot, but with the added 
capability of having separate scales on the horizontal axes. This plot is useful when you are plotting two groups of data 
that need to have separate independent (X) axes and share the same dependent (Y) axis.

 

                 
Example Double X Plots

 
To create a Double X plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Linear > Double X to display the Variable Selection dialog.
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Click the appropriate check boxes to select the independent (X1) and dependent (Y) variables. A range of data 
columns can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name 
of the last column, and clicking one of the check boxes in the Y column.

Click Add to add a plot group to the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X2) and dependent (Y) variables.
Click Add to add a plot group to the Variable Selection dialog.
Click Plot to generate a plot based on your selections.

 

Double XY Plot
Use a Double XY plot to display two groups of data, each with its own horizontal and vertical scale. Each line in the plot 
represents a separate data column. The data is displayed as a series of X-Y pairs, connected to the next point by a line. 
The data does not have to be sorted, but it is important to note that the points are connected in the order they appear in 
the data window.
 
The Double XY plot gives you the same amount of control over the display of the data as the Line plot, but with the added 
capability of having separate scales on the horizontal and vertical axes. This plot is useful when you are plotting two 
groups of data that need to have separate independent (X) and dependent (Y) axes.

 

                 
Example Double XY Plots

 
To create a Double XY plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Linear > Double XY to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X1) and dependent (Y) variables. A range of data 

columns can be selected for Y or Y2 by clicking the name of the first column, pressing Shift and selecting the 
name of the last column, and clicking one of the check boxes in the Y or Y2 column.

Click Add to add a plot group to the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X2) and dependent (Y2) variables.
Click Add to add a plot group to the Variable Selection dialog.
Click Plot to generate a plot based on your selections.

 

High/Low Plot
This plot type is designed for many uses. The most common is to create High/Low/Close plots for the financial industry. 
This plot normally contains a vertical bar, representing the range of values from low to high, and a marker, representing 
the ending or closing value.
 
The order of the columns in the data window does not matter. However, this plot appears differently depending on how 
many Y variables are plotted for a given X.

One Y variable (Line plot) - A standard Line plot is generated. This is often useful when overlaying a High/Low 
plot with some additional X-Y data.

Two Y variables (Spike plot) - A vertical line is drawn between the two data points. The first plotted variable 
controls the color, line style, width, and marker style.
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Three or more Y variables (High/Low/Close plot) - A vertical line is drawn between the minimum and maximum 
data points. The first plotted variable controls the color, line style, width, and marker style. All of the data 
points between the minimum and maximum are drawn as ticks to the right of the vertical line. The size of the 
tick is controlled by the marker size of the first plotted variable.

 

                 
Example High/Low Plots

 
To create a High/Low plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Linear > High/Low to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables. A range of data 

columns can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name 
of the last column, and clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

Step Plot
A Step plot is a variation of a Line plot. It can be used to compare data that does not show a trend. Each line in the plot 
represents a separate data column. The data is potted as a series of steps. The data does not have to be sorted, but it is 
important to note that the points are connected in the order they appear in the data window.
 
Note: It is not possible to display markers on a Step plot. The placement of the steps is controlled using the Plot Options

command (Plot menu).
 

                 
Example Step Plots

 
To create a Step plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Linear > Step to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables. A range of data 

columns can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name 
of the last column, and clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.
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Fill Plot
A Fill plot is a variation of a Line plot, where a fill pattern is displayed below the variable lines. When plotting one Y 
variable, the area between the variable line and the X axis is filled. When plotting more than one Y variable, each 
successive column is stacked on the previous variable. In this case, the line for the previous variable becomes the 
baseline for the next variable.
 
Note: This plot only supports the use of a single independent (X) variable.

 

                 
Example Fill Plots

 
To create a Fill plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Linear > Fill to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables. A range of data 

columns can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name 
of the last column, and clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

Bubble Plot
Bubble plots are very similar to Scatter plots in that each X-Y pair is represented by a unique marker on the plot. They 
differ from Scatter plots in that a third variable is plotted which represents the area or diameter of the marker. Bubble plots 
can be used to display social, economical, and any other data where it is useful to have the size of the marker represent a 
third variable.
 
A second legend is displayed on the plot that shows the bubble sizes and labels. This legend is controlled by the settings 
for the Y2 axis limits in the Axis Options dialog.
 
It is not possible to display a partial set of markers or a line between the points.

 

                
Example Bubble Plots

 
To create a Bubble plot:

Open or enter the data you want to plot. This plot requires three columns: X, Y, and Y2 (bubble size).
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Linear > Bubble to display the Variable Selection dialog.
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Click the appropriate check boxes to select the independent (X), dependent (Y), and bubble size (Y2) variables. 
Use the Add button to create additional plot groups in order to plot multiple Y variables on the same plot.

Click Plot to generate a plot based on your selections.

 

Probability Plot
Use a Probability plot to display the graph of a variable normalized to either a linear or normal probability distribution. The 
X axis is scaled in probability (between zero and 100%) and shows the percentage of the Y variable whose value is less 
than the data point. The Y axis displays the range of the data.
 
The Probability plot gives rough information about the local density of the data and symmetry. The plotted data points do 
not coincide, even if there are exact duplicates in the data. It is easy to read information from the plot and it can 
accommodate a large number of observations. The Probability plot is not a summary but a display of all the data.
 
Note:  The Plot Options command (Plot menu) controls whether a linear or normal distribution is used.

 

     

  

 

  

 
Example Probability Plots

 
To create a Probability plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Stat > Probability to display the Variable Selection dialog.
Click the appropriate check boxes to select the dependent (Y) variables. A range of data columns can be selected 

for Y by clicking the name of the first column, pressing Shift and selecting the name of the last column, and 
clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

X-Y Probability Plot
The X-Y Probability plot is similar to the Probability plot. The only difference is that in an X-Y Probability plot, you enter the 
probability associated with each Y value. The data is entered as X-Y pairs, where X is the probability (between zero and 
100%) and Y is the data value.
 
The X-Y Probability plot gives rough information about the local density of the data and symmetry. It is easy to read 
information from the plot and it can accommodate a large number of observations. The X-Y Probability plot is not a 
summary but a display of all the data.
 
Note:  The Plot Options command (Plot menu) controls whether a linear or normal distribution is used.
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Example X-Y Probability Plots
 
To create an X-Y Probability plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Stat > X-Y Probability to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables. A range of data 

columns can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name 
of the last column, and clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

Histogram Plot
A Histogram calculates the number of data points that fall within a specified bin size. The resulting plot displays the range 
of the data on the X axis and the number of data points in each bin on the Y axis. If more than one variable is plotted, the 
Y axis displays the total number of points in each bin.
 
KaleidaGraph supports two different methods for creating Histograms. You can either specify the bin size or specify the 
number of bins. The Histogram portion of the Plot Options dialog determines which method is used.

If you choose to create the Histogram by specifying the bin size, the Limits portion of the Axis Options dialog 
contains the fields for the bin size, reference value, and number of bins that get added or removed. This is the 
method that was used in versions 3.5 and 3.6 of KaleidaGraph.

If you choose to create the Histogram by specifying the number of bins, the Histogram portion of the Plot Options 
dialog contains a setting to control the number of bins. This is the method that was used prior to version 3.5 of 
KaleidaGraph.

It is also possible to use the Bin Data command (Functions menu) to perform the binning routine for the Histogram. This 
command provides additional binning options and the results can be used to create other types of plots.
 
Note:  The maximum number of bins is 200.

 

                 
Example Histogram Plots

 
To create a Histogram plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Stat > Histogram to display the Variable Selection dialog.
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Click the appropriate check boxes to select the dependent (Y) variables. A range of data columns can be selected 
for Y by clicking the name of the first column, pressing Shift and selecting the name of the last column, and 
clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

Box Plot
A Box plot enables you to quickly examine a number of variables and extract their major characteristics. While this does 
not provide detailed information about the data, it does give you a look at its global behavior. A Box plot represents each 
variable as a separate box. The X axis displays the names of each variable and the Y axis displays the range of the data.
 
Additional variables may (optionally) be overlaid as markers on each plot. The markers are matched one to one with the 
plotted variables. The first value in a marker column is matched with the first box, the second value in a marker column is 
matched with the second box, and so on.
 
A few additional notes about Box plots:

The width of the boxes is controlled by the Column Offset field in the Bar portion of Plot Options.
The thickness of the boxes is controlled by the Line Thickness field in the General portion of Plot Options.
The color of the box is controlled by the Line Color pop-up menu in Variable Settings.

 

                 
Example Box Plots

 
To create a Box plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Stat > Box to display the Variable Selection dialog.
Click the appropriate check boxes to select the dependent (Y) variables and any markers. A range of data columns 

can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name of the 
last column, and clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

Percentile Plot
A Percentile plot represents each variable as a separate box. The X axis displays the names of each variable and the Y 
axis displays the range of the data. Each box encloses 90% of the data.
 
The bottom and top of each box represent 5% and 95% of the data. Three lines are drawn inside each box. The middle 
line represents the median value of the data (50%), while the lower and upper dashed lines represent 25% and 75% of the 
data, respectively.
 
Additional variables may (optionally) be overlaid as markers on each plot. The markers are matched one to one with the 
plotted variables. The first value in a marker column is matched with the first box, the second value in a marker column is 
matched with the second box, and so on.
 
A few additional notes about Percentile plots:

The width of the boxes is controlled by the Column Offset field in the Bar portion of Plot Options.
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The thickness of the boxes is controlled by the Line Thickness field in the General portion of Plot Options.
The color of the box is controlled by the Line Color pop-up menu in Variable Settings.

 

                 
Example Percentile Plots

 
To create a Percentile plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Stat > Percentile to display the Variable Selection dialog.
Click the appropriate check boxes to select the dependent (Y) variables and any markers. A range of data columns 

can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name of the 
last column, and clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

Dot Plot
A Dot plot enables you to quickly examine a number of variables and extract their major characteristics. Dot plots are often 
used to illustrate the major features of the distribution of the data in a convenient form. A Dot plot can also help detect any 
unusual observations (outliers), or any gaps in the data set.
 
The X axis displays the names of each variable and the Y axis displays the range of the data. You can use the Dot portion 
of the Plot Options dialog (Plot menu) to control the options associated with this type of plot.
 
It is also possible to use the Overlay Markers command (Plot menu) to essentially overlay a Dot plot over a Box, 
Percentile, or Summary Column plot.

 

                 
Example Dot Plots

 
To create a Dot plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Stat > Dot to display the Variable Selection dialog.
Click the appropriate check boxes to select the dependent (Y) variables. A range of data columns can be selected 

for Y by clicking the name of the first column, pressing Shift and selecting the name of the last column, and 
clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.
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Summary Column Plot
A Summary Column plot is similar to a Column plot. The biggest difference is that this plot does not require an 
independent (X) variable. This plot is particularly useful when you have individual data values that you want to display with 
different fill patterns or colors, or when comparing statistical attributes of variable data. You can place each value in a 
separate column and create a Summary Column plot.
 
The X axis displays the names of each variable and the Y axis displays the range of the data. To change the statistical 
attribute displayed in the Summary Column plot, select the attribute from the Display pop-up menu in the Bar portion of 
the Plot Options dialog (Plot menu).
 
The Display pop-up menu is also used when supplying error values in a data column. If you plot the mean of the data and 
add error bars from a data column, the error bar will represent the mean of the error values.

 

                 
Example Summary Column Plots

 
To create a Summary Column plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Stat > Summary Column to display the Variable Selection dialog.
Click the appropriate check boxes to select the dependent (Y) variables. A range of data columns can be selected 

for Y by clicking the name of the first column, pressing Shift and selecting the name of the last column, and 
clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

Horizontal Bar Plot
A Horizontal Bar plot is a graph of data selected from one window. The data is displayed as a series of horizontal bars. 
The length of each bar represents the value of a variable. Multiple values for the same category (row) are displayed as 
side-by-side bars. The horizontal axis displays the range of the dependent values and the vertical axis displays the 
categories.
 
Note: This plot only supports the use of a single independent (X) variable. It is not possible to adjust the axis limits for the 

X axis, so if you need to plot a subset of the data, make the selection before creating the plot.
 

                 
Example Horizontal Bar Plots

 
To create a Horizontal Bar plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
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Choose Gallery > Bar > Horizontal Bar to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables. A range of data 

columns can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name 
of the last column, and clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

Stack Bar Plot
A Stack Bar plot is a graph of data selected from one window. As in a Horizontal Bar plot, the data is displayed as a series 
of horizontal bars. The difference between a Stack Bar plot and a Horizontal Bar plot is that variables belonging to the 
same category (row) are displayed as bars stacked one on top of another. The length of each bar represents the sum of 
the data points for a category. The horizontal axis displays the range of sums for a category and the vertical axis displays 
the categories.
 
Note: This plot only supports the use of a single independent (X) variable. It is not possible to adjust the axis limits for the 

X axis, so if you need to plot a subset of the data, make the selection before creating the plot.
 

                 
Example Stack Bar Plots

 
To create a Stack Bar plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Bar > Stack Bar to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables. A range of data 

columns can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name 
of the last column, and clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

Double Y Bar Plot
A Double Y Bar plot is a graph of data selected from one window. As in a Horizontal Bar plot, the data is displayed as a 
series of horizontal bars. The Double Y Bar plot differs from the Horizontal Bar plot in that it provides you with two 
independent Y axes.
 
The length of each bar represents the value of a variable. Multiple values for the same category (row) are displayed as 
side-by-side bars. The horizontal axes display the range of the dependent values and the vertical axis displays the 
categories.
 
Note: This plot only supports the use of a single independent (X) variable. It is not possible to adjust the axis limits for the 

X axis, so if you need to plot a subset of the data, make the selection before creating the plot.
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Example Double Y Bar Plots

 
To create a Double Y Bar plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Bar > Double Y Bar to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y1 and Y2) variables. A range of 

data columns can be selected for Y or Y2 by clicking the name of the first column, pressing Shift and 
selecting the name of the last column, and clicking one of the check boxes in the Y or Y2 column.

Click Plot to generate a plot based on your selections.

 

Floating Bar Plot
A Floating Bar plot is a graph of data selected from one window. As in a Horizontal Bar plot, the data is displayed as a 
series of horizontal bars. The Floating Bar plot differs from the Horizontal Bar plot in that it requires two or more 
dependent variables that determine the beginning, intermediate, and ending bar positions for each X value.
 
The bars range from the minimum value to the maximum value being plotted for each category. Any other values are 
shown as intermediate values in the bar. The fill patterns correspond to the appropriate data column and are drawn from 
the minimum value to the first intermediate value, from the first intermediate value to the second, and so on. The 
horizontal axis displays the range of the dependent values and the vertical axis displays the categories.
 
Note: This plot only supports the use of a single independent (X) variable and requires a minimum of two dependent (Y) 

variables. It is not possible to adjust the axis limits for the X axis, so if you need to plot a subset of the data, make 
the selection before creating the plot.

 

                 
Example Floating Bar Plots

 
To create a Floating Bar plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Bar > Floating Bar to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables. You must pick at 

least two Y variables for this plot. A range of data columns can be selected for Y by clicking the name of the 
first column, pressing Shift and selecting the name of the last column, and clicking one of the check boxes in 
the Y column.

Click Plot to generate a plot based on your selections.
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Column Plot
A Column plot is a graph of data selected from one window. The data is displayed as a series of vertical bars. The height 
of each bar represents the value of a variable. Multiple values for the same category (row) are displayed as side-by-side 
columns. The horizontal axis displays the categories and the vertical axis displays the range of the variables.
 
Note: This plot only supports the use of a single independent (X) variable. It is not possible to adjust the axis limits for the 

X axis, so if you need to plot a subset of the data, make the selection before creating the plot.
 

                 
Example Column Plots

 
To create a Column plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Bar > Column to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables. A range of data 

columns can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name 
of the last column, and clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

Stack Column Plot
A Stack Column plot is a graph of data selected from one window. As in a Column plot, the data is displayed as a series of 
vertical bars. The difference between a Stack Column plot and a Column plot is that variables belonging to the same 
category (row) are displayed as columns stacked one on top of another. The height of each bar represents the sum of the 
data points for a category. The horizontal axis displays the categories and the vertical axis displays the range of sums for 
all variables in that category.
 
Note: This plot only supports the use of a single independent (X) variable. It is not possible to adjust the axis limits for the 

X axis, so if you need to plot a subset of the data, make the selection before creating the plot.
 

                 
Example Stack Column Plots

 
To create a Stack Column plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Bar > Stack Column to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables. A range of data 

columns can be selected for Y by clicking the name of the first column, pressing Shift and selecting the name 
of the last column, and clicking one of the check boxes in the Y column.
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Click Plot to generate a plot based on your selections.

 

Double Y Column Plot
A Double Y Column plot is a graph of data selected from one window. As in a Column plot, the data is displayed as a 
series of vertical bars. The Double Y Column plot differs from the Column plot in that it provides you with two independent 
Y axes.
 
The height of each bar represents the value of a variable. Multiple values for the same category (row) are displayed as 
side-by-side columns. The horizontal axis displays the categories and the vertical axes display the range of the dependent 
values.
 
Note: This plot only supports the use of a single independent (X) variable. It is not possible to adjust the axis limits for the 

X axis, so if you need to plot a subset of the data, make the selection before creating the plot.
 

                 
Example Double Y Column Plots

 
To create a Double Y Column plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Bar > Double Y Column to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y1 and Y2) variables. A range of 

data columns can be selected for Y or Y2 by clicking the name of the first column, pressing Shift and 
selecting the name of the last column, and clicking one of the check boxes in the Y or Y2 column.

Click Plot to generate a plot based on your selections.

 

Floating Column Plot
A Floating Column plot is a graph of data selected from one window. As in a Column plot, the data is displayed as a series 
of vertical bars. The Floating Column plot differs from the Column plot in that it requires two or more dependent variables 
that determine the beginning, intermediate, and ending column positions for each X value.
 
The columns range from the minimum value to the maximum value being plotted for each category. Any other values are 
shown as intermediate values in the column. The fill patterns correspond to the appropriate data column and are drawn 
from the minimum value to the first intermediate value, from the first intermediate value to the second, and so on. The 
horizontal axis displays the categories and the vertical axis displays the range of the dependent values.
 
Note: This plot only supports the use of a single independent (X) variable and requires a minimum of two dependent (Y) 

variables. It is not possible to adjust the axis limits for the X axis, so if you need to plot a subset of the data, make 
the selection before creating the plot.
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Example Floating Column Plots

 
To create a Floating Column plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Bar > Floating Column to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables. You must pick at 

least two Y variables for this plot. A range of data columns can be selected for Y by clicking the name of the 
first column, pressing Shift and selecting the name of the last column, and clicking one of the check boxes in 
the Y column.

Click Plot to generate a plot based on your selections.

 

Polar Plot
In a Polar plot, the data is plotted on the polar coordinate system. Each point in this system is specified by an angle (φ) in 
degrees and a radius (R). As an option, an alternate data format can be used, where the data is specified in X-Y format 
and then transformed to the polar coordinate system. In either case, an independent variable (φ or X) and one or more 
dependent variables (R or Y) are selected for plotting.
 
Using the Plot Options command (Plot menu), you can specify the grid type, data format, reference angle, and direction 
for Polar plots.

 
  

 

  

 
Example Polar Plots

 
To create a Polar plot:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Polar to display the Variable Selection dialog.

Click the appropriate check boxes to select the independent (φ or X) and dependent (R or Y) variables. A range of 
data columns can be selected for Y by clicking the name of the first column, pressing Shift and selecting the 
name of the last column, and clicking one of the check boxes in the Y column.

Click Plot to generate a plot based on your selections.

 

Pie Chart
A Pie chart displays the values as a percentage of the total area of a circle. Each of the categories is represented as a 
segment of the circle (or a wedge of the pie). Only two variables may be plotted at one time in a Pie chart. The first is the 
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independent variable (X) or category. This variable contains the name of each category. The second variable (Y) contains 
the category values, which must be numeric.
 
Note:  Negative values cannot be plotted in a Pie chart. If the data contains negative values, a dialog gives you the option 

of plotting the absolute value of the data or canceling the plot.
 

     

  

 
Example Pie Charts

 
To create a Pie chart:

Open or enter the data you want to plot.
To plot a portion of the data, make a selection in the data window.
Choose Gallery > Pie to display the Variable Selection dialog.
Click the appropriate check boxes to select the independent (X) and dependent (Y) variables.
Click Plot to generate a plot based on your selections.

 

Function Plot
The Function plot can be used to display a mathematical function as a plot. Choosing this plot type displays a dialog 
where you can enter the function, the minimum and maximum X values, and the number of points to plot.
 
Once the plot is created, it behaves like a Line plot. You have full control over the line style, markers, and all other 
components of the plot.

 

                 
Example Function Plots

 

Text Plot
This plot type allows you to create a plot window whose intended use is text. Text plots are particularly useful when you 
want to generate a plot that only contains text, lines, boxes, tables, or pictures.
 
Note: Certain tools in this window are unavailable, because they can only be used when data is plotted.
 

Template Plot
The Template plot is used to generate the same type of plot, using different data. It allows you to take any plot and use it 
as a base for plotting new data. This works for both new plots and plots that have been saved.
 
When you choose Gallery > Template, a new data selection can be plotted. The new data is auto-scaled unless the limits 
are specified otherwise in the Axis Options dialog. The legend reflects the new variables being plotted, but all other text 
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labels and objects remain the same as the template. Any curve fits or error bars in the original plot are applied and 
recalculated in the new plot.
 
Once a Template plot has been created, it can be modified like any other plot. The limitation when using the Template plot 
is that only one plot can be generated at a time. If you need the ability to generate multiple plots at once, use the Plot 
Script feature instead.
 

Variable Selection Dialog
The Variable Selection dialog (shown below) is displayed after choosing most of the plot types in the Gallery menu. This 
dialog can be used to plot a maximum of 99 variables on a single plot.
 

 
 The Variable Selection dialog contains the following features:

The names of any open data windows are listed on the left side of the dialog.
The column names and numbers for the selected data window are displayed to the right of the data window 
names.
The bottom half of the dialog lists any plot groups that are added. It is only necessary to add plot groups when 
plotting from multiple data windows or plotting multiple X-Y pairs.
The New button clears all of the check boxes.
The Add button creates a plot group of the current variable selections. This button needs to be used when plotting 
from multiple data windows, plotting multiple independent variables, or creating Double X or Double XY plots. A 
maximum of 40 plot groups can be created for a single plot.
The Edit button is used to edit the variables selected for an existing plot group.
The Delete button removes the selected plot group.
The dialog can be resized in three different ways:

Drag the lower-right corner of the dialog to increase the size of the entire dialog.
Horizontally drag the control in the upper portion of the dialog to adjust the amount of space available for the 

data window names and column titles.
Vertically drag the control in the lower portion of the dialog to adjust the amount of space used for the column 

titles and plot groups.
A range of data columns can be selected for Y or Y2 by clicking the name of the first column, pressing Shift and 
selecting the name of the last column, and clicking one of the check boxes in the Y or Y2 column.
Plot groups appear in the lower half of the dialog when you use the Add button. They will also appear when 
choosing a plot type from the Gallery menu when a plot window is active to display what variables were plotted in 
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the current plot. If there are multiple plot groups, the order can be changed by clicking the plot group and clicking 
the up or down arrow buttons. This changes the order in which the variables are listed in the legend.
The order of the variables within a plot group can also be changed with the up and down arrows, as long as the 
group is not in Edit Mode.

 

Arranging Data for Plots
All of the plots in KaleidaGraph are created by plotting one or more columns of data. The following sections describe the 
basic requirements for the various types of plots.
 

Linear and X-Y Probability Plots
Most of these plot types require one column of X values and one or more columns of Y values. In the case of the Double Y 
plot, columns must be selected for both the Y and Y2 variables. When creating Double X and Double XY plots, two 
columns of X values must be plotted.
 

Bubble Plots
Bubble plots require three data columns: one column of X values, one column of Y values, and a third column containing 
the area or diameter of the marker.
 

Probability, Box, Percentile, Dot, and Summary Column Plots
These plots only require columns of Y data. The Box and Percentile plots also allow additional columns to be plotted and 
overlaid as markers on the plots.
 

Bar and Column Plots
These plots require one column of X values (categories) and one or more Y columns containing the numeric values for 
each category. In the case of the Double Y Bar and Double Y Column plots, columns must be selected for both the Y and 
Y2 variables.
 

Polar Plots
The Polar plot requires two data columns for plotting, however the data can be organized in one of two ways. The data 
can either be in φ - R format (where φ is an angle in degrees and R is a radius) or it can be in X -Y format (where the data 
gets transformed to the polar coordinate system). There is a Data Format setting in the Polar section of the Plot Options 
dialog that specifies what type of data is provided.
 

Pie Charts
A Pie chart requires two data columns: one column of X values (categories) and one Y column containing the numeric 
values for each category.
 

Creating a Plot
The Gallery menu contains the plot types available in KaleidaGraph. You can create a plot using any of the open data 
windows. If a selection is made in the data you are plotting, only the selected data is used in making the plot.
 
To create a plot:

Open the data to be plotted.
Make any selections in the data windows to plot a subset of the data.
Choose a plot type from the Gallery menu to display the Variable Selection dialog.
Click the appropriate check boxes to select the columns to be plotted. A range of data columns can be selected for 

Y or Y2 by clicking the name of the first column, pressing Shift and selecting the name of the last column, and 
clicking one of the check boxes in the Y or Y2 column.

Note: In the case of the Double X and Double XY plots, you need to click the Add button after choosing the first 
set of X and Y variables. This adds a plot group to the list and allows you to continue making variable 
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selections for the plot. The Add button would also be used anytime you need to plot different X columns 
on the same plot.

Click Plot to create the plot.

 
At this point, the plot is linked to the original data window. If another plot is opened or created, the data for the previous 
plot becomes embedded in the plot. If the plot is saved, a copy of the data is embedded in the plot and saved as part of 
the plot file. Once data is embedded in the plot, it can be extracted by choosing Plot > Extract Data or clicking the Extract 
button  in the plot window.
 

Plotting from Multiple Data Sets
Unless you are creating a Fill plot, Pie chart, or one of the plots in the Bar submenu, you can plot data from multiple data 
windows. This is accomplished by making variable selections for each data set to be used.
 
Note: If a text column is used as the independent variable, you may not select any other independent variables and you 

can only plot from that particular data window.
 
To create a plot from multiple data sets:

Open the data to be plotted. To plot subsections of any data sets, select the appropriate rows in each data window.
Choose a plot type from the Gallery menu. A Variable Selection dialog appears.
Make the independent and dependent variable selections for the active data window and click Add. A plot group 

will be added to the Variable Selection dialog.
Click the name of a different data window, make the variable selections, and click Add. Continue doing this until all 

of the variables to be plotted are selected.
Click Plot to create a plot based on the selections.

 

Plotting Multiple X-Y Pairs from the same Data Window
The X-Y Probability, Polar, and all of the Linear plots other than the Fill plot allow you to plot multiple independent 
variables from the same data window. If the independent variable is a text column, you may only have one independent 
variable.
 
To create a plot from one data window, with different X variables:

Open the data to be plotted.
Choose a plot type from the Gallery menu. A Variable Selection dialog appears.
Make the first set of X and Y variable selections and click Add. A plot group will be added to the Variable Selection 

dialog.
Make another set of X and Y variable selections and click Add. Continue doing this until all of the selections are 

made.
Click Plot to create a plot based on the selections.

 

Plotting Duplicate Categories in Bar/Column Plots
If you select variables for plotting that have duplicate X values (duplicate category values) in any of the Bar/Column plot 
types, a dialog is displayed to specify how any duplicate values are handled by the plot. A description of the options 
follows:

treating each occurrence as a new category - For each Y variable, this option plots the Y values for each 
duplicate category value as a separate, independent category.

ignoring all except the first occurrence - For each Y variable, this option only plots the first occurrence of a 
category. Any duplicate categories are ignored and not plotted.

summing the values of the occurrences - For each Y variable, one value representing the sum of all Y values is 
plotted.
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averaging the values of the occurrences - For each Y variable, one value representing the average of all Y 
values is plotted.

using the largest value of the occurrences - For each Y variable, one value representing the largest of all Y 
values is plotted.

using the lowest value of the occurrences - For each Y variable, one value representing the smallest of all Y 
values is plotted.

counting the number of occurrences - For each Y variable, a frequency value representing the number of 
duplicate categories is plotted.

 

Plotting a Function
KaleidaGraph provides a Function plot that can be used to plot any mathematical function. The function you enter is 
evaluated between the specified limits and is displayed as a plot.
 
When defining your function, use x for the independent variable. The operators and math functions found in Formula Entry 
can be used in defining your function. Constants and other shorthand references can be defined in the library.
 
Some example Function plot definitions are listed below:
5 * x^2
gaussfit(1, 5, 1, 10)
m1 + m2 * exp(–m3 * x); m1 = 5; m2 = 1; m3 = 0.5
a * exp(–b * x) * cos(c * x + d); a = 4; b = 0.7; c = 2.2; d = 15
 
To create a Function plot:

Choose Gallery > Function to display the Function Plot dialog, shown below.

 

 

Enter the function you want to plot. The File button can be used to load a saved function definition.
If necessary, change the values for the minimum, maximum, and number of points.
Click New Plot to plot the function.

 
Once the Function plot is created, it behaves like a Line plot. You have full control over the line style, markers, and all 
other components of the plot. If you want to see the data generated by the function, choose Plot > Extract Data or click 
the Extract button  in the plot window. This is useful if you want to plot a function along with your other data. You can plot 
the function, extract the data, and then include this data when creating the plot. If you would want to plot multiple 
functions, you would need to create multiple Functions plots, extract the data from each plot, and plot all of the data using 
a Line plot.
 

Generating Similar Plots
If you routinely create the same types of plots in KaleidaGraph, it helps to set some defaults or templates so that most of 
the work can be done automatically. KaleidaGraph provides several features that can be used to generate similar plots.
 
The following topics provide a general idea of when to use each to achieve a consistent look for your plots:
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Style Files - This feature is useful for setting program defaults like font information, plot characteristics, colors, and 
so on. This information is used any time a new plot is created. It is possible to export separate Style files so 
that you can load different settings as needed.

Template Plots - This feature is useful when you have an existing plot and want to replace the data, keeping the 
appearance of the plot intact. If the original plot contains curve fits or error bars, the resulting plot will also 
have these applied. The plot and axis titles will remain the same; however, the legend will reflect the names of 
the new variables.

Plot Scripts - This feature is useful when you need to generate several identical plots at one time from different 
data sets. If the script is pointed at a plot that contains curve fits or error bars, each resulting plot will also 
have these applied. Other features include the option to automatically save or print each plot and the ability to 
set the titles and legend information for each plot.

Formula Scripts - This feature is useful for automating the process of creating plots. Using a formula script, it is 
possible to open saved data files, manipulate the data with Formula Entry, and create plots.

 

Using Style Files
One way to generate similar plots is through the use of Style files, which store the settings associated with the 
appearance of a plot. This includes the color table, text defaults, and the default layouts for the plots. Each of the plots in 
the Gallery menu can have its own layout. The layout remembers the default style for the legend, the position of the axis 
titles, plot title, axes, and legend, and the size of the axes, frame, and legend.
 
To define the layout for a plot:

Open an existing plot or create a plot of the type you want to define.
Modify the position and size of the titles, plot, and legend.
Choose Plot > Define Layout. The following dialog appears, asking if you want to save the layout for this plot 

type.

 

 

Click OK to save the layout.

 
Defining the layout of a plot only saves the position of the titles and legend. It does not save any of the settings for the text 
labels.
 
You need to save the Style file when quitting for these changes to be remembered the next time you start KaleidaGraph. 
To create individual Style files for different projects, choose File > Export > Style. This way you can save any number of 
different Style files which can be opened at a later time using the Open command.
 

Using Template Plots
The Template plot is used to generate the same type of plot, using different data. It allows you to take any graph and use it 
as a base for plotting new data. This works for new graphs and graphs that were saved.
 
The new data is autoscaled unless the limits are fixed in the Axis Options dialog. The legend reflects the new variables 
being plotted, but all other text labels and objects remain the same. Any curve fits or error bars in the original plot are 
applied and recalculated on the new plot.
 
Once a Template plot has been created, it can be modified like any other plot. If you need the ability to generate multiple 
plots at once, use the Plot Script feature.
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To use a plot as a template for creating other plots:

Open or create the data to be plotted.
Open or create the plot you want to use as a base for creating other plots.
Choose Gallery > Template to display a Variable Selection dialog, shown below.

 

 

Click the appropriate buttons to select the variables to be plotted.
Click New Plot to generate a plot based on your selections.

Note: It is not necessary to use the Template plot if you are only modifying the original data used to create the plot. 
Instead, you can extract the data from the plot, modify it, and update the plot.

 

Using Plot Scripts
Another way to generate similar plots is the Plot Script command (Windows menu). This feature enables you to choose 
any plot type or an existing plot and use it as a template for creating multiple plots at once.
 
The script feature is intended for the user who has a Template plot and wants to plot different data sets and view the 
resulting curves. Even if you only need to generate a simple plot, but you generate it all of the time with different data, you 
will find plot scripts very useful.
 
The advantage of a plot script over a Template plot is that a script can generate multiple plots. Also, you can control 
legend descriptions and plot titles using a script. In a Template plot, the legend descriptions come from the column names 
of the plotted variables and the plot title remains unchanged.
 

Using Formula Scripts
The last feature that allows you to generate similar plots is a formula script. This feature has a command, #SCRIPT, which 
has all of the same options as the Plot Script window. You can create a plot script from scratch or you can use a command 
to open one that is saved.
 
The advantage of using a formula script is that you can open and modify data windows as part of the script. You can also 
execute more than one plot script inside of a formula script.
 
The disadvantage of using this feature is that you cannot select a specific plot to be used as the template. It must either be 
a Gallery plot type or a plot that is opened as part of a saved plot script.
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Hiding, Displaying, and Closing Plots
The Windows menu contains four commands that can be used to hide and display plot windows. These commands 
operate on either a single window or all of the plot windows at once.
 

Changing the Active Window
To make a plot window active, click anywhere in the desired plot window or choose Windows > Show Plot and select its 
name.
 

Hiding Plot Windows
To hide a plot window, choose Windows > Hide Window and select its name. You can hide all open plots by choosing 
Windows > Hide All Plots.
 

Displaying Plot Windows
You can display a hidden plot window with the Show Plot command (Windows menu). Names of hidden plot windows 
show two dashes before the name. Select the name of the desired plot window to bring it to the front. The Show All Plots
command can be used to display all of the plot windows at once.
 

Closing Plot Windows
You can use the Close All Plots command (Windows menu) to close all of the open plot windows at once. Individual plot 
windows can be closed by choosing File > Close or clicking the close box of each window. A dialog may be displayed, 
asking if you want to save the plot before closing.
 
Note: If you do not want to save the plot, this dialog can be avoided by pressing Shift while either clicking the close box or 

choosing File > Close/NoSave.
 
You can have a maximum of 50 plots open at one time in KaleidaGraph. If you have 50 plots open and try to create 
another plot, either the oldest plot is automatically disposed or a dialog prompts whether to save or dispose of the oldest 
plot. The General tab of the Preferences dialog contains an option that controls the automatic disposal of plots. If 
Automatically dispose of old plots is selected, the oldest plot is discarded. If this check box is cleared, the dialog is 
displayed.
 

Changing the Magnification of the Plot Window
KaleidaGraph provides several options to change the magnification level of the plot window. The magnification setting 

 is located to the left of the horizontal scroll bar in the plot window. Alternately, you can use the Set Plot 
View command (Plot menu).
 
To change the magnification of the plot window:

Right-click the magnification setting and choose the desired magnification level from the pop-up menu. The 
available percentages range from 25 to 800%.

Type a value in the field to enter a specific magnification level. The available percentages range from 25 to 1000%.
Click the up or down controls to adjust the magnification levels in 25% increments.

 

Displaying Rulers and Grids in the Plot Window
To turn the rulers and grids on and off in the plot window:

With the plot window active, choose Plot > Rulers & Grids.
Click the appropriate check boxes to display the rulers, grids, or both.
Select the proper units that you want to use.
Click OK to return to the plot window.

The Preferences dialog contains Show plot rulers and Show plot grids options that can be used to globally show these 
for new plots.
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Overview: Modifying the Legend
The legend consists of a frame, the plot symbols, and the labels used to identify each variable in the plot. By default, the 
labels are taken from the column names in the data window. The legend displays the variables in the order they are 
selected for plotting.
 
Refer to the following topics to learn how to modify the legend:

Changing Foreground and Background Color
Changing Fill and Pen Patterns
Changing Line Style and Width
Setting Legend Frame Defaults
Editing Legend Text Attributes as a Group
Editing Individual Items in the Legend
Changing Legend Text Color Independent of Variable Color
 

Changing Foreground and Background Color
The Color icon on the toolbox consists of two sections: a foreground section (upper-left) for setting the foreground color 
and a background section (lower-right) for setting the background color. When you select a fill or pen pattern, the 
foreground color is applied to the black portion of the pattern and the background color is applied to the white portion of 
the pattern.
 
To change the foreground or background color of the legend:

Click the legend to select it.
Click the foreground or background section of the Color icon to display the current color choices, as shown below.

         
Foreground Color palette         Background Color palette

Select a different color from the palette.

 

Changing Fill and Pen Patterns
The Pattern icon on the toolbox consists of two sections: an inner section for setting the fill pattern and an outer section for 
setting the pen pattern. The fill pattern controls the interior of the legend; the pen pattern controls the legend frame.
 
You can change the fill or pen pattern by selecting a different pattern from the pop-up menu that appears when you click 
the appropriate portion of the Pattern icon. Black portions of the pattern represent the foreground color and white portions 
represent the background color.
 
To change the fill or pen pattern of the legend:

Click the legend to select it.
Click the interior or outer portion of the Pattern icon to display the pattern choices, as shown below.

         



Working with Plots

Page 105

3.

1.
2.

3.

1.
2.
3.

Fill pattern choices         Pen pattern choices

Select a different pattern from the pop-up menu.

 

Changing Line Style and Width
The Style icon on the toolbox controls the line style and width of the legend frame. The left portion of the icon controls the 
line style; the right portion controls the line width.
 
To change the line style or width of the legend frame:

Click the legend to select it.
Click the line style or line width portion of the Style icon. One of the following pop-up menus appears with the 

available choices.

         
Line style pop-up menu         Line width pop-up menu

 

Select a different line style or width from the pop-up menu. To completely remove the frame around the legend, 
choose None from the Line Style pop-up menu.

 

Setting Legend Frame Defaults
To make the current legend style the default, choose Plot > Define Layout. Choosing this command only remembers the 
settings for this particular type of plot because each plot type in the Gallery menu can have its own layout.
 
This information is saved as part of the Style file. You must save the Style file for the layout to be remembered the next 
time you start KaleidaGraph.
 

Editing Legend Text Attributes as a Group
To edit the items in the legend as a group:

Select the Selection Arrow from the toolbox.
Double-click any of the labels in the legend.
The Edit String dialog is displayed, as shown below. This dialog can only be used to modify the attributes of the 

text labels.
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Click OK when you are finished.

Note: Using this method, you cannot edit the text in any of the labels. You need to use the Text tool to do this.
 

Editing Individual Items in the Legend
To edit the items in the legend individually:

Select the Text tool from the toolbox.
Double-click any of the labels in the legend.
The Edit String dialog is displayed to modify the attributes and text of the selected label.
Click OK when you are finished.

Note: The labels in the legend can be moved to different locations using the Text tool. This is accomplished by dragging a 
label to a new position with the Text tool. To delete an item in the legend, use the Eraser.

 

Changing Legend Text Color Independent of Variable Color
By default, the color of the legend text is linked to the variable color set in the Variable Settings dialog. To make these 
different colors, choose Plot > Text Options and clear the Link Text To Variable Color check box. The text and variable 
colors can now be set independently.
 

Overview: Modifying Axes
The Axis Options dialog contains almost all of the options related to the display of the axes. This dialog can be displayed 
by either choosing Plot > Axis Options or triple-clicking one of the axes.
 
Refer to the following topics to learn how to modify the axes:

Setting the Axis Limits
Selecting Linear or Log Scaling
Changing the Position of an Axis
Inserting an Axis Break
Removing an Axis Break
Hiding an Axis
Exchanging Axes
Reversing the Variables on an Axis
Changing Axis Color
Changing Axis Thickness
 

Setting the Axis Limits
The axis limits are based on the data used to create the plot. KaleidaGraph automatically calculates the minimum and 
maximum values and the placement of tick marks along the axes.
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You can specify your own limits in the Axis Options dialog. The Minimum and Maximum fields determine the lowest and 
highest values on the selected axis. The Anchor Tick field indicates the value from which all major tick marks on a linear 
axis are calculated. The Anchor Tick field has no affect on axes with logarithmic scales.
 
If the X column is formatted as Text, the values are treated as categories instead of numeric values and the axis limits 
roughly correspond to the row numbers in the data window. Row 0 in the data window would be represented by a value of 
1 for the Minimum value. A Minimum value of 0 allows you to add a little bit of space between the Y axis and the first 
data point. If these values should be treated as numbers, make sure the X data column is formatted as Float or Double.
 
In the case of Bar and Column plots, the Maximum value represents the number of categories that have been plotted 
along the X axis. It is not possible to adjust the axis limits for these plots. To plot a subset of the data, you would need to 
make a selection before creating the plot.
 
To set the axis limits:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Limits if it is not already selected. The Axis Options dialog changes to display the options available for 

controlling axis limits.
Enter values for Minimum, Maximum, and Anchor Tick. To return to the original values calculated by 

KaleidaGraph, click the Auto check boxes.
Click OK to return to the plot.

 

Selecting Linear or Logarithmic Scaling
The numeric axes in KaleidaGraph can have linear or logarithmic scaling. When Linear scaling is selected, the axis is 
divided into equal sections. When Log, Ln, or Log2 scaling is used, each increment of the axis is a power of 10, e, or 2, 
respectively.
 
Note: The Minimum value in the Axis Options dialog must be greater than zero to use log scaling. If you try to use non-

positive limits, a message appears and the axis scaling reverts to linear.
 
To change the scaling of an axis:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Limits if it is not already selected. The Axis Options dialog changes to display the options available for 

controlling axis limits.
Choose Linear, Log, Ln, or Log2 from the Scale pop-up menu.
Click OK to return to the plot.

 

Overview: Changing the Position of an Axis
By default, KaleidaGraph places the axes at the edge of the plot area. However, you have complete control over where to 
place each of the axes on the plot. The axes can be positioned away from the plot to create offset axes, at a specific value 
on the X or Y axis, or at a percentage of the length of the X or Y axis.
 
Refer to the following topics to learn how to change the position of an axis:

Changing the Position via the Axis Options Command
Changing the Position with the Selection Arrow

 
The following examples show some different ways that you can position the axes:

Example 1 - Offset Axes
Example 2 - Axes that Intersect at the Origin
Example 3 - Both X Axes at the Bottom of the Plot
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Changing the Position via the Axis Options Command
You can use the Axis Options command (Plot menu) to control the position for each of the axes in a plot.
 
To change the position of an axis:

Choose Plot > Axis Options to display the Axis Options dialog.
Click the appropriate axis tab at the top of the dialog.
Click Position. The Axis Options dialog changes to display the options available for controlling the axis position.
Specify where you want this axis positioned:

Choose Bottom, Left, Top, or Right to return the axis to its default location.
Choose % From Bottom, % From Left, % From Top, or % From Right and enter the axis length percentage 

to offset the axis from the default location. Enter a positive value to move the axis towards the center of 
the plot; enter a negative value to move the axis away from the center of the plot.

Choose At Y = or At X = to place the axis at a specific value along the axis. If the value is outside the limits or 
occurs within a break, the axis will be placed at the nearest point along the axis.

Click OK to return to the plot.

 

Changing the Position with the Selection Arrow
The Selection Arrow can be used to manually change the position of an axis.
 
To change the position of an axis:

Double-click one of the axes with the Selection Arrow. The first click selects the plot frame, the second click selects 
the individual axis. A dotted box will be drawn around the selected axis.

Drag the axis to a new position. You can also use the arrow keys to move the axis.

Note: The axes can only be moved in one direction. The horizontal axes can only move vertically, and the vertical axes 
can only move horizontally.

 

Example 1 - Offset Axes
By entering a negative percentage, it is possible to create offset axes as shown in the following plot:
 

 
The Axis Options dialog had the following settings for the Position:
X axis: -8% From Bottom
Y axis: -5% From Left
 
To remove the X2 and Y2 axes, the Turn Off Axis option was selected for both the X2 and Y2 axes.
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Example 2 - Axes that Intersect at the Origin
You can force the axes to cross at specific values, as shown in the following plot:
 

 
The Axis Options dialog had the following settings for the Position:
X axis: At Y = 0
Y axis: At X = 0
 
To remove the X2 and Y2 axes, the Turn Off Axis option was selected for both the X2 and Y2 axes.
 

Example 3 - Both X Axes at the Bottom of the Plot
You can place multiple axes on the same side of the graph, as shown in the following plot:
 

 
The Axis Options dialog had the following settings for the Position:
X2 axis: 125% From Top
The axis labels and axis title were manually moved to get this appearance.
 
To remove the Y2 axis, the Turn Off Axis option was selected.
 

Inserting an Axis Break
Most of the plots in KaleidaGraph allow you place a break in the axis. Breaks are normally used when you have large 
gaps in the values that you are plotting.
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KaleidaGraph provides options to control the data range of the break, the placement of the break, the symbol used to 
identify the break, and the scaling and tick marks displayed after the break.
 
To insert a break in an axis:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Breaks. The Axis Options dialog changes to display the options available for inserting an axis break.
Enter the range of values you want excluded in the Omit and To fields. As soon as you make any changes, the 

Show Axis Break check box is automatically selected.
To control the position of the break, enter a value in the Position field. The position represents a percentage of the 

axis length, starting at the origin. The default is to place the break in the middle of the axis.
To control the width of the break, edit the Width field.
To select a different symbol for the axis break, use the Gap Style pop-up menu. The length of these symbols is set 

using the Length field.
To change the scaling or tick marks on the other side of the axis break, use the Post Break Interval, Major Ticks, 

and Minor Ticks pop-up menus.
Click OK to return to the plot.

Note: Once an axis break is inserted, the Data Selection and Zoom Selection tools become disabled.
 
The following examples show some different ways that you can insert breaks in the axes:

Example 1 - Break in the Middle of the Y Axis
Example 2 - Breaks on the X and Y Axes
Example 3 - Using a Break to Display 0 on a Log Scale

 
 

Removing an Axis Break
To remove an axis break:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Breaks. The Axis Options dialog changes to display the options available for axis breaks.
Clear the Show Axis Break check box.
Click OK to return to the plot.

 

Example 1 - Break in the Middle of the Y Axis
The following plot has an axis break between 15000 and 125000 on the Y axis.
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The Axis Options dialog had the following settings for the Y axis:
Limits: Minimum of 0 and a Maximum of 200000.
Ticks: Interval of 5000
Break: Omit 15000 To 125000, auto Position, Plain Gap Style, Width of 20, auto Post Break Interval, and an Interval of 
25000 for the Major Ticks.
 

Example 2 - Breaks on the X and Y Axes
The following plot displays axis breaks on both the X and Y axes:
 

 
The Axis Options dialog had the following settings for the X axis:
Limits: Minimum of 6/1/99 and a Maximum of 10/1/03.
Ticks: Interval of 1 month
Break: Omit 10/1/99 To 6/1/03, auto Position, Slanted Gap Style, Width of 20, Length of 5, and an auto Post Break 
Interval.
 
The Axis Options dialog had the following settings for the Y axis:
Limits: Minimum of 10 and a Maximum of 120.
Ticks: Interval of 10
Break: Omit 30 To 90, auto Position, Slanted Gap Style, Width of 20, Length of 5, and an auto Post Break Interval.
 
The Y2 axis labels were displayed by selecting Y Axis, Y Labels from the Link To pop-up menu for the Y2 axis.
 

Example 3 - Using a Break to Display 0 on a Log Scale
The following plot makes use of an axis break so that a reference value of 0 can be displayed on a log scale:
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The Axis Options dialog had the following settings for the X axis:
Limits: Minimum of –0.001 and a Maximum of 1000.
Break: Omit 0.001 To .04, Position of 8, Plain Gap Style, Width of 12, and a Post Break Interval of Log.
 

Hiding an Axis
It is possible to hide each of the four axes in a plot using the Turn Off Axis option in the Axis Options dialog.
 
To hide an axis:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Position. The Axis Options dialog changes to display the options available for controlling the axis position.
Click the Turn Off Axis check box.
Click OK to return to the plot.

 

Exchanging Axes
The Exchange X and Y Axis option in the Axis Options dialog can be used to swap the X and Y axes of a plot. When this 
check box is selected, the X and X2 axes switch position with the Y and Y2 axes.
 
Note: Using this option does not change the independent and dependent variables. It only changes their position in the 

plot. This option is not available for Double Y, Double X, Double XY, Bubble, Bar, Polar, and Pie plots.
 
To exchange the X and Y axes:

With the plot window active, choose Plot > Axis Options.
Click the X or Y axis tab at the top of the dialog.
Click Position. The Axis Options dialog changes to display the options available for controlling the axis position.
Click the Exchange X and Y Axis check box.
Click OK to return to the plot.

 

Reversing the Variables on an Axis
You can control whether the variables are plotted in ascending or descending order along an axis. By selecting the 
Reverse Axis Direction check box in the Axis Options dialog, variables are plotted in descending order along the 
selected axis.
 
To reverse an axis on the plot:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Limits if it is not already selected. The Axis Options dialog changes to display the options available for 

controlling axis limits.
Click the Reverse Axis Direction check box.
Click OK to return to the plot.

 

Changing Axis Color
To change the color of an axis:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Colors. The Axis Options dialog changes to display the color options available for this axis.
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Select the desired color from the Axis pop-up menu.
Click OK to return to the plot.

Note: To edit the colors that appear in the pop-up menus, use the Edit Colors command (Object menu).
 

Changing Axis Thickness
To change the thickness of the axes:

With the plot window active, choose Plot > Axis Options.
Click the All tab at the top of the dialog.
Click Thickness. The Axis Options dialog changes to display the thickness options available.
Choose the desired thickness from the Axis Thickness pop-up menu.
Click OK to return to the plot.

Note: Depending on the thickness selected, you may not notice the change on the screen; however, there will be a 
difference when the plot is printed.

 

Overview: Modifying Tick Marks and Grid Lines
The Axis Options dialog contains all of the options related to the display of tick marks and grid lines. This dialog can be 
displayed by either choosing Plot > Axis Options or triple-clicking one of the axes.
 
Refer to the following topics to learn how to modify the tick marks and grid lines:

Changing the Display of Tick Marks and Grid Lines
Changing the Number of Tick Marks
Changing the Tick Mark Interval
Changing Tick Mark and Grid Line Color
Changing Tick Mark Length
Changing Tick Mark and Grid Line Thickness
Linking Ticks on the X2 and Y2 Axes
 

Changing the Display of Tick Marks and Grid Lines
The major and minor ticks can be displayed inside, outside, or on both sides of the axis. You can also choose not to 
display them at all.
 
Grid lines can be displayed at each of the major and minor tick marks. The lines can be gray (dotted), solid, or not 
displayed at all.
 
Note: For most plots, the ticks along the X2 and Y2 axes are based on the setting of the Link To pop-up menu in the 

Limits portion of the Axis Options dialog.
 
To control how major and minor ticks and grid lines are displayed:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Ticks & Grids. The Axis Options dialog changes to display the options available for controlling major and 

minor ticks and grid lines.
To change how the tick marks are displayed, choose In, Out, Both, or None from the Display Tick pop-up menus.
To change how grid lines are displayed, choose Gray, Solid, or None from the Display Grid pop-up menus.
Click OK to return to the plot.
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Changing the Number of Tick Marks
When Linear scaling is selected for an axis, the number of major tick marks is controlled by the Quantity pop-up menu. 
They can either be calculated automatically or set to a specific number.
 
To change the number of major ticks:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Ticks & Grids. The Axis Options dialog changes to display the options available for controlling major and 

minor ticks and grid lines.
Choose Auto or Fixed # from the Quantity pop-up menu.
If Fixed # is selected, enter the desired number of divisions in the field below the pop-up menu.

Note: Entering a different value in this field automatically selects Fixed # from the menu.

 Click OK to return to the plot.

 
The number of minor tick marks is controlled in the same manner as major ticks. You can either specify a fixed number or 
let KaleidaGraph calculate the number of minor ticks.
 

Changing the Tick Mark Interval
When Linear scaling is selected for an axis, KaleidaGraph automatically determines the number of major tick marks. 
Using the Axis Options command, it is possible to place the tick marks at specific intervals along an axis.
 
To change the interval between major tick marks:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Limits if it is not already selected. The Axis Options dialog changes to display the options available for 

controlling axis limits.
Enter a value in the Anchor Tick field. The intervals are calculated from the Anchor Tick value.
Click Ticks & Grids.
Choose Interval from the Quantity pop-up menu and enter the desired interval in the field below it. When 

specifying an interval for dates, the interval can be entered in the following units: years, months, weeks, days, 
hours, minutes, or seconds. For time intervals, the interval should be entered in a D:H:M:S format.

Note: Entering a value with a decimal point automatically selects Interval from the menu.

Click OK to return to the plot.

 

Changing Tick Mark and Grid Line Color
To change the color of the tick marks or grid lines:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Colors. The Axis Options dialog changes to display the color options available for this axis.
Select the desired colors from the Major Tick and Major Grid pop-up menus.
To change the color of minor ticks or minor grids, clear the Link Tick Colors or Link Grid Colors check box and 

select the desired color from the Minor Tick or Minor Grid pop-up menu.
Click OK to return to the plot.

Note: To edit the colors that appear in the pop-up menus, use the Edit Colors command (Object menu).
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Changing Tick Mark Length
To change the length of the tick marks:

With the plot window active, choose Plot > Axis Options.
Click the All tab at the top of the dialog.
Click Tick Length. The Axis Options dialog changes to display the options available.
Edit the Inside Length and Outside Length fields for the major and minor ticks.
Click OK to return to the plot.

 

Changing Tick Mark and Grid Line Thickness
To change the thickness of the tick marks or grid lines:

With the plot window active, choose Plot > Axis Options.
Click the All tab at the top of the dialog.
Click Thickness. The Axis Options dialog changes to display the thickness options available.
Choose the desired thickness from the Tick Thickness or Grid Thickness pop-up menu.
Click OK to return to the plot.

Note: Depending on the thickness selected, you may not notice the change on the screen; however, there will be a 
difference when the plot is printed.

 

Linking Ticks on the X2 and Y2 Axes
You can control the display of the tick marks on the X2 and Y2 axes using the Link To pop-up menu. This pop-up menu is 
only available when the X2 or Y2 axis tab is selected.
 
Note: The Link To pop-up menu is not available for certain axes in Double Y, Double X, Double XY, Double Y Bar, and 

Double Y Column plots because they are independent of the main axis and cannot be linked.
 
To link the X2 or Y2 tick marks:

With the plot window active, choose Plot > Axis Options.
Click the X2 or Y2 axis tab at the top of the dialog.
Click Limits if it is not already selected. The Axis Options dialog changes to display the options available for 

controlling axis limits.
From the Link To pop-up menu, select how the axis should be linked. The options include:

No Ticks, No Labels - The X2 or Y2 axis does not have any ticks or labels.
Ticks, No Labels - The X2 or Y2 axis has the same tick marks as the main axis, but does not have any 

labels.
Ticks & Labels - The X2 or Y2 axis has the same tick marks and labels as the main axis.
Custom Ticks & Labels - Depending on the scaling of the main axis, the X2 or Y2 axis is linked by either a 

linear or exponential equation. The tick marks and labels are calculated and displayed on the X2 or Y2 
axis.

Click OK to return to the plot.

 

Overview: Modifying Axis Labels
You can use the Axis Options dialog to control the frequency and format of the axis labels.
 
Refer to the following topics to learn how to modify the axis labels:

Controlling the Frequency of Axis Labels
Formatting Axis Labels
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Linking Axis Labels on the X2 and Y2 Axes
 

Controlling the Frequency of Axis Labels
KaleidaGraph automatically calculates the frequency of axis labels. The frequency depends on the number of major tick 
marks. You can specify a different frequency or you can choose to remove the axis labels from the plot.
 
Note: For most plots, the labels along the X2 and Y2 axes are based on the setting of the Link To pop-up menu in the 

Limits portion of the Axis Options dialog.
 
To control the frequency of the axis labels:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Labels. The Axis Options dialog changes to display the options available for specifying label frequency.
Choose Auto, Every Nth, or None from the Placement pop-up menu to specify how often the labels should be 

displayed. If you select Every Nth, enter a value in the field below the menu.

Note: Entering a different value in the field automatically selects Every Nth from the menu.

Click OK to return to the plot.

 

Formatting Axis Labels
The format of the axis labels can also be controlled using the Axis Options dialog. Some of the options available include 
selecting scientific or engineering notation, specifying the number of significant digits, and adding a prefix or suffix to the 
axis labels.
 
Note: If Text data was plotted along the axis, the format of the labels will not change.
 
To change the format of the axis labels:

With the plot window active, choose Plot > Axis Options.
Click the appropriate axis tab at the top of the dialog.
Click Labels. The Axis Options dialog changes to display the options available for changing the label format.
Make your selections in the dialog.
Click OK to return to the plot window.

 

Linking Axis Labels on the X2 and Y2 Axes
You can control the display of the axis labels on the X2 and Y2 axes using the Link To pop-up menu. This pop-up menu is 
only available when the X2 or Y2 axis tab is selected.
 
Note: The Link To pop-up menu is not available for certain axes in Double Y, Double X, Double XY, Double Y Bar, and 

Double Y Column plots because they are independent of the main axis and cannot be linked.
 
To link the X2 or Y2 axis labels:

With the plot window active, choose Plot > Axis Options.
Click the X2 or Y2 axis tab at the top of the dialog.
Click Limits if it is not already selected. The Axis Options dialog changes to display the options available for 

controlling axis limits.
From the Link To pop-up menu, select how the axis should be linked. The options include:

No Ticks, No Labels - The X2 or Y2 axis does not have any ticks or labels.
Ticks, No Labels - The X2 or Y2 axis has the same tick marks as the main axis, but does not have any 

labels.
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Ticks & Labels - The X2 or Y2 axis has the same tick marks and labels as the main axis.
Custom Ticks & Labels - Depending on the scaling of the main axis, the X2 or Y2 axis is linked by either a 

linear or exponential equation. The tick marks and labels are calculated and displayed on the X2 or Y2 
axis.

Click OK to return to the plot.

 

Overview: Modifying Lines, Markers, and Fill Patterns
The Variable Settings dialog contains most of the options related to the display of the plot variables. This dialog can be 
displayed by either choosing Plot > Variable Settings or double-clicking a legend symbol.
 
Refer to the following topics to learn how to modify the tick marks:

Selecting Variables in the Variable Settings Dialog
Changing Marker Type, Size, Color, or Number Displayed
Selecting Fill Patterns
Changing Appearance of Variable and Curve Fit Lines
Changing Line and Marker Thickness
Plotting Missing Values
Adding Drop Lines
Adding Text Labels to the Markers
Using Letters as Markers
Displaying Bars in Place of Markers

 

Selecting Variables in the Variable Settings Dialog
Before variables can be modified, they need to be selected in the Variable Settings dialog. Each variable is independently 
controlled in this dialog.

To select individual variables, press Command (Mac) or Ctrl (Windows,) and click the variable name.
To select a range of variables, drag with the mouse.
To select all of the variables, press Command+A (Mac) or Ctrl+A (Windows).
To deselect a variable, press Command (Mac) or Ctrl (Windows) and click the variable name.

Note: When working with variables that have long names, you can resize the dialog to see the entire string.
 

Changing Marker Type, Size, Color, or Number Displayed
Most of the plots have the ability to display markers on the plot. The exceptions are the Histogram, Stack Bar, Floating 
Bar, Stack Column, Floating Column, and Pie plots. The Variable Settings dialog controls the type, size, color, and number 
of markers displayed in the plot.
 
To change the marker type, size, color, or number of markers:

With the plot window active, choose Plot > Variable Settings.
Select the variable to be edited.
To change the marker type, select one of the symbols from the Marker pop-up menu. The first six markers in the 

left column are transparent; all of the others are opaque.
To change the size of the marker, select a new size from the Marker Size pop-up menu.
To change the color of the marker frame, choose a color from the Line Color pop-up menu. The same color will 

also be used for the variable line.
If the marker contains a solid interior region, you can set the color of this region using the Fill Color pop-up menu. 

This allows you to use different colors for the marker frame and interior. White portions of the marker will 
remain white.

To change the number of markers displayed, make a selection from the Show Markers pop-up menu. You can 
choose whether all, a fixed number, a percentage, every Nth, or none of the markers are displayed on the 
plot.
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Click OK to return to the plot.

Note: Scatter plots always show all of the markers. Use a Line plot to show fewer markers.
 

Selecting Fill Patterns
Most of the plots have the ability to have a fill pattern displayed for the variable. For some plots, like the Line plot, this is 
only possible if Bar is selected as the marker type in the Variable Settings dialog.
 
Note: It is not possible to assign a fill pattern to the markers.
 
To change the fill pattern:

With the plot window active, choose Plot > Variable Settings.
Select the variable to be edited.
Select one of the patterns from the Fill Pattern pop-up menu.
Select the desired color for the fill pattern from the Fill Color pop-up menu.
Click OK to return to the plot.

 

Changing Appearance of Variable and Curve Fit Lines
Many of the plots can use a line to represent a plotted variable or have a curve fit applied. The style, width, and color of 
the variable or curve fit lines can be set using the Variable Settings dialog.
 
Note: Changing the variable color also changes the color of the marker frame. The associated legend text is also changed 

if Link Text To Variable Color is selected in the Text Options dialog (Plot menu). Variable and curve fit line 
colors are controlled independently of each other, unless Link to Variable Color is selected in the Curve Fit tab 
of the Variable Settings dialog.

 
To change the line style, width, or color of variable or curve fit lines:

With the plot window active, choose Plot > Variable Settings.
Select the variable to be edited.
If changes are being made to the variable line, proceed to the next step. Otherwise, click the Curve Fit tab at the 

top of the dialog to make changes to the curve fit line.
To change the line style, select a different option from the Line Style pop-up menu. Choose None from this list to 

hide the line.
To change the line width, select a different option from the Line Width pop-up menu.
To change the color, select a different color from the Line Color or Color pop-up menu. Any changes to the Line 

Color pop-up menu will also be used for the marker frame.
Click OK to return to the plot.

 

Changing Line and Marker Thickness
The Variable Settings dialog contains options for setting the thickness of the variable and curve fit lines, however, these 
settings do not affect the thickness of the markers. The General portion of the Plot Options dialog contains a Line 
Thickness setting that can be used to increase the thickness of variable and curve fit lines and a Marker Thickness
setting that can be used to increase the thickness of the markers.
 
To change the thickness of the markers, variable lines, and curve fit lines:

Choose Plot > Plot Options.
Click General.
To increase the thickness of variable and curve fit lines, change the Line Thickness to 200, 300, or 400%. This 

setting also applies to error bars and the thickness of Box, Percentile, Summary Column, Bar, and Pie plots.
To increase the thickness of markers, change the Marker Thickness to 200, 300, or 400%.
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Click OK to exit the Plot Options dialog and return to the plot.

Note: Depending on the value entered, you may not notice the change on the screen; however, there will be a difference 
when the plot is printed.

 

Plotting Missing Values
By default, KaleidaGraph will ignore any missing values when plotting a variable. This will result in a continuous variable 
line when plotting data using Line, Double Y, Double X, Double XY, High/Low, Step, X-Y Probability, and Polar plots. The 
Missing Data Breaks option in the General portion of the Plot Options dialog (Plot menu) determines whether the line is 
continuous or if there are gaps where missing values are present.
 
To show a gap in the variable line:

With the plot window active, choose Plot > Plot Options.
Click General.
Select the Missing Data Breaks check box so that a gap will be displayed anywhere there are missing X or Y 

values.
Click OK to exit the Plot Options dialog and return to the plot.

 

Adding Drop Lines
Drop lines can be added to a number of different plot types to connect the data points to their axis values. The drop lines 
can be added to either or both axes, except for the Bar and Column plots, which only allow drop lines for the Y axis. Drop 
lines are added for every point in a given variable. The Variable Settings dialog controls the line style, thickness, and color 
of the drop lines.
 
To add drop lines to a plot:

With the plot window active, choose Plot > Variable Settings.
Select the variable to be edited.
Click the Drop Line tab.
Specify the Line Style, Line Width, and Line Color for the X and/or Y drop lines. If Link to Variable Color is 

selected, the drop lines will be the same color as the variable.
Click OK to return to the plot.

 

Adding Text Labels to the Markers
Through the use of text error bars, it is possible to annotate the markers in the plot with text labels. When a Text data 
column is used for the error type, the data in the column is displayed as text labels at the corresponding points on the plot. 
Only data points that have errors associated with them have text labels displayed.
 
The direction of the labels is the same as the error type selected (horizontal for X Err or vertical for Y Err). If the Center 
Text check box is selected, the labels are centered on the markers. Otherwise, they are justified and placed on the side of 
the marker which had the error selected. The text labels can be moved individually with the Text tool or as a group with the 
Selection Arrow.
 
Note: Text error bars use the same default attributes as value labels. These labels can also include subscripts or 

superscripts.
 
To add text labels to the markers:

In the data window, place the data to be displayed as labels into a Text column.
Select the plot that will have the error bars added.
Choose Plot > Error Bars to display the Error Bar Variables dialog.
Click one of the check boxes to display the Error Bar Settings dialog.
Clear the Link Error Bars check box.
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Choose None for one of the portions of the bar. For the other, choose Data Column and select the text column 
containing the labels.

To center the labels on the marker, select the Center Text check box. Otherwise, the labels are justified.
Click OK. Then, click Plot to add the labels to the plot.

Note: If the Link Error Bars check box is selected and the Center Text check box is cleared, text labels are placed on 
both sides of the marker.

 

Using Letters as Markers
Unless you are using a Scatter plot, it is possible to display letters instead of markers. This is done by hiding the original 
markers and adding text error bars to the variable. When a Text data column is used for the error type, the data in the 
column is displayed as text labels at the corresponding points on the plot. Only data points that have errors associated 
with them have text labels displayed.
 
The direction of the labels is the same as the error type selected (horizontal for X Err or vertical for Y Err). By selecting the 
Center Text check box, the labels will be placed where the markers would normally be plotted.
 
Note: Text error bars use the same default attributes as value labels. These labels can also include subscripts or 

superscripts.
 
To use letters (or any font characters) as markers:

In the data window, place the text to be displayed as markers into a Text column.
Select the plot that will have the error bars added.
Choose Plot > Variable Settings.
Select the variable to be edited.
Choose None from the Show Markers pop-up menu to hide the markers for the selected variables.
Click OK.
Choose Plot > Error Bars to display the Error Bar Variables dialog.
Click one of the check boxes to display the Error Bar Settings dialog.
Clear the Link Error Bars check box.
Choose None for one of the portions of the bar. For the other, choose Data Column and select the text column 

containing the labels.
Select the Center Text check box to center the labels over the plotted data values.
Click OK. Then, click Plot to add the labels to the plot. You can now double-click the labels to change the font or 

any of the other attributes associated with the text.

 

Displaying Bars instead of Markers
KaleidaGraph provides a marker type of Bar that can be used to display bars on plots that would normally only contain 
markers or lines. This allows you to combine bars and lines on a single plot. This is also useful for creating Bar and 
Column plots that treat the X axis as numbers instead of categories.
 
To change the marker to a bar:

With the plot window active, choose Plot > Variable Settings.
Select the variable to be displayed as a bar.
Choose Bar from the Marker pop-up menu.
Use the Marker Size pop-up menu to change the width of the bars.
Select one of the patterns from the Fill Pattern pop-up menu.
Select the desired color for the fill pattern from the Fill Color pop-up menu.
Click OK to return to the plot.
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The Draw Column Frame and Black Column Frame settings in the Bar portion of the Plot Options dialog (Plot menu) 
also apply to these types of bars.
 

Overlaying Markers
Box, Percentile, and Summary Column plots can display the raw data over the resulting plot. This is similar to overlaying a 
Dot plot on one of these plot types.
 
To overlay markers on a plot:

Select the Box, Percentile, or Summary Column plot which will have the markers added.
Turn on Overlay Marker s in the Plot menu. The markers from a Dot plot are added to the plot.

 
The appearance of the markers can be controlled using the Variable Settings command (Plot menu). The Dot portion of 
the Plot Options dialog (Plot menu) can be used to handle the display of overlapping points and duplicate values.
 
Note: This command does not have any effect if markers are being plotted in a Box or Percentile plot. Outliers will not 

have separate markers displayed in a Box plot.
 

                 
Example Plots with Markers

 
 

Changing Plot Color
The Axis Options command controls the interior and background colors for a plot.
 
Note: To edit the colors that appear in the pop-up menus, use the Edit Colors command (Object menu).
 
To change the plot colors:

With the plot window active, choose Plot > Axis Options.
Click the All tab at the top of the dialog.
Click Colors. The Axis Options dialog changes to display the color options available.
Select the desired colors from the Interior and Background pop-up menus. If Transparent Interior or 

Transparent Background is selected, that particular portion of the plot is transparent.
Click OK to return to the plot.

 

Overview: Resizing the Plot
There are two methods available for changing the size of the plot: the Set Plot Size command and the Selection Arrow. 
Changing the size of the plot has no affect on the size of the plot window.
 
Refer to the following topics to learn how to resize the plot:

Resizing with the Set Plot Size Command
Resizing with the Selection Arrow
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Resizing with the Set Plot Size Command
You can use the Set Plot Size command (Plot menu) to specify the exact dimensions for the axes and frame, as well as 
the position of the axis origin.
 
To set the size of the plot:

Choose Plot > Set Plot Size to display the Set Plot Size dialog.
Click Axis Size, Frame Size, or both and enter the desired X and Y dimensions.

If only Axis Size is selected, the frame is scaled proportionately to the new dimensions.
If only Frame Size is selected, the axis is scaled proportionately to the new dimensions.
If both are selected, the axis and frame sizes are set independently. Be careful; this can cause parts of the 

plot to be placed outside of the plot frame.

Note: Typing the word auto allows a floating dimension, while specifying the size of the other dimension. This 
allows the plot to remain proportional to its original size.

If necessary, click the Axis Origin check box and specify where to place the upper-left corner of the axes.
Click OK. The plot is resized based on the new settings.
To make these settings the new default for this type of plot, choose Plot > Define Layout and click OK.

 
If the values in the Frame Size field are larger than the Paper dimensions, a dotted line is displayed to represent the 
printable area of the paper. You can hide these lines by clearing the Show the plot paper boundary check box in the 
General tab of the Preferences dialog.
 

Resizing with the Selection Arrow
The Selection Arrow can be used to manually resize the axes or plot frame. Once the plot has been resized, you can 
make these settings the new default for this type of plot by choosing Plot > Define Layout and clicking OK.
 
To resize the axes:

Click one of the axes with the Selection Arrow. Object handles appear at each corner of the plot.
Drag one of the handles to a new position. As you drag, the window shown below appears in the upper-left corner 

of the plot window. This dialog contains the current plot dimensions and axis origin (offset).

Note: To resize the plot proportionally about its center, press Option (Mac) or Alt (Windows) when dragging 
an object handle. By pressing Shift as you drag, you can constrain the plot to a square.

Release the mouse button when the axes are the desired size.

 
To resize the plot and the surrounding white space:

Locate the lower-right corner of the plot frame. You can use the scroll bars or increase the size of the plot window 
to find it.

Using the Selection Arrow, click the Size box  in the lower-right corner.
Drag the box to resize the plot frame. As you drag, a dialog appears in the upper-left corner of the plot window to 

display the current dimensions.
Release the mouse button when the plot frame is the desired size. The size of the plot changes proportionately to 

the new size of the frame.

Note: The Limit plot size to the paper boundary option (Preferences dialog) determines if the plot can be larger 
than the current paper size.
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Extracting Data from a Plot
When you save a plot with data, the data windows used to create it are archived with the plot. This enables you to save 
the graph and data in a single file instead of saving them separately. The data is not saved with the plot if either of the 
following occurs:

The data windows used to create the plot are closed by pressing Shift and either clicking the close box or 
choosing File > Close/No Save before the plot is saved.

The plot is saved by choosing File > Save Graph As and selecting KaleidaGraph Picture from the pop-up menu 
in the Save dialog.

 
The next time the plot is opened, you can make any necessary changes to the plot. If you want to modify the data, it 
needs to be extracted from the plot. This is accomplished by choosing Plot > Extract Data or clicking the Extract button 
in the plot window. Once the data is extracted, it can be modified, saved, or used to create new plots.
 
Note: The Extract Data command is unavailable if the plot does not have archived data associated with it, the plot was 

just created, or the data has already been extracted.
 
To extract a data set:

Make a plot window the active window.

Choose Plot > Extract Data or click the Extract button  in the upper-right corner of the plot window. The data 
used to create the plot is displayed.

 
The title of the extracted data window begins with the same name as the original data file. Additionally, a date and time 
stamp is appended to the name, identifying when the data was archived in the plot.
 

Updating Plotted Data
The Plot menu contains two commands that can be used to update the data in a plot: Auto Link and Update Plot. Both 
of these commands operate in a similar manner. They cause the current plot to be updated to reflect any changes in the 
data. Curve fits and error bars are also recalculated based on any changes in the data.
 
The difference between these two commands is that Auto Link revises the plot after each individual change in the data 
while Update Plot only causes an update when you choose the command. Clicking the Update Plot button  in the data 
window performs the same function as choosing the Update Plot command.
 
These commands are useful if you have a saved plot and need to add or edit points. You can extract the data from the 
plot, modify the data, and use the Auto Link or Update Plot commands to revise the plot.
 
To update plots using the Auto Link command:

Open or activate the plot to be updated.

Choose Plot > Extract Data or click the Extract button  to display the data used to create the plot.
Turn on Auto Link in the Plot menu.
Modify the data and move to another cell. After each value is modified, the plot is redrawn to show the changes.

 
To update plots using the Update Plot command:

Open or activate the plot to be updated.

Choose Plot > Extract Data or click the Extract button  to display the data used to create the plot.
Make any changes to the extracted data.

Choose Plot > Update Plot or click the Update Plot button  in the data window to redraw the plot.

Note: To update the plot using a subset of the data, select the data, press Shift, Option (Mac), or Alt (Windows), and 
either choose Plot > Update Plot or click the Update Plot button. This particular selection will be remembered 
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until you make a different selection and press Shift, Option , or Alt when updating the plot. To go back to using 
the entire data set, either select all of the data or click a single cell and then press Shift, Option , or Alt when 
updating the plot.

 

Plotting Additional Data
To add additional variables to a plot:

Open or activate the plot which will have new data plotted.

Choose Plot > Extract Data or click the Extract button  to display the data used to create the plot.
Open the new data or add it to an existing data window.
Switch back to the plot and choose Gallery > Template.
Select all of the data to be plotted (including the data from the original plot) and click Plot.

 
A new plot will be created that includes the additional data. Any curve fits and error bars from the original plot will be 
applied to the new plot.
 
Note: If you just need to add a few points to an existing curve, you can extract the data from the plot, modify it, and update 

the plot.
 

Customizing Bubble Plots
The Bubble plot is similar to a Scatter plot, so most of the editing is done in the same way. The X and Y tabs in Axis 
Options can be used to adjust the settings for the axes. The Variable Settings dialog controls the marker type and color for 
the individual variables. One area that is unique to Bubble plots is the additional legend that appears for the various 
bubble sizes. The bubble legend displays a range of bubbles and labels based on the values being plotted for the Y2 
variables.
 
By default, the text in the bubble legend uses the default attributes assigned to a Y2 legend in Text Options. The one 
exception would be that the text color is linked to be the same as the color of the first variable, unless Link Text To 
Variable Color is turned off in Text Options. The labels in the bubble legend can be edited as a group (using the Selection 
Arrow) or individually (using the Text tool), however if the plot is redrawn, any changes made using the Text tool will be 
lost.
 
To adjust the settings for the additional legend in a Bubble plot:

Choose Plot > Axis Options.
Click the Y2 tab at the top of the dialog.
To change the range of bubble sizes displayed, edit the Minimum and Maximum fields.
To change the number of bubble labels displayed, choose Fixed or Interval from the Levels pop-up menu and 

enter a value in the field below the pop-up menu. If Interval is selected, the interval is calculated from the 
value in the Anchor Tick field.

To change the maximum size of the bubbles, edit the Max Size field.
To specify what the bubble size represents, choose Area or Diameter from the Scale pop-up menu.
To have the bubbles drawn from largest to smallest in the legend, select the Reverse Order check box.
Click OK to exit the dialog.

 

Customizing Box and Percentile Plots
To change the spacing between the boxes:

Choose Plot > Plot Options.
Click Bar.
Edit the Column Offset percentage. Entering a value of 0% removes all space between them.
Click OK to leave the Plot Options dialog and return to the plot.
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To change the color of the box frame:

With the plot window active, choose Plot > Variable Settings.
Select the variable to be edited.
Select a different color from the Line Color pop-up menu.
Click OK to return to the plot.

 
To change the thickness of the box frame:

Choose Plot > Plot Options.
Click General.
Change the Line Thickness to 200, 300, or 400%. This setting also applies to variable and curve fit lines, error 

bars, and the thickness of Bar, Summary Column, and Pie plots.
Click OK to exit the Plot Options dialog and return to the plot.

Note: Depending on the value entered, you may not notice the change on the screen; however, there will be a difference 
when the plot is printed.

 

Customizing Histogram Plots
KaleidaGraph supports two different methods for creating Histograms. You can either specify the bin size or specify the 
number of bins. The Histogram portion of the Plot Options dialog determines which method is used.

If you choose to create the Histogram by specifying the bin size, the Limits portion of the Axis Options dialog 
contains the fields for the bin size, reference value, and number of bins that get added or removed. This is the 
method that was used in versions 3.5 and 3.6 of KaleidaGraph.

If you choose to create the Histogram by specifying the number of bins, the Histogram portion of the Plot Options 
dialog contains a setting to control the number of bins. This is the method that was used prior to version 3.5 of 
KaleidaGraph.

It is also possible to use the Bin Data command (Functions menu) to perform the binning routine for the Histogram. This 
command provides additional binning options and the results can be used to create other types of plots.
 
To change the attributes of the column frame:

Choose Plot > Plot Options.
Click Bar.
To change the color of the column frame, clear the Black Column Frame check box. The frame color can then be 

set using the Line Color pop-up menu in Variable Settings.
To remove the frame surrounding each bar, clear the Draw Column Frame check box.
Click OK to leave the Plot Options dialog and return to the plot.

 
To change the thickness of the column frame:

Choose Plot > Plot Options.
Click General.
Change the Line Thickness to 200, 300, or 400%. This setting also applies to variable and curve fit lines, error 

bars, and the thickness of Box, Percentile, Bar, and Pie plots.
Click OK to exit the Plot Options dialog and return to the plot.

Note: Depending on the value entered, you may not notice the change on the screen; however, there will be a difference 
when the plot is printed.

 
To add value labels to a plot:

Select the plot which will have the value labels added.
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Turn on Add Values in the Plot menu. The actual values of each bar are added to the plot.

 
These labels can be moved individually with the Text tool or as a group with the Selection Arrow. The Value Label Format
command (Plot menu) can be used to change the numeric format of the labels.
 
Note: Any time the plot is redrawn, the value labels are placed back at their original position. If you are displaying only a 

few of the labels, use the Text tool to add them to the plot. You can place them exactly where you want and you 
do not have to worry about the label moving when the plot is redrawn.

 

Customizing Dot Plots
To change the spacing between the variables:

Choose Plot > Plot Options.
Click Dot.
Edit the Variable Offset percentage. Entering a value of 0% removes all space between them.
Click OK to leave the Plot Options dialog and return to the plot.

 
To change how overlapping and duplicate markers are displayed:

Choose Plot > Plot Options.
Click Dot.
To prevent the markers from overlapping each other, Scatter Overlapping Points should be selected.
To see multiple markers for values that are identical, select the Scatter Duplicate Points check box.
To represent duplicate values with a line instead of markers, select the Draw Duplicates as a Line check box. 

Turning on this option will disable the Scatter Duplicate Points check box.
Click OK to exit the Plot Options dialog and return to the plot.

 
To display the mean or median line for each variable on the plot:

Choose Plot > Plot Options.
Click Dot.
To draw the mean of each variable on the plot, select the Show Variable Mean check box.
To draw the median of each variable on the plot, select the Show Variable Median check box.
Click OK to exit the Plot Options dialog and return to the plot.

 

Customizing Bar, Column, and Summary Column Plots
To change the attributes of the bars:

Choose Plot > Plot Options.
Click Bar to display the options available for Bar and Column plots.
To change the spacing between the bars, edit the Column Offset percentage. Entering a value of 0% removes all 

space between the bars; a value of 100% displays the bars as spikes.
To change the color of the column frame, clear the Black Column Frame check box. The frame color can then be 

set using the Line Color pop-up menu in Variable Settings.
To remove the frame surrounding each bar, clear the Draw Column Frame check box.
To use a baseline of 1.0 for log scales, select the Adjust Log Baseline check box. Otherwise, the minimum axis 

limit is used for the baseline.
Click OK to leave the Plot Options dialog and return to the plot.

 
To change the thickness of the column frame:
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Choose Plot > Plot Options.
Click General.
Change the Line Thickness to 200, 300, or 400%. This setting also applies to variable and curve fit lines, error 

bars, and the thickness of Box, Percentile, Histogram and Pie plots.
Click OK to exit the Plot Options dialog and return to the plot.

Note: Depending on the value entered, you may not notice the change on the screen; however, there will be a difference 
when the plot is printed.

 
To add value labels to a plot:

Select the plot which will have the value labels added.
Turn on Add Values in the Plot menu. The actual values of each bar are added to the plot.

 
These labels can be moved individually with the Text tool or as a group with the Selection Arrow. The Value Label Format
command (Plot menu) can be used to change the numeric format of the labels.
 
Note: Any time the plot is redrawn, the value labels are placed back at their original position. If you are displaying only a 

few of the labels, use the Text tool to add them to the plot. You can place them exactly where you want and you 
do not have to worry about the label moving when the plot is redrawn.

 
To make a Line/Column plot:

Create a Horizontal Bar, Double Y Bar, Column, or Double Y Column plot, including the variable to be displayed as 
a line.

Choose Plot > Variable Settings.
Select the variable to be displayed as a line.
Select a Fill Pattern of Line, as well as the line style, line width, and number of markers to be displayed.
Click OK and the plot updates to display a Line/Column plot. The figures below show a sample Column plot and 

the result of displaying the second variable as a line.

 

  

   

Sample Column plot       Plot displaying variable as 
a line

 
 
 

Customizing Polar Plots
There are two commands in the Plot menu that can be used to change the appearance of Polar plots: Axis Options and 
Plot Options.
 

Changing the Display of Tick Marks, Grid Lines, and Axis Labels

The angular (φ or X) and the radial (R or Y) axes can be modified using the Axis Options command.
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The angular axis is controlled by the X axis settings in the Axis Options dialog. You can use the options for Ticks & Grids
and Labels to modify this axis. You can also use the Turn Off Axis option in the Position portion of the dialog to remove 
the angular axis.
 
The radial axis is controlled by the Y axis settings in the Axis Options dialog. You can use the options for Limits, Ticks & 
Grids, and Labels to modify the axis. You can also choose a different scaling, or remove the axis with the Turn Off Axis
option in the Position portion of the dialog.
 

Setting the Grid Type, Reference Angle, and Direction
Polar plots have several unique options that control their appearance. These options include the data format, grid type, 
reference angle, and direction. All of these options are contained in the Polar portion of the Plot Options dialog.
 

The figure on the left shows a Polar plot displayed in a clockwise direction, with a circular grid and a 45o reference angle. 
The figure on the right shows a Polar plot displayed on a square grid.
 

  

   

Polar plot on circular grid       Polar plot on square grid
 
 
 

Customizing Pie Charts
To move or explode a pie segment:

Using the Selection Arrow, click twice on the segment to be moved. The first click selects the entire pie. The 
second click selects the individual segment.

Drag the segment away from the rest of the pie. Do not worry about what direction you drag, the segment only 
moves along its radius. The figure below shows an example of an exploded Pie chart.

 
To change the color of the frame:

Choose Plot > Variable Settings.
To make all of the frames the same color, select all of the variables on the left side of the dialog and choose the 

desired color from the Line Color pop-up menu.
To change the color of individual frames, select the variable on the left side of the dialog and choose the desired 

color from the Line Color pop-up menu. Repeat this process for any other variables that need to be edited.
Click OK to exit the dialog.
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To remove the frame surrounding each slice:

Choose Plot > Plot Options.
Click Pie to display the options available for Pie charts.
Clear the Draw Pie Frame check box.
Click OK to exit the dialog.

 
To add value labels to a Pie chart:

Select the Pie chart which will have the value labels added.
Turn on Add Values in the Plot menu. The percentage values of each pie slice are added to the plot. To display 

the actual values, select the Display Pie Values check box in the Plot Options dialog. The figure below shows 
an example of a Pie chart with value labels.

 
These labels can be moved individually with the Text tool or as a group with the Selection Arrow. The Value Label Format
command (Plot menu) can be used to change the numeric format of the labels.
 
Note: Any time the plot is redrawn, the value labels are placed back at their original position. If you are displaying only a 

few of the labels, use the Text tool to add them to the plot. You can place them exactly where you want and do 
not have to worry about the label moving when the plot is redrawn.
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KaleidaGraph Toolbox
The toolbox contains the tools used to create and edit items in the plot and layout windows. The toolbox normally appears 
automatically when a plot or layout window is the active window. The Show Plot Tools and Hide Plot Tools commands 
(Plot menu) can be used to display or hide the toolbox in the current plot or layout window. It is also possible to use the 

 and  buttons in the plot or layout window to perform the same function.
 
Tools are selected by clicking the appropriate icon.
 

 

Selection Arrow
The Selection Arrow  is the default tool in the toolbox. It is automatically selected whenever a new plot is created. Also, 
most tool selections revert to the Selection Arrow after being used. This tool is used to select, move, and resize objects in 
the plot or layout window. Once an object is selected, you can copy, duplicate, or delete it.
 
Shortcut

Pressing the Spacebar selects the Selection Arrow in the toolbox.

 

Text Tool
The Text tool  is used to add and edit plot labels. Clicking the plot or layout window after selecting this tool displays a 
dialog for typing and modifying the text.
 
Clicking this tool and holding down the mouse button displays a pop-up menu that can be used to edit selected text labels. 
You can use this menu to modify the font, size, style, color, justification, rotation, and background of any selected text.
 
Shortcuts

Use the Text tool to select and edit labels that belong to groups, such as legend text and axis labels.
Pressing T selects the Text tool in the toolbox.
Double-clicking a label or text item automatically enables the text editing features.

 

Line/Arrow Tool
The Line/Arrow tool  is used to add lines or arrows to the plot or layout. Clicking this tool and holding down the mouse 
button displays a pop-up menu that contains the lines and arrows that can be drawn. If you press Shift when creating a 
line or arrow, you can constrain the line to rotate in 45 degree increments.
 
Shortcut

Pressing L selects the Line/Arrow tool in the toolbox.
If you have already created an arrow, you can edit the arrowhead by double-clicking the arrow.
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Object Tool
The Object Tool displays a submenu with tools for adding a variety of objects to the plot or layout window.
 

Box Tool
The Box tool  is used to draw square and rectangular boxes on the plot or layout. You can create a square by pressing 
Shift as you use the Box tool.
 
Shortcut

Pressing 1 selects the Box tool in the toolbox.

 

Rounded Rectangle Tool
The Rounded Rectangle tool  is used to draw squares and rectangles with rounded corners. You can create a square 
with rounded corners by pressing Shift as you use the Rounded Rectangle tool.
 
Shortcut

Pressing 2 selects the Rounded Rectangle tool in the toolbox.

 

Oval Tool
The Oval tool  is used to draw ovals and circles in the plot or layout window. You can create a circle by pressing Shift
as you use the Oval tool.
 
Shortcut

Pressing 3 selects the Oval tool in the toolbox.

 

Polygon Tool
The Polygon tool  is used to create polygons. Polygons consist of multiple line segments connected at the segment 
end points. They can either be closed (the first and last segments connect) or open (the first and last segments do not 
connect). If you press Shift when creating a line segment, you can constrain it to rotate in 45 degree increments.
 
Shortcuts

Pressing 4 selects the Polygon tool in the toolbox.
If you have already created a polygon, you can edit the line segments by double-clicking the polygon.

 

Arc Tool
The Arc tool  creates an arched line between two points. The arc’s curvature and angle are determined by the position, 
direction, and relative distance of the two points. The direction of the arc’s curve is determined by the initial mouse 
dragging direction. If you press Shift when creating an arc, you can constrain it to a quarter-circle.
 
Shortcut
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Pressing 5 selects the Arc tool in the toolbox.

 

Bezier Curve Tool
You can use the Bezier curve tool  to draw complex objects. Bezier curves are irregularly shaped, multi-sided objects 
that can have curved line segments. They can either be closed (the first and last segments connect) or open (the first and 
last segments do not connect).
 
Each segment in a Bezier curve is defined by four points: two anchor points and two direction points. The anchor points 
determine where the segments begin and end. The direction points, along with the tangent lines that connect them to the 
anchor points, determine the size and positioning of the curve segments.
 
Shortcuts

Pressing 6 selects the Bezier curve tool in the toolbox.
If you have already created a Bezier curve, you can edit the curve by double-clicking it.

 

Table Tool
The Table tool  is used to create tables that have up to 16 columns and 64 rows. Each cell can contain a unique text 
font size, style, color, and justification, horizontal and vertical line styles, and background color and fill. The complete table 
has a selectable frame style and color.
 
Text data can be pasted into the table or loaded from a text file. The text data must be tab-separated.
 
A picture of the table can be exported to the Clipboard using the Copy Table command (from the Table tool’s Edit menu).
 
Shortcut

Pressing A selects the Table tool in the toolbox.

 

Creating and Editing Tables
Tables can be added to any plot or layout window in KaleidaGraph. Tables can be created by either using the Table tool or 
by pasting text from the Clipboard. Tables are also created to display the results of General and Polynomial curve fits 
when Display Equation is turned on in the Plot menu.
 
To create a table:

Select the Table tool  from the toolbox.
Click anywhere in the plot or layout window to display the Edit Table dialog.
Customize the appearance of the table by adding rows, adding columns, or applying style changes. Then, type 

data into the cells.
Click OK to return to the plot or layout window.

 
To edit a table:

Double-click the table with the Selection Arrow. The Edit Table dialog appears, displaying the contents of the table.
Make the necessary changes to the table.
Click OK to return to the plot or layout window.

 

Setting Defaults for Tables
The Edit Table dialog initially displays four cells. In addition to being part of the table, they are used to set the default 
layout for generating new tables. They control the layout as follows:
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cell 1 (upper-left): This cell controls itself and does not affect the defaults for the rest of the table.
cell 2 (upper-right): This cell controls the default settings for the top row of the table (excluding cell 1).
cell 3 (lower-left): This cell controls the default settings for column one of the table (excluding cell 1).
cell 4 (lower-right): This cell controls the default settings for the body of the table (everything except row one and 

column one).

 
Change the attributes (font, size, style, justification, and so on) in each of the four cells. Then, choose File > Set Defaults
to remember the settings.
 

Eraser Tool
The Eraser  deletes labels and objects from the plot or layout window. Grouped items, such as the legend and axis 
labels, can also be removed using this tool. The Eraser cannot remove any markers or lines that represent plotted data.
 
Shortcut

Pressing E selects the Eraser tool in the toolbox.

 

Identify Tool
The Identify tool  is used to find the coordinates of points on the graph. Click anywhere on the plot to display the X and 
Y position in the upper-left corner of the plot window. If you drag the Identify tool around the plot, the X and Y position 
updates in real time.
 
Note: If the plot contains an axis break, the Identify tool will not display coordinates within the break or outside the axis 

limits.
 
To leave the coordinates on the plot as a label, press Option (Mac) or Alt (Windows) when the mouse button is released. 
The appearance of the coordinate labels is based on the settings in the Axis Options dialog, with the exception of adding 
one extra digit of accuracy.
 
You can also place the coordinates on the Clipboard. To do this, press Shift when releasing the mouse button. The first 
time you do this, the Clipboard is cleared and the first set of coordinates is copied. Any additional coordinates are 
appended to the information already stored on the Clipboard.
 
If you want to place the coordinates from multiple plots on the Clipboard, press Command+Shift (Mac) or Ctrl+Shift 
(Windows) when releasing the mouse button. As soon as you use the Shift key without pressing Command (Mac) or Ctrl 
(Windows), the Clipboard is cleared.
 
Note: If you will be pasting the data into the data window, press the Shift key during the paste to perform a Paste w/

Titles. This will use the first line from the Clipboard as column titles and get the data formatted correctly.
 
Shortcut

Pressing I selects the Identify tool in the toolbox.

 

Align Tool
KaleidaGraph has two ways to align objects: the Align tool  in the toolbox and the Align command from the Object
menu. Either method can be used to align the selected objects by their edges or centers.
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Data Selection Tool
The Data Selection tool  can be used to temporarily include or exclude a portion of data from the plot and curve fits. 
This fast, visual way of excluding outliers or selecting subsets of data allows you to quickly perform a series of what-if 
scenarios to help you learn more from the data and possibly even influence future directions of your research.
 
Using KaleidaGraph’s Data Selection tool you can either:

Graphically exclude outliers (one or thousands).
Graphically select (include) subsets of data to plot and fit.

 
The Data Selection tool operates by enclosing any points to be temporarily included or excluded in a polygon. As soon as 
you close the polygon:

Any data removed from the plot will be masked (indicated by a red frame) in the data window.
The plot will be redrawn automatically.
Any error bars and curve fits that were applied to the plot will be recalculated and new results, (including 

parameters and error values) will be displayed.

 
Once you are finished viewing and learning from this set of results:

Double-click the Data Selection tool.
The data you temporarily omitted will automatically return to the plot and will no longer be masked in the data 

window.
The plot will be redrawn automatically to include the additional points.
Any error bars and curve fits that were applied to the plot will be recalculated and new results (including 

parameters and error values) will be displayed.

 
Note: This tool cannot be used if the plot contains an axis break. It is also disabled for the following plots: High/Low, Fill, 

Probability, Histogram, Box, Percentile, Dot, Summary Column, Polar, Pie, and all of the plots in the Bar
submenu.

 
Shortcuts/Tips

Pressing S selects the Data Selection tool in the toolbox.
Pressing Option (Mac) or Alt (Windows) while creating the data selection polygon causes the enclosed data to be 

masked and all other data to be kept.
Any polygon bounding a selection region can have at most 100 bounding points.
Double-clicking the Data Selection tool unmasks the data in the data window and returns to the original plot.

 

Graphically Removing Outliers
To exclude a set of data points from the plot:
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Select the Data Selection tool  from the toolbox.
Press the Option (Mac) or Alt (Windows) key while performing steps 3-6.
Position the cursor where you want to begin forming line segments and click. A small square marks the starting 

point.
Move the cursor where you want the first segment of the polygon to end.
Move the cursor and click again to create the second segment.
Continue moving and clicking until the desired data is enclosed in a polygon. You can complete the polygon by 

clicking the hollow square, double-clicking, pressing Return (Mac) or Enter (Windows), or clicking when the 
cursor is positioned over the toolbox. The plot is then redrawn and only the points that lie outside the polygon 
are replotted. The points that are removed become masked (indicated by a red frame) in the data window.

To return to the original plot and unmask the data, double-click the Data Selection tool.

 

Graphically Selecting a Subset of Data
To select a subset of data points:

Select the Data Selection tool  from the toolbox.
Position the cursor where you want to begin forming line segments and click. A small square marks the starting 

point.
Move the cursor to the point where you want the first segment of the polygon to end and click.
Move the cursor and click again to create the second segment.
Continue moving and clicking until the desired data is enclosed in a polygon. You can complete the polygon by 

clicking the hollow square, double-clicking, pressing Return (Mac) or Enter (Windows), or clicking  when the 
cursor is positioned over the toolbox. The plot is then redrawn and only the points that lie inside the polygon 
are replotted. The points that are removed become masked (indicated by a red frame) in the data window.

To return to the original plot and unmask the data, double-click the Data Selection tool.

 

Zoom Selection Tool
The Zoom Selection tool  can be used to quickly change the axis limits. To use the Zoom Selection tool, drag over a 
region of the graph. The upper-left and lower-right corners of the zoom box define the new limits for the plot. For Double Y, 
Double X, Double XY, Double Y Bar, and Double Y Column plots, you can rescale the X2 and Y2 axes by pressing 
Command (Mac) or Ctrl (Windows) when creating the zoom box. This tool produces an effect similar to specifying axis 
limits in the Axis Options dialog (Plot menu).
 
This tool cannot be used if the plot contains an axis break. It is also disabled for the following plots: Histogram, Stack Bar, 
Stack Column, and Pie.
 
Shortcuts/Tips

Pressing Z selects the Zoom Selection tool in the toolbox.
When zoomed, you can adjust the position by pressing Option (Mac) or Alt (Windows) and clicking in the direction 

you want to move. For Double Y, Double X, Double XY, Double Y Bar, and Double Y Column plots, you can 
adjust the X2 and Y2 axes by pressing Command (Mac) or Ctrl (Windows) and clicking. The point you click is 
placed in the center of the redrawn plot.

Double-click the Zoom Selection tool to return to the original plot.

 

Toolbox Icons
The bottom portion of the toolbox contains icons that vary according to what is currently selected. Clicking any of the icons 
displays a pop-up menu that can be used to quickly edit an item’s attributes, without having to choose a command or 
display a dialog.
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When a Shape or the Legend Is Selected
The Color icon controls the foreground and background color of the selected object. The Pattern icon controls the fill and 
pen patterns. The Style icon sets the line style and width for selected objects.
 

 

When the Plot Frame Is Selected
The Color icon controls the interior and background colors for the plot. The Transparency icon allows you to leave the 
interior or background transparent.
 

 

When an Axis Is Selected
The Color icon determines the axis and grid colors of the selected axis. The first of the two Axis Options icons allows you 
to hide the selected axis or exchange the X and Y axes. The second Axis Options icon controls axis scaling, tick mark 
display, grid line display, and the format of the axis labels. If the X2 or Y2 axis is selected, you can also link the axes. The 
interior of the icon displays which axis is currently selected.
 

 

When a Marker Is Selected in the Legend
The Color icon controls the line and fill color of the variable. The two icons in the middle control the variable markers and 
fill patterns. The Marker icon determines the marker type, size, and number of markers displayed. The Fill Pattern icon 
controls the fill pattern. The Style icon determines the variable’s line style and width.
 

 

Selecting Objects
To select an object:

Select the Selection Arrow tool from the toolbox.
Position the pointer over the object and click. Object handles appear around the object.

 
To select multiple objects, use one of the following methods:

Press Shift and use the Selection Arrow to click the objects one at a time.
Use the Selection Arrow to drag a dotted box around the objects to be selected.
Choose Edit > Select All to select all of the objects.
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Note: When multiple objects are selected, changes affect each of the selected objects. For example, if you change the fill 
pattern, it changes in all of the selected objects.

 
To select a single text label within a group of labels (legend text, axis labels, and so on):

Select the Text tool from the toolbox.
Position the pointer over the text label and click. Object handles appear around the label.

 
To deselect objects:

To deselect all selected objects, click a blank portion of the window or press Esc.
To deselect objects one at a time, press Shift while clicking the object. The object you click is deselected. All other 

objects remain selected.

 

Moving Objects
After objects are created in the plot or layout window, it may be necessary to reposition them. The plot, legend, and any 
text labels can also be moved using the method described below.
 
To move objects:

Select the object to be moved.
Position the pointer over the selected object and drag it to a new position. As you drag, an outline of the object is 

displayed. If you drag to the edge of the window, the window scrolls.
Release the mouse button when the object is in the desired location.

Note: You can also move selected objects vertically or horizontally using the arrow keys. If the arrow keys are used, the 
objects move one pixel in the specified direction (10 pixels if you press Shift at the same time).

 

Resizing Objects
Any object can be resized in the plot or layout window. This includes the plot axes, legend, and any shapes created with 
the drawing tools.
 
Note: The legend cannot be resized if it only contains a single item.
 
To resize an object:

Select the object to be resized.
Drag any one of the handles until the object reaches the desired size.

Note: To resize the object proportionally about its center, press Option (Mac) or Alt (Windows) when dragging the handle. 
By pressing Shift as you drag, you can constrain the shape to a square or circle.

 

Duplicating Objects
You can create duplicates of selected objects using the Duplicate command from the Edit menu. The duplicate appears 
slightly offset from the original.
 
To duplicate an object:

Select the object to be duplicated.
Choose Edit > Duplicate. A copy of the object is placed slightly below and to the right of the original. Its handles 

are visible to indicate that it is selected.

Note: You can also duplicate objects by pressing Option (Mac) or Alt (Windows) and dragging the object.
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Copying Objects
To copy one or more objects:

Select the objects to be copied.
Choose Edit > Copy Selection. The objects are copied to the Clipboard, replacing the previous contents, if any.

Note: If you copy anything associated with the original plot (legend, plot title, axis title, and so on), the entire plot is copied 
to the Clipboard.

 

Pasting Objects
To paste objects from the Clipboard:

Open the plot or layout window that will receive the object on the Clipboard.
Choose Edit > Paste. The object is placed in the active window.

 

Deleting Objects
To delete an object in the plot or layout window:

Select the object to be deleted.
Press Delete (Mac), Backspace (Windows), or choose Cut or Clear from the Edit menu. Cut places the object on 

the Clipboard; the other methods remove the object from the window.

Note: You can also use the Eraser tool to delete individual objects.
 

Grouping and Ungrouping Objects
Grouping allows you to combine several objects into a single object. This is useful if you want to move several objects and 
maintain their relative spacing or if you want to apply the same changes to multiple objects.
 
Note: Except for the axis titles, it is not possible to group or ungroup any part of the original plot.
 
To group objects:

Select the objects to be grouped. Object handles appear around each object that is selected.
Choose Object > Group. Each object’s handles disappear and are replaced by a single set of object handles 

around the grouped object.

 
Once you have grouped objects together, you can no longer select or modify the objects individually. The UnGroup
command can be used to separate a grouped object into its original components.
 
To ungroup an object:

Select the object to be ungrouped.
Choose Object > UnGroup. Object handles appear for each individual object.

 

Aligning Objects
KaleidaGraph has two ways to align objects: the Align tool in the toolbox and the Align command (Object menu). The 
icons in this menu indicate the type of alignment applied to the objects.
 
To align objects:

Select the objects to be aligned.
Choose Object > Align or select the Align tool from the toolbox to display the alignment options.
Select one of the icons from the menu. The objects are aligned based on your selection.
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Sending Objects Up or Down
Each time you create an object in the plot or layout window, it is placed on top of all other objects in the object stacking 
order. This order is important because objects near the bottom of the stack may be hidden or difficult to modify.
 
Note: Except for the axis titles,all of the elements of the original plot are drawn on the same plane.
 
To change the ordering of an object:

Select the object to be modified.
Choose the appropriate command from the Object menu. The selected object is repositioned in the window.

Up - Moves the selected object forward one level in the object order.
Bring To Front - Moves the selected object in front of all other objects.
Down - Moves the selected object backward one level in the object order.
Send To Back - Moves the selected object behind all other objects.

 

Overview: Creating and Editing Text Labels
Labels can be created and edited using the Text tool. Clicking the plot or layout window after selecting this tool displays 
the Edit String dialog. Use this dialog to create and edit text labels within the plot or layout window.
 
The following topics explain how to create and edit text labels in KaleidaGraph:

Creating a Text Label
Editing Plot Labels
Adding Subscripts and Superscripts to a Text Label
Adding Greek or Special Characters to a Text Label
Setting Defaults for Text Labels
 

Creating a Text Label
Text labels can be created anywhere in the plot or layout window. The initial position of the label is not important because 
once it is created, you can use the Selection Arrow to reposition it.
 
To create a text label in the plot or layout window:

Select the Text tool  from the toolbox.
Position the pointer anywhere in the window and click once. The Edit String dialog appears.
Type text and modify the attributes using the various controls in the dialog. This dialog supports fully-stylized text, 

so you can use multiple fonts, styles, and colors in a text label.
Click OK to return to the plot or layout window.

Note: Due to adding support for Unicode, typing a Latin character in the Edit String dialog on the Mac and converting it to 
the Symbol font will not immediately display the Greek character. It will be displayed when you exit the dialog. It 
is possible to see the character immediately if you copy it from the Font Book application and paste it into the 
Edit String dialog.

 

Editing Plot Labels
Legend Text
The legend text can be edited using the Text tool  . Double-clicking a text label displays the Edit String dialog. Change 
the legend text as needed and click OK to return to the plot.
 
It is also possible to move items in the legend to different locations using the Text tool. This is accomplished by dragging a 
label to a new position with the Text tool.
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Plot and Axis Titles
Plot and axis titles can be edited by double-clicking them with either the Text tool or the Selection Arrow. The Edit String 
dialog appears, containing the current text string. Change the text as needed and click OK to return to the plot.
 

Value, Axis, and Bubble Labels
These labels are unique because they can be edited individually or as a group.
 
To edit these labels individually:

Select the Text tool from the toolbox.
Double-click the label to be modified. The label appears in the Edit String dialog.
Change the label text and formatting.
Click OK to return to the plot.

Note: Be careful when editing these types of labels in this manner. If the plot is redrawn, the labels revert to their original 
state.

 
To edit these labels as a group:

Select the Selection Arrow from the toolbox.
Double-click one of the labels in the group. The label appears in the Edit String dialog, but the label text cannot be 

edited because the labels are selected as a group.
Make the necessary formatting changes to the label.
Click OK to return to the plot. The entire group is redrawn to reflect the changes.

Individual Text Labels
Any text label created with the Text tool can be edited by double-clicking it with either the Text tool or the Selection Arrow. 
The Edit String dialog appears, containing the current text string. Change the text as needed and click OK to return to the 
plot.
 

Adding Subscripts and Superscripts to a Text Label
To add subscripts or superscripts to a text label:

Using the Text tool, double-click an existing label or click within the plot or layout window to create a new label.
Select the text to be converted.

Click the subscript  or superscript  control.
Click OK.

Note: The Edit String dialog does not display characters as subscripts or superscripts. Instead, KaleidaGraph inserts 
either \d (subscript) or \u (superscript) before the characters and \n (normal) after the characters. These extra 
characters are only displayed in the Edit String dialog. As soon as you return to the plot or layout, the subscripts 
or superscripts are displayed correctly.

 
The Text Options dialog (Plot menu) contains three settings (Superscript Offset, Subscript Offset, and Sub/Super 
Size) that affect the appearance of subscripts and superscripts. These settings can be modified to control the offset and 
size of these characters.
 

Adding Greek or Special Characters to a Text Label
The following information can be used to insert Greek or other special characters into your text label.
 
Mac Version:
The Font Book application can be used to see the characters available for a given font. The desired character can be 
copied to the Clipboard and pasted into the Edit String dialog in KaleidaGraph. Greek characters are available in the 
Symbol and Baskerville fonts.
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Note: Due to adding support for Unicode, typing a Latin character in the Edit String dialog on the Mac and converting it to 
the Symbol font will not immediately display the Greek character. It will be displayed when you exit the dialog. It 
is possible to see the character immediately if you copy it from the Font Book application and paste it into the 
Edit String dialog.

 
Windows Version:
The Character Map utility can be used to display the characters available for a given font. The desired character can be 
copied to the Clipboard and pasted into the Edit String dialog in KaleidaGraph. If the character does not appear correctly, 
verify the font selected in KaleidaGraph for this character matches the font selected in Character Map.
 

Setting Defaults for Text Labels
You can set defaults for a number of different text labels in the Text Options dialog (Plot menu). The attributes that you 
select are saved as part of the Style file. This enables you to set your preferences and have KaleidaGraph remember 
them the next time you start the program.
 
To set defaults for text labels:

Choose Plot > Text Options.
Click the labels for which you want to set new defaults. The different text labels are described below:

Standard Labels - Axis titles and any text created with the Text tool.
Legends - Any text that appears in the legend.
Plot Titles - The text representing the plot’s title.
Equation Labels - Text that appears when displaying the equation calculated by a curve fit.
Value Labels - Text that appears when Add Values is turned on or text error bars are applied.
X, Y, X2, or Y2 Axis Labels - The labels placed at major tick marks to display their value.
Y2 Legend - Text that appears in the Y2 legend of a Double Y, Double XY, Double Y Bar, or Double Y 

Column plot.

Select your new defaults from the pop-up menus.
Click OK to return to the plot window. Any labels that had their attributes changed are updated.
To make these settings permanent, make sure you save changes to the Style when quitting KaleidaGraph.

 

Overview: Creating and Editing Shapes
You can create lines, arrows, rectangles, rounded rectangles, ovals, polygons, arcs, and Bezier curves in the plot or layout 
window. Once a shape is created, you can use the icons in the toolbox to change the object’s attributes.
 
Six of the drawing tools are located on a pop-up menu that appears when clicking the Object tool icon and holding down 
the mouse button. This pop-up menu is shown below.
 

 
The following shapes can be created in KaleidaGraph:

Lines
Arrows
Rectangles and Squares
Rounded Rectangles and Squares
Ovals and Circles
Polygons
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Arcs
Bezier curves

 

Creating and Editing Lines
To create a line:

Click the Line tool on the toolbox.
Click the Line tool again and choose the first item in the pop-up menu to draw a line.
Position the cursor at the point where you want to begin drawing the line.
Click and drag to draw the line. By pressing Shift as you drag, you can constrain the line to rotate in 45 degree 

increments. The line appears with object handles to indicate that it is selected.

Note: If the line is not visible after creating it, make sure the foreground color is not set to White, the pen pattern is not set 
to White or None (N), and that the line style is not set to None.

 
To edit a line:

Select the line with the Selection Arrow. Object handles appear at the ends of the line.
Position the pointer over one of the handles.
Drag the handle to adjust the length or angle of the line.
When you are finished, click away from the line to deselect it.

 

Creating and Editing Arrows
Arrows are created and edited in the same manner as lines. The only difference is that you need to select the type of 
arrowhead to be displayed. Arrowheads can be placed at one or both ends of the arrow.
 
To create an arrow:

Click the Line tool on the toolbox.
Click the Line tool again and choose the type of arrow to be created from the pop-up menu that appears.
Position the cursor where you want to begin drawing the arrow. The point of the arrowhead is placed at this 

position.
Click and drag to draw the arrow. By pressing Shift as you drag, you can constrain the arrow to rotate in 45 

degree increments. The arrow appears with object handles to indicate that it is selected.

Note: If the arrow is not visible after creating it, make sure the foreground color is not set to White, the pen pattern is not 
set to White or None (N), and that the line style is not set to None.

 
To edit an arrow:

Select the arrow with the Selection Arrow. Object handles appear at the ends of the line.
Position the pointer over one of the handles.
To change the arrow’s size or angle, drag one of the handles.
To change the arrowhead type, select a different arrow from the pop-up menu. You can switch the ends of the 

arrow by choosing Reverse from the menu.
When you are finished, click away from the arrow to deselect it.

 
To edit an arrowhead:

Double-click the arrow (or click once and choose Object > Edit Object) to display the Edit Arrowheads dialog.
Edit the values in the dialog until the arrowhead in the preview window looks the way you want it.
Click OK to update the arrow.

Note: If you want to modify the default set of arrowheads, use the Edit Arrow Heads command (Object menu).
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Creating and Editing Rectangles and Squares
To create a rectangle or a square:

Select the Box tool from the toolbox.
Position the cursor where you want to begin drawing.
Click and drag to draw the rectangle. By pressing Shift as you drag, you can constrain its shape to a square. The 

rectangle or square appears with object handles to indicate that it is selected.

 
To edit a rectangle or square:

Select the object with the Selection Arrow. Object handles appear at each corner.
Drag any one of the handles until the object reaches the desired size.
When you are finished, click away from the object to deselect it.

 

Creating and Editing Rounded Rectangles and Squares
To create a rounded rectangle or square:

Select the Rounded Rectangle tool from the toolbox.
Position the cursor where you want to begin drawing.
Click and drag to draw the rectangle with rounded corners. By pressing Shift as you drag, you can constrain its 

shape to a square with rounded corners. The rounded rectangle or square appears with object handles to 
indicate that it is selected.

 
To edit a rounded rectangle or square:

Select the object with the Selection Arrow. Object handles appear at each corner.
Drag any one of the handles until the object reaches the desired size.
When you are finished, click away from the object to deselect it.

 

Creating and Editing Ovals and Circles
To create an oval or a circle:

Select the Oval tool from the toolbox.
Position the cursor where you want to begin drawing.
Click and drag to draw the oval. By pressing Shift as you drag, you can constrain the shape to a circle. The oval or 

circle appears with object handles to indicate that it is selected.

 
To edit an oval or a circle:

Select the object with the Selection Arrow. Object handles appear at the corners of the area occupied by the oval 
or circle.

Drag any one of the handles until the object reaches the desired size.
When you are finished, click away from the object to deselect it.

 

Creating and Editing Polygons
The Polygon tool is used to create polygons. Polygons consist of multiple line segments connected at the segment end 
points. They can either be closed (the first and last segments connect) or open (the first and last segments do not 
connect).
 
To create a polygon:
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Select the Polygon tool from the toolbox.
Position the cursor where you want to begin drawing. Then, click to begin drawing. A small square marks the 

starting point.
Move the cursor to where you want the first segment of the polygon to end. By pressing Shift, you can constrain 

the segment to rotate in 45 degree increments.
Move the cursor and click again to create the second segment.
Continue moving and clicking until the desired number of segments are created. You can close the polygon by 

clicking the hollow square. To leave the polygon open, double-click, press Return (Mac) or Enter (Windows), 
or position the cursor on the toolbox and click.

 
To edit the segment points of the polygon:

Double-click the polygon (or click once and choose Object > Edit Object). The four object handles disappear and 
are replaced by handles at each segment point of the polygon.

Drag any one of the segment points until the polygon reaches the desired size.
When you are finished editing, click outside of the polygon to deselect it.

 

Creating and Editing Arcs
The Arc tool creates an arched line between two points. The arc’s curvature and angle are determined by the position, 
direction, and relative distance of the two points. The direction of the arc’s curve is determined by the initial dragging 
direction.
 
To create an arc:

Select the Arc tool from the toolbox.
Position the cursor where you want to begin drawing.
Click and drag diagonally to draw the arc. By pressing Shift as you drag, you can constrain the arc to a quarter-

circle. The arc appears with object handles to indicate that it is selected.

 
To edit an arc:

Select the arc with the Selection Arrow. Object handles appear at the corners of the area occupied by the arc.
Drag any one of the handles until the object reaches the desired size.
When you are finished editing, click outside of the arc to deselect it.

 

Creating and Editing Bezier Curves
The Bezier curve tool can be used to draw complex objects. Bezier curves are irregularly shaped, multi-sided objects that 
can have curved line segments. They can either be closed (the first and last segments connect) or open (the first and last 
segments do not connect).
 
Each segment in a Bezier curve is defined by four points: two anchor points and two direction points. The anchor points 
determine where the segments begin and end. The direction points, along with the tangent lines that connect them to the 
anchor points, determine the size and positioning of the curve segments.
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Bezier curve definition
 

Creating a Bezier Curve
To create a Bezier curve:

Select the Bezier curve tool from the toolbox.
Position the cursor where you want to begin drawing and click.
Move the cursor to where you want the first segment to end.
Click and hold the mouse button down. If you release immediately, a straight line appears between the points. If 

you hold down the mouse button and drag, a tangent line appears that allows you to drag the curve into the 
position you want.

Release when the segment is the desired shape. The tangent line disappears and handles appear at the anchor 
points.

Continue creating more segments and setting the angle and shape of the curve with the tangent lines. The 
segments are automatically connected.

You can close the curve by clicking the hollow square. To leave the curve open, double-click, press Return (Mac) 
or Enter (Windows), or position the pointer on the toolbox and click. The curve appears with object handles to 
indicate that it is selected.

Creating a Bezier curve
 

Editing a Bezier Curve
You can change the position of each anchor point and the shape of each curve. If a segment is straight, there is no 
tangent line and you can only change its position. Segments can be deleted by selecting an anchor point and pressing 
Delete (Mac) or Backspace (Windows).
 
To edit a Bezier curve:

Double-click the curve (or click once and choose Object > Edit Object). The four object handles disappear and 
are replaced by handles at each anchor point of the curve.

Position the arrow over each anchor point you want to move and drag until the point is in the desired position. The 
tangent line is displayed with round handles at each direction point. You can drag these handles to control the 
size and shape of the curves.
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Select either of the direction points and drag to edit the shape of the curve. The curve is reshaped in the direction 
you move the handle.

Continue moving anchor points and reshaping curves until the curve is the desired shape.
When you are finished editing, click outside of the curve to deselect it.

Editing a Bezier curve
 

Overview: Adding Colors and Patterns to Shapes
The area beneath the tools on the toolbox contains several icons that are used to set and modify the attributes of an 
object. These attributes include: foreground color, background color, fill pattern, pen pattern, line style, and line width. 
Using these icons, you can control the appearance of any object in the plot or layout window.
 
The following topics discuss the use of these icons:

Setting Default Attributes for Shapes
Changing Foreground and Background Colors
Changing Fill and Pen Patterns
Changing Line Styles and Widths
 

Setting Default Attributes for Shapes
Attributes for shapes drawn in the plot or layout window are controlled using the icons below the tools in the toolbox 
(shown below). If no objects are selected in the window, you can set default attributes. These attributes are applied to any 
new shapes created in KaleidaGraph.
 

 
To set the default attributes:

Verify that no items are selected in the plot or layout window.
Make selections for the foreground color, background color, fill pattern, pen pattern, line style, and line width.

Note: If the object is not visible after creating it, check the default settings for the foreground color, pen pattern, and line 
style.

 
The attributes that you select are saved as part of the Style file. This enables you to set your preferences and have 
KaleidaGraph remember them the next time you start the program.
 

Changing Foreground and Background Colors
The Color icon consists of two sections: a foreground section (upper-left) for setting the foreground color and a 
background section (lower-right) for setting the background color. When you select a fill or pen pattern, the foreground 
color is applied to the black portion of the pattern and the background color is applied to the white portion of the pattern.
 
Note: To edit the colors that appear in the color palettes, use the Edit Colors command (Object menu).
 
To change the foreground or background color of an object:
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Select the object to be edited.
Click the foreground or background section of the Color icon. One of the following color palettes appears with the 

current color choices.

         
Foreground Color palette         Background Color palette

Select a different color from the palette.

 

Changing Fill and Pen Patterns
The fill pattern is used to represent the interior of an object. The pen pattern is used to represent object lines. You can 
change the fill or pen pattern by selecting a different pattern from the pop-up menu that appears when you click the 
appropriate portion of the Pattern icon. Black portions of the pattern represent the foreground color and white portions 
represent the background color.
 
To change the fill or pen pattern of an object:

Select the object to be edited.
Click the interior or outer portion of the Pattern icon to display the pattern choices, as shown below.

         
Fill pattern choices         Pen pattern choices

Select a different pattern from the pop-up menu.

 

Changing Line Styles and Widths
The Style icon controls the line styles and widths used for objects. The left portion of the icon (the area to the left of the up 
and down arrows) controls the line style; the right portion (the up and down arrows) controls the line width.
 
To change the line style or line width of an object:

Select the object to be edited.
Click the line style or line width portion of the Style icon. One of the following pop-up menus appears with the 

available choices.
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Line style pop-up menu         Line width pop-up menu

Select a different line style or thickness from the pop-up menu.
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Purpose of Curve Fitting
Curve fitting, also known as regression analysis, is used to find the "best fit" line or curve for a series of data points. Most 
of the time, the curve fit will produce an equation that can be used to find points anywhere along the curve. In some 
cases, you may not be concerned about finding an equation. Instead, you may just want to use a curve fit to smooth the 
data and improve the appearance of your plot. KaleidaGraph provides curve fits that can be used in both of these 
scenarios.
 

Types of Curve Fits
The curve fits included in KaleidaGraph can be divided into three main categories: Least Squares curve fits, nonlinear 
curve fits, and smoothing curve fits. This section provides an overview of each category.
 
Please note:

It is possible to apply a Least Squares curve fit and a General curve fit to the same data and get slightly different 
results. This is because these fits use different methods to arrive at their results.

Parameter errors can only be displayed using the General curve fit. If you want to view the error values for any of 
the parameters, program that particular function into the General curve fit.

Least Squares Curve Fits
Least Squares is a method of curve fitting that has been popular for a long time. Least Squares minimizes the square of 
the error between the original data and the values predicted by the equation. While this technique may not be the most 
statistically robust method of fitting a function to a data set, it has the advantage of being relatively simple (in terms of 
required computing power) and of being well understood.
 
The major weakness of the Least Squared method is its sensitivity to outliers in the data. If a data point is widely different 
from the majority of the data, it can skew the results of the regression. For this reason, the data should always be 
examined for reasonableness before fitting. KaleidaGraph’s Data Selection tool provides a simple method of graphically 
removing outliers from a plot.
 
The five Least Squares fits available in KaleidaGraph are: Linear, Polynomial, Exponential, Logarithmic, and Power.

Nonlinear Curve Fits
Nonlinear curve fitting is accommodated in KaleidaGraph through the General curve fit function. Using this function, you 
can define your own equation or choose one from our library of over 100 curve fit definitions. This is the most powerful 
fitting option in KaleidaGraph because you can specify virtually any equation to be fitted to the data.
 
The General curve fit is based on the Levenberg-Marquardt algorithm and is calculated using an iterative procedure. 
KaleidaGraph starts with the initial guesses for the unknown parameters that were supplied with the equation. It then 
calculates a Chi Square value that represents the sum of the squared error between the original data and the calculated 
fit. During each iteration, KaleidaGraph varies the parameter values slightly and re-evaluates Chi Square until it finds the 
best fit.

Smoothing Curve Fits
The smoothing fits in KaleidaGraph are different from the other two types of fits in that these curve fits do not generate an 
equation for the resulting curve. This is because there is no single equation that can be used to represent the curve. 
These curve fits are useful when you just want to improve the appearance of the plot by drawing a smooth curve through 
the data.
 
The four smoothing fits available in KaleidaGraph are: Smooth, Weighted, Cubic Spline, and Interpolate. Each one of 
these curve fits uses a different technique to arrive at the final curve, so you may want to apply more than one to see 
which one looks the best.
 
The Smooth and Interpolate curve fits are based on the same underlying technique, with the Smooth curve fit 
incorporating a geometric weight to arrive at the final curve. The Weighted curve fit uses the locally weighted Least 
Squares error (Lowess) method. The Cubic Spline curve fit is calculated using a series of cubic polynomials.
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Choosing a Curve Fit Model
Since KaleidaGraph provides a number of different curve fit types and over 100 General curve fit equations, choosing a 
model for a particular data set can be a difficult task. When you are deciding on a curve fit model, it helps to know some of 
the underlying properties associated with the data to make an educated decision on which model to use.
 
Depending on your field of study, you may find that certain equations or families of equations are used on a regular basis. 
For example, Sigmoidal curves are normally used to fit dose response data and Hyperbolic functions are normally used to 
fit ligand binding data in the field of enzyme kinetics.
 
If you do not know what type of curve fit to use, you may be able to ask a colleague or do some research to see what 
curve fits are normally used with the type of data that you have collected. If that proves to be fruitless or if nothing is 
known about the data, then the selection of the model must be based on the raw data.
 
You can use a Scatter plot to plot the data and see the general shape of the curve. The following figures provide a glimpse 
of the general shape associated with some of the more common families of General curve fits that are used in 
KaleidaGraph. Within each family, KaleidaGraph provides a number of different curve fit equations and it may take some 
trial and error to find the equation that produces the best results.
 
General Shape of Various Curve Fit Families

 

Peak Sigmoidal Hyperbola Exponential Rise
       

Exponential Growth Exponential Decay Power Waveform
 

Applying a Linear Curve Fit
A Linear curve fit produces a straight line through your data, of the form y = m0 + m1 * x. There are no data restrictions 
associated with this curve fit.
 
Note: On a semi-log or log-log plot, this fit appears as a curved line.
 
To apply a Linear curve fit:

Choose Curve Fit > Linear. The Curve Fit Selections dialog appears. All dependent variables are listed under 
Column Names.

Click the check box for each variable to be fit.
Click OK to return to the plot window and fit a line to the selected variables.

 

Applying a Polynomial Curve Fit
A Polynomial curve fit produces a curve through your data, of the form y = m0 + m1 * x + m2 * x2 + m3 * x3 +...+ m9 * x9. 
The more complex the curvature of the data, the higher the polynomial order required to fit it. There are no data 
restrictions associated with this curve fit.
 
To apply a Polynomial curve fit:

Choose Curve Fit > Polynomial. The Curve Fit Selections dialog appears. All dependent variables are listed 
under Column Names.

Click the check box for each variable to be fit.
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Each time a variable is selected, a second dialog appears. Use this dialog to specify the order of the polynomial 
you want to fit.

Click OK to both dialogs to return to the plot window and fit a polynomial curve to the selected variables.

Please note the following:

If you press Shift when selecting variables for this fit, the current polynomial order is used for each variable. This 
enables you to select the order once and set it for the rest of the variables without displaying the second 
dialog.

If you are fitting a lot of data or the data has sharp peaks, you may want to increase the number of Curve Fit 
Points in the Curve Fit Options dialog to improve the appearance of the curve fit line.

 

Applying an Exponential Curve Fit
An Exponential curve fit produces a curve through your data, of the form y = m0 * em1 * x. It is generally used to fit data 
that increases or decreases at a high rate. This curve fit cannot fit negative data or data equal to zero.
 
Note: On a semi-log plot with a linear X axis, the curve appears as a straight line.
 
To apply an Exponential curve fit:

Choose Curve Fit > Exponential. The Curve Fit Selections dialog appears. All dependent variables are listed 
under Column Names.

Click the check box for each variable to be fit.
Click OK to return to the plot window and fit an exponential curve to the selected variables.

 

Applying a Logarithmic Curve Fit
A Logarithmic curve fit produces a curve through your data, of the form y = m0 + m1 * log(x). A logarithmic curve fit is 
generally used with data that spans decades (100, 101, 102, and so on). This curve fit cannot be used to fit negative data 
or data equal to zero.
 
Note: On a semi-log plot with a linear Y axis, the curve appears as a straight line.
 
To apply a Logarithmic curve fit:

Choose Curve Fit > Logarithmic. The Curve Fit Selections dialog appears. All dependent variables are listed 
under Column Names.

Click the check box for each variable to be fit.
Click OK to return to the plot window and fit a logarithmic curve to the selected variables.

 

Applying a Power Curve Fit
A Power curve fit produces a curve through your data, of the form y = m0 * xm1. This curve fit cannot be used to fit 
negative data or data equal to zero.
 
Note: On a log-log plot, the curve appears as a straight line.
 
To apply a Power curve fit:

Choose Curve Fit > Power. The Curve Fit Selections dialog appears. All dependent variables are listed under 
Column Names.

Click the check box for each variable to be fit.
Click OK to return to the plot window and fit a power curve to the selected variables.
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Applying a Smooth Curve Fit
A Smooth curve fit produces a smoothed curve to the data. KaleidaGraph starts by applying a Stineman function to the 
data. The output of this function then has a geometric weight applied to the current point and ±10% of the data range, to 
arrive at the smoothed curve.
 
The only data restriction associated with this curve fit is that the independent (X) variable must be in ascending order in 
the data window. There is no single expression that represents this curve; therefore, there are no parameters to view or 
copy.
 
Note: If you are fitting a lot of data or the data has sharp peaks, you may want to increase the number of Curve Fit 

Points in the Curve Fit Options dialog to improve the appearance of the curve fit line.
 
To apply a Smooth curve fit:

Choose Curve Fit > Smooth. The Curve Fit Selections dialog appears. All dependent variables are listed under 
Column Names.

Click the check box for each variable to be fit.
Click OK to return to the plot window and fit a smooth curve to the selected variables.

 

Applying a Weighted Curve Fit
A Weighted curve fit produces a curve to the data, using the locally weighted Least Squared error method. The result of 
this curve fit is to plot a best fit smooth curve through the center of the data. This is an extremely robust fitting technique. 
Unlike the standard Least Squared error method, this technique is nearly insensitive to outliers. However, this does not 
come for free. The Weighted curve fit is computationally complex and can take longer to compute for a large data set.
 
The only data restriction associated with this curve fit is that the independent (X) variable must be in ascending order in 
the data window. There is no single expression that represents this curve; therefore, there are no parameters to view or 
copy.
 
To apply a Weighted curve fit:

Choose Curve Fit > Weighted. The Curve Fit Selections dialog appears. All dependent variables are listed under 
Column Names.

Click the check box for each variable to be fit.
Each time a variable is selected, a second dialog appears. It allows you to modify the smoothing factor, which 

controls the fraction of the data population considered during smoothing. The larger the value, the less 
individual points affect the final curve. Typical values are between 33 and 66. The minimum value is zero and 
the maximum value is 100.

Click OK to both dialogs to return to the plot window and apply a weighted curve to the selected variables.

Please note the following:

If you press Shift when selecting variables for this fit, the current smoothing factor is used for each variable. This 
enables you to select the factor once and set it for the rest of the variables without displaying the second 
dialog.

Pressing esc, Command+Period (Mac), or Ctrl+Period (Windows) stops the calculation of a Weighted curve fit.
If you are fitting a lot of data or the data has sharp peaks, you may want to increase the number of Curve Fit 

Points in the Curve Fit Options dialog to improve the appearance of the curve fit line.

 

Applying a Cubic Spline Curve Fit
Moving left to right along the curve in increasing X, every group of four consecutive data points defines a cubic polynomial 
equation. A series of these cubic polynomials connected together define a cubic spline curve. Using this curve fit is similar 
to using a French curve to connect all of the data points.
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The only data restriction associated with this curve fit is that the independent (X) variable must be in ascending order in 
the data window. There is no single expression that represents this curve; therefore, there are no parameters to view or 
copy.
 
Note: If you are fitting a lot of data or the data has sharp peaks, you may want to increase the number of Curve Fit 

Points in the Curve Fit Options dialog to improve the appearance of the curve fit line.
 
To apply a Cubic Spline curve fit:

Choose Curve Fit > Cubic Spline. The Curve Fit Selections dialog appears. All dependent variables are listed 
under Column Names.

Click the check box for each variable to be fit.
Click OK to return to the plot window and fit a cubic spline curve to the selected variables.

 

Applying an Interpolate Curve Fit
An Interpolate curve fit produces a curve that passes through the data points and matches the slopes at those points. The 
advantage of this curve fit is that it does not produce wild results near an abrupt change of slope, as can happen with the 
Cubic Spline curve fit.
 
The only data restriction associated with this curve fit is that the independent (X) variable must be in ascending order in 
the data window. There is no single expression that represents this curve; therefore, there are no parameters to view or 
copy.
 
Note: If you are fitting a lot of data or the data has sharp peaks, you may want to increase the number of Curve Fit 

Points in the Curve Fit Options dialog to improve the appearance of the curve fit line.
 
To apply an Interpolate curve fit:

Choose Curve Fit > Interpolate. The Curve Fit Selections dialog appears. All dependent variables are listed under 
Column Names.

Click the check box for each variable to be fit.
Click OK to return to the plot window and fit an interpolated curve to the selected variables.

 

Curve Fit Definition
The curve fit definition is the equation that is fitted to the data. Curve fit definitions are composed of the same items as 
formulas in Formula Entry: operators, parameters, functions, and constants, in addition to an independent variable.

The independent variable in an equation is represented by m0. You can use x, but only if it is defined in the 
Library.

The parameters being calculated by the fit are represented by m1 - m9. Parameters should be entered wherever 
you have an unknown quantity and you want KaleidaGraph to calculate the best value.

Use an asterisk (*) for multiplication and a caret (^) to raise quantities to a power.
KaleidaGraph does not distinguish between upper and lower case letters (m0 and M0 are the same).
Constants and other shorthand references can be defined in the library for use in a curve fit definition. Some 

definitions in the default library are used to substitute x for m0, and a, b, c, and d for m1, m2, m3, and m4, 
respectively.

To include a column number as part of the curve fit definition, the table function must be used. This method also 
enables you to fit equations containing multiple independent variables.

 
Some equations and how they appear as curve fit definitions in KaleidaGraph are shown below.
 

Original Equations Curve Fit Definitions
a * x + b m1 * m0 + m2
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a + b * x^c m1 + m2 * m0^m3
a + b * exp(-c * x) m1 + m2 * exp(-m3 * m0)
a * exp(-b * x) * cos(c * x + d) m1 * exp(-m2 * m0) * cos(m3 * m0 + m4)
 

Initial Conditions
Even though KaleidaGraph calculates values for unknown parameters, you must supply an initial value for each 
parameter. The algorithm used to calculate the final results requires a reasonable guess to point it in the right direction. 
KaleidaGraph improves upon these values during each iteration of the fit.
 
Note: Since the fit starts with initial guesses and improves upon them with each iteration, the final values may be different 

for a separate set of initial guesses.
 
Do not get carried away trying to find good guesses; the initial conditions are just that, guesses. If you are not sure what 
the guesses should be, keep the initial conditions non-zero, and at the correct order of magnitude that you might expect 
(be it 0.001, 1, or 1000).
 
The initial conditions are entered immediately following the curve fit definition. Place a semicolon at the end of the 
definition and begin entering the initial guesses, separating each with a semicolon. Some definitions with initial guesses 
are shown below.
 

Curve Fit Definitions with Initial Guesses
m1 * m0 + m2; m1 = 0.5; m2 = 23
m1 + m2 * m0^m3; m1 = -2; m2 = 3; m3 = 2
m1 + m2 * exp(-m3 * m0); m1 = 5; m2 = 1; m3 = 0.5
m1 * exp(-m2 * m0) * cos(m3 * m0 + m4); m1 = 4; m2 = 0.7; m3 = 2.2; m4 = 15
 

General Curve Fit Definition Dialog
The General Curve Fit Definition dialog, shown below, is used to enter the equation, initial guesses, and allowable error to 
be used in the curve fit. You can also choose to specify partial derivatives or to weight the data.
 

 
 
This dialog can be displayed using either of the following methods:

Choose a curve fit from the General submenu (Curve Fit menu). In the dialog that is displayed, click Define 
Function.

Choose Curve Fit > General > Edit General. In the dialog that is displayed, select the name of a curve fit and 
click Edit.

 
The settings in the General Curve Fit Definition dialog are discussed below.
 
Degrees/Radians Buttons
These buttons determine whether the results of trigonometric functions are in degrees or radians.
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Allowable Error:
The value entered in this field helps KaleidaGraph determine when to stop iterating. Iterations stop if either of the following 
occurs:

Chi Square does not change for a certain number of iterations.
The percent change in the normalized Chi Square is less than the Allowable Error.

 
Specify Partials
The algorithm that KaleidaGraph uses in calculating each iteration of the General curve fit requires evaluating the partial 
derivative of the function with respect to each parameter. If Specify Partials is not selected, KaleidaGraph numerically 
approximates the derivative. If this option is selected, the dialog expands.
 
The nine buttons at the bottom of the dialog allow each partial derivative to be entered in the text field above the buttons. 
The biggest advantage of specifying the partial derivatives is accuracy. The curve fit algorithm uses these partial 
derivatives to direct itself where to move after each iteration to find the best solution.
 
You can choose to specify only some of the partial derivatives, but not all of them. It is better to let KaleidaGraph 
approximate the partial instead of specifying the wrong derivative. If a partial derivative is missing, KaleidaGraph 
numerically approximates that partial derivative.
 
Weight Data
When selected, you can specify a data column that contains weights for the variable you are fitting. These weights should 
represent the individual errors of the data values. Each weight is used internally as: 1/(weight^2). The smaller the error 
value, the larger the internal weight. If this check box is not selected, a weight value of 1.0 is used for all data points.
 
Help...
Click this button to display the Help dialog.
 
File...
Clicking this button displays a text editor that can be used to create, open, or save a curve fit definition. The definition 
appears on the first line and any partial derivatives appear on the lines below it.
 

Overview: Predefined General Curve Fit Equations
KaleidaGraph includes over 100 predefined equations that can be used with the General curve fit. The curve fit definitions 
are divided into the following categories:

Enzyme Kinetics
Exponential Decay
Exponential Growth
Exponential Rise
Hyperbola
IC50/EC50
Logarithmic
Peaks
Polynomial
Power
Rational
Sigmoidal
Waveforms
Yield Growth/Density
Miscellaneous Definitions

 
These curve fit definitions are provided in the following formats for use in KaleidaGraph:

Each curve fit definition is stored as a text file in the Curve Fits folder.
Each category of definitions is stored as a Macros file that can be imported to load the definitions into the General

submenu.
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• Each category of definitions is stored as a text file for use in the Library.

 

Enzyme Kinetics Definitions
The following Enzyme Kinetics curve fit definitions are included with KaleidaGraph. The name in parentheses is the name 
of the text file or library definition associated with that curve fit.
 
Michaelis-Menten (michaelismenten)
a*x/(b+x)
a = vmax, b = dissociation constant
 
One Site Ligand Binding (onesite)
a*x/(b+x)
a = top asymptote, b = median
 
One Site Ligand Binding w/ NSB (onesitewnsb)
a*x/(b+x)+c*x
a = capacity, c = non-specific binding
 
Two Site Ligand Binding (twosite)
a*x/(b+x)+c*x/(d+x)
a = capacity of site 1, c = capacity of site 2
 
Two Site Ligand Binding w/ NSB (twositewnsb)
a*x/(b+x)+c*x/(d+x)+f*x
a = capacity of site 1, c = capacity of site 2, f = non-specific binding
 
Logistic Sigmoid (lgstsigmoid)
a+(b-a)/(1+exp(-c*(x-d)))
a = y min, b = y max, d = x50
 
Asymmetric Sigmoid (asymsigmoid)
a+(b-a)/(1+(x/c)^d)
a = y min, b = y max, c = point of inflection, d = slope
 
Log Logistic Growth (loglgst)
a-ln(1+b*exp(-c*x))
 
Log Logistic Growth with Offset (loglgstwoffset)
a*ln(b*(x-c))
 
Gompertz Growth (gompertzgrowth)
a*exp(exp(b-c*x))
 
Morgan-Mercer-Flodin Growth (mmf)
(a*b+c*x^d)/(b+x^d)
 
Richards Growth (richards)
a/((1+b*exp(-c*x))^d
 
Allosteric Kinetics (allosteric)
(a*x^b)/(c+x^b)
 
PKa Determination (pka)
(a+b)*10^(x-c)/(1+10^(x-c))
a= lower limit, b = upper limit, c = pka
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Substrate Inhibition (substrateinhib)
(a*x)/(b+(x*(1+x/c)))
a = vmax, b = dissociation constant, c = comp. inhibition constant
 
Power Law w/ X and Y Offsets (powerlaw)
a+b*(x-c)^d
 
Five Parameter PKa (fiveppka)
a+(b*((c/(c+x)))) + (d*((f/(f+x))))
 
Modified Five Parameter PKa (modfiveppka)
a+(b*(10^(x-c)))/(1+10^(x-c)) + (d*(10^(x-f)))/(1+10^(x-f))
 
Morrison Equation (morrison)
1-((a+x+b-sqrt((a+x+b)^2 - 4*a*x))/(2*a))
 

Exponential Decay Definitions
The following Exponential Decay curve fit definitions are included with KaleidaGraph. The name in parentheses is the 
name of the text file or library definition associated with that curve fit.
 
One Parameter Exponential Decay (expdecay1)
exp(-a*x)
a = rate constant
 
Two Parameter Exponential Decay (expdecay2)
a*exp(-b*x)
a = amplitude, b = rate constant
 
Three Parameter Exponential Decay (expdecay3)
a + b*exp(-c*x)
a = y offset, b = amplitude, c = rate constant
 
Double Exponential Decay (dblexpdecay)
a + b*exp(-c*x) + d*exp(-f*x)
a = y offset, b+d = amplitude, c and f = rate constants
 
Modified Exponential Decay (modexpdecay)
a*exp(b/(x+c))
a = coefficient, b = coefficient, c = coefficient
 
Exponential Linear Combination (explinear)
a + b*exp(-c*x) + d*x
a = offset, b = coefficient, c = coefficient, d = coefficient
 

Exponential Growth Definitions
The following Exponential Growth curve fit definitions are included with KaleidaGraph. The name in parentheses is the 
name of the text file or library definition associated with that curve fit.
 
One Parameter Exponential Growth (expgrowth1)
exp(a*x)
a = growth constant
 
Two Parameter Exponential Growth (expgrowth2)
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a*exp(b*x)
a = amplitude, b = growth constant
 
Three Parameter Exponential Growth (expgrowth3)
a + b*exp(c*x)
a = y offset, b = amplitude, c = growth constant
 
Double Exponential Growth (dblexpgrowth)
a + b*exp(c*x) + d*exp(f*x)
a = y offset, b+d = amplitude, c and f = growth constants
 
Modified Exponential Growth (modexpgrowth)
exp(a*(x-b))
a = growth constant, b = position
 
Exponential base 10 curve fit (exp10fit)
a*10^(b*x)
 
Two Parameter Exponential Function (expfunction1)
a*b^x
a = position, b = position
 
Three Parameter Exponential Function (expfunction2)
a + b*c^x
 
Stirling Model (stirling)
a + b*(exp(c*x) - 1)/c
a = y offset, b = coefficient, c = coefficient
 

Exponential Rise Definitions
The following Exponential Rise curve fit definitions are included with KaleidaGraph. The name in parentheses is the name 
of the text file or library definition associated with that curve fit.
 
One Parameter Exponential Rise (exprise1)
1 - exp(-a*x)
a = rate constant
 
Two Parameter Exponential Rise (exprise2)
a*(1 - exp(-b*x))
a = amplitude, b = rate constant
 
Three Parameter Exponential Rise (exprise3)
a + b*(1 - exp(-c*x))
a = y offset, b = amplitude, c = rate constant
 
Double Exponential Rise (dblexprise)
a + b*(1 - exp(-c*x)) + d*(1 - exp(-f*x))
a = y offset, b+d = amplitude, c and f = rate constants
 
Modified Exponential Rise (modexprise)
a + b*(1 - c^x)
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Hyperbola Definitions
The following Hyperbola curve fit definitions are included with KaleidaGraph. The name in parentheses is the name of the 
text file or library definition associated with that curve fit.
 
One Site Ligand Binding - Two Parameter Rectangular Hyperbola (onesite)
a*x/(b+x)
a = top asymptote, b = median
 
One Site Ligand Binding w/ NSB - Three Parameter Rectangular Hyperbola (onesitewnsb)
a*x/(b+x)+c*x
a = Bmax, b = KD, c = Nonspecific binding
 
Two Site Ligand Binding - Four Parameter Double Rectangular Hyperbola (twosite)
a*x/(b+x)+c*x/(d+x)
a = first top asymptote, b = first median, c = second top asymptote, d = second median
 
Two Site Ligand Binding w/ NSB - Five Parameter Double Rectangular Hyperbola (twositewnsb)
a*x/(b+x)+c*x/(d+x)+f*x
 
Rectangular Hyperbola (recthyperb)
a*b*x/(1+b*x)
a = coefficient, b = coefficient
 
Hyperbolic Decay (hyperdecay)
(a*b)/(b+x)
 
Modified Hyperbola (modhyperb1)
a*x/(1+b*x)
 
Modified Hyperbola (modhyperb2)
x/(a+b*x)
a = amplitude, b = coefficient
 
Modified Hyperbola (modhyperb3)
a-b/(1+c*x)^(1/d)
a = coefficient, b = coefficient, c = coefficient, d = coefficient
 
Bent Hyperbola Model (benthyperb)
a+b*x-sqrt((c+b*x)^2+d^2)
 

IC50/EC50 Definitions
The following curve fit definitions are included with KaleidaGraph for determining IC50 or EC50 values. The name in 
parentheses is the name of the text file or library definition associated with that curve fit.
 
Dose Response Logistic (dosersplgst)
a+(b-a)/(1+(x/c)^d)
a = y min, b = y max, c = IC50, d = slope
 
Modified Dose Response Logistic (moddosersplgst)
a+b/(1+(x/c)^d)
a = y min, b = range of transition (y max - y min), c = IC50, d = slope
 
Three Parameter Hill Function (hill)
a*x^b/(c^b+x^b)
a = y min, b = slope, c = IC50
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Four Parameter Hill Function (hill4)
a+b*x^c/(d^c+x^c)
a = y min, b = y max, c = slope, d = IC50
 
Sigmoidal Dose Response (sigdosersp)
a+(b-a)/(1+10^(c-x))
a = y min, b = y max, c = IC50
 
Sigmoidal Dose Response - Variable Slope (sigdoserspvar)
a+(b-a)/(1+10^((c-x)*d))
a = y min, b = y max, c = IC50, d = slope
 
Three Parameter Dose Response (threepdose)
a+(b-a)/(1+(x/c))
a = Nonspecific binding, b = Maximum binding, c = IC50
 
Four Parameter IC50 Function (fourpic50)
a+(b-a)/(1+exp(c*(d-x)))
a = y min, b = y max, c = slope, d = IC50
 

Logarithmic Definitions
The following Logarithmic curve fit definitions are included with KaleidaGraph. The name in parentheses is the name of 
the text file or library definition associated with that curve fit.
 
Log base 10 curve fit (logfit)
a + b * log(x)
a = y offset, b = coefficient
 
Log base e curve fit (lnfit)
a + b * ln(x)
a = y offset, b = coefficient
 
One Parameter Log Fit (logfit1)
ln(x-a)
a = center
 
Two Parameter Log Fit (logfit2)
a*ln(x-b)
a = coefficient, b = center
 
Three Parameter Log Fit (logfit3)
a+b*ln(x-c)
 
Quadratic Log Fit (quadlog)
a+b*ln(x)+c*(ln(x))^2
 
Reciprocal Log Fit (reciplog)
1/(a+b*ln(x))
 
Log Logistic Growth (loglgst)
a-ln(1+b*exp(-c*x))
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Peak Definitions
The following Peak curve fit definitions are included with KaleidaGraph. The name in parentheses is the name of the text 
file or library definition associated with that curve fit.
 
Gaussian curve fit (gaussfit)
a+b*exp(-(x-c)^2/d^2)
 
Gaussian curve fit (gaussian)
a+b*exp(-.5*((x-c)/d)^2)
a = offset, b = area, c = center, d = width
 
Sum of Two Gaussians (twogauss)
a*exp(-(x-b)^2/c^2)+d*exp(-(x-f)^2/g^2)
 
Lorentzian curve fit (lorent)
a/(1+((x-b)/c)^2)
 
Sum of Two Lorentzians (twolorent)
a/(1+((x-b)/c)^2)+d/(1+((x-f)/g)^2)
 
Log Normal (lognormal)
a+b*exp(-.5*(ln(x/c)/d)^2)
a = y offset, b = height, c = x value at peak, d = width of peak
 
Double Exponential (dblexp)
a*exp(-x/b)+c*exp(-x/d)
 

Polynomial Definitions
The following Polynomial curve fit definitions are included with KaleidaGraph. The name in parentheses is the name of the 
text file or library definition associated with that curve fit.
 
Linear curve fit through the origin (line0fit)
a*x
a = slope
 
Linear curve fit (linefit)
a + b*x
a = intercept, b = slope
 
Segmented Linear curve fit (segmented)
((x < a) ? b+c*x : 0) + ((x >=a) ? c*a + b+d*(x-a) : 0)
a = breakpoint, b= intercept of first segment, c = the slope of first segment, and d = slope of second segment
 
Quadratic curve fit (quadratic)
a + b*x + c*x^2
 
Cubic curve fit (cubic)
a + b*x + c*x^2 + d*x^3
 
Inverse Fit (inverse)
a+b/x
 
Modified Line (modline)
a*(x-b)
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Power Definitions
The following Power curve fit definitions are included with KaleidaGraph. The name in parentheses is the name of the text 
file or library definition associated with that curve fit.
 
One Parameter Power Function (power1)
x^a
a = power
 
Two Parameter Power Function (power2)
a*x^b
a = coefficient, b = power
 
Three Parameter Power Function (power3)
a + b*x^c
a = y offset, b = coefficient, c = power
 
Symmetric Power Function (symmetric)
a + b*abs(x-c)^d
a = y offset, b = amplitude, c = center, d = power
 
Modified Two Parameter Power Function (modpower1)
a*(1 - x^(-b))
a = coefficient, b = power
 
Modified Two Parameter Power Function (modpower2)
a*(1 + x)^b
a = coefficient, b = power
 
Pareto Function (pareto)
1 - 1/(x^a)
a = power
 
Modified Pareto Function (modpareto)
1 - 1/(1 + a*x)^b
a = coefficient, b = power
 
Shifted Power Fit (shiftpower)
a*(x-b)^c
a = coefficient, b = position, c = power
 
Geometric Fit (geometric)
a*x^(b*x)
 
Modified Geometric Fit (modgeometric)
a*x^(b/x)
 
Root Fit (root)
a^(1/x)
 
Hoerl Model (hoerl)
a*(b^x)*(x^c)
 
Modified Hoerl Model (modhoerl)
a*b^(1/x)*(x^c)
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Rational Definitions
The following Rational curve fit definitions are included with KaleidaGraph. The name in parentheses is the name of the 
text file or library definition associated with that curve fit.
 
One Parameter Rational Function (rational1)
1/(x+a)
 
One Parameter Rational Function (rational2)
1/(1+x*a)
 
Two Parameter Rational Function (rational3)
1/(a+b*x)
 
Two Parameter Rational Function (rational4)
a/(1+b*x)
 
Three Parameter Rational Function (rational5)
(a+b*x)/(1+c*x)
 
Three Parameter Rational Function (rational6)
(1+a*x)/(b+c*x)
 
Three Parameter Rational Function (rational7)
(a+b*x)/(c+x)
 
Three Parameter Rational Function (rational8)
(a+x)/(b+c*x)
 
Three Parameter Rational Function (rational9)
a+b/(x+c)
 

Sigmoidal Definitions
The following Sigmoidal curve fit definitions are included with KaleidaGraph. The name in parentheses is the name of the 
text file or library definition associated with that curve fit.
 
Sigmoidal curve fit (sigmoidal)
a+b/(1+exp(-(x-c)/d))
 
Logistic Sigmoid (lgstsigmoid)
a+(b-a)/(1+exp(-c*(x-d)))
 
Dose Response (dosersp)
a+(b-a)/(1+10^(c-x))
a = y min, b = y max, c = center
 
Dose Response - Variable Slope (doserspvar)
a+(b-a)/(1+10^(c-x)*d)
a = y min, b = y max, c = center, d = hill slope
 
Dose Response Logistic (dosersplgst)
a+(b-a)/(1+(x/c)^d)
a = y max, b = y min, c = x value at midpoint of y, d = slope at midpoint area
 
Five Parameter Logistic (fiveplgst)
a+(b/(1+(x/c)^d))^f
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a = y min, b = y max, c = x value at midpoint of y, d = slope at midpoint area, f = asymmetry factor
 
Boltzman Function (boltzman)
a+(b-a)/(1+exp((x-c)/d))
a = y max, b = y min, c = center, d = width
 
Chapman-Richards Model (chapman)
a*(1-exp(-b*x))^c
a = coefficient, b = coefficient, c = coefficient
 
Gompertz Growth (gompertz)
a*exp(-exp(-(x-b)/c))
 
Hill Function (hill)
a*x^b/(c^b+x^b)
 
Logistic Model (logistic)
a/(1+exp(b-c*x))
 
Morgan-Mercer-Flodin Growth (mmf)
(a*b+c*x^d)/(b+x^d)
 
Weibull Model (weibull)
a-b*exp(-c*x^d)
 

Waveform Definitions
The following Waveform curve fit definitions are included with KaleidaGraph. The name in parentheses is the name of the 
text file or library definition associated with that curve fit.
 
Sine wave (sinewave1)
a + b*sin(c*x + d)
a = y offset, b = amp., c = freq., d = phase shift
 
Sine wave (sinewave2)
a + b*sin(2*pi*x/c + d)
a = y offset, b = amp., c = period, d = (2*pi/c)*phase shift
 
Sine squared (sinesqr)
a + b*(sin(2*pi*x/c + d))^2
a = y offset, b = amp., c = 1/2 period, d = (2*pi/c)*phase shift
 
Damped Sine (dampsine)
a + b*exp(-x/f)*sin(2*pi*x/c + d)
a = y offset, b = amp., c = 1/2 period, d = phase shift, f = decay constant
 
Modified Sine (modsine)
a*sin(pi*(x-b)/c)
a = amp., b = center, c = width
 
Modified Damped Sine (moddampsine)
a*exp(-x/d)*sin(pi*(x-b)/c)
a = amp., b = center, c = width, d = decay constant
 
Modified Sine squared (modsinesqr)
a*(sin(pi*(x-b)/c))^2
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a = amp., b = center, c = width
 
Sinusoidal Function (sinusoid)
a+b*cos(c*x+d)
a = y offset, b = amp., c = freq., d = phase shift
 
Exponential-Cosine curve fit (expcosfit)
a*exp(-b*x) * cos(c*x+d)
 

Yield Growth/Density Definitions
The following Yield Density/Growth curve fit definitions are included with KaleidaGraph. The name in parentheses is the 
name of the text file or library definition associated with that curve fit.
 
Bleasdale Model (bleasdale)
(a+b*x)^(-1/c)
a = coefficient, b = coefficient, c = coefficient
 
Harris Model (harris)
1/(a+b*x^c)
a = coefficient, b = coefficient, c = power
 
Holliday Model (holliday)
1/(a+b*x+c*x^2)
a = coefficient, b = coefficient, c = coefficient
 
Modified Holliday Model (modholliday)
a/(1+b*x+c*x^2)
a = coefficient, b = coefficient, c = coefficient
 
Nelder Model (nelder)
(x+a)/(b+c*(x+a)+d*(x+a)^2)
 
Yield Fertilizer Model (yldfert1)
a+b*c^x
a = y offset, b = coefficient, c = coefficient
 
Yield Fertilizer Model (yldfert2)
a+b*exp(-c*x)
a = y offset, b = coefficient, c = coefficient
 

Miscellaneous Definitions
The following miscellaneous curve fit definitions are included with KaleidaGraph. The name in parentheses is the name of 
the text file or library definition associated with that curve fit.
 
BET Model (bet)
x/(a+b*x-(a+b)*x^2)
a = coefficient, b = coefficient
 
Exponential Association Fit (expassoc)
a*(b-exp(-c*x))
 
Extended Freundlich Model (extfreund)
a*x^(b*x^(-c))
a = coefficient, b = coefficient, c = power
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Extended Langmuir Model (extlang)
1/(a+b*x^(c-1))
a = coefficient, b = coefficient, c = coefficient
 
Freundlich Model (freund)
a+b*x^(1/c)
 
Gunary Model (gunary)
x/(a+b*x+c*sqrt(x))
a = coefficient, b = coefficient, c = coefficient
 
Heat Capacity Model (heatcap)
a+b*x+c/x^2
 
Modified Exponential Fit (modexp)
a*exp(b/x)
 
Modified Freundlich Model (modfreund)
a*x^(1/b)
a = amplitude, b = width
 
Vapor Pressure Model (vapor)
exp(a+b/x+c*ln(x))
 

Master Curve Fit List
KaleidaGraph maintains a master list of curve fits that are displayed in the General submenu whenever a new plot is 
created. The only way to edit the master list is to create a new plot and use the Edit General command. The master list is 
not affected if you do either of the following:

Use a saved plot (or any plot that had its data archived).
Choose a curve fit from the General submenu and click Define Function to edit the definition.

 

Adding a Curve Fit to the Master List
To add a curve fit to the master curve fit list:

Create a new plot.
Choose Curve Fit > General > Edit General.
Select a fit in the current list.
Click New and a New Fit appears below the selected fit in the list. The name of the fit can be changed by selecting 

it and editing the name in the text field.
Click Edit to enter the definition in the General Curve Fit Definition dialog.
Click OK when you are finished. Now you can use this fit in the active plot or any new plots that are created. 

Remember to save changes to the Macros file to make the changes permanent.

 

Rearranging the Master Curve Fit List
To rearrange the curve fit list:

Create a new plot.
Choose Curve Fit > General > Edit General.
Select the curve fit to be repositioned and drag it to a new location.
Click OK to exit the General Curve Fits dialog.
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Removing a Curve Fit from the Master List
To remove a curve fit from the master list:

Create a new plot.
Choose Curve Fit > General > Edit General.
Select the curve fit to be deleted.
Click Remove to delete the curve fit from the listing.
Click OK to exit the General Curve Fits dialog.

 

Saving Changes to the Curve Fit Menu
The curve fits in the General submenu are saved, by default, in a file called KG Macros. This file is loaded each time you 
start KaleidaGraph.
 
To save any changes made to the Curve Fit menu, it is necessary to save the changes to the default Macros file using 
one of the following methods:

In the Preferences dialog, click the File Settings tab and select Prompt from the Macros pop-up menu. When 
exiting KaleidaGraph, a dialog asks whether or not to overwrite the KG Macros file that was opened at launch.

In the Preferences dialog, click the File Settings tab and select Always from the Macros pop-up menu. When 
exiting KaleidaGraph, the KG Macros file that was opened at launch is automatically overwritten.

Choose File > Export > Macros and overwrite the default KG Macros file. The file must be named KG Macros
and saved in the following location:

In the Mac version, this file must be in the KaleidaGraph Preferences folder for it to be opened. To view 
the KaleidaGraph Preferences folder, you may need to press the Option key and choose Library from 
the Go menu at the Finder. The KaleidaGraph Preferences folder will be in the main Preferences 
folder.

In the Windows version, this file must be in the \Users\(user)\AppData\Local\Synergy 
Software\KaleidaGraph5.0 directory for it to be opened. Windows stores the settings files in a hidden 
directory. You will need to turn on the setting in the Folder and Search options (under the Organize
menu in the Windows Explorer window) to Show hidden files to access hidden locations. (user) in the 
previous path is the name of your account on the computer.

Note: Only changes made to a new plot using the Edit General command are saved as part of the Macros file. Any 
changes made to a saved plot or by choosing a curve fit from the General submenu and clicking Define 
Function apply solely to that particular plot.

 

Entering a Custom Curve Fit Equation
If you need to use a curve fit equation that is not included with the predefined equations, you can easily enter a custom 
equation and use it in KaleidaGraph.
 
Note: Custom curve fit equations can also be defined in the library.
 
To create a custom curve fit definition (and have it available for all future plots):

Create a new plot.
Choose Curve Fit > General > Edit General.
Select a fit in the current list.
Click Add and a New Fit appears below the selected fit in the list. The name of the fit can be changed by selecting 

it and editing the name in the text field.
Click Edit to display the General Curve Fit Definition dialog.
Enter the curve fit equation in the General Curve Fit Definition dialog. Make sure you include the initial guesses for 

each of the unknown parameters. An example curve fit equation and its initial guesses are shown below:

m1+m2*exp(-(m0-m3)*(m0-m3)/(m4*m4));m1=1;m2=5;m3=1;m4=10
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Click OK until you return to the plot window. Now you can use this fit in the active plot or any new plots that are 
created. Remember to save changes to the Macros file to make the changes permanent.

If a syntax error is found after entering the equation, a dialog similar to the following is displayed to show the portion of the 
equation that triggered the error.
 

 

Importing Definitions from a Text File
The Curve Fits folder contains each curve fit definition as a text file. This allows you to import specific curve fit definitions 
for use in KaleidaGraph.
 
To load a text file containing a curve fit definition (and have it available for all future plots):

Create a new plot.
Choose Curve Fit > General > Edit General.
Select a fit in the current list.
Click Add and a New Fit appears below the selected fit in the list. The name of the fit can be changed by selecting 

it and editing the name in the text field.
Click Edit to display the General Curve Fit Definition dialog.
Click File in the General Curve Fit Definition dialog. A text editor appears.
Click Open.
Locate and open a curve fit definition from the Curve Fits folder. The definition and initial guesses for the 

parameters will be displayed in the editor.
Click OK  to display the curve fit equation in the General Curve Fit Definition dialog. Make sure you change the 

initial guesses, because all of the initial guesses are set equal to 1.0 by default.
Click OK until you return to the plot window. Now you can use this fit in the active plot or any new plots that are 

created. Remember to save changes to the Macros file to make the changes permanent.

 

Importing Definitions from a Macros File
The Macros folder contains a Macros file for each category of curve fit definitions. Importing one of these Macros files 
loads the curve fit definitions into the General submenu.
 
Note: If a plot is already open, you will not see the imported curve fit definitions until a new plot is created.
 
To load the definitions from a Macros file:

Choose Open, Import > New Macros, or Import > Append Macros. Open or New Macros would replace the list 
of curve fits but would not affect the default KG Macros file.

Locate and open the Macros file of interest from the Macros folder.
Create a new plot. The curve fit definitions stored in the Macros file will be listed under the General submenu.
You can now apply one of these fits to your data. Make sure you change the initial guesses, because all of the 

initial guesses are set equal to 1.0 by default.

 

Importing Definitions into the Library
The Library folder contains text files for each category of curve fit definitions. These text files can be loaded into the 
library for use in the General curve fit.
 
To load a text file into the library:
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Choose Macros > Library or Curve Fit > General > Library.
Click Open.
Locate and open the curve fit category of interest from the Library folder.
Browse through the library and make note of the shorthand reference and number of unknowns for the curve fits 

that you will be using.
Click OK.

 
You can now use these library definitions to apply a General curve fit. When entering the definition in the General Curve 
Fit Definition dialog, you can enter the shorthand reference defined in the library with the initial guesses, for example 
gaussfit(1,5,1,10). KaleidaGraph will perform the necessary substitutions before applying the fit.
 

Applying a General Curve Fit
To apply a General curve fit:

Open the plot window that will have the curve fit applied.
Choose a curve fit from the General submenu (Curve Fit menu). A Curve Fit Selections dialog appears. All 

dependent variables are listed under Column Names.
If the equation has not been entered, click Define Function to enter the equation or shorthand reference to be 

applied to the data. When you are finished, click OK to exit the dialog. If this equation will be used frequently, 
you may want to add the curve fit equation to the master curve fit list.

Click the check box for each variable to be fit.
Click OK to apply the curve fit.

Please note the following:

Pressing esc, Command+Period (Mac), or Ctrl+Period (Windows) stops the calculation of a General curve fit.
If you are fitting a lot of data or the data has sharp peaks, you may want to increase the number of Curve Fit 

Points in the Curve Fit Options dialog to improve the appearance of the curve fit line.

 

Weighting Data
The General curve fit provides an option to weight the data. When Weight Data is selected in the General Curve Fit 
Definition dialog, the data is weighted during the curve fit. These weights are taken from a specified column in the data 
window. The weights should represent the individual error values of the fitted data.
 
Each weight is used internally as: 1/(weight^2). Specifying a weight less than 1.0 for a data point increases the internal 
weight of that point and can make the total error much larger. Weight values larger than 1.0 reduce the internal weights. 
When Weight Data is not selected, a weight value of 1.0 is used for all data points.
 
When the Weight Data option is selected and you choose a variable to fit, the following dialog appears. Use this dialog to 
select the column containing the weights for your data.
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Specifying Partial Derivatives
The algorithm that KaleidaGraph uses in calculating each iteration of the General curve fit requires evaluating the partial 
derivative of the function with respect to each parameter. The General Curve Fit Definition dialog contains an option called 
Specify Partials that allows you to define the partial derivatives.
 
The biggest advantage of specifying the partial derivatives is accuracy. The curve fit algorithm uses these partial 
derivatives to direct itself where to move after each iteration to find the best solution. In general, sharp deviations in the 
surface may not be accurately approximated, so the actual partial derivatives are preferred.
 
You can choose to specify only some of the partial derivatives, but not all of them. It is better to let KaleidaGraph 
approximate the partial instead of specifying the wrong derivative. If a partial derivative is missing, KaleidaGraph 
numerically approximates that partial derivative. Most, if not all, of the curve fit equations in the Curve Fits folder 
(Examples folder) include the partial derivatives for the equation.
 
To define the partial derivatives:

Within the General Curve Fit Definition dialog, select the Specify Partials check box. The dialog will expand to 
show a text field and nine buttons for defining each of the partial derivatives.

Enter the partial derivatives by clicking the appropriate button and typing the partial in the text field.

 
The partials can also be entered all at once in the text editor that appears when clicking the File button in the General 
Curve Fit Definition dialog. The text editor will show the curve fit definition along with any partial derivatives that currently 
defined. An example is shown below:
 

m1+m2*m0^m3;m1=0;m2=1;m3=1
1
m0^m3
m2*m0^m3*ln(m0)

 
The first line represents the curve fit definition, the second line shows the partial derivative with respect to m1, the third 
line shows the partial with respect to m2, and so on. Since there are only three parameters, only three partials are 
needed.
 

Fitting Equations with Multiple Independent Variables
Through the use of the table function, KaleidaGraph can fit equations containing multiple independent variables. For 
example, to fit an equation like y = a*x + b*x2 +c, you would enter the following curve fit definition: a*x + b*table(m0, x 
col, x2 col) + c. You need to replace x col and x2 col with the appropriate column numbers from the data window (for 
example, table(m0, c0, c2)). The result of using the table function is that for each value of x, the corresponding value from 
the x2 column is evaluated as part of the curve fit.
 
Note: This function has the constraint that y col# = f(x col#) may only describe a single value function, meaning that you 

cannot have the same Y value for multiple X values.
 

Setting Limits for Curve Fit Parameters
Limits on curve fit parameters can be set in one of two ways. The first method is to use conditional testing on the 
parameter. The second method is to use the limit function from the default library.
 
Suppose that a General curve fit is being defined to fit a straight line to a set of data. The equation is of the form: a+b*x. In 
this example, you want to limit the value of b so that it is not a negative number.
 
In the General Curve Fit Definition dialog, enter either of the following definitions:
 

a + (b=(b<0) ? 0 : b) *x; a=1; b=1
a + (b=limit(0, 1000, b))*x; a=1; b=1
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In the first definition, a conditional test is performed to see if b is less than zero. If true, b is set to zero; if false, b is set 
equal to itself.
 
In the second definition, the limit function is used. The limit function requires that a lower and upper boundary be set for 
the parameter. In this case, zero and 1000 are used to bound the extremes of b.
 
Whenever a parameter is bound in a General curve fit definition, you must specify partial derivatives. Otherwise, a 
Singular Coefficient Matrix error may occur if the parameter being limited gets pegged at a bounding point for multiple 
iterations.
 
Note: Even though you put limits on the parameters, it is still possible to end up with results that are outside of the limits. 

This is because the limits are not used when KaleidaGraph attempts to improve upon your initial guesses. The 
resulting fit will show you KaleidaGraph's best guess at the final value and this value does not get passed 
through the limit function.

 

The General Curve Fit and the Macro Calculator
Calculations for the General curve fit are performed in the Macro Calculator. After performing a General curve fit, the 
memory registers in the Macro Calculator store information about the fit. The memory registers and their contents are 
listed below:
 

m0 R value
m1 - m9 The values of the parameters.
m22 Chi Square value
m23 % error term
m24 Chi Square of the last iteration.
m25 Number of iterations completed.
m26 Number of parameters in the fit.

 
Note: Almost all memory registers, alpha registers, and program space are overwritten during the execution of a General 

curve fit.
 

Displaying the Curve Fit Equation
The curve fit equation can be displayed by turning on Display Equation in the Plot menu. The results from any General, 
Linear, Polynomial, Exponential, Logarithmic, or Power curve fits are displayed in the plot window. Not only is the resulting 
equation displayed, but if any updates occur to the curve fit, the equation updates automatically.
 
Depending on the type of curve fit, the equation is displayed in a table or as a text label. The General and Polynomial 
curve fits display equations in a table because the equations for these fits can be much longer than the others. The 
appearance of the equation can be edited by double-clicking it with the Selection Arrow.
 
The numeric format of the equation can be controlled using the Equation Label Format command (Plot menu). Some of 
the options available include number format, number of significant digits, and trailing zeros.
 

Viewing Curve Fit Coefficients
To view the coefficients from the curve fit:

Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog appears with a drop-down arrow 
under View for each variable that has a curve fit applied.

Click one of the drop-down arrows and choose View Results from the pop-up menu that appears. A dialog similar 
to one of the following will be displayed containing the coefficients from the curve fit. In the case of a Linear 
curve fit, a number of additional statistics will also be displayed in the table.
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Linear Fit Results Polynomial Fit Results

To copy the coefficient table to the Clipboard, click Clipboard. This enables you to paste the results into another 
window or program.

To copy the coefficients to the Calculator, click Calculator. This enables you to use the results in a Formula Entry 
function.

Click OK until you return to the plot window.

 

Correlation Coefficients
A correlation coefficient (R or R^2) is displayed with the curve fit’s equation and coefficients. The correlation coefficient 
indicates how well the calculated curve fits the original data.
 
The R and R^2 values typically fall between 0 and 1. It is possible for a curve fit to produce a negative value for R^2. This 
occurs when the resulting curve fits the data worse than a horizontal line passing through the mean of all the Y values. 
This could be due to selecting the wrong curve fit equation or fitting data that is extremely noisy.
 
The correlation coefficient for the Power curve fit shows the correlation between the Power curve fit and the original data. 
Some other programs show the correlation between the Linear curve fit and the log of the data. That is why when you 
apply a Linear fit to the logged data in KaleidaGraph, you get the same R value as some other programs report for their 
Power fits.
 
You can choose to display the Linear Correlation Coefficient (R) or the Coefficient of Determination (R^2) as part of the 
results. The Display R^2 instead of R check box in the Curve Fit Options dialog (Curve Fit menu) controls which is 
displayed.
 
Note: If Force Line fit through zero is selected in the Curve Fit Options dialog, the R and R^2 values will not be 

calculated for a Linear curve fit.
 
The equations used to calculate R are listed below:
 
Pearson’s R (Least Squares curve fits)

 
Pearson’s R (General curve fit)

 

Parameter Errors
The General curve fit displays a column of errors to the right of the parameter values. The errors represent the standard 
error values of the parameters. These values should be read as: parameter value ± error.
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If the fit gives high error values for the parameters, it means that you could get a similar fit using a wide range of values for 
the parameters. This can happen if you have not collected enough data across a wide range of X values, if the formula is 
too complicated for your data, or if the formula has redundant parameters.
 

Chi Square Value
The General curve fit reports a Chi Square value as part of the results. This value is the sum of the squared error between 
the original data and the calculated curve fit. In general, the lower the Chi Square value, the better the fit.
 
The equation used to calculate Chi Square is listed below:
 

 
The sigma value in the equation represents the weight value assigned to the Y value (when Weight Data is turned on). A 
value of 1.0 is used if weights are not supplied.
 

Linear Curve Fit Statistics
In addition to the correlation coefficient, a number of additional statistics are calculated when performing a Linear curve fit. 
The additional statistics are not displayed with the resulting equation because of the size of the table, but they can be 
viewed by choosing View Results or Copy Parameters to Clipboard from the View pop-up menu in the Curve Fit 
Selections dialog, or by choosing Curve Fit > Export All Curve Fits.
 
The additional statistics include:

Adjusted R^2 - This value is a modification of the R^2 value that takes into account the number of parameters in 
the equation. This value will always be less than or equal to the R^2 value.

Standard Errors - These values are calculated for both the overall fit and for the individual parameters. For the 
overall fit, this value represents the standard error of the estimate. For the individual parameters, it is the 
standard error for each parameter.

F value - This value is used to determine the P value for the fit. It is the ratio of the regression mean square over 
the residual mean square.

P values- These values are calculated for both the overall fit and the individual parameters. The P value for the 
slope is usually of particular interest to determine if the slope is significantly different than zero. If the P value 
of the slope is less than 0.05, you can conclude that the slope does not equal zero.

t values - These values are used to determine the P values for the individual parameters. The t value is calculated 
by dividing the parameter value by its standard error.

Upper and lower 95% confidence limits - These values give you a general idea where the values for these 
parameters are most likely to be. You can be 95% confident that the slope and intercept fall somewhere in the 
interval formed by their corresponding parameter values and confidence limits.

 
If Force Line fit through zero is selected in the Curve Fit Options dialog, the R, R^2, adjusted R^2, and F values will not 
be calculated.
 

Exporting All Curve Fit Results
KaleidaGraph provides an Export All Curve Fits command in the Curve Fit menu that can be used to compile the results 
of any General or Least Squares curve fits and export them into a new data window. The data window will contain the 
name or type of fit, the title of the Y data column, the name of the data window, the R and R2 values, and the parameter 
values. If the plot contains any General curve fits, the Chi Square and parameter errors are included. If the plot contains 
any Linear curve fits, the adjusted R2, standard error, F value, and P value for the overall fit, as well as the standard error, 
t value, P value, and upper and lower 95% confidence limits for the slope and intercept are included.
 
The dialog below shows an example data window that appears after choosing this command.
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Copying the Parameters to the Clipboard or Calculator
To copy the parameter values to the Clipboard or Calculator:

Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog appears with a drop-down arrow 
under View for each variable that has a curve fit applied.

To copy the coefficient table to the Clipboard, click one of the drop-down arrows and choose Copy Parameters to 
Clipboard from the pop-up menu that appears. This enables you to paste the results into another window or 
program.

Note: If you paste the results into the plot window, the coefficients in the table do not change if the curve fit is 
updated. For this reason, we recommend that you use the Display Equation command instead.

 To copy the coefficients to the Calculator, click one of the drop-down arrows and choose Copy Parameters to 
Calculator from the pop-up menu that appears. This enables you to use the results in a Formula Entry 
function.

Click OK to return to the plot window.

Note: It is also possible to copy the parameters by choosing View Results from the pop-up menu and clicking the 
Clipboard or Calculator button.

 

Copying the Curve Fit Values to the Data Window
To copy the values of the curve fit line to the data window:

Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog appears with a drop-down arrow 
under View for each variable that has a curve fit applied.

Click one of the drop-down arrows and choose Copy Curve Fit to Data Window from the pop-up menu that 
appears.

Click OK to return to the plot window.

 
KaleidaGraph will append the results after any existing data in your data window. The first column will be a series of X 
values. Except for the Weighted curve fit which uses the original X values, the number of X values will be equal to the 
number of curve fit points specified in the Curve Fit Options dialog (Curve Fit menu). The second column will contain the 
values from the curve fit at each of these locations.
 
If you want to obtain the values from the curve fit at the original X values, use the Copy Predicted Values to Data 
Window command instead of Copy Curve Fit to Data Window.
 
Note: If you want to supply your own X values, you need to use Formula Entry to calculate the curve fit values.
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Copying the Residuals to the Data Window
To copy the residual values to the data window:

Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog appears with a drop-down arrow 
under View for each variable that has a curve fit applied.

Click one of the drop-down arrows and choose Copy Residuals to Data Window from the pop-up menu that 
appears.

Click OK to return to the plot window.

 
KaleidaGraph will append the residual values after any existing data in the data window. These values represent the 
difference between the original Y values and the values calculated by the curve fit.
 

Copying the Confidence Values to the Data Window
To copy the confidence values for a Linear curve fit to the data window:

Reselect Linear from the Curve Fit menu. A Curve Fit Selections dialog appears with a drop-down arrow under 
View for each variable that has a curve fit applied.

Click one of the drop-down arrows and choose Copy Confidence Values to Data Window from the pop-up menu 
that appears.

Enter the desired confidence limit in the dialog that appears and click OK.
Click OK to return to the plot window.

 
KaleidaGraph will append the lower and upper confidence values after any existing data in the data window. These values 
can then be plotted as additional variables on the plot.
 

Copying the Predicted Values to the Data Window
To copy the predicted values to the data window:

Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog appears with a drop-down arrow 
under View for each variable that has a curve fit applied.

Click one of the drop-down arrows and choose Copy Predicted Values to Data Window from the pop-up menu 
that appears.

Click OK to return to the plot window.

 
KaleidaGraph will append the predicted values after any existing data in the data window. These values represent the Y 
values from the curve fit at the original X values.
 
Note: This command will not give results for any masked or missing values.
 

Using Formula Entry to Obtain Values from a Curve Fit
The Curve Fits menu in Formula Entry contains commands that can be used to analyze the values along a fitted curve. 
These commands enable you to find values at any point on the curve, as well as calculate the residual error between the 
fitted curve and the original data.
 
Unless the curve fit is extrapolated to the axis limits, the results are only accurate if the X values lie within the original 
range of the data. If the values fall outside the data range, the results are linearly interpolated.
 
Note: Before you can get values from a curve fit, you must first create a plot and apply a curve fit to the data. Otherwise, 

an error message is displayed when you try to run the formula.
 
To calculate values from a curve fit:

Activate the data window that contains the fitted variables.
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Choose Windows > Formula Entry.
Enter the formula into the window. The formula should be of the form z = fit(x,y), where:

z is the destination column.
x is either a single value or a column containing X values.
y is the column that had the curve fit applied.
fit is replaced by the appropriate command from the Curve Fits menu of Formula Entry.

Click Run to execute the formula. The destination column is filled with the values of the curve fit at the specified X 
values.

 
Example Formulas
c2=gen(c0,c1)
c4=lin(c5,c1)
c11=smooth(c3,c4)
 
Note: This method uses the curve fit points originally calculated when the fit was applied. You may want to increase the 

number of calculated points to make the values from the fit more accurate.
 
It is also possible to use the original equation and the parameters calculated by KaleidaGraph to find the values from a fit. 
This would involve writing out the equation in Formula Entry in terms of the column number containing the X values, and 
the memory registers for the parameters.
 
Before doing this, make sure you copy the curve fit coefficients to the Calculator. This will give full precision values and 
prevent any round-off error from occurring.
 

Removing a Curve Fit
Curve fits can be removed from a plot in the same way that they are added. After applying a curve fit, a check mark 
appears next to that type of fit in the Curve Fit menu to indicate that a curve fit is applied.
 
To remove a curve fit from the plot:

From the Curve Fit menu, choose the type of curve fit to be removed. A dialog is displayed containing the list of 
variables. The check box of each fitted variable is selected.

Clear any check boxes for the fits to be removed. Clicking Deselect clears all of the check boxes at once.
Click OK to return to the plot and remove the curve fits and any associated equations.

 

Changing the Appearance of the Curve Fit Line
To change the line style, width, or color of the curve fit line:

With the plot window active, choose Plot > Variable Settings.
Select the variable to be edited.
Click the Curve Fit tab to make changes to the curve fit line.
To change the line style, select a different option from the Line Style pop-up menu.
To change the line width, select a different option from the Line Width pop-up menu.
To change the color, select a different color from the Color pop-up menu.
Click OK to return to the plot.

Note:  If you want the curve fit to use the same color as the variable, select the Link to Variable Color check box in the 
Curve Fit tab.
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Changing the Appearance of the Curve Fit Equation
Changing the Color
When you first apply a curve fit, the color of the curve fit equation matches the color of the curve fit line. For Polynomial 
and General curve fits, you can double-click the resulting table to change the color of the curve fit results. For the 
remaining curve fits, you must first choose Plot > Text Options and deselect the Link Text to Variable Color check box. 
Once this check box is cleared, you can double-click the equation and change the color of the equation.
 

Changing the Precision or Format of the Parameter Values
The precision of the values in the curve fit equation is controlled using the Equation Label Format command (Plot
menu). This command can be used to display more significant digits in the results. It can also be used to display the 
results in scientific or engineering notation.
 

Extrapolating to the Axis Limits
Curve fits are normally displayed between the minimum and maximum data values plotted on the independent axis. 
However, you can choose to extrapolate the curve fits to the axis limits. The extrapolated portion of the fit is based on the 
calculated equation.
 
Note: It is not possible to extrapolate the Smoothing fits (Smooth, Weighted, Cubic Spline, and Interpolate) because they 

cannot be represented by a single equation.
 
To extrapolate a curve fit:

Choose Curve Fit > Curve Fit Options.
Select the Extrapolate Fit to Axis Limits check box.
Click OK to return to the plot. After recalculating the curve fits, the plot is redrawn to extend the curve fits to the 

axis limits.

 

Forcing a Linear Fit Through the Origin
By default, the slope and intercept are calculated when applying a Linear curve fit. KaleidaGraph provides an option that 
forces the curve fit to pass through the origin (0,0), so that only the slope of the line is calculated.
 
To force a Linear curve fit through the origin:

Choose Curve Fit > Curve Fit Options.
Select the Force Line fit through zero check box.
Click OK to return to the plot. Any Linear curve fits will be recalculated using a Y-intercept of zero, however, the R 

or R^2 value will be suppressed in the resulting equation.

 

Increasing the Number of Curve Fit Points
Any time a curve fit is applied (except for the Weighted fit), KaleidaGraph calculates a predetermined number of points 
along the fit. These points are used to draw the curve fit and calculate values from the fit. You may find it useful to 
increase the number of curve fit points when using Formula Entry to place values from the fit into the data window. This 
increases the accuracy of these values.
 
To increase the number of curve fit points:

Choose Curve Fit > Curve Fit Options.
Enter a different value in the Curve Fit Points field. If the data has sharp transitions or a number of peaks and 

valleys, you will want to use a large number of points (1000 or more).
Click OK to return to the plot window and recalculate the fits.
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Displaying Only the Curve Fit
There may be times when you are only interested in displaying the curve fit on the plot without the original data points. 
This can be accomplished using the Variable Settings dialog, provided the plot is not a Scatter plot.
 
To display only the curve fit:

With the plot window active, choose Plot > Variable Settings. The Variable Settings dialog appears.
Select the variable to be edited.
Choose None from both the Show Markers and Line Style pop-up menus. This hides the markers and line used 

to represent the original data.
Click OK to return to the plot. The variable is hidden and only the curve fit is displayed.

 

Plotting the Confidence Bands for a Linear Curve Fit
After applying a Linear curve fit, it is possible to obtain the confidence band values for the curve fit and have them 
appended to the data window. These values can then be plotted as additional variables on the plot.
 
Note: This process works best with Line, Double Y, Double X, and Double XY plots, provided the X data values are not 

formatted as Text. For Scatter, Bar, and any plots that have a category axis, it may be necessary to plot the 
confidence bands on a separate plot and overlay them in the layout window to get the desired results.

 
To copy the confidence values for a Linear curve fit to the data window:

Reselect Linear from the Curve Fit menu. The Curve Fit Selections dialog appears with a drop-down arrow under 
View for each variable that has a curve fit applied.

Click one of the drop-down arrows and choose Copy Confidence Values to Data Window from the pop-up menu 
that appears.

Enter the desired confidence limit in the dialog that appears and click OK.
Click OK to return to the plot window.

 
The confidence values will be appended to the data window associated with this plot. If the data window is not visible, 
choose Plot > Extract Data or click the Extract button .
 
To use the original plot as a template and add the confidence bands:

Switch back over to the original plot window and choose Gallery > Template.
Make the same X and Y data selections from the original plot and click Add.
Create a new plot group using X Values for X, and the Lower CL and Upper CL columns for Y.
Click Plot.

 
A new plot will be created with the same attributes as the original, and the Linear curve fit will be applied. In addition, the 
upper and lower confidence limits will be plotted on the graph. The markers for these variables can be hidden and the 
appearance of the lines can be controlled using the Variable Settings dialog (Plot menu).
 
The plots below show an example plot that has had a Linear curve fit applied and the resulting plot after plotting the 
original data and the confidence values using a Template plot. The Variable Settings dialog was used to hide the markers 
and change the line style of the lines representing the confidence bands.
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Original plot with Linear fit       After plotting 95% confidence 
intervals

 

Overview: Working with Error Bars
Error bars illustrate the amount of error for the plotted data. Error bars normally appear as lines extending from the data 
points, with caps on either end to represent the upper and lower values of the spread.
 
The following topics explain how to add and remove error bars in your plots:

Adding Error Bars
Plotting Error Values from a Data Column
Creating Single-sided Error Bars
Adding Text Error Bars
Adding Error Arcs
Displaying Only the Cap
Changing Error Bar Attributes
Removing Error Bars
 

Adding Error Bars
To add error bars to a graph:

Select the plot that will have the error bars added.
Choose Plot > Error Bars to display the Error Bar Variables dialog. Each plotted variable is listed, with two check 

boxes preceding it.
Click one of the check boxes for the variable to which you want to add error bars. The Error Bar Settings dialog 

appears so that you can specify the options for this particular set of error bars.
Make your selections, including the color and thickness for the error bars, and click OK.
Repeat steps 3 and 4 until error bars have been selected for all of the desired variables.
Click OK to add error bars to the variables in the plot. The plot is redrawn and the error bars are displayed.

 

Plotting Error Values from a Data Column
If you do not want to use one of the available error types, you can supply your own set of error values and plot them as 
error bars.
 
To plot error values from a data column:

In the data window, create a column containing the error values.
Select the plot that will have the error bars added.
Choose Plot > Error Bars to display the Error Bar Variables dialog.
Click one of the check boxes to display the Error Bar Settings dialog.
Choose Data Column for the error type and select the name of the data column containing the error values.
Click OK to both dialogs to add the error bars to the plot.
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Creating Single-Sided Error Bars
Single-sided error bars are useful when you only want to display the bar on one side of the data point. You can choose a 
single error type and decide whether to display the positive or negative portion of the bar.
 
A special case of these error bars results when the errors are taken from a data column. Here the direction of the error bar 
is controlled by the sign of the data and whether positive or negative error types have been selected. For positive data, 
bars are displayed in the same direction as the error type. For negative data, the bars are displayed in the opposite 
direction.
 
To create single-sided error bars:

Select the plot that will have the error bars added.
Choose Plot > Error Bars to display the Error Bar Variables dialog.
Click one of the check boxes to display the Error Bar Settings dialog.
Clear the Link Error Bars check box.
Choose None for either the positive or negative error type.
Choose the type of error to be displayed for the other portion of the bar.
Click OK to both dialogs to add the error bars to the plot. The following plot contains single-sided error bars.

 

Adding Text Error Bars
Error bars can also be used to annotate specific markers or columns in the plot with text labels. When a Text data column 
is used for the error type, the data in the column is displayed as text labels at the corresponding points on the plot. Only 
data points that have errors associated with them have text labels displayed.
 
The direction of the labels is the same as the error type selected (horizontal for X Err or vertical for Y Err). If the Center 
Text check box is selected, the labels are centered on the markers. Otherwise, they are justified and placed on the side of 
the marker which had the error selected. The text labels can be moved individually with the Text tool or as a group with the 
Selection Arrow.
 
Note: Text error bars use the same default attributes as value labels. These labels can also include subscripts or 

superscripts.
 
To add text error bars to a plot:

In the data window, place the data to be displayed as labels into a Text column.
Select the plot that will have the error bars added.
Choose Plot > Error Bars to display the Error Bar Variables dialog.
Click one of the check boxes to display the Error Bar Settings dialog.
Clear the Link Error Bars check box.
Choose None for one of the portions of the bar. For the other, choose Data Column and select the text column 

containing the labels.
To center the labels on the marker, select the Center Text check box. Otherwise, the labels are justified.
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Click OK to both dialogs to add the labels to the plot. The following plot has text error bars added to some of the 
markers.

 
 

Adding Error Arcs
Error arcs can be displayed instead of error bars. This is done by selecting the Draw Error Arc check box in the Error Bar 
Settings dialog. An arc is displayed when one of the error types is set to None. If both positive and negative errors are 
selected for X Err and Y Err, an ellipse is displayed.
 
All four quadrants of the ellipse can be controlled independently. The vertical distance is determined by the Y Err and the 
horizontal distance is determined by the X Err. This gives you a number of possibilities for displaying error arcs and 
ellipses.
 
To add error arcs:

Select the plot that will have the error arcs added.
Choose Plot > Error Bars to display the Error Bar Variables dialog.
Click the X Err check box for one of the variables to display the Error Bar Settings dialog.
Select the Draw Error Arc check box.
Choose the positive and negative error types. Then, click OK.
Click the Y Err check box for that same variable to define the vertical dimension of the arc. Repeat steps 4 and 5 

to set up all of the errors of interest.
Click OK to add the error arcs to the plot. The following plot has error arcs added.

 

Displaying Only the Cap
You have the option to remove the line that connects the data point with the error cap. This is accomplished by selecting 
the Draw Cap Only check box in the Error Bar Settings dialog.
 
This option can help remove a number of unnecessary lines from the plot and make it easier to see the data. This feature 
is useful when the Standard Deviation error type is selected. Because all of the error bars are drawn from the mean, the 
lines connecting the point and the cap are not needed. By removing the lines and adjusting the length of the caps, you can 
have a dashed or solid error line across the entire plot.
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To display only the error cap:

Select the plot that will have the error bars added.
Choose Plot > Error Bars to display the Error Bar Variables dialog.
Click one of the check boxes to display the Error Bar Settings dialog.
Select the Draw Cap Only check box.
Choose the positive and negative error types.
Click OK to both dialogs to add the error bars to the plot. The following plot has standard deviation error bars 

applied and is set to only display the caps.

Changing Error Bar Attributes
Changing the Color or Thickness
To change the color or thickness of error bars:

Choose Plot > Error Bars to display the Error Bar Variables dialog.
Deselect and reselect the check box for the error bars to be edited. This will display the Error Bar Settings dialog.
Choose the desired color and thickness using the Color and Width pop-up menus.
Click OK to both dialogs to return to the plot.

Note: Depending on the thickness selected, you may not notice the change on the screen; however, there will be a 
difference when the plot is printed. It is also possible to adjust the thickness using the Line Thickness setting in 
the Plot Options dialog.

 

Changing the Cap Length
To change the cap length of error bars:

Choose Plot > Plot Options.
Click General.
Edit the value in the Error Bar Length field. A cap is not displayed if zero is entered in this field.
Click OK to return to the plot.

 

Removing Error Bars
You can easily remove error bars from individual variables or from all the variables at once.
 
To remove error bars:

Choose Plot > Error Bars to display the Error Bar Variables dialog.
Clear the check boxes of the error bars to be removed. Clicking Deselect clear all of the check boxes at once.
Click OK to return to the plot window. The plot is redrawn without any error bars.
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Opening Plots
To open a saved plot:

Choose File > Open.
Locate the name of the plot to be opened and double-click it. Multiple files can be opened at once by pressing 

Shift, Command (Mac), or Ctrl (Windows) and clicking the file name.

 
The plot will open into a new plot window. To view the data associated with the plot, it needs to be extracted. This is 
accomplished by choosing Plot > Extract Data or clicking the Extract button  in the plot window. Once the data is 
extracted, it can be modified, saved, or used to create new plots.
 
If the plot was saved without data, you can print the plot, copy it to the Clipboard, or reposition it once it is loaded back into 
KaleidaGraph. Labels can also be added or modified. However, because the data was not saved with the plot, it cannot be 
edited in a manner that requires it to be rebuilt from the original data. This includes resizing axes, scaling to a new set of 
limits, editing markers, and modifying error bars or curve fits.
 

Importing Images from Other Programs
KaleidaGraph is able to insert a variety of images created in other programs. When you import a graphic file, the picture is 
placed in the active plot or layout window. You cannot edit any parts of the imported picture. However, you can move and 
resize the image, and modify its frame.
 
To import an image that was exported as a file:

Make the desired plot or layout window the active window.
Choose File > Open.
Locate and open the file to be imported. The imported image appears as an object in the plot or layout window, 

with four object handles around it.

 
To paste a graphic from the Clipboard:

Make the desired plot or layout window the active window.
Choose Edit > Paste. The graphic appears as an object in the plot or layout window, with four object handles 

around it

 
To resize an imported graphic:

Select the object to be resized.
Drag any one of the handles to resize the image and maintain the aspect ratio.

Note: To resize the object proportionally about its center, press Option (Mac) or Alt (Windows) when dragging the handle. 
By pressing Shift as you drag, you can resize the image without maintaining the aspect ratio.

 

Printing Plots
To print a plot:

Make sure that the plot window to be printed is active.
To change page options, such as page orientation or paper size, use the Page Setup command from the File

menu.
Choose File > Print.
Review your printing options and click Print.

Note: The options in the Page Setup and Print dialogs vary depending on the printer and operating system.
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Saving Plots
To save a plot with its data:

Make sure the plot to be saved is active.
Choose Save Graph or Save Graph As from the File menu.
Verify KaleidaGraph Plot is selected from the pop-up menu in the Save dialog.
Specify the location and file name for the file and click Save.

Note: If the plot has not been saved and you close the data window by pressing Shift and either clicking the close box or 
choosing File > Close/No Save, the plot will be saved without the data.

 

Saving a Plot without Data
It is possible to save a plot without the data used to create it. This can save disk space if you create plots from large data 
sets and do not want to save the data as part of the file.
 
Once a plot without data is loaded back into KaleidaGraph, you can print it, copy it to the Clipboard, or reposition it. Labels 
can also be added or modified. However, because the data was not saved with the plot, it cannot be edited in a manner 
that requires it to be rebuilt from the original data. This includes resizing axes, scaling to a new set of limits, editing 
markers, and modifying error bars or curve fits.
 
To save a plot without the data:

Make sure the plot to be saved is active.
Choose File > Save Graph As.
Select KaleidaGraph Picture from the pop-up menu in the Save dialog.
Specify the location and file name for the file and click Save.

 

File Formats Available in KaleidaGraph
KaleidaGraph can export the plots in a variety of formats. The file formats currently supported are listed below with a 
description of each:

Windows BMP - The Windows BMP format can be used to take images into other programs. This format produces 
raster images that cannot be edited.

JPEG - The JPEG format is often used for web images. This format produces raster images that cannot be edited.
PNG - The PNG format is often used for web images. This format produces raster images that cannot be edited.
TIFF - The TIFF format is often used for printed publications. This format produces raster images that cannot be 

edited.
SVG - The SVG format is often used for printed publications. These vector images can be opened in other 

applications for further editing.
PDF - The PDF format is often used for printed publications. These vector images can be opened in other 

applications for further editing.
Windows Metafile - This format is used for exporting graphics on the Windows platform. These vector images can 

be opened in other applications for further editing.
Enhanced Metafile - This format is used for exporting graphics on the Windows platform. If you copy a plot to the 

Clipboard in the Windows version, an enhanced Metafile image is placed on the Clipboard. These vector 
images can be opened in other applications for further editing.

Device Independent Bitmap - This format is used for copying graphics on the Windows platform. If you copy a 
plot to the Clipboard in the Windows version, a Device Independent Bitmap image is placed on the Clipboard 
and can be pasted using the Paste Special command. These images cannot be edited.

 
The resolution gets specified when exporting the image. The images can either be saved at a multiple of the screen 
resolution (72 dpi) or at a specific dpi. For example, setting a Resolution of 8X Screen produces a 576 dpi image.
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Copying Plots to the Clipboard
The easiest way to export the plot is to use the Copy Graph command (Edit menu). TIFF and PDF (Mac) or 
enhanced Metafile and Device Independent Bitmap (Windows) images are copied to the Clipboard that can be pasted into 
another program.
 
The Copy Graph command is available when a plot window is active and does not contain a selection. This command 
copies the entire plot to the Clipboard. You can then paste the image into another plot window or into a different program.
 
To copy a plot to the Clipboard:

Make sure the plot window to be exported is active.
Choose Edit > Copy Graph. The Export Settings dialog, shown below, is displayed to set the size and resolution 

of the exported file.

 

 

Make your selections in the dialog and click OK.
The entire plot is now on the Clipboard and can be inserted into another program using the Paste or Paste 

Special command. Use the Paste Special command to select which format is pasted.

 
Note: Copying the graph by using the Select All command followed by the Copy Selection command will not give you 

the same resolution as using the Copy Graph command. The Copy Selection command will yield a 72 dpi image 
whereas the Copy Graph command can produce an image with a resolution between 72 and 1400 dpi.

 

Exporting Images in a Specific File Format
KaleidaGraph is able to save plots in a variety of different formats for inclusion in another program. If one of these files is 
loaded into KaleidaGraph, it is treated as a picture. You cannot edit any parts of the picture. However, you can move and 
resize the image within the plot or layout window.
 
To export a plot in a specific file format:

Make sure the plot window to be exported is active.
Choose File > Save Graph As and select the desired file format from the pop-up menu in the Save dialog.
Specify the location and file name for the file and click Save. The Export Settings dialog, similar to the one 

below, is displayed to set the size and resolution of the exported file. The options available in the dialog will 
vary depending on which format you are exporting.
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Make your selections in the dialog and click OK to export the file. This file can then be imported into another 
program.

 
Note: If the plot has been assigned a transparent background, this can be maintained if you copy the plot to the Clipboard 

or export it in a PNG or TIFF format. However if you save it in one of the other formats, the transparent 
background will be lost.

 

Controlling the Size, Resolution, and Color Depth of Exported Images
Setting the Size of the Exported Image
Images can either be exported at the same size as the original file or can be a fixed size. To make the resulting image a 
different size, you need to make use of the Fix Size setting when exporting the image. After clicking Fix Size, you need to 
click either the Axis or Frame button and enter the new axis or frame dimension in the X or Y field. To maintain the aspect 
ratio and prevent the plot from being distorted, enter auto for the other dimension.
 
For example, if the original plot has a frame size of 5" x 7" and you want to export it at 50% of the original size, click Fix 
Size, click Frame, enter 2.5 for the X dimension of the Frame, and enter auto for the Y dimension.
 

Setting the Resolution of the Exported Image
The images can either be copied or saved at a multiple of the screen resolution (72 dpi) or at a specific dpi. Setting the 
Resolution to 8X Screen would produce a 576 dpi image. By choosing other DPI from the Resolution pop-up menu, it is 
possible to get an image with a resolution between 72 and 1400 dpi.
 

Exporting Grayscale Images
KaleidaGraph allows Windows BMP, JPEG, PNG, and TIFF images to be saved as grayscale images. When exporting 
one of these formats, deselect the Color check box to obtain a grayscale version of the image.
 

Exporting Tips
The easiest way to export the plot is to use the Copy Graph command. TIFF and PDF (Mac) or 
enhanced Metafile and Device Independent Bitmap (Windows) images are copied to the Clipboard that can be pasted into 
another program.
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Copying the graph by using the Select All command followed by the Copy Selection command will not give you the 
same resolution as using the Copy Graph command. The Copy Selection command will yield a 72 dpi image whereas the 
Copy Graph command can produce an image with a resolution between 72 and 1400 dpi.
 
If you export a plot into other program and get a low resolution image:

When copying the plot, make sure you are using Copy Graph and not Copy Selection.
When exporting the image, set the Resolution to 4X Screen or higher. 4X Screen will give a 288 dpi image; 8X 

Screen will give a 576 dpi image. You can also choose other DPI and set a resolution between 72 and 1400 
dpi.

 
If you save the plot in a vector format, you can often edit the resulting image in another program to change colors, fonts, 
line styles, line thicknesses, and so on of specific pieces of the image. Raster images cannot be broken apart to make 
these types of changes. It is usually necessary to take raster images into a drawing program to make any changes to the 
image.
 
If some of the lines seem to disappear or become too faint:

Use solid grid lines instead of dashed, since dashed grid lines may disappear.
Increase the thickness settings in the Axis Options and Plot Options dialogs. For pop-up menus, go above Hairline 

(H); for fields start at 200%. This will prevent the ticks, grids, lines, and markers from becoming very faint or 
disappearing altogether. The Line Thickness setting in Plot Options will make variable lines, curve fit lines, 
and error bars thicker. You may not notice a change on the screen, but you will when the plot is printed.

 
If the plot needs to be a specific size, it is usually best to use the Set Plot Size dialog to set the plot to the desired size. If 
that would make editing the plot too difficult, work in a multiple of the final size (for example, twice as large as the final 
size). This will help prevent problems that could occur when resizing plots in another program.
 
If you notice problems with subscripts and superscripts when a plot is exported into another program and resized:

Export the plot from KaleidaGraph at the desired size so that KaleidaGraph performs the resizing and not the 
destination application. Either use the Set Plot Size command to change the size or use the Fix Size option 
when exporting.

 

Embedding an OLE Object
Through the use of Object Linking and Embedding (OLE), it is possible to embed a KaleidaGraph for Windows plot into 
another Windows program. The embedded plot, called an object, becomes part of the source document. The object 
maintains a link with KaleidaGraph, allowing you to double-click the object and make changes to the plot from within 
KaleidaGraph. When you are finished modifying the object, the changes are reflected in the source document.
 
Note: KaleidaGraph acts only as an OLE server, not a client. If you have older versions of KaleidaGraph installed you may 

want to uninstall them if you make use of OLE. If KaleidaGraph is not running, double-clicking an OLE object 
could open the plot in an older version.

 
There are two methods available for embedding a KaleidaGraph plot. They are:
 

Copying and Pasting an OLE Object
Creating and Embedding a New OLE Object
 

Copying and Pasting an OLE Object
To embed a KaleidaGraph plot into a Windows document via the Clipboard:

Make sure the plot that you want to export is active.
Choose Edit > Copy OLE Object to display the dialog below.
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Make your selections in the dialog and click OK.
Switch to the destination program and choose Paste. The plot is inserted into the document as an embedded 

object.

 

Creating and Embedding a New OLE Object
To create and embed a new KaleidaGraph plot into a Windows document:

Open the document that will receive the embedded plot.
Choose Insert > Object > Create New within your program. The name and location of this command may vary 

from one program to another.
Select KaleidaGraph Plot from the list of object types and click OK. This opens KaleidaGraph and displays a 

blank plot window.
Import or open the data to be plotted.
Switch back to the blank plot window and choose the type of plot you want to create from the Gallery menu.
Make your variable selections and click Replot.
When you are finished, choose Update or Update and Return from the File menu to embed the plot in the 

document.

Note:  If the plot has already been created, it can be inserted by choosing Create from File in step 2 above and clicking 
Browse to locate the plot.

 

Editing OLE Objects
To edit an embedded OLE object:

Open the Windows document that contains the embedded KaleidaGraph plot.
Double-click the embedded image to open the plot in KaleidaGraph.
Make the necessary changes to the plot. The OLE Options command (Edit menu) can also be used to change 

the settings for the embedded object.
When you are finished, choose Update or Update and Return from the File menu. You can also click the close 

box to close the plot and update the object.

Note  If you have older versions of KaleidaGraph installed you may want to uninstall them if you make use of OLE. If 
KaleidaGraph is not running, double-clicking an OLE object could open the plot in an older version.
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Displaying the Layout Window
The layout window can be displayed using the Show Layout (Windows menu) and New Layout (File menu) commands. 
The Show Layout command lists any layouts that have been opened or created since the program was started. This 
submenu may contain an item called KG Layout, which displays the default Layout file (if one has been saved).
 
The New Layout command creates an empty layout window. If any changes were made to the current layout, a dialog 
asks if you want to save the changes before displaying the new layout window.
 
When the layout window is active, a Layout menu is added to the menu bar. You can use the commands in this menu to 
place plots in the layout, arrange the plots, and add a background or frame to the layout.
 

Placing Plots in the Layout Window
You can place up to 50 plots in the layout window.
 
To add a plot to the layout window:

Choose Layout > Select Plot. This command displays a submenu that lists the plots that are currently open, from 
newest to oldest.

Select a plot from the submenu that appears. The selected plot is placed in a cell in the layout window.

Note: The plot’s name is displayed in the lower-left corner of the plot in the layout. This is for identification purposes only; 
it is not included when you export the layout.

 
As plots are added to the layout window, KaleidaGraph maintains a link between the cell in the layout and the position of 
the plot in the Select Plot submenu. If a particular cell contains the first plot in the list, opening or creating another plot will 
cause the cell to display this new plot.
 
Any time you open, create, or close a plot, it is possible for the plots in the layout to change positions because the location 
of the plots in the Select Plot submenu has changed. For this reason, it is best if you open or create all of your plots 
before arranging them in the layout window.
 
It is also possible to use empty cells to organize the layout. These can be added to the layout window by choosing Layout
> New Position. The empty cells can be replaced at a later time by clicking the cell and choosing a plot from the Select 
Plot submenu.
 

Setting Plot Size and Position
There are two methods available for setting the size and position of plots in the layout window. The first method is to 
manually drag the plot to resize it or move it to a new position. The second method is to double-click the plot to specify the 
size and position via the Plot Size dialog.
 

Manually Resizing the Plot
The plot size and position can be set directly in the layout window by clicking a plot and dragging. When resizing a plot, 
the Axis and Frame buttons in the Plot Size dialog determine whether to resize relative to the axis or the frame. The Plot 
Size dialog is displayed when you double-click a plot in the layout window.
 
When a plot is selected, object handles appear in one of two places. When Axis is selected in the Plot Size dialog, object 
handles are displayed at the end of each axis. When Frame is selected, object handles are placed at the corners of the 
plot frame.
 
To manually resize the plot, drag one of the object handles. As you drag, a dialog containing the current plot dimensions 
and axis origin (offset) is displayed in the upper-left corner of the layout window. The aspect ratio of the plot is maintained 
as you resize the plot. By pressing Shift as you drag, it is possible to resize the plot without maintaining the aspect ratio.
 

Using the Plot Size Dialog
The size and position of the plots in the layout can also be controlled using the Plot Size dialog. The Plot Size dialog is 
displayed whenever you double-click a plot in the layout window. The settings in this dialog determine the size and 
location of the plot, as well as whether or not the aspect ratio of the plot is maintained.
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Arranging Plots
The Arrange Layout command (Layout menu) provides a fast and easy way to take the plots and organize them in the 
layout window. The plots are arranged in the order they were added to the layout window, starting at the top of the page 
and working down from left to right.
 
Note: This command can only be used to arrange plots in the layout window. It does not have any affect on any other 

objects in the layout window.
 
To arrange the plots in the layout window:

Place all of the plots in the layout window.
Choose Layout > Arrange Layout.
Enter the desired number of rows and columns into the Arrange Layout dialog. You can also specify the size of the 

margin around each of the positions in the layout.
Click OK. The layout window is divided equally, based on the number of rows and columns entered. The plots are 

automatically resized and placed into the positions.

 

Overlaying Plots
You can use the layout window to position two or more plots on top of each other. These plots must have the same frame 
and axis dimensions, and any plots being placed on top of another must have a transparent interior and background color. 
This is useful if you need to display a single plot with more than the maximum number of variables allowed or if you want 
to combine two different types of plots. By creating separate plots, you can overlay them to get the appearance of a single 
plot.
 
To overlay two or more plots:

Open or create all of the plots that you need to overlay. The plots must be identical in size for them to overlay 
properly. To ensure that the plots are of equal size, either choose Plot > Define Layout after creating the first 
plot or use the first plot as a template for creating any remaining plots. You can also use the Set Plot Size
command (Plot menu) for each plot to make sure the origin, axis, and frame settings are identical.

Remove the text labels from all but one of the plots.
Switch to the layout window.
Use the Select Plot command (Layout menu) to import the plots into the layout window.
Provided that all of the plots are identical in size, you can use the Align tool to overlay the plots. This is done by 

selecting the plots and using the Align tool to align either the edges or centers in both the horizontal and 
vertical directions.

The layout window can then be printed, copied to the Clipboard, or saved in a variety of file formats. You can also 
save this layout for future use.

 

Adding a Background or Border
A background or border can be added to the layout window or to the plots in the layout window. The following sections 
explain how to add backgrounds and borders in the layout window.
 

Adding to the Layout Window
A background or border can be added to the layout window using the Set Background command in the Layout menu. 
This allows you to select a fill pattern for any part of the page not covered by a plot. It also lets you have a frame around 
the entire layout.
 
Note: Text labels may or may not have the background displayed behind the text. The Erase Background command (in 

the Format menu of the Edit String dialog) controls what happens. When this command is turned on, the 
background is erased.

 
To add a background or border to the layout:
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Choose Layout > Set Background.
Make your selections by clicking the appropriate section of each icon. The background is controlled by the Color 

icon and the Fill Pattern portion of the Pattern icon. The border is controlled by the Style icon and the Pen 
Pattern portion of the Pattern icon.

Click OK to exit the Set Background dialog and apply the background or border to the layout window.

Adding to a Plot in the Layout
It is possible for each plot in the layout window to have its own background and border. This is accomplished by selecting 
the plot in the layout and using the Color, Pattern, and Style icons from the bottom of the toolbox.
 
The background is controlled by the Color icon and the Fill Pattern portion of the Pattern icon. If a background color is 
specified in the original plot window, these settings do not have any affect on the appearance of the plot. The border is 
controlled by the Style icon and the Pen Pattern portion of the Pattern icon.
 
Note: Any background applied to the layout is also applied to any plots which have None selected for the Fill Pattern and 

do not have a background color selected in the original plot window.
 

Copying Layouts
You can copy a layout to the Clipboard for use in another program.
 
To export a layout to the Clipboard:

Make sure the layout window to be exported is active.
Choose Edit > Copy Layout. The Export Settings dialog is displayed to set the size and resolution of the exported 

image.
Make your selections in the dialog and click OK.
TIFF and PDF (Mac) or enhanced Metafile and Device Independent Bitmap (Windows) images of the layout are 

copied to the Clipboard that can be pasted into another program.

 
Note: If the Copy Selection command is displayed in the Edit menu, something is currently selected in the layout window. 

Do not use this command because it causes the image to have lower resolution.
 
 

Exporting the Layout in a Specific File Format
KaleidaGraph is able to save layouts in a variety of different formats for inclusion in another program. If one of these files 
is loaded into KaleidaGraph, it is treated as a picture. You cannot edit any parts of the picture. However, you can move 
and resize the image within the plot or layout window.
 
To export a layout for use in another application:

Make sure the layout window to be exported is active.
Choose File > Save Layout As and select the desired file format from the pop-up menu in the Save dialog.
Specify the location and file name for the file and click Save The Export Settings dialog is displayed to set the size 

and resolution of the exported file. The options available in the dialog will vary depending on which format you 
select.

Make your selections in the dialog and click OK to export the file. This file can then be imported into another 
program.

 
Note: If the plots or layout have been assigned a transparent background, this can be maintained if you copy the plot to 

the Clipboard or export in a PNG or TIFF format.  However if you save it in one of the other formats, the 
transparent background will be lost.
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Printing Layouts
To print a layout:

Make sure that the layout window to be printed is active.
To change page options, such as page orientation or paper size, use the Page Setup command (File menu).
Choose File > Print.
Review your printing options and click Print.

Note: The options in the Page Setup and Print dialogs vary depending on the printer and operating system.
 

Types of Layout Files
KaleidaGraph can save two types of Layout files: basic Layout files and Group Layout files. The only difference between 
the two types of files is how they handle the plots within the layout window.
 
A basic Layout file stores the following information: size and position of the cells, the contents and location of any text 
labels or objects, and the background settings. The plots are not saved as part of the layout file; however, the cells are 
assigned position numbers based on the order of the plots in the Select Plot submenu. For example, if a cell contains the 
second plot in the Select Plot submenu, the next time you open this layout file, the second plot in the Select Plot
submenu will automatically be loaded into this cell.
 
Group Layout files provide the added benefit of saving a copy of each plot embedded within the Layout file. This allows 
you to organize your plots, save a Group Layout file, and open a single file at a later date to make changes to any of the 
original plots.
 

Opening Saved Layout Files
You can use the Open command (File menu) to open any Layout files that have been saved previously. The type of 
Layout file that you open (basic or group layout file) determines how it is handled.
 
If you open a basic Layout file, KaleidaGraph will load any open plots into the layout window, using the same procedure 
that was used when the layout was created originally. Each of the cells are assigned position numbers based on the order 
of the plots in the Select Plot submenu. To see the position numbers for each of the cells, open the layout file before 
opening or creating any plots. Any cells that show Position #0 are empty cells and will not automatically have plots loaded 
into them.
 
If you open a Group Layout file, KaleidaGraph will display the layout window and the plots that were saved as part of the 
layout file. Each of the plots is opened at the same time, although they are hidden by default. You can either click the 
Extract button  in the upper-right corner of the layout window or use the Show Plot command (Windows menu) to 
display the original plots.
 

Saving the Layout File
Once you have created a layout, you can save the layout for future use. You have the choice of saving a basic Layout file 
(which does not include the plots) or a Group Layout file (which saves a copy of each plot as part of the layout file).
 
To save a layout:

With the desired layout as the active window, choose File > Save Layout As.
To save a basic Layout file, verify that KaleidaGraph Layout is currently selected from the pop-up menu in the 

Save dialog. This will save the size and position of the cells, the contents and location of any text labels or 
objects, and the background settings. It will not save any of the plots as part of the Layout file.

To save a Group Layout file, verify that KaleidaGraph Group Layout is currently selected from the pop-up menu 
in the Save dialog. This will save the plot files as part of the Layout file.

Give the file an appropriate name and click Save.

 



Working with the Layout Window

Page 195

•

•

•

•
•

1.
2.
3.
4.

Modifying Plots in a Group Layout File
When you open a Group Layout file, the plots used in the layout are opened at the same time, although they are hidden 
by default. The following methods can be used to display the individual plot windows for further editing:

Click the Extract button  in the upper-right corner of the layout window. The plots used in the layout will be 
brought to the front.

Use the Show Plot command (Windows menu) to bring an individual plot to the front.

 

Changing the Magnification of the Layout Window
KaleidaGraph provides several options to change the magnification level of the layout window. The magnification setting 

 is located to the left of the horizontal scroll bar in the layout window. Alternately, you can use the Set Plot 
View command (Plot menu).
 
To change the magnification of the layout window:

Right-click the magnification setting and choose the desired magnification level from the pop-up menu. The 
available percentages range from 25 to 800%.

Type a value in the field to enter a specific magnification level. The available percentages range from 25 to 1000%.
Click the up or down controls to adjust the magnification levels in 25% increments.

 

Displaying Rulers and Grids in the Layout Window
To turn the rulers and grids on and off in the layout window:

With the layout window active, choose Plot > Rulers & Grids.
Click the appropriate check boxes to display the rulers, grids, or both.
Select the proper units that you want to use.
Click OK to return to the layout window.

The Preferences dialog contains Show plot rulers and Show plot grids options that can be used to globally show these 
for new plots.
 

Switching Between Layouts
KaleidaGraph provides a Show Layout command in the Windows menu that can be used to switch between the default 
KG Layout and any other layouts that have been opened or created since the program was started. The active layout is 
listed first in the submenu. Older layouts are listed below the dotted line. The Clear History command in the submenu can 
be used to remove the files from the list.
 

Deleting Items from the Layout
You can delete any unwanted items from the layout window in one of two ways. You can either select the item and press 
Delete (Mac) or Backspace (Windows), or select the Eraser from the toolbox and click the unwanted item. These 
methods work for plots or any other objects you want to delete.





Working with Scripts

Page 197

1.

2.
3.

4.

Using Plot Scripts
One way to generate similar plots is the Plot Script command (Windows menu). This feature enables you to choose any 
plot type or an existing plot and use it as a template for creating multiple plots at once.
 
The script feature is intended for the user who has a Template plot and wants to plot different data sets and view the 
resulting curves. Even if you only need to generate a simple plot, but you generate it all of the time with different data, you 
will find plot scripts very useful.
 
The advantage of a plot script over a Template plot is that a script can generate multiple plots. Also, you can control 
legend descriptions and plot titles using a script. In a Template plot, the legend descriptions come from the column names 
of the plotted variables and the plot title remains unchanged.
 
The following topics discuss the use of plot scripts:

Creating a Plot Script
Setting Titles and Legends
Using Pattern Recognition to Create New Groups
Pointing Groups to Different Data Windows
Exporting Plots Automatically
Saving and Loading Scripts
 

Creating a Plot Script
The Plot Script command is similar to the Template plot but provides you with more options for creating plots. Using plot 
scripts, you can create multiple plots at once, automatically print or save the plots, and set the plot title or legend for each 
plot.
 
Choosing Windows > Plot Script displays the Plot Script window. This window is used to make your selections for the 
current script. The script selections include: plot type, variable selections, plot titles, legend text, auto print, and auto save 
options.
 
To create a plot script:

Choose Windows > Plot Script to display the Plot Script window, shown below.

 

 

If groups are already listed in this window, click Clear All to remove the groups and start a new script.
Using the Graphic Template pop-up menu, choose either a Gallery plot type or an existing plot to use as a 

template. Only one graphic template can be used in a script.
Click Add. A Variable Selection dialog is displayed.
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Select the variables to be plotted.
Click OK. Group 1 will be created in the Plot Script window. Continue using the Add button to create new groups. 

Each group generates a separate plot.
When you are finished creating groups, click Run to execute the script.

Note: If you exceed the maximum number of open plot windows while executing a script, the situation is handled based 
on the current state of the Automatically dispose of old plots option in the General tab of the Preferences 
dialog. When this check box is selected, the oldest plot is discarded, without asking for your approval.

 

Setting Titles and Legends
By default, the titles are the same as the template and the legend comes from the column names of the plotted variables. 
You can set the plot titles and legends for each plot being created using the Set Titles and Set Legends buttons in the 
Plot Script window. Clicking either of these buttons displays a text editor.
 
Each line in the editor corresponds to a different plot. Plot titles are entered on separate lines, followed by a return. If you 
choose to set the titles, you must set them for all of the plots. If a specific plot is not to have a title, create a blank line in 
the editor by pressing Return (Mac) or Enter (Windows). Each title appears to the right of the corresponding data group in 
the Plot Script window.
 
Note: Multi-line titles can be created using the \r characters. Any text that follows \r will be placed on a separate line.
 
To set the plot titles for a script:

Click Set Titles.
Enter a plot title for each group. An example is shown below.

 

 

Click OK. The titles are listed to the right of the groups.

 
The legend information for each plot is also placed on separate lines, followed by a return. To indicate that the labels 
belong to the same plot, each legend label should be separated with either a comma or a tab. For Double Y, Double XY, 
Double Y Bar, and Double Y Column plots, enter the labels for the Y1 legend followed by the Y2 labels (on the same line). 
All labels prior to a return belong to the same plot. Only use the Return (Mac) or Enter (Windows) key to separate legend 
titles associated with different plots.
 
Note: Multi-line legend labels can be created using the \r characters. Any text that follows \r will be placed on a separate 

line.
 
To set the legends for a script:

Click Set Legends.
Enter the legend titles. An example is shown below.
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Click OK.

 

Using Pattern Recognition to Create New Groups
The Plot Script window includes a pattern recognition feature. Once you add a third data group, KaleidaGraph tries to 
identify a pattern in the way you are setting up the groups. If KaleidaGraph’s selections are correct, you can replicate the 
pattern throughout the data window by clicking Repeat instead of OK. KaleidaGraph continues the selection pattern 
across all of the columns in your data window, and creates the groups automatically.
 
Note: The pattern recognition feature only works across the columns of a data window or across the columns of a set of 

data windows. KaleidaGraph cannot identify a plotting pattern that jumps from one data window to another.
 

Pointing Groups to Different Data Windows
The Data Windows pop-up menu can be used to select a different data window for each individual set of variable 
selections. This pop-up menu contains up to 99 X Set menu items (X - X99). A set is defined as an X variable and its 
associated Y variables (such as: X, Y1, Y2). The number of X Set menu items depends on the number of independent 
variables selected for the current group.
 
The sets are listed in the pop-up menu in the order they were created. Selecting one of the sets displays a submenu 
containing a list of the open data windows. They are listed in the order they are stacked on the screen, from front to back. 
The data window currently associated with a particular set is preceded by a check mark. The dialog below shows the Plot 
Script window with the Data Windows pop-up menu and the X Set submenu.
 

 
To change the data window associated with a particular set:

Click the group to be edited.
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Click the Data Windows pop-up menu, select an X Set, and specify a different data window. The selected data 
window is now used for that particular set of variable selections.

Note: The only other way to change the data window referenced by a set is to use the Change button after selecting each 
individual group. This method must be used to select different columns for plotting.

 

Exporting Plots Automatically
You can automatically print or save script-generated plots using the Auto Print and Auto Save options in the Plot Script 
window.
 
To automatically print plots:

Click the Auto Print check box.
Choose either Print Graphics or Print Layout from the pop-up menu immediately below Auto Print.
Execute the script by clicking Run. The plots are automatically printed.

 
To automatically save plots:

Click the Auto Save check box.
Choose the type of graphic file to be created from the pop-up menu immediately below Auto Save.
Enter a prefix to be used for the saved plot files. By default, the naming convention uses the word Prefix followed 

by an underscore (_) and a number.
Click Run to execute the script. KaleidaGraph displays a dialog allowing you to specify a location for the saved 

plots.

 

Saving and Loading Scripts
Once you have created a script, you can save it by choosing File > Save Script As. If you used an existing plot for the 
Graphic Template, it is saved as part of the script file.
 
A default Script file is automatically opened each time KaleidaGraph is started. This way you can save your plot script and 
have it opened the next time you use the program.
 
Custom Script files can be opened at any time from within KaleidaGraph by choosing File > Open. The Plot Script window 
changes to reflect the contents of the new Script file and opens the template plot if one was used.
 

Creating a Formula Script
KaleidaGraph supports an internal set of scripting commands in the Posted Note of Formula Entry. Using these 
commands, you can automate the process of opening and closing data windows, creating plots, and exporting plots to a 
printer, the Clipboard, or file. Scripts are particularly useful if you repeatedly open the same types of text files, perform the 
same set of data manipulations, and generate the same types of plots.
 
Formula scripts are similar to multi-line formulas. The main difference is that there are a number of additional commands 
that are supported by KaleidaGraph. These commands enable you to open data files, create plots, print plots, and export 
the plots in a variety of formats.
 
To enter and execute a formula script:

Verify that a data window is already open. The script cannot execute unless a data window is available.
Choose Windows > Formula Entry.

Click the Posted Note button  to display the text editor.
Enter the formula script into the Posted Note.
When you are finished entering the script, click Run to execute the script in the Posted Note.

If a syntax error is found during the execution of the script, a dialog similar to the following is displayed to show the portion 
of the script that triggered the error.
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You can save the script by clicking Save As in the Posted Note dialog. Once the script has been saved, it can be 
reopened by clicking Open in the Posted Note dialog. Alternately, you can use the execute function in Formula Entry to 
load and execute a saved formula script.
 

Formula Script Commands
The following scripting commands can be used in the Formula Posted Note.
 
Definitions
BOOLEAN yes/no/true/false
STRING "character string surrounded by quotes"
 
The equal sign (=) is optional in this syntax. Anywhere the equal sign is used, the command is also valid without it.
 
The commands are case sensitive. The examples for each command show how it should be entered in the Posted Note 
window.
 
Comments can be added between formula script commands with the use of a semicolon. Any lines that begin with a 
semicolon are treated as comments. Place comment lines before or after individual formula script procedures. A syntax 
error message is displayed if the comment is included within the formula script command definition.
 
File paths must use "/" to separate directories in the path instead of ":" or "\" that were used in earlier versions.. Absolute 
paths begin with a  "/"; relative paths do not.:
 
List of Commands
#CLEAR
#CLEARDATA
#CLOSE
#CLOSE/ALL
#CLOSE/OPT
#COPY
#CUT
#DATA
#DATA/NOTITLE
#DATAFILE
#FORMULA
#MERGEFILE
#METAFILE
#METAFILE/OPT
#OPEN
#PAGE_PRINT
#PASTE
#PICT
#PICT/OPT
#PLOT_PRINT
#SAVE
#SCRIPT
#SELECTION
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#SET_DIRECTORY
 

#CLEAR
This command deletes the specified selection in the active data window. The cells below the selection shift up to fill the 
void. You may optionally delete column titles in addition to the data. The syntax for this command follows:
 
#CLEAR
title = BOOLEAN   Start_Row End_Row Start_Column End_Column
#END
 
The numbers should be separated by any white space characters. As a special case, if Start_Row has a value of -1, the 
entire window is selected. The active cell in the data window is moved to the location specified by Start_Row, 
Start_Column. The selection addresses for both row and column positions begin at zero and are counted from the upper-
left corner of the data window (position 0,0). The default action is to not delete titles.
 
Example: Delete the data in rows 0-50 of columns 10-20.
 
#CLEAR
0 50 10 20
#END
 
Example: Delete the data and column titles in rows 0-10 of columns 10-11.
 
#CLEAR
title true 0 10 10 11
#END
 

#CLEARDATA
This command clears the specified selection in the active data window. The syntax for this command follows:
 
#CLEARDATA
Start_Row End_Row Start_Column End_Column
#END
 
The numbers should be separated by any white space characters. As a special case, if Start_Row has a value of -1, the 
entire window is selected. The active cell in the data window is moved to the location specified by Start_Row, 
Start_Column. The selection addresses for both row and column positions begin at zero and are counted from the upper-
left corner of the data window (position 0,0).
 
Example: Clear the data in rows 50-100 of columns 15-25.
 
#CLEARDATA
50 100 15 25
#END
 

#CLOSE
This command closes the active window, without saving its contents. The syntax for this command follows:
 
#CLOSE
 

#CLOSE/ALL
This command closes all visible windows, without saving their contents. The syntax for this command follows:
 
#CLOSE/ALL
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#CLOSE/OPT
This command closes the specified plot or data window. You have the option of saving the window before closing it. Only 
plot and data windows should be taken into account when determining the position number of the window. The syntax for 
this command follows:
 
#CLOSE/OPT
window = # (the position of the window from front to back, where the frontmost window is position 1)
save = BOOLEAN
wintype = plot/data (optional)
#END
 
Example: Save and close the frontmost data window.
 
#CLOSE/OPT
window = 1
save = true
wintype = data
#END
 
Example: Close the second plot window from the front without saving.
 
#CLOSE/OPT
window = 2
save = false
wintype = plot
#END
 

#COPY
This command copies the selection in the active data window to the Clipboard. You may optionally specify a selection as 
part of the command options. If no selection is specified, the current selection in the window is used. You may also specify 
whether to get column titles in addition to any data. The syntax for this command follows:
 
#COPY
title = BOOLEAN    Start_Row End_Row Start_Column End_Column
#END
 
The numbers should be separated by any white space characters. As a special case, if Start_Row has a value of -1, the 
entire window is selected. The active cell in the data window is moved to the location specified by Start_Row, 
Start_Column. The selection addresses for both row and column positions begin at zero and are counted from the upper-
left corner of the data window (position 0,0). The default action is to not return titles.
 
Example: Copy the selection in rows 5-15, columns 1-3 (no titles).
 
#COPY
5 15 1 3
#END
 
Example: Copy the selection in rows 0-10, columns 1-2 (with titles).
 
#COPY
title = true 0 10 1 2
#END
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#CUT
This command cuts the selection in the active data window. The cells below the selection shift up to fill the void. You may 
optionally specify a selection as part of the command options. If no selection is specified, the current selection in the 
window is used. You may also specify whether to delete column titles in addition to the data. The syntax for this command 
follows:
 
#CUT
title = BOOLEAN     Start_Row End_Row Start_Column End_Column
#END
 
The numbers should be separated by any white space characters. As a special case, if Start_Row has a value of -1, the 
entire window is selected. The active cell in the data window is moved to the location specified by Start_Row, 
Start_Column. The selection addresses for both row and column positions begin at zero and are counted from the upper-
left corner of the data window (position 0,0). The default action is to not include titles.
 
Example: Cut the data in rows 100-500 of columns 0-20, without including the titles.
 
#CUT
title = false 100 500 0 20
#END
 
Example: Cut the selection in rows 0-10, columns 1-2 (with titles).
 
#CUT
title = true 0 10 1 2
#END
 

#DATA
This command places tab-separated data in a new data window. The first row should contain titles. The syntax for this 
command follows:
 
#DATA
(First row contains tab-separated titles.)
(The remaining rows contain tab-separated data.)
#END
 
Example: Use the first row for titles and place the remaining data in a new data window.
 
#DATA
Time Test#1 Test#2
1.0 38.6 39.7
1.5 41.2 40.9
2.0 42.7 42.3
#END
 

#DATA/NOTITLE
This command places tab-separated data in a new data window. The first row should contain data. The syntax for this 
command follows:
 
#DATA/NOTITLE
(All rows contain tab-separated data.)
#END
 
Example: Place the data in a new data window.
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#DATA/NOTITLE
1.0 38.6 39.7
1.5 41.2 40.9
2.0 42.7 42.3
#END
 

#DATAFILE
This command loads the data file named in the string. If the file is a text file, it is loaded using the specified parameters. 
The syntax for this command follows:
 
Note: File paths must use "/" to separate directories in the path instead of ":" or "\" that were used in earlier versions.. 

Absolute paths begin with a  "/"; relative paths do not.
 
#DATAFILE
file = STRING (This string should be either a simple name or a fully or partially qualified path to the file. The Open dialog is 

displayed if the path or file name is incorrect, or if "*.*" is used for the string.)
delimiter = tab/comma/space/special/STRING (if STRING is used, only the first character of the string is important)
skip = # (the number of lines to be skipped at the beginning of the file)
read_titles = BOOLEAN
del_number = # (0 if delimiter == 1, 1  if delimiter >= 1, 2  if delimiter >= 2, 3  if delimiter >= 3)
title_format = STRING (only used when delimiter = special)
data_format = STRING (only used when delimiter = special)
#END
 
Example: Display the Open dialog to open any data file.
 
#DATAFILE
file = "*.*"
#END
 
Example: Open a comma-delimited text file.
 
#DATAFILE
file = "Macintosh HD/Users/Physics_Lab/Documents/Data/Data 1.csv"
delimiter = comma
#END
 
Example: Open a text file using the special format.
 
#DATAFILE
file = "C:/Users/Physics_Lab/My Documents/Data/Data_2.txt"
delimiter = special
skip = 0
read_titles = TRUE
title_format = "3(a)"
data_format = "A f3 2(A v)"
#END
 

#FORMULA
This command executes a list of standard formulas. A semicolon should be placed at the end of each formula. It is valid to 
omit the #FORMULA and #END statements if you wish. The syntax for this command follows:
 
#FORMULA
(List of standard formulas.)
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#END
 
Example: Calculate the average of two columns and give the output column a title.
 
#FORMULA
c3 = (c1 + c2) /2;
name("average", c3);
#END
 

#MERGEFILE
This command loads the data file named in the string, starting at the specified row and column position. If the position is 
not specified, it defaults to row 0, column 0. The file is loaded using the specified parameters. The syntax for this 
command follows:
 
Note: File paths must use "/" to separate directories in the path instead of ":" or "\" that were used in earlier versions.. 

Absolute paths begin with a  "/"; relative paths do not.
 
#MERGEFILE
file = STRING (This string should be either a simple name or a fully or partially qualified path to the file. The Open dialog is 

displayed if the path or file name is incorrect, or if "*.*" is used for the string.)
delimiter = tab/comma/space/special/STRING (if STRING is used, only the first character of the string is important)
skip = # (the number of lines to be skipped at the beginning of the file)
read_titles = BOOLEAN
del_number = # (0 if delimiter == 1, 1  if delimiter >= 1, 2  if delimiter >= 2, 3  if delimiter >= 3)
title_format = STRING (only used when delimiter = special)
data_format = STRING (only used when delimiter = special)
position = # # (row number and column number separated by a tab)
#END
 
Example: Display the Open dialog to merge any data file.
 
#MERGEFILE
file = "*.*"
position = 0 4
#END
 
Example: Merge a comma-delimited text file.
 
#MERGEFILE
file = "Documents/Data/Data 1.csv"
delimiter = comma
read_titles = true
position = 10 8
#END
 

#METAFILE
This command is only available in the Windows version. It exports the active plot or layout window as an enhanced 
Metafile image via the Clipboard. The syntax for this command follows:
 
#METAFILE
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#METAFILE/OPT
This command is only available in the Windows version. It exports the active plot or layout window as an enhanced 
Metafile image to a file or the Clipboard, using the specified parameters. It is not possible to export the plot as 
an OLE object using this command. The syntax for this command follows:
 
Note: File paths must use "/" to separate directories in the path instead of ":" or "\" that were used in earlier versions. File 

name extensions are added automatically based on the type of file being saved. Absolute paths begin with a  "/"; 
relative paths do not.

 
#METAFILE/OPT
size = same_as_plot/fix_axis/fix_frame
x_size = # / auto
y_size = # / auto
units = inch/cm/centimeter
min_whitespace = BOOLEAN
dpi = # (ranging from 72 to 1400)
file = STRING
#END
 
Example: Export the active plot as a 300 dpi enhanced Metafile image with a minimal amount of white space.
 
#METAFILE/OPT
dpi = 300
min_whitespace = TRUE
file = "Documents/Images/Image_1"
#END
 

#OPEN
This command opens the specified file. It can be used to open any file that KaleidaGraph recognizes. The syntax for this 
command follows:
 
Note: File paths must use "/" to separate directories in the path instead of ":" or "\" that were used in earlier versions.. 

Absolute paths begin with a  "/"; relative paths do not.
 
#OPEN
file = STRING (This string should be either a simple name or a fully or partially qualified path to the file. The Open dialog is 

displayed if the path or file name is incorrect, or if "*.*" is used for the string.)
#END
 
Example: Open a saved Style file.
 
#OPEN
file = "Documents/KG Files/KG Style.qst"
#END
 
Example: Open a saved Layout file.
 
#OPEN
file = "C:/Users/Physics_Lab/My Documents/KG Layouts/Layout_1.qpl"
#END
 

#PAGE_PRINT
This command prints one or more plot windows using the current settings in the layout window. The syntax for this 
command follows:
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#PAGE_PRINT
 

#PASTE
This command pastes text or binary data from the Clipboard into the active data window. You may optionally specify a 
selection as part of the command options. If no selection is specified, the current selection in the window is used. You can 
also specify whether to paste column titles in addition to any text data. The syntax for this command follows:
 
#PASTE
title = BOOLEAN    Start_Row End_Row Start_Column End_Column
#END
 
The numbers should be separated by any white space characters. As a special case, if Start_Row has a value of -1, the 
entire window is selected. The active cell in the data window is moved to the location specified by Start_Row, 
Start_Column. The selection addresses for both row and column positions begin at zero and are counted from the upper-
left corner of the data window (position 0,0). The default action is to not return titles.
 
Example: Replace rows 0-10, columns 1-2 with the data on the Clipboard (with titles).
 
#PASTE
title = true 0 10 1 2
#END
 
Example: Replace rows 10-30, columns 4-5 with the data on the Clipboard (without titles).
 
#PASTE
title = false 10 30 4 5
#END
 

#PICT
This command exports the active plot or layout window as a TIFF (Mac) or enhanced Metafile (Windows) image via the 
Clipboard. The syntax for this command follows:
 
#PICT
 

#PICT/OPT
This command exports the active plot or layout window to a file or the Clipboard, using the specified parameters. The 
syntax for this command follows:
 
Note: File paths must use "/" to separate directories in the path instead of ":" or "\" that were used in earlier versions. File 

name extensions are added automatically based on the type of file being saved. Absolute paths begin with a  "/"; 
relative paths do not.

 
#PICT/OPT
type = bmp/jpeg/png/tiff/svg/pdf
size = same_as_plot/fix_axis/fix_frame
x_size = # / auto
y_size = # / auto
units = inch/cm/centimeter
min_whitespace = BOOLEAN
dpi= # (ranging from 72 to 1400)
compression = jpeg_superb/jpeg_high/jpeg_good/jpeg_average/jpeg_low/tiff_none/tiff_lzw
grayscale = BOOLEAN
transparent_background = BOOLEAN
file = STRING
#END
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Example: Export the active plot as a 600 dpi TIFF image.
 
#PICT/OPT
type = tiff
dpi = 600
file = "Documents/Image Folder/Test file"
#END
 
Example: Export the active plot as a 300 dpi PNG image.
 
#PICT/OPT
type = png
size = fix_frame
x_size 6
y_size auto
units inch
dpi = 300
min_whitespace = true
transparent_background = true
file = "Documents/Image Folder/Test file1"
#END
 

#PLOT_PRINT
This command prints the active plot window. The syntax for this command follows:
 
#PLOT_PRINT
 

#SAVE
This command saves the specified plot or data window. Only plot and data windows should be taken into account when 
determining the position number of the window. The syntax for this command follows:
 
Note: File paths must use "/" to separate directories in the path instead of ":" or "\" that were used in earlier versions. File 

name extensions are added automatically based on the type of file being saved. Absolute paths begin with a  "/"; 
relative paths do not.

 
#SAVE
window = # (the position of the window from front to back, where the frontmost window is position 1)
wintype = plot/data (optional)
file = STRING
#END
 
Example: Save the second plot window from the front.
 
#SAVE
window = 2
wintype = plot
file = "Documents/Plots/Test Plot"
#END
 
Example: Save the frontmost data window.
 
#SAVE
window = 1
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wintype = data
file = "Documents/Updated Data"
#END
 

#SCRIPT
This command can be used to either load a specific Script file or create a script from scratch.
 
Please note the following:

The y2 options in the script are only used for Double Y, Double XY, Double Y Bar, and Double Y Column plots.
The x2 options in the script are only used for Double X and Double XY plots.
The only way to use a template plot or apply error bars is to open a saved plot script file.
File paths must use "/" to separate directories in the path instead of ":" or "\" that were used in earlier versions.. 

Absolute paths begin with a  "/"; relative paths do not.
The Scripts folder (Examples folder) contains several example scripts that use a number of the options available 

in the #SCRIPT command.

The syntax for this command follows:
 
#SCRIPT
file = STRING  (Load the script file. This file should be in the same folder as the last script file that was opened or specified 

by a fully qualified path. The Open dialog is displayed if the path or file name is incorrect, or if "*.*" is used for the 
string.)

plot_type =line/scatter/double_y/double_x/double_xy/hilo/step/fill/bubble/probability/xy_probability/ histogram/box/
percentile/dot/summary_column/bar/stack_bar/ double_ybar/floating_bar/column/ stack_column/ double_ycolumn/
floating_column/polar/pie

auto_print = BOOLEAN
print_mode = single/layout
auto_save = BOOLEAN
save_mode = with_data/without_data/metafile/bmp/jpeg/png/tiff/svg/pdf
prefix = STRING
 
set_axis_options_defaults   (Returns the Axis Options dialog to its default settings.)
set_variable_settings_defaults   (Returns the Variable Settings dialog to its default settings.)
 
x/y/x2/y2 axis title STRING
x/y/x2/y2 axis linear/log/ln/log2
x/y/x2/y2 axis limits maximum auto or #  (Dates or times can be entered as a STRING.)
x/y/x2/y2 axis limits minimum auto or #  (Dates or times can be entered as a STRING.)
x/y/x2/y2 axis limits anchor auto or #  (Dates or times can be entered as a STRING.)
x/y/x2/y2 axis reverse BOOLEAN
y2 axis levels quantity auto
y2 axis levels quantity fixed #
y2 axis levels interval #
max_bubble_size #
bubble_scale area or diameter
hist_options bin_count auto or #
hist_options bin_size auto or #
hist_options bin_ref_value #
hist_options bin_ref_location edge or middle
hist_options expand_limits BOOLEAN
hist_options bins_added #
hist_options bins_subtracted #
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x2/y2 axis link no_ticks_labels/show_ticks/show_ticks_labels
x2/y2 axis link custom # #  (First number is for A, second number is for B in the custom equation.)
 
x/y/x2/y2 axis position default
x/y/x2/y2 axis position offset #
x/y/x2/y2 axis position at #
x/y/x2/y2 axis show_axis BOOLEAN
exchange_XY BOOLEAN
 
x/y/x2/y2 axis break show_break BOOLEAN
x/y/x2/y2 axis break omit # #  (Dates or times can be entered as a STRING.)
x/y/x2/y2 axis break position auto or #
x/y/x2/y2 axis break width #
x/y/x2/y2 axis break gap_style plain/flat/slant/curved
x/y/x2/y2 axis break gap_length #
x/y/x2/y2 axis break post_break interval auto/linear/log
x/y/x2/y2 axis break post_break major auto
x/y/x2/y2 axis break post_break major fixed #
x/y/x2/y2 axis break post_break major interval #  (Dates or times can be entered as a STRING.)
x/y/x2/y2 axis break post_break minor auto
x/y/x2/y2 axis break post_break minor fixed #
 
x/y/x2/y2 axis major tick in/out/both/none
x/y/x2/y2 axis major grid gray/solid/none
x/y/x2/y2 axis major quantity auto
x/y/x2/y2 axis major quantity fixed #
x/y/x2/y2 axis major interval #
 
x/y/x2/y2 axis minor tick in/out/both/none
x/y/x2/y2 axis minor grid gray/solid/none
x/y/x2/y2 axis minor quantity auto
x/y/x2/y2 axis minor quantity fixed #
 
x/y/x2/y2 axis label placement auto/none
x/y/x2/y2 axis label placement every_nth #
x/y/x2/y2 axis label format general/fixed/scientific/engineering # (# is the Precision, 0 to 16)
x/y/x2/y2 axis label notation # (Notation menu position, 1 to 5)
x/y/x2/y2 axis label date_format # (Format menu position, 1 to 14) # (Precision menu position, 1 to 4)
x/y/x2/y2 axis label time_format # (Format menu position, 1 to 10) # (Precision, 0 to 16)
x/y/x2/y2 axis label show_trailing_zeros BOOLEAN
x/y/x2/y2 axis label show_thousands BOOLEAN
x/y/x2/y2 axis label show_prefix BOOLEAN
x/y/x2/y2 axis label set_prefix STRING    Note: This also turns on the show_prefix flag
x/y/x2/y2 axis label show_suffix BOOLEAN
x/y/x2/y2 axis label set_suffix STRING    Note: This also turns on the show_suffix flag
x/y/x2/y2 axis label short_date BOOLEAN
 
x/y/x2/y2 axis color # (1 to 64)
x/y/x2/y2 axis major tick color # (1 to 64)
x/y/x2/y2 axis major grid color # (1 to 64)
x/y/x2/y2 axis minor tick color # (1 to 64)
x/y/x2/y2 axis minor grid color # (1 to 64)
x/y/x2/y2 axis link minor tick color
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x/y/x2/y2 axis link minor grid color
 
interior color # (1 to 64)
interior color transparent
background color # (1 to 64)
background color transparent
major tick inside_length #
major tick outside_length #
minor tick inside_length #
minor tick outside_length #
tick thickness # (1 to 10)
grid thickness # (1 to 10)
axis thickness # (1 to 10)
 
Note: All of the variable commands can either take a single variable # or a range: # to #
 
variable # marker_type # (1 to 60, 60 is Bar)
variable # marker_size # (1 to 13)
variable # marker_size custom #
variable # fill_pattern # (1 to 24, 23 is None and 24 is Line)
variable # line_style # (1 to 11, 11 is None)
variable # line_style none
variable # line_width # (1 to 10)
variable # line_color # (1 to 64)
variable # fill_color # (1 to 64)
variable # show_markers none
variable # show_markers all
variable # show_markers fixed # (1 to 10)
variable # show_markers fixed custom #
variable # show_markers percentage # (1 to 12)
variable # show_markers every_nth # (1 to 12)
variable # curve_fit line_style # (1 to 11, 11 is None)
variable # curve_fit line_style none
variable # curve_fit line_width # (1 to 10)
variable # curve_fit color # (1 to 64)
variable # drop_line x line_style # (1 to 11)
variable # drop_line x line_style none
variable # drop_line x line_width # (1 to 10)
variable # drop_line x color #  (1 to 64)
variable # drop_line y line_style # (1 to 11)
variable # drop_line y line_style none
variable # drop_line y line_width # (1 to 10)
variable # drop_line y color #  (1 to 64)
 
Note: All of the curve fit commands can either take a single variable # or a range: # to #
 
add_fit #  linear/log/power/exp/smooth/cubic_spline/interpolate
add_fit #  polynomial # (1 to 9)
add_fit #  weighted # (0 to 100 )
add_fit # general # (index to the General fit menu 1 to 30)
add_fit # general # (index to the General fit menu 1 to 30) # (weighting column number)
 
begin_group (select variables, plot title, and legend text for the group)
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title = STRING (one title per group)
legend = STRING (Used to define the legend text for each Y variable.)
x = # (specify X column number)
y = # (specify Y column number or a range of columns # to #)
y2 = # (specify Y2 column number or a range of columns # to # for Double Y, Double X-Y, Bubble, Double Y Bar, or Double 
Y Column plots)
x2 = # (only for Double X or Double XY plots)
window = # (Specify a data window for plotting. The default is the frontmost data window (window 1). The last window 

specified is remembered until a new script is encountered or a new window number is specified.)
end_group
(Add as many groups as you need to the script. Each group creates a new plot.)
#END
 
Example: Display the Open dialog to load and execute a plot script.
 
#SCRIPT
file = "*.*"
#END
 
Example: Create and save a Scatter plot from two data windows.
 
#SCRIPT
auto_save = TRUE
save_mode = with_data
prefix = "1/31_Group"
plot_type = scatter
begin_group
title = "Lot 10938"
x = 0
y = 1
y = 2
window = 2
x = 0
y = 1
y = 2
end_group
#END
 
Example: Create a Line plot from two sets of X-Y data in the same data window.
 
#SCRIPT
plot_type = line
begin_group
x = 0
y = 1
x = 2
y = 3
end_group
#END
 
Example: Create two Double Y plots from a single data window.
 
#SCRIPT
plot_type = double_y
begin_group
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x = 0
y = 1
y2 = 2
end_group
begin_group
x = 3
y = 4
y2 = 5
end_group
#END
 

#SELECTION
This command sets the selection in the active data window. The syntax for this command follows:
 
#SELECTION
Start_Row End_Row Start_Column End_Column
#END
 
The numbers should be separated by any white space characters. As a special case, if Start_Row has a value of -1, the 
entire window is selected. The active cell in the data window is moved to the location specified by Start_Row, 
Start_Column. The selection addresses for both row and column positions begin at zero and are counted from the upper-
left corner of the data window (position 0,0).
 
Example: In the active data window, select rows 5-15, in columns 1-3.
 
#SELECTION
5 15 1 3
#END
 
Example: Select the entire data window.
 
#SELECTION
-1
#END
 

#SET_DIRECTORY
This command sets the default directory. The syntax for this command follows:
 
Note: File paths must use "/" to separate directories in the path instead of ":" or "\" that were used in earlier versions. 

Absolute paths begin with a  "/"; relative paths do not.
 
#SET_DIRECTORY
directory = STRING/home/desktop/documents/app_directory (STRING is a fully or partially qualified path to the desired 

directory.)
#END
 
Example: Move up one directory.
 
#SET_DIRECTORY
directory = "../"
#END
 
Example: Change the current directory to the Data folder.
 
#SET_DIRECTORY
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directory ="Documents/Data"
#END
 
Example: Set the default directory to be the application directory.
 
#SET_DIRECTORY
directory = app_directory
#END
 

Example Formula Scripts
The examples in this section follow the same basic format. An overview describes the goal of the script. Then the example 
script is listed, just as it would appear if it were being entered directly into the Posted Note of the Formula Entry window. 
Following the script is an explanation of each step in the script.
 
Note: The Scripts folder (Examples folder) contains these three formula scripts as well as some other example scripts.
 
Example Scripts:

Basic Example
Intermediate Example
Advanced Example

 

Basic Example
This example script performs the following functions:

Selects a portion of the data window.
Executes four Formula Entry functions, two of which generate columns of data.
Copies the data and the titles to the Clipboard.
Pastes the information into another part of the data window.

 
The example script is listed below, followed by a description of how it operates.
 
#SELECTION
0 99 0 1
#END
 
#FORMULA
c0 = index() + 1;
c1 = log(c0);
name("Series", c0);
name("log(x)", c1);
#END
 
#COPY
title = true –1
#END
 
#PASTE
title = true 10 110 2 2
#END
 
The #SELECTION command selects rows 0 through 99 in the first two data columns. The #FORMULA command 
executes formulas which operate only on the selected data cells. The formulas create a data series from 1 to 100 in the 
first column, calculate the log of each value in the second column, and name the two columns.
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The #COPY command copies the entire data window, including titles, because the starting row is set to –1. Finally, the 
#PASTE command pastes the information on the Clipboard into the data window, starting at row 10 in the third data 
column.
 

Intermediate Example
This example script performs the following functions:

Imports a tab-delimited text file.
Executes two Formula Entry functions.
Creates a Scatter plot of the raw data.
Exports the plot to the printer.

 
The example script is listed below, followed by a description of how it operates.
 
#SET_DIRECTORY
directory = app_directory
#END
 
#DATAFILE
file = "Examples/Data/Text Example.txt"
delimiter = tab
skip = 0
read_titles = TRUE
del_number = 1
#END
 
#FORMULA
c3 = (c1 + c2) /2;
name("Average", c3);
#END
 
#SCRIPT
auto_print = true
print_mode = single
plot_type = scatter
begin_group
title = "Sample Script Plot"
legend = "Mean of Test Data"
x = 0
y = 3
end_group
#END
 
The #DATAFILE opens the specified text file. The text file is imported as a tab-delimited file which has a single tab 
between data values, skipping zero lines, and reading the first line as titles. The #FORMULA command executes two 
Formula Entry commands which calculate the average of two columns and place a title in the output column.
 
The #SCRIPT command generates a Scatter plot from the calculated data. The plot title and legend information are set 
directly via the title and legend options within the script. After the plot is created, it is automatically exported to the printer.
 



Working with Scripts

Page 217

•
•
•
•
•

Advanced Example
This example script performs the following functions:

Sets the program directory as the default directory.
Opens a data file.
Makes a selection in the data window.
Plots the selected data as a Stack Column plot.
Exports the plot as a 600 dpi TIFF file.

 
The example script is listed below, followed by a description of how it operates.
 
#SET_DIRECTORY
directory = app_directory
#END
 
#DATAFILE
file ="Examples/Data/Housing Starts.QDA"
#END
 
#SELECTION
0 5 0 3
#END
 
#SCRIPT
plot_type = stack_column
y axis title "Range"
y axis limits minimum 0
y axis limits maximum 450
begin_group
x = 0
y = 1 to 3
end_group
#END
 
#SET_DIRECTORY
directory = documents
#END
 
#PICT/OPT
type = tiff
dpi = 600
file = "Example Plot"
#END
 
The #SET_DIRECTORY command sets the program directory to be the default path. The #DATAFILE command opens 
the Housing Starts data file. The path to this file begins in the same directory as the program.
 
The #SELECTION command selects the first six rows in the data set. The #SCRIPT command creates a Stack Column 
plot of the selected data. The title and limits for the Y axis are defined within this command. The plot is then exported as a 
600 dpi TIFF file using the #PICT/OPT command. The TIFF file is given the specified name and is saved in the 
Documents folder.
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Overview of the Library
The library is displayed by choosing either Macros > Library or Curve Fit > General > Library. The current library is 
displayed in a text editor. You can use the editor to modify the current library, open a saved library, or create a new 
library. The editor contains Open,Save As, and Print buttons and an option to show the row numbers, while normal 
editing commands are supported via keyboard shortcuts and right-clicking within the dialog. The editor also supports 
multiple undos, but not through the History window.
 
The default library provided with KaleidaGraph contains a number of definitions for variables, constants, math functions, 
and curve fit equations. The definitions are grouped together to make it easier to locate a particular function, but this is not 
a requirement. You can place the definitions in any order you choose.
 
One of the main reasons for using the library is to form aliases or shorthand references for functions, variables, and 
constants. This is particularly useful for defining sections of a formula that exceed the 256 character limit in the Formula 
Entry, Function plot, and General curve fit windows.
 
KaleidaGraph searches the current library for any substitutions and makes them before proceeding. You may want to 
enclose the definition with parentheses to maintain the proper syntax after the substitution takes place.
 
Any definitions that you add to the library appear automatically in the Library menu in the Formula Entry window.
 

Library Syntax
The syntax used in the library is similar to what is used when creating multi-line formulas in Formula Entry. Each function 
should begin on a new line and terminate with a semicolon.
 
When creating names for your functions, keep the following in mind:

Do not assign the function a name that is used elsewhere in the program (column numbers, memory registers, 
Formula Entry commands, and so on).

Use at least two characters in the function name.
To avoid syntax errors, the name should only include letters and numbers, and not any other characters.
The library is not case sensitive. If two functions named S1() and s1() are defined, KaleidaGraph will substitute the 

last one that it finds in the library.

 
Comments can be included anywhere in the library through the use of a semicolon. Anything after the semicolon to the 
first occurrence of a carriage return is treated as a comment.
 
Note: A special case occurs if the semicolon is preceded by a backslash (\). In this case, the information after the 

semicolon is treated as a continuation of the function. This syntax is normally used to set up initial conditions 
when defining a curve fit equation in the library, but it can also be used to string multiple formulas together.

 

Defining Variables in the Library
Variable definitions can be used anytime you want to make use of the memory registers in a function or curve fit equation. 
The five variable definitions in the default library enable you to use x, a, b, c, and d in place of m0, m1, m2, m3, and m4, 
respectively. Additional variables can be defined by following this syntax:
 

variable1 = memory_register;
variable2 = memory_register;

 
Note: To avoid syntax errors, the name should only include letters and numbers, and not any other characters.
 
To add a variable definition to the library:

Choose Macros > Library or Curve Fit > General > Library to display the contents of the library.
Locate the section of the library that includes the current variable definitions. The definition can be placed 

anywhere in the library, but it makes it easier to find if the definitions are grouped together.
Enter the variable definition on a new line, making sure to terminate the definition with a semicolon.
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Click OK to leave the library. The definition is now available for use in Formula Entry, a Function plot, or a General 
curve fit.

 
Some example variable definitions are shown below:
 

Ymin = m1;
Ymax = m2;
IC50 = m3;
Slope = m4;

 

Defining Constants in the Library
Constant definitions can be created for any value that is used on a regular basis. The default library includes one constant 
definition, e=exp(1). Additional constants can be defined by following this syntax:
 

constant1 = value;
constant2 = value;

 
Note: To avoid syntax errors, the name should only include letters and numbers, and not any other characters.
 
To add a constant definition to the library:

Choose Macros > Library or Curve Fit > General > Library to display the contents of the library.
Locate the section of the library that includes the current constant definitions. The definition can be placed 

anywhere in the library, but it makes it easier to find if the definitions are grouped together.
Enter the constant definition on a new line, making sure to terminate the definition with a semicolon.
Click OK to leave the library. The definition is now available for use in Formula Entry, a Function plot, or a General 

curve fit.

 
Some example constant definitions are shown below:
 

DtSYR = .004805;
LSYR = .01027;
XSYR = .318;
Wa = 55.5;

 

Defining Mathematical Functions in the Library
Any individual or multi-line formula that you run in the Formula Entry window can be defined in the library. The default 
library contains a number of mathematical and miscellaneous functions that perform various operations on the data 
window. Each of these definitions follows the same basic structure:
 

functionname(var1, var2, ...) = definition;

functionname is the name assigned to the definition in the library. To avoid syntax errors, the name should only 
include letters and numbers, and not any other characters.

var1, var2, and so on represent any variables that are used in the formula. The variables can represent column 
numbers or memory registers. The names of the variables do not have to be defined elsewhere before using 
them. A maximum of 10 variables are permitted in the definition.

definition is the formula that is being defined. If you are entering multiple formulas for the definition, each of the 
definitions except for the last one should have a backslash (\) prior to the semicolon.

 
To add a definition for a mathematical function to the library:

Choose Macros > Library or Curve Fit > General > Library to display the contents of the library.
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Locate the section of the library that includes the current mathematical functions. The definition can be placed 
anywhere in the library, but it makes it easier to find if the definitions are grouped together.

Enter the mathematical function on a new line, making sure to terminate the definition with a semicolon.
Click OK to leave the library. The definition is now available for use in Formula Entry.

 
Some example mathematical functions are shown below:
 

colseries(x, a, b) = (x = a + b * index());
residual(x, y) = (gen(x, y) - y);
pisinc5x(x, y) = (x = (pi/99 * index()) - pi/2)\; y = ((x) == 0.0) ? 1 : (sin(5*x)/(x));
 

The following dialog shows how to call one of the example definitions from within Formula Entry.
 

 

Defining Curve Fits in the Library
Any valid curve fit function can be defined in the library. The default library contains a number of curve fit functions for use 
in the General curve fit. Each of these definitions follows the same basic structure:
 
fitname(a0,b0, ...) = definition\;
a=a0\;b=b0;

fitname is the name assigned to the curve fit definition in the library. To avoid syntax errors, the name should only 
include letters and numbers, and not any other characters.

a0, b0, and so on represent any unknown parameters that are used in the curve fit.
definition is the curve fit function that is being defined.
the second line of the definition (a=a0\;b=b0;) allows the initial guesses for the parameters to be included when 

using the shorthand reference.

Note: To avoid syntax errors, the name should only include letters and numbers, and not any other characters.
 

Creating a Basic General Curve Fit Definition
This example defines the equation (a*x)/(b+a*x) in the library.
 
To add the definition to the library:

Choose Macros > Library or Curve Fit > General > Library to display the contents of the library.
Locate the section of the library that includes the current curve fit definitions. The definition can be placed 

anywhere in the library, but it makes it easier to find if the definitions are grouped together.
Enter the following definition on a new line: sample1(a0,b0) = (a*x)/(b+a*x)\; a=a0\; b=b0;
Once the definition is entered, click OK to leave the library. The definition is now available for use in the General 

Curve Fit Definition dialog or in a Function plot.

 
The following dialog shows how to call the library definition from within the General Curve Fit Definition dialog. Because of 
the two commands (a=a0\; b=b0;) that follow the main definition in the library, initial guesses can be entered directly into 
the curve fit definition.
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Creating a Complex General Curve Fit Definition
Now that a basic curve fit definition has been defined, let’s create a more complex curve fit definition. This example 
creates a definition for the following equation:
 

a*exp(-(x-b)^2/(c*c)) + d*exp(-(x-f)^2/(g*g)) + h*exp(-(x-i)^2/(j*j))
 
To add this definition to the library:

Open the library again so that the definition can be added.
Add the following commands should be added to the existing Variable Definitions. These commands are 

necessary to define a formula that uses all of the parameters available (m1 - m9).

f=m5;
g=m6;
h=m7;
i=m8;
j=m9;

 Add the following commands to the existing Curve Fit Definitions.

form1() = a*exp(-(x-b)^2/(c*c));
;
form2() = d*exp(-(x-f)^2/(g*g));
;
form3() = h*exp(-(x-i)^2/(j*j));
;
sample2(a0, b0, c0, d0, f0, g0, h0, i0, j0) = form1() + form2() + form3()\;
a=a0\; b=b0\; c=c0\; d=d0\; f=f0\; g=g0\; h=h0\; i=i0\; j=j0;

 Click OK to leave the library.

 
Notice the original equation has been split into three smaller parts and all three parts are tied together into one formula. 
The following dialog shows how to call the library definition from within the General Curve Fit Definition dialog. The name 
of the definition is entered, followed by all of the initial guesses.
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Loading a Saved Library File
KaleidaGraph provides several library files within the Library folder (Examples folder). Most of these contain curve fit 
definitions, although the default library (Library.txt) that ships with KaleidaGraph is also included in this folder should you 
ever need to reload the original library.
 
To load a saved library:

Choose Macros > Library or Curve Fit > General > Library.
Click Open.
Locate and open the library file to be imported. This library will replace the current library.
Click OK to leave the library.

 

Saving the Current Library
There are two ways to save the current library. The library can be exported as a text file which can be reloaded at a later 
time. The library can also be exported as part of the Macros file.
 
To save the current library as a text file:

Choose Macros > Library or Curve Fit > General > Library to display the contents of the library.
Click Save As.
Give the file an appropriate name and click Save.
Click OK to leave the library.

 
To save the current library as part of a Macros file, save the Macros file by choosing File > Export > Macros.
 

Creating a New Library
To create a new library:

Choose Macros > Library or Curve Fit > General > Library.
To save a copy of the current library, use the Save As button.
To start a new library, delete any definitions in the Edit Library dialog.
Enter your new definitions, making sure to terminate each one with a semicolon.
When completed, save the new library.
Click OK to leave the library. If you want to load a different library, load it before closing the window.

 
To save the current library as part of a Macros file, save the Macros file by choosing File > Export > Macros.
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Using the Macro Calculator
The Macro Calculator is a powerful tool that provides the ability to write programs for analyzing and transforming data in 
the data window. Instead of performing each step of a task in KaleidaGraph yourself, you can often write a macro to do it 
for you automatically. For example, you can create a macro that clears the contents of any data cell containing masked 
data.
 
To display the Macro Calculator, choose Windows > Macro Calculator. The calculator combines the RPN (Reverse 
Polish Notation) programming language found in HP calculators with 2000 program steps to give you a number of ways to 
manipulate and transform data.
 

Single Number Functions
RPN calculators use an operating logic that is different from most other calculators. In the RPN calculator, answers appear 
immediately after a numerical function key is pressed. Therefore, all operands must be entered before a function is 
executed.
 
Single number functions operate on the value in the display. Examples of single number functions include: sine, square 
root, and logarithm.
 
To use a single number function:

Key in the number (if the number is not already in the display).
Click a function button.

 
For example:

Key in 4.5. This can be done with the mouse or the keyboard.
Click COS. The calculator displays 0.99692 (degrees) or –0.2108 (radians).

 

Two Number Functions
A two number function requires two values to be entered into the calculator before the result can be calculated. Some 
examples of two number functions are addition, subtraction, multiplication, and division.
 
To use any two number function:

Enter the first number.
Click Enter to separate the first number from the second.
Enter the second number.
Click a function button. The result of the operation will appear in the display.

 
Examples:
 

To Calculate: Press: Display 
Shows:

8 + 6  8 ENTER 6 
+ 14.000

8 - 6  8 ENTER 6 
- 2.000

8 * 6  8 ENTER 6 
x 48.000

8 / 6  8 ENTER 6 
÷ 1.333
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In each of the above examples, the first number is typed followed by the Enter button. The second number gets typed and 
a function button is clicked. Here is what is happening:

Both numbers are in the calculator before clicking a function button.
The Enter button separates two numbers typed one after the other. If the number is already in the calculator 

display from a previous function, it is not necessary to click Enter.
Pressing a function button causes the calculator to execute immediately and display the result.

 
Some more examples are shown below:
 

To Calculate: Press: Display Shows:
12 * (10 - 6)  12 ENTER 10 ENTER 6 - x 48.000
5 * (8 - 2) / 3  8 ENTER 2 - 5 x 3 ÷ 10.000

(9 - 3) * (3 / 9)  9 ENTER 3 - 3 ENTER 9 ÷ x 2.000
625 / (20 + 5)  625 ENTER 20 ENTER 5 + ÷ 25.000

 
 

The Automatic Stack
The automatic stack is where the calculator retains intermediate results. The stack consists of 24 storage locations, called 
registers. The bottom value of the stack is always displayed. All values that are entered or are the result of a function are 
placed in the bottom register.
 
The bottom register in the stack is the X register. The Y register is directly above the X register. The x <> y key exchanges 
the numbers in the X and Y registers without affecting the rest of the stack. The last 12 values of the stack may be viewed 
at any time by clicking the X register display, as shown below.
 

 
Single number functions do not cause the stack to drop. The result of the function is placed in the X register, and replaces 
the value operated on by the function. Two number functions cause the stack to drop whenever they are executed. The 
result of the function is placed in the X register and the two numbers that were used in the calculation are removed from 
the stack, causing it to drop.
 

Storing and Recalling Numbers
The Macro Calculator has 100 memory registers numbered 00-99. These registers are accessed through the STO (store) 
and RCL (recall) commands. These commands operate using the X register of the calculator.
 
Note: The RCL command causes the stack to be lifted; the STO command does not.
 
To store a value into a memory register:

Enter the value to be stored into the calculator.
Click STO.
Enter the memory location (00-99).
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The value is stored in the specified memory location.

 
To recall a value from a memory register:

Click RCL.
Enter the memory location (00-99).
The value in the specified memory location is placed in the X register.

 
For example:

STO 05     Stores the X register’s value in memory location 05.
STO 29     Stores the X register’s value in memory location 29.
RCL 15     Places the value in memory location 15 into the X register.
RCL 34     Places the value in memory location 34 into the X register.
 

Calculator Commands
There are three buttons that control the operation of the Macro Calculator.

When Calculator is selected, you can use the Macro Calculator as a typical RPN calculator.
When Trace is selected, the Macro Calculator expands to show a list of the program steps in the editor. The SST

and R/S buttons can be used to troubleshoot the macro.
Clicking Run executes the macro in the editor.

 
The Edit Program button displays a text editor that can be used to load or enter an RPN program.
 
Most of the remaining buttons on the Macro Calculator are pretty standard. A few of them are discussed below:

CE (Clear Entry) - This button clears the display (X register) without affecting previous entries.
CM (Clear Memory) - This button resets the contents of the memory registers to 0.
CP (Clear Program) - This button erases the entire program in the program text editor.
FIX (Fixed Decimal Notation) - In this notation, the calculator displays numbers rounded to the specified number of 

decimal places. To change the number of decimal places displayed, click FIX and enter the number of decimal 
places (0–9).

SCI (Scientific Notation) - In this notation, the calculator displays numbers with one digit to the left and a specified 
number of digits to the right of the decimal point. To change the number of decimal places displayed, click SCI
and enter the number of decimal places (0–9).

EEX (Exponent Notation) - This button allows numbers to be entered in exponent form (A x 10B). Enter the 
decimal (A) portion of the number, click EEX, and type the exponent (B).

→ P (Polar-To-Rectangular) - This button converts the numbers in the X and Y registers (R and Ø) to rectangular 
coordinates (X and Y). Ø can be expressed in either degrees or radians, depending on the calculator setting.

→ R (Rectangular-To-Polar) - This button converts the numbers in the X and Y registers (X and Y) to polar 
coordinates (R and Ø). Ø can be expressed in either degrees or radians, depending on the calculator setting.

INV (Inverse) - Clicking this button before selecting any of the trig functions computes the inverse of the specified 
trigonometric function.

 

Program Text Editor
Clicking the Edit Program button of the Macro Calculator displays a program editor. The program text editor is shown 
below:
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This editor is used to create new macros and edit existing macros. The editor contains Open and Save As buttons and an 
option to show the row numbers, while normal printing and editing commands are supported via the File and Edit menus, 
keyboard shortcuts, and right-clicking within the dialog. It also supports multiple undos, but not through the History 
window.
 
When you are finished editing, click OK to check the syntax and leave the text editor. If a syntax error is found, the 
offending line will be highlighted.
 

Steps for Creating a Macro
Planning the Macro
The first step in creating a macro is to determine exactly what the macro will do. It is a good idea to write down some of 
the commands that will be used and to think about how the data window will be accessed (using either indirect or vector 
commands). As a general rule, if the task can be performed using Formula Entry, vector addressing will normally work for 
the macro. If not, use indirect addressing.
 

Entering the Macro
To enter a program, you need to be in the program editor. Click Edit Program to display the program editor. Delete any 
text currently in the editor. You are now ready to enter a macro.
 

Running the Macro
Once the program is entered into the Macro Calculator, it is ready for execution. If you are in the program editor, click 
OK to check the syntax and leave the text editor. If a syntax error is found, the offending line will be highlighted.
 
Once you return to the Macro Calculator, click Run to execute the program. The program runs until a STOP command is 
reached. If a STOP command is not encountered, KaleidaGraph searches the entire 2000 step program memory for 
another command before aborting the macro.
 
Note: The STOP command does not have to be the last program step in a macro. It can be located anywhere that is 

logical within the program.
 

Debugging a Macro
There may be times when you run a macro and the results are not what you expect. When this occurs, it is useful to go 
through the program step by step to determine where the problem lies. There are two buttons on the Macro Calculator that 
aid in debugging a program.
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SST (Single-Step) - This button executes the program one step at a time. You can advance to the next step by 
clicking SST or by pressing the Spacebar. At each step of the program, the current value of the X register is 
displayed. If any key besides the Spacebar is typed, the program switches to Run mode and executes the 
rest of the program.

R/S (Run/Stop) - This button is useful for debugging long loops. When the R/S command is hit during program 
execution, the calculator switches from Run mode to Single-Step mode. You can then proceed as you 
normally would in single-step mode. If any key besides the Spacebar is typed, the program returns to Run 
mode and continues to execute the rest of the program.

 

Adding Comment Lines
After a macro runs correctly, comments can be added to the program. Comments are used to make a program more 
readable, by describing the purpose of the program and the use of each memory register. Comments that are placed with 
a program step should explain exactly what the step is doing.
 
Comments can be added anywhere in the macro with the use of a semicolon. Anything after the semicolon to the first 
occurrence of a carriage return is treated as a comment. The comments can be on the same line as the command, or they 
can be on a separate line.
 

Saving the Macro
Once the macro is complete, it should be saved for future use. Click Save As in the program editor to save a copy of the 
macro. The macro can also be added to the Macros menu using the Show Macros command.
 

Adding a Macro to the Macros Menu
Once you have written a program, you can add it to the Macros menu and use it again later. A maximum of 100 macros 
can be stored in the menu at once.
 
 If the macro is already in the program window of the Calculator, the steps required to add it are:

Choose Macros > Show Macros.
Select one of the macros listed in the dialog. The macro you are adding is inserted above this macro.
Click Add from Calculator. The name Calculator is inserted into the macros list. This is the default name 

assigned to the macro.
Use the text field below the macros list to edit the name of the macro. The name change takes effect when a 

different macro is selected or you click OK.

Note: If you would like to insert a dashed line between groups of macros, create a new macro and use a dash (-) for the 
name of the macro.

 

Editing a Macro
Once a program is in the Macros menu, it is possible to retrieve it for editing. If the macro is not listed in the Macros 
menu, it can be opened from within the program editor.
 
The steps required to edit the macro are:

Choose Macros > Show Macros.
Double-click the name of the macro to be edited, or click the name and click Edit. The program’s source code 

appears in a text editor. The normal editing commands are supported via keyboard shortcuts and right-clicking 
within the dialog. The Degree Mode setting (checked for degrees or unchecked for radians) determines 
whether degrees or radians are used for trigonometric functions when running the macro.

Once the original macro has been modified, click OK to leave the editor.
Click OK to exit the Show Macros dialog.

 

Reordering the Macros Menu
To change the order of the macros:
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Choose Macros > Show Macros.
Click the name of the macro and drag it to a new position.
Click OK to keep your changes and exit the dialog.

Note: If you would like to insert a dashed line between groups of macros, create a new macro and use a dash (-) for the 
name of the macro.

 

Saving Changes to the Macros Menu
The macros that appear in the Macros menu are taken from the default Macros file. If any changes are made to these 
macros or if any macros are added or deleted, you need to save the changes to the Macros file using one of the following 
ways.

Choose File > Preferences, click the File Settings tab, and select Prompt from the Macros pop-up menu. When 
exiting KaleidaGraph, a dialog asks whether or not to overwrite the Macros file that was opened at launch.

Choose File > Preferences, click the File Settings tab, and select Always from the Macros pop-up menu. When 
exiting KaleidaGraph, the Macros file that was opened at launch is automatically overwritten.

Choose File > Export > Macros to save the Macros file. The file must be named KG Macros and saved in the 
following location:

In the Mac version, this file must be in the KaleidaGraph Preferences folder for it to be opened. To view 
the KaleidaGraph Preferences folder, you may need to press the Option key and choose Library from 
the Go menu at the Finder. The KaleidaGraph Preferences folder will be in the main Preferences 
folder.

In the Windows version, this file must be in the \Users\(user)\AppData\Local\Synergy 
Software\KaleidaGraph5.0 directory for it to be opened. Windows stores the settings files in a hidden 
directory. You will need to turn on the setting in the Folder and Search options (under the Organize
menu in the Windows Explorer window) to Show hidden files to access hidden locations. (user) in the 
previous path is the name of your account on the computer.

 

Constraints
Command Constraints
Most of the commands have n, nn or nnn after them to specify the constraints associated with each command. If the 
command is followed by n, the value of n can range from 0 to 9, except for the inpt command which can range from 1 to 
6. If a command is followed by nn, the value of nn can range from 0 to 99. If nnn follows a command, the value of nnn can 
range from 0 to 999.
 

Indirect Addressing Constraints
Indirect addressing allows you to specify the row and column address of a number to be used in a calculation. The 
address of the number is stored in a memory register. The integer portion of the number is the row address and the 
fractional portion of the number is the column address. For example, if a memory register has 9.03 stored, an indirect 
function operates on the data cell at row 9, column 3.
 
If the ibase command appears anywhere in the macro, the column address can range from .000 to .999. If the ibase 
command is not in the macro, the column address can only range from .00 to .99.
 
Note: All address calculations are referenced to the start of a data selection.
 

Constants
Constants can be used within a macro by simply typing the number. When a constant is encountered during program 
execution, the number is placed in the X register. Constants are commonly used to set the default values in dialogs.
 
Constants are double precision by default. If you want to have a single precision number, precede the number with const.
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Program Control and Looping
Program Labels

LBL  nn - There are 100 program labels numbered 00 - 99. Labels are used as markers at the beginning of a 
series of program steps and as targets for either forward or backward program jumps.

Jumps

GTO  nn - This command is used to branch to another portion of the program. When the GoTo command (GTO 
 nn) is encountered, the program jumps to LBL nn and continues execution from there.

GTOi  nn - This command is another form of the GoTo command. The indirect jump (GTOi  nn) reads the value of 
the specified memory register and uses it as the target label for the jump. This command allows the target of a 
jump to be modified during the execution of the program.

Calling Subroutines

XEQ  nn - The execute command (XEQ  nn) is similar to the GoTo statement. As with the GoTo command, the 
XEQ command branches to another part of the program and continues running. However, when a return 
command (RTN) is found, the program returns to the program step immediately following the execute 
command it came from originally.

XEQi  nn - This command is another form of the XEQ statement. The difference between them is that XEQi reads 
the value of the specified memory register and uses that value as the target label for the subroutine. The 
program continues to run from that point until a return command (RTN) is encountered. The program then 
returns to the program step immediately following the XEQi command it came from originally. This instruction 
allows the target subroutine to be modified during the execution of the program.

 
Note: A maximum of 20 XEQ/XEQi statements can be nested before finding a RTN.

 

Looping

ISG  nn - The increment and skip if greater command (ISG  nn) is useful for looping in programs. This function 
increments the value in the specified memory register (nn) by 1.0 and tests it against the value in the X 
register. If the value of the memory register is less than or equal to the X register, the next program step is 
executed. If its value is greater than the X register, the next program step is skipped.

DSE  nn - The decrement and skip if equal command (DSE  nn) is useful for looping in programs. This function 
decrements the value in the specified memory register (nn) by 1.0 and tests it against the value in the X 
register. If the value of the memory register is greater than the X register, the next program step is executed. If 
its value is less than or equal to the X register, the next program step is skipped.

Entry and Exit Subroutines
The entry and exit functions are useful for initializing macros or for clean-up after a macro is executed. These commands 
are used together with the end command to define special subroutines that are executed only at the beginning or end of a 
macro. These functions must be placed after the STOP command at the end of the macro.
 

Conditional Tests
A conditional test allows you to make decisions during the execution of a program. The basic format is:

If a conditional test is TRUE
then execute the next statement

else
skip the next step and jump to the following statement

 
The conditional test is used to determine whether or not the next statement should be executed or skipped. This statement 
can be any valid command. A complete list of the conditional tests follows:

x > y True if X register > Y register.
x < y True if X register < Y register.
x <= y True if X register <= Y register.
x >= y True if X register >= Y register.
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x != y True if X register is not equal to the Y register.
x = y True if X register = Y register.

Note: To use these commands in a macro, they must be typed correctly into the program editor. A space must be entered 
after the x and before the y for KaleidaGraph to recognize the command.

 

Boolean Functions
Boolean Tests
Boolean tests are similar to conditional tests in that the values in the X and Y registers are being compared. The difference 
is that the Boolean places the result of the comparison (0=false, non-zero = true) in the X register and drops the original X 
and Y values from the stack. A complete list of the Boolean tests follows:

bool 0  y > x True if Y register > X register.
bool 1  y >= x True if Y register >= X register.
bool 2  y < x True if Y register < X register.
bool 3  y <= x True if Y register <= X register.
bool 4  y = x True if Y register = X register.
bool 5  y != x True if Y register is not equal to the X register.
bool 6  y || x True if Y register or the X register is true.
bool 7  y && x True if Y register and the X register are true.

 

Other Boolean Commands

BMv  nnn (Boolean mask vector) - If the Boolean value in the X register is true (non-zero), the current row in 
column nnn is masked.

BUv  nnn (Boolean unmask vector) - If the Boolean value in the X register is true (non-zero), the current row in 
column nnn is unmasked.

ifelse - This command uses the bottom three registers in the stack: Boolean, Y, and X. If the Boolean is true (non-
zero), the value in the Y register is placed in the X register. If the Boolean is false (0), the value in the X 
register remains unchanged. All other registers are dropped from the stack.

 

Addressing the Data Window
Indirect Addressing

ibase - The ibase command must be used to address columns outside of the 100 column default range. When this 
command is used, the column portion of the indirect address can range from .0 to .999. This command can 
appear anywhere in the macro and only needs to be used once.

Recalling Data

RCL  nn - Recalls the value from memory register nn and places the value in the X register.
rclr  nn - The relative recall (rclr  nn) reads the value from the target memory register specified in memory register 

nn. The value is placed in the X register.
RCLv  nnn - This function is used to recall data from a data selection on a row-by-row basis. The program is 

evaluated once for each row in the selection. This command skips over any masked data cells.
RCLi  nn - This command recalls the data value from the address specified in memory register nn. The integer 

portion of the number is used as the row address and the fractional part of the number is the column number. 
For example, if a memory register has 9.03 stored, a RCLi command returns the data value in row 9, column 
3.

getcell - Gets the value of a cell at a specific address and places the value in the X register. The address is 
specified by the bottom two registers in the stack (X and Y). The column address value must be less than 
1000 and is located at the bottom of the stack (X). The row address value is in the stack above it (Y). When 
the command is executed, the addresses are removed from the stack and the value that is retrieved from the 
cell is placed in the X register.
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Note: If a macro tries to recall a number in a row or column that does not exist, it stops with a message that you specified 
a position that has not been created.

 

Storing Data

STO  nn - Stores the value of the X register in memory register nn.
stor  nn - The relative store (stor nn) places the value in the X register into the target memory register specified in 

memory register (nn).
STOv  nnn - This command is used to store the results of a vector calculation. The results are stored on a row-by-

row basis in column nnn. As a special case, if an alpha command is placed immediately before a STOv 
command, the text string is written into the output column, provided the column is formatted as Text.

STOi  nn - This command stores the value of the X register in the address specified in memory register nn. The 
integer portion of the number is used as the row address and the fractional part of the number is the column 
number. As a special case, if an alpha command is placed immediately before a STOi command, the text 
string is written into the output column, provided the column is formatted as Text.

setcell - Stores the value of the X register in a cell at a specific address. The value to be stored is in the bottom 
register of the stack (X). The address is specified by the next two registers in the stack (Y and Z). The column 
address value must be less than 1000 and is located in the Y register. The row address value is in the Z 
register. When the command is executed, the addresses are removed from the stack and the X register is left 
undisturbed.

Note: If a program tries to store a number in a row or column that has not been created, KaleidaGraph expands the data 
window. This is limited by the maximum number of columns in a data window (1000) and the amount of available 
memory.

 

Error Conditions
There are three commands that are used to test for errors. The first test is used to detect any errors during the execution 
of the program. The other two tests are used to detect recall indirect command (RCLi) errors.

test 0 - This test is true if any type of error occurs during the execution of the program. Once this flag is set, it 
cannot be reset until the program stops.

test 1 - This test is used to determine if a data cell contains a number before using the value in a calculation. The 
test is true if the last RCLi command attempted to read data from an empty cell. The flag is reset when the 
next RCLi instruction is executed.

test 2 - This test is used to determine if a data cell is masked before trying to use the value in a calculation. The 
test is true if the last RCLi command attempted to read data from a masked cell. The flag is reset when the 
next RCLi instruction is executed.

 

Clearing Data Cells

CLRv  nnn - This command clears the current cell during a vector calculation. A macro using this command is 
repeatedly executed on a row-by-row basis in the data selection.

CLRi  nn - This command clears the cell specified by the address in memory register nn. The integer portion of the 
number is used as the row address and the fractional part of the number is the column number.

 

Masking/Unmasking Data

Mv  nnn - This command masks the current cell during a vector calculation. A macro using this command is 
repeatedly executed on a row-by-row basis in the data selection.

UMv  nnn - This command unmasks the current cell during a vector calculation. A macro using this command is 
repeatedly executed on a row-by-row basis.

Mi  nn - This command masks the cell specified by the address in memory register nn. The integer portion of the 
number is used as the row address and the fractional part of the number is the column number.

UMi  nn - This command unmasks the cell specified by the address in memory register nn. The integer portion of 
the number is used as the row address and the fractional part of the number is the column number.
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Other Commands

index - The index command is used in macros that use vector addressing. It enables the index number of the 
current row to be referenced in calculations. The index number is referenced to the start of a data selection. 
The index command returns a value of 0 for the first row in a selection.

size - The size command determines the number of rows and columns in the current data selection. If no selection 
exists, the size of the entire data window is determined (including blank rows and columns). The number of 
rows is placed in the X register and the number of columns is placed in the Y register.

 

Using Strings
The Macro Calculator allows up to 100 strings in a single program. Strings can be used to name columns in a data 
window, to prompt the user for input, or to label an output display.
 
The first and last characters of the string should be the double-quote (") character.
 
The alpha register is an important factor in the use of strings. The alpha register is a temporary storage place for strings. 
Strings are placed in the alpha register when they are encountered in the execution of a program.
 
Note: The alpha register and its memory locations are independent of the normal data memory locations and calculator 

stack. It is possible to read and write strings from the data window. Text that is recalled from a data window is 
stored in the alpha register; text that is placed in a data window is written from the alpha register.

 

STOa  n - The STOa command stores a string once it has been placed in the alpha register. The string is stored in 
any one of ten (0-9) alpha memory locations.

RCLa  n - The RCLa command recalls the contents of a specific alpha memory location and places the string in 
the alpha register.

Ncol  nnn - This command is used to name data columns in the active data window. Specify a column number 
(0-999) and the selected column is renamed with the contents of the alpha register.

sload - This command loads a plot script specified by an alpha string or a RCLa command. The Script file is 
loaded from your launch directory (program, style, or macro), or from the last directory from which a plot script 
was loaded during the current session.

srun - This command executes the current plot script.

 

Input and Output
prmt  n - The prmt command is used to input a single value into a macro during execution. This command is 

useful if a program has information or constants that change each time the program is executed.

When the prompt command is executed, a dialog with a title, a prompt string, and an edit field is displayed. 
The field displays a default value and allows you to change its value. The default value can be defined by 
storing a value into the same memory register the prmt command accesses when it is executed.
 
This command makes use of the contents of the alpha register, an alpha memory location, and a numeric 
memory location. The contents of the alpha register are used as the title of the dialog and alpha memory n is 
used as the prompt string. If you click OK, the value entered in the dialog is placed in data memory location n. 
Thus, the first 10 data memory registers (0-9) are matched with the 10 alpha memories (0-9).

inpt  n - The inpt function is also used to supply input into a program. The advantage of this command over the 
prmt command is that you can enter up to six different values at one time.

When the inpt command is executed, a dialog is displayed with a title and up to six different strings and 
numeric fields. Each field displays a default value and allows you to change its value. The default values can 
be defined by storing a constant in the data memory register that corresponds to the alpha memory register 
displayed to the right of the field.
 
This command uses the contents of the alpha register and up to six alpha and data memory locations (0-5). 
The title of the dialog is taken from the contents of the alpha register. The contents of the alpha memory 
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locations are displayed to the right of the fields, which contain the default values. If you click OK, the values 
entered in the dialog are placed in the appropriate data memory registers.

 
Note: For the inpt command, the value of n must be between 1 and 6.

 

view  n - The view command is useful for displaying the results of a calculation. Up to nine variables can be 
displayed at once.

When this command is executed, a dialog appears which contains a title and a maximum of nine different 
output values. Each of the output variables can also have a string to describe its meaning. The output values 
are stored in memory registers 00 through 08 and the strings are stored in the corresponding alpha memory 
locations. The title of the dialog is taken from the alpha register.
 

Register Calculations
Single Number Functions

abs - This function determines the absolute value of the value in the X register.
erf - Calculates the error function of the value in the X register.
erfc - Calculates the complementary error function of the value in the X register.
exp - Calculates the value of e (2.7182...) raised to the power specified in the X register.
factorial - Calculates the factorial of the value in the X register.
ln - Calculates the natural logarithm (base e) of the value in the X register.
log - Calculates the common logarithm (base 10) of the value in the X register.
ran# - Generates a random number between 0 and 1.
sqrt - Calculates the square root of the value in the X register.
+/- - Changes the sign of the value in the X register.
pi - Places an approximate value of pi (3.14159...) in the X register.
1/x - Computes the reciprocal of the value in the X register.
x^2 - Computes the square of the value in the X register.
10^x - Calculates 10 to the power of the value in the X register.
int - This function determines the integer portion of the X register. If 5.08 is in the X register, the int command 

causes 5.00 to be stored in the X register.
frac - This function determines the fractional portion of the X register. If 5.08 is in the X register, the frac command 

causes 0.08 to be stored in the X register.

Two Number Functions

x<>y - Exchanges the values in the X and Y registers.
y^x - Raises the number in the Y register to the power specified in the X register. Negative values of Y are only 

allowed if X is an integer.
corr – Calculates the linear correlation of the columns specified in the X and Y registers. To use this function, the 

two columns being compared must have the same number of data points.

p->r - Converts the numbers in the X and Y registers (R and φ) to rectangular coordinates (X and Y). φ can be 
expressed in either degrees or radians, depending on the calculator setting.

r->p - Converts the numbers in the X and Y registers (X and Y) to polar coordinates (R and φ). φ can be 
expressed in either degrees or radians, depending on the calculator setting.

Addition

+ - Adds the value in the Y register to the value in the X register.
Add  nn - Adds the value in the X register to the specified memory register (nn).
Addi  nn - Adds the value in the X register to the memory location specified in memory register (nn).
rsum  nnn - Computes the running sum of column nnn and places the result in the X register.
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Subtraction

-  - Subtracts the value in the X register from the value in the Y register.
Sub  nn - Subtracts the value in the X register from memory register (nn).
Subi  nn - Subtracts the value in the X register from the memory location specified in memory register (nn).
diff  nnn - Calculates the difference between each value and the one that follows it in column nnn.

Multiplication

* - Multiplies the value in the Y register by the value in the X register.
Mul  nn - Multiplies memory register nn by the value in the X register.
Muli  nn - Multiplies the memory location specified in memory register nn by the value in the X register.

Division

/ - Divides the value in the Y register by the value in the X register.
Div  nn - Divides memory register nn by the value in the X register.
Divi  nn - Divides the memory location specified in memory register nn by the value in the X register.
mod - The mod function computes the integer value of X mod Y and places the result in the X register.

Distribution

norm - This function calculates the normal distribution of the value in the X register.
inorm - This function calculates the inverse normal distribution of the value in the X register.

Trigonometric Commands

cos - Determines the cosine of the value in the X register. The value is in radians or degrees, based on the setting 
in the Macro Calculator.

inv-cos - Determines the inverse cosine of the value in the X register. The value is in radians or degrees, based 
on the setting in the Macro Calculator.

inv-sin - Determines the inverse sine of the value in the X register. The value is in radians or degrees, based on 
the setting in the Macro Calculator.

inv-tan - Determines the inverse tangent of the value in the X register. The value is in radians or degrees, based 
on the setting in the Macro Calculator.

sin - Determines the sine of the value in the X register. The value is in radians or degrees, based on the setting in 
the Macro Calculator.

tan - Determines the tangent of the value in the X register. The value is in radians or degrees, based on the setting 
in the Macro Calculator.

->deg - Assuming the X register contains a value in radians, this function computes the corresponding value in 
degrees.

->rad - Assuming the X register contains a value in degrees, this function computes the corresponding value in 
radians.

Other Commands

CM - Resets the contents of the memory registers to 0.
FIX  n - Using this command, the calculator displays numbers rounded to the specified number of decimal places.
SCI  n - Using this command, the calculator displays numbers with one digit to the left and a specified number of 

digits to the right of the decimal point.
tbl - This command performs a linear approximation of x, based on the function defined by the data in an x column 

and a y column. The x and y column numbers can range from 0 - 999. The result is that for a given value of x, 
this function determines a linear estimate for y. This command uses the last three registers in the stack (X, Y, 
and Z):

Z = x value.
Y = y column number.
X = x column number.
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Statistics Functions
Statistics on a Specific Group of Data
The following commands allow you to perform statistics on a specific set of data. The data to be used is determined by the 
row and column addresses entered before the command is executed. These commands are able to operate on the entire 
data window. The addresses for these commands are stored in the bottom four registers of the stack (S0 - S3). All of these 
commands follow the same pattern shown below:
 

S3 contains the number of the starting row.
S2 contains the number of the ending row.
S1 contains the number of the starting column.
S0 (the X register) contains the number of the ending column.

 
After the command is executed, the four addresses are removed from the stack and the result of the function is placed in 
the X register.

cmin - Determines the minimum value within the specified data range.
cmax - Determines the maximum value within the specified data range.
csum - Calculates the sum of all the values in the data range.
npts - Determines the number of points within the specified data range.
mean - Calculates the mean of the data range.
median - Calculates the median of the data range.
rms - Calculates the root mean square of the data range.
std - Calculates the standard deviation of the data range.
var - Calculates the variance of the data range.
stderr - Calculates the standard error of the data range.
skew - Calculates the skewness of the data range.
kurtosis - Calculates the kurtosis of the data range using the formula for excess kurtosis.

Row-By-Row Statistics
The following commands allow you to perform statistics on a row-by-row basis. The data to be used is determined by the 
column addresses entered before the command is executed. These commands are able to operate on the entire data 
window. The addresses for these commands are stored in the bottom two registers of the stack (S0 and S1). All of these 
commands follow the same pattern shown below:
 

S1 contains the number of the starting column.
S0 (the X register) contains the number of the ending column.

 
After the command is executed, the two addresses are removed from the stack and the result of the function is placed in 
the X register.

rstat 00 - Determines the minimum value across the specified range of columns.
rstat 01- Determines the maximum value across the specified range of columns.
rstat 02- Calculates the sum of all the values across the specified range of columns.
rstat 03- Determines the number of points across the specified range of columns.
rstat 04- Calculates the mean across the specified range of columns.
rstat 05- Calculates the median across the specified range of columns.
rstat 06- Calculates the root mean square across the specified range of columns.
rstat 07- Calculates the standard deviation across the specified range of columns.
rstat 08- Calculates the variance across the specified range of columns.
rstat 09- Calculates the standard error across the specified range of columns.
rstat 10- Calculates the skewness across the specified range of columns.
rstat 11- Calculates the kurtosis across the specified range of columns using the formula for excess kurtosis.
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Curve Fit Functions
The following commands are useful if a curve fit has been applied to any of the columns in the data window. Each 
command finds f(x) for a specific value of x. The value in the X register is used for the value of x. The address of the data 
column that has the appropriate curve fit is used for the value of nnn in the command.
 
Note: The answer is only accurate if x is within the original range of data. If x lies outside of the original range, the answer 

is linearly interpolated.
 

Nonlinear Curve Fits

gen  nnn - This command calculates the value of the General curve fit applied to column nnn at the value 
specified in the X register.

genf  nnn - This command is similar to the gen nnn command. The difference is that the genf nnn command 
makes use of the alpha register to determine which General curve fit should be used to determine the value of 
x. This is useful if more than one general curve fit is applied to a column of data.

 

Least Squares Curve Fits

lin  nnn - This command calculates the value of the Linear curve fit applied to column nnn at the value specified in 
the X register.

poly  nnn - This command calculates the value of the Polynomial curve fit applied to column nnn at the value 
specified in the X register.

expr  nnn - This command calculates the value of the Exponential curve fit applied to column nnn at the value 
specified in the X register.

logr  nnn - This command calculates the value of the Logarithmic curve fit applied to column nnn at the value 
specified in the X register.

pow  nnn - This command calculates the value of the Power curve fit applied to column nnn at the value specified 
in the X register.

 

Smoothing Curve Fits

smh  nnn - This command calculates the value of the Smooth curve fit applied to column nnn at the value 
specified in the X register.

wgt  nnn - This command calculates the value of the Weighted curve fit applied to column nnn at the value 
specified in the X register.

spln  nnn - This command calculates the value of the Cubic Spline curve fit applied to column nnn at the value 
specified in the X register.

intp  nnn - This command calculates the value of the Interpolate curve fit applied to column nnn at the value 
specified in the X register.

 

Miscellaneous Commands
peek  nn - This command displays the value of any specified memory register (nn) without changing the contents 

of the X register. The result of this command is placed in the display region of the Macro Calculator. In Trace 
mode this can be an invaluable aid when debugging a macro, where the address of an indirect recall or store 
operation is calculated in the program.

abort - The abort command can be used to stop the execution of a macro. This is particularly useful if an error is 
detected during the execution of the program.

version - This command returns the current KaleidaGraph version number. The version number is multiplied by 
100 and placed in the X register.

up - This command moves all of the values in the stack up one position.
down - This command moves all of the values in the stack down one position.
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Settings Files
KaleidaGraph maintains five settings files to save the modifications made to the program. These files are opened each 
time you start KaleidaGraph, provided they are in the correct location and have the correct file name. If a settings file has 
a different name or is located in a different directory, it is not opened.
 
The five settings files are:

KG Prefs
KG Style
KG Macros
KG Layout
KG Script
 

The default settings files are located:

In the Mac version, these files must be in the KaleidaGraph Preferences folder to be opened. To view the 
KaleidaGraph Preferences folder, you may need to press the Option key and choose Library from the Go
menu at the Finder. The KaleidaGraph Preferences folder will be in the main Preferences folder.

In the Windows version, these files must be in the \Users\(user)\AppData\Local\Synergy 
Software\KaleidaGraph5.0 directory  to be opened. Windows stores the settings files in a hidden directory. You 
will need to turn on the setting in the Folder and Search options (under the Organize menu in the Windows 
Explorer window) to Show hidden files to access hidden locations. (user) in the previous path is the name of 
your account on the computer.

 

KG Prefs
The KG Prefs settings file is saved automatically when quitting the program. This file stores a number of settings that were 
previously saved in the Style file, including the Recent Files list, all of the settings in the Preferences dialog, the recent font 
list, and the defaults for the table tool. Opening an older Style or Macros file will not overwrite any settings currently stored 
in the KG Prefs file.
 
The default settings file is named KG Prefs and is located in the following location:

In the Mac version, this file must be in the KaleidaGraph Preferences folder for it to be opened. To view the 
KaleidaGraph Preferences folder, you may need to press the Option key and choose Library from the Go
menu at the Finder. The KaleidaGraph Preferences folder will be in the main Preferences folder.

In the Windows version, this file must be in the \Users\(user)\AppData\Local\Synergy Software\KaleidaGraph5.0 
directory for it to be opened. Windows stores the settings files in a hidden directory. You will need to turn on 
the setting in the Folder and Search options (under the Organize menu in the Windows Explorer window) to 
Show hidden files to access hidden locations. (user) in the previous path is the name of your account on the 
computer.

 

KG Style
Style files contain the settings associated with the appearance of the plot. This includes the color table, text defaults, plot 
layouts, and the settings for the various dialogs associated with plots.
 
Prior to v5, Style files stored a number of other settings that are now saved automatically in the KG Prefs file. Opening a 
saved Style file will not overwrite the settings in the KG Prefs file.
 
A default Style file is automatically opened each time KaleidaGraph is started. This way you can save the settings and 
have them opened the next time you use the program. Custom Style files can be created by choosing File > Export > 
Style. These files can be opened by choosing Open or Import > Style from the File menu. All of the settings change to 
reflect the contents of the new Style file. If a plot window is active, opening a saved Style file will change many of the plot's 
settings, but it will not resize the plot.
 
The default settings file is named KG Style and is located in the following location:
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In the Mac version, this file must be in the KaleidaGraph Preferences folder for it to be opened. To view the 
KaleidaGraph Preferences folder, you may need to press the Option key and choose Library from the Go
menu at the Finder. The KaleidaGraph Preferences folder will be in the main Preferences folder.

In the Windows version, this file must be in the \Users\(user)\AppData\Local\Synergy Software\KaleidaGraph5.0 
directory for it to be opened. Windows stores the settings files in a hidden directory. You will need to turn on 
the setting in the Folder and Search options (under the Organize menu in the Windows Explorer window) to 
Show hidden files to access hidden locations. (user) in the previous path is the name of your account on the 
computer.

 

KG Macros
Macros files contain the macros in the Macros menu, the contents of the library, any formulas assigned to the function 
buttons in Formula Entry, and the curve fits in the General submenu.
 
Prior to v5, Macros files stored other settings that are now saved automatically in the KG Prefs file. Opening a saved 
Macros file will not overwrite the settings in the KG Prefs file.
 
A default Macros file is automatically opened each time KaleidaGraph is started. This way you can save the settings and 
have them opened the next time you use the program. Custom Macros files can be created by choosing File > Export > 
Macros. These files can be opened by choosing Open, Import > New Macros, or Import > Append Macros from the 
File menu. All of the affected menus and options change to reflect the contents of the new Macros file. If a plot window is 
active, opening a saved Macros file will not change the list of curve fits until you create a new plot. Only the Append 
Macros command could be used to modify the default KG Macros file.
 
The default settings file is named KG Macros and is located in the following location:

In the Mac version, this file must be in the KaleidaGraph Preferences folder for it to be opened. To view the 
KaleidaGraph Preferences folder, you may need to press the Option key and choose Library from the Go
menu at the Finder. The KaleidaGraph Preferences folder will be in the main Preferences folder.

In the Windows version, this file must be in the \Users\(user)\AppData\Local\Synergy Software\KaleidaGraph5.0 
directory for it to be opened. Windows stores the settings files in a hidden directory. You will need to turn on 
the setting in the Folder and Search options (under the Organize menu in the Windows Explorer window) to 
Show hidden files to access hidden locations. (user) in the previous path is the name of your account on the 
computer.

 

KG Layout
KaleidaGraph can save two types of Layout files: basic Layout files and Group Layout files. The only difference between 
the two types of files is how they handle the plots within the layout window.
 
A basic Layout file stores the following information: size and position of the cells, the contents and location of any text 
labels or objects, and the background settings. The plots are not saved as part of the layout file.
 
Group Layout files provide the added benefit of saving a copy of each plot embedded within the Layout file. This allows 
you to organize your plots, save a Group Layout file, and open a single file at a later date to make changes to any of the 
original plots.
 
If one has been created, a default Layout file is automatically opened each time KaleidaGraph is started. This way you can 
save a layout and have it opened the next time you use the program. You can access this default layout by choosing 
Windows > Show Layout > KG Layout. Custom Layout files can be created by choosing File > Save Layout As when a 
layout window is active. These files can be opened by choosing File > Open. The layout opens into a new window, 
displaying any items that were saved as part of the layout.
 
The default settings file is named KG Layout and is located in the following location:

In the Mac version, this file must be in the KaleidaGraph Preferences folder for it to be opened. To view the 
KaleidaGraph Preferences folder, you may need to press the Option key and choose Library from the Go
menu at the Finder. The KaleidaGraph Preferences folder will be in the main Preferences folder.

In the Windows version, this file must be in the \Users\(user)\AppData\Local\Synergy Software\KaleidaGraph5.0 
directory for it to be opened. Windows stores the settings files in a hidden directory. You will need to turn on 
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the setting in the Folder and Search options (under the Organize menu in the Windows Explorer window) to 
Show hidden files to access hidden locations. (user) in the previous path is the name of your account on the 
computer.

 

KG Script
Script files contain the settings and group selections from the Plot Script window. If an existing plot is used as a template, 
a copy of the plot is saved as part of the script file.
 
If one has been created, a default Script file is automatically opened each time KaleidaGraph is started. This way you can 
save the plot script and have it opened the next time you use the program. Custom Script files can be created by choosing 
File > Save Script As when the Plot Script window is active. These files can be opened by choosing File > Open. The 
Plot Script window changes to reflect the contents of the new Script file.
 
The default settings file is named KG Script and is located in the following location:

In the Mac version, this file must be in the KaleidaGraph Preferences folder for it to be opened. To view the 
KaleidaGraph Preferences folder, you may need to press the Option key and choose Library from the Go
menu at the Finder. The KaleidaGraph Preferences folder will be in the main Preferences folder.

In the Windows version, this file must be in the \Users\(user)\AppData\Local\Synergy Software\KaleidaGraph5.0 
directory for it to be opened. Windows stores the settings files in a hidden directory. You will need to turn on 
the setting in the Folder and Search options (under the Organize menu in the Windows Explorer window) to 
Show hidden files to access hidden locations. (user) in the previous path is the name of your account on the 
computer.

 

Shortcut Menus
KaleidaGraph displays pop-up menus when you press Control (Mac) or right-click (Windows) and click in the data, plot, 
and layout windows. The commands in these pop-up menus vary depending on what object is selected when you use this 
shortcut.
 

Using the Toolbar
KaleidaGraph provides a data window toolbar, shown below, for easy access to some commonly used commands. If the 
toolbar is not displayed for a particular data window, choose Data > Show Data Tools. The Preferences dialog contains a 
Show Data Window Toolbar option that controls the default state of the toolbar for any new data windows.
 
Data Window Toolbar

          
 
The Windows version of KaleidaGraph also displays an application toolbar under the menu bar. The toolbar provides quick 
and easy access to some of the most commonly used commands.
 
Application Toolbar for the Data Window

 
Application Toolbar for the Plot and Layout Windows

 

Editing Keyboard Shortcuts
To edit a keyboard shortcut:

Choose KaleidaGraph > Preferences (Mac) or File > Preferences (Windows) to display the Preferences dialog.
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Click the Menu Shortcuts tab.
In the dialog that is displayed, double-click a command from the scrolling list.
Type a valid key sequence. This sequence becomes that command’s keyboard shortcut.

 
Note: Modifier keys include Command (Mac), Ctrl (Windows), Shift, Option (Mac), and Alt (Windows). Valid keys 

include: A-Z 0-9 [ ]  - + , = \ /     If you type an invalid sequence it will not be assigned to the command.
 
To remove a keyboard shortcut, double-click the command from the list and press Delete (Mac), Backspace (Windows), 
or the Spacebar. You can return to the default settings at any time by clicking Defaults.
 

Dialog Shortcuts
The following shortcuts are available in most dialogs that contains an OK or Cancel button:
 
OK
You can exit the dialog and accept any changes by pressing Return (Mac) or Enter (Windows). Exceptions include the 
Text Tool and Table Tool dialogs.
 
Cancel
You can exit the dialog and cancel any changes (if cancel is appropriate) by typing Esc, Command+Period (Mac), or 
Ctrl+Period (Windows).
 

Quit/Exit Dialog Shortcuts
The following keyboard shortcuts are available in the Quit (Mac) and Exit (Windows) dialog:
 

Buttons: Mac: Windows:
Clicking OK Return or Enter Enter
Clicking None Delete Backspace
Clicking Cancel Esc Esc

: 
Check boxes    
Clear/Select Data D Alt+D
Clear/Select Plots P Alt+P
Clear/Select Layout L Alt+L
Clear/Select Macros M Alt+M
Clear/Select Script S Alt+S
Clear/Select Style T Alt+T

 
 

Data Window Shortcuts
The following shortcuts are available in the data window:
 
Closing a Data Window
If Shift is pressed while closing a data window, you are not prompted to save the window contents.
 
Appending a Data Column
If the active cell is at the window boundary and you press the Right Arrow key, a column is automatically added to the 
window and the active cell is moved to the newly created column.
 
Choosing Macros from the Macros Menu
Press Command (Mac) or Ctrl (Windows) and click in the data window to display a menu containing the current set of 
macros.
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Replotting Data

The Update Plot button  in the toolbar portion of the data window rebuilds the plot that is associated with the current 
data window. To update the plot using a subset of the data, select the data, press Shift, Option (Mac), or Alt (Windows) 
and click this button.
 

Plot Window Shortcuts
The following shortcuts are available in the plot window:
 
Closing a Plot Window
If Shift is pressed while closing a plot window, you are not prompted to save the window contents.
 
Editing Legend and/or Axis Labels
Select the Text tool and double-click the label to be edited.
 
Axis Limits
After using the Zoom Selection tool, double-clicking the Zoom Selection icon or pressing z twice restores the original plot.
 
Data Selection Tool
After using the Data Selection tool, double-clicking the Data Selection icon or pressing s twice restores the original plot.
 
Constraining Objects
If Shift is pressed while you are resizing an object on the plot, such as a box, round cornered box, polygon, arc, picture, or 
axis frame, the object is forced to be square. In the case of an oval, pressing Shift while you are resizing the object forces 
it to be a circle.
 
Resizing from the Center
If Option (Mac) or Alt (Windows) is pressed while you are resizing any object such as a box, round cornered box, 
polygon, arc, picture, or axis frame, the object is resized from its center.
 
Picture Aspect Ratio
By default, pictures are forced to maintain the same aspect ratio as the original when they are resized. If Shift is pressed 
while you are resizing a picture (that has been pasted into the plot or imported from a file), the new picture can be set to 
any aspect ratio and size. Pictures which contain either circles or text look much better when plotted if the aspect ratio is 
held constant.
 
Line/Arrow Rotation
If you press Shift while you are adjusting a line/arrow, the rotation of the object is set to 45 degree increments.
 
Selecting/Deselecting Objects
Pressing the Spacebar twice selects all of the objects in the plot window. Pressing Esc deselects all objects.
 

Edit String Dialog Shortcuts
The following keyboard shortcuts are available in the Edit String dialog:
 

Action: Mac: Windows:
Undo/Redo Command+Z Ctrl+Z
Cut Command+X Ctrl+X
Copy Command+C Ctrl+C
Paste Command+V Ctrl+V
Select All Command+A Ctrl+A
Left Justify Command+L Ctrl+L
Center Justify Command+M Ctrl+M
Right Justify Command+R Ctrl+R
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Plain Command+P Ctrl+P
Bold Command+B Ctrl+B
Italic Command+I Ctrl+I
Normal Command+N Ctrl+N
Superscript Command+U Ctrl+U
Subscript Command+D Ctrl+D
Alt. Font Command+F Ctrl+F

 
 

Text Editor and Posted Note Shortcuts
The following keyboard shortcuts are available in the various text editors and the Posted Note window for Formula Entry:
 

Action: Mac: Windows:
Undo/Redo Command+Z Ctrl+Z
Cut Command+X Ctrl+X
Copy Command+C Ctrl+C
Paste Command+V Ctrl+V
Select All Command+A Ctrl+A
Find Command+Shift+F Ctrl+Shift+F
Find Again Command+Shift+G Ctrl+Shift+G
Open Command+O Ctrl+O
Save Command+S Ctrl+S
Print Command+P Ctrl+P

 
 

Shortcuts for Selecting Plot Tools
The following keyboard shortcuts are available for selecting tools:
 

Spacebar Selection Arrow
T Text tool
L Line/Arrow tool
O Current tool in object pop-up menu
1 Box tool
2 Round-Rectangle tool
3 Oval tool
4 Polygon tool
5 Arc tool
6 Bezier Curve tool
A Table tool
E Eraser tool
I Identify tool
S Data Selection tool
Z Zoom Selection tool

 
Pressing Command (Mac) or Ctrl (Windows) allows you to use the last tool selected.
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Changing Axis Options from the Toolbox
Before using the toolbox to change the axis options, an axis must be selected by clicking twice on the desired axis. The 
bottom portion of the toolbox will display the icons shown below:
 

 

Exchanging and Removing Axes
To exchange or remove axes:

Select the desired axis.
Click the first Axis Options icon to display the pop-up menu shown below.

 

 

Turn on Swap X & Y to exchange the X and Y axes or No Axis to remove the selected axis and its tick marks.

 

Axis Scaling, Reversing, and Auto Limits
To change scaling, reverse an axis, or return to auto limits:

Select the desired axis.
Click the second Axis Options icon to display the pop-up menu shown below.

 

 

Choose Linear, Log, Ln, or Log2 from the Scale submenu to change the axis scaling, turn on Reverse to reverse 
the axis, or turn on AutoScale to return to the limits originally calculated by KaleidaGraph.

 

Linking Axes
To link the X2 or Y2 axes:

Select the X2 or Y2 axis.
Click the second of the two Axis Options icons to display the pop-up menu shown below.
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Choose Link to display the submenu shown below.

 

 

Choose the type of link to be used for the selected axis.

 

Tick Marks and Grid Lines
To change the display of tick marks and grid lines or to let KaleidaGraph calculate the number of ticks:

Select the appropriate axis.
Click the second of the two Axis Options icons to display the pop-up menu shown below.

 

 

Choose Major or Minor to display a submenu that contains the tick mark and grid line options. The submenus for 
Major and Minor are identical.
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For tick marks, use the Inside and Outside commands to change how the ticks are displayed. Turn on Auto to 
have KaleidaGraph calculate the number of tick marks displayed on the selected axis.

For grid lines, turn on Grid to display a gray (dotted) line or Solid to display a solid line. If both items are turned 
off, grid lines are not displayed.

 

Axis Labels
To change the display of the axis labels:

Select the desired axis.
Click the second of the two Axis Options icons to display the pop-up menu shown below.

 

 

Choose # Format to display a submenu that contains the display options. The options in the submenu depend on 
the format of the data plotted along the selected axis. The following three figures show the submenus that 
appear for Numeric (Float, Double, or Integer), Date, and Time formats.

Numeric 
formats  Date formats

Time 
formats

 
Using these options, you can change the format of the axis labels as well as display trailing zeros, commas, a 
prefix, or a suffix. Changes are based on the settings for the current axis in the Axis Options dialog (Plot 
menu).

Make the desired changes to the submenu.

 

Changing Variable Settings from the Toolbox
Before using the toolbox to change the variable settings, a plot symbol must be selected in the legend by clicking twice on 
the symbol. The bottom portion of the toolbox will display the Variable Settings icons shown below.
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Line or Fill Color
To change the line or fill color from the toolbox:

Select a plot symbol in the legend.
Click one of the icons in the palette to display a color palette containing the color choices.

The Color icon controls the line and fill color. It consists of two sections: a line color icon (upper-left) for setting 
the color of the variable line and marker frame, and a fill color icon (lower-right) for setting the color of the fill 
pattern and the interior color of filled markers.

 

 

Select a different color from the palette.

 

Marker Type, Size, or Number of Markers
To change the marker type, size, or number of markers displayed:

Select a plot symbol in the legend.
Click the Marker icon to display the pop-up menu shown below.

 

 

Select a different marker type, size, or number from the pop-up menu.

 

Fill Pattern
To change the fill pattern of the variable:

Select a plot symbol in the legend.
Click the Fill Pattern icon to display the pop-up menu shown below.
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Select a different fill pattern from the pop-up menu.

 

Variable Line Style or Width
To change the variable’s line style or width:

Select a plot symbol in the legend.
To change the line style, click the left portion of the Style icon and select a different line style. The active line style 

is enclosed in a dotted box.
To change the line width, click the right portion of the Style icon and select a different line width. The active line 

width is enclosed in a dotted box.

 

         
Line Style pop-up menu         Line Width pop-up menu

 
 

Changing Plot Color from the Toolbox
Before using the toolbox to change the plot colors, either the plot frame or an axis must be selected. If the frame is 
selected, you can edit the interior and background colors. If an axis is selected, you can change the axis and grid colors.
 

Interior and Background Colors
To change the interior or background colors from the toolbox:

Click any of the axes once to select the plot’s frame. The bottom portion of the toolbox will display the icons shown 
below.
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The Color icon controls the interior and background color. It consists of two sections: an interior color icon 
(upper-left) for setting the plot’s interior color, and a background icon (lower-right) for setting the background 
color.
 

Click one of the icons in the palette to display a color palette containing the color choices.

 

 

Select a different color from the palette.

 
To make the interior or background of the plot transparent:

Click any of the axes once to select the plot’s frame. The bottom portion of the toolbox will display two icons.
Click the bottom icon to display the following pop-up menu.

 

 

Turn on either of the commands in this pop-up menu to make that portion of the plot transparent.

 

Axis and Grid Colors
To change the axis or grid colors from the toolbox:

Select one of the plot’s axes. The bottom portion of the toolbox will display the icons shown below.

 
The first icon controls the axis and grid color. It consists of two sections: an axis color icon (upper-left) for 
setting the color of the current axis, and a grid icon (lower-right) for setting the grid color.
 

Click one of the icons in the palette to display a color palette containing the color choices.
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Select a different color from the palette.

 

Changing Text Attributes from the Toolbox
Holding down the mouse button after clicking the Text tool displays the pop-up menu shown below. You can use this pop-
up menu to change the attributes of selected text objects directly from the toolbox. If a selection is not present in the plot 
window, the default attributes can be set for any text labels created with the Text tool.
 

 
To change the attributes of a text label directly from the toolbox:

Select the label(s) to be modified.

Individual labels are selected by clicking the label once with either the Text tool or Selection Arrow.
Legend text is selected by clicking the label once with the Text tool.
Axis or value labels are selected as a group by clicking any of the labels in the group with the Selection Arrow. 

They may also be selected individually by clicking with the Text tool.
Multiple text labels can be selected by pressing Shift and clicking each label with the Selection Arrow or Text 

tool.
All of the text labels can be selected at once by choosing Edit > Select All. Everything in the plot is selected, 

but changes made using the Text tool only affect text objects.

Click the Text tool and hold down the mouse button to display the pop-up menu.
Choose any of the commands in the pop-up menu. Choosing any of the commands except Erase Background

displays a submenu that contains the options for that item.
Continue making selections from the pop-up menu until all of the labels are set up as desired.

 
To set the default attributes for the Text tool:

Verify that a selection is not present in the plot window.
Click the Text tool and hold down the mouse button to display the pop-up menu.
Choose any of the commands in the pop-up menu. Choosing any of the commands except Erase Background

displays a submenu that contains the options for that item.
Make the desired changes in the pop-up menu.
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Any text objects that you create with the Text tool have these attributes. The attributes that you set are saved as part of 
the Style file. You can also use the Text Options command (Plot menu) to set the defaults for standard text labels.
 

Formula Entry Shortcuts
The Enter key on the numeric keypad can be used to run the current formula(s).
 
The contents of the Formula Entry window can be cut or copied to the Clipboard by selecting the contents and typing 
Command+C (Mac) or Ctrl+C (Windows).
 
When Formula Entry is the active window, typing the F1-F9 function keys on the keyboard will activate the various function 
buttons. F9 activates the Posted Note window.
 
Multiple functions can be strung together in both the Posted Note or in the main area of the Formula Entry window. Each 
function in a multiple line string must end with a semicolon except for the last function in the list.
 

Gallery Menu Shortcuts
A keyboard shortcut (Command+D (Mac) or Ctrl+D (Windows)) is available in the Gallery menu for reselecting a plot 
type from the keyboard. This shortcut is always associated with the last plot type selected.
 
When the plot window is the active window and you select a command from the Gallery menu, a dialog appears that 
allows you to replot the variables used in the current plot with the type just selected. This allows you to quickly switch 
between different displays of the same data.
 
To plot a subset of a column or a group of columns, make the appropriate selection in the data window before you select 
the plot type from the Gallery menu.
 

Curve Fit Menu Shortcuts
All Curve Fits
When selecting variables for a curve fit, typing Command+A (Mac) or Ctrl+A (Windows) selects all of the variables at 
once.
 
General
Pressing esc, Command+Period (Mac), or Ctrl+Period (Windows) stops the calculation of a General curve fit.
 
Polynomial
If Shift is pressed when selecting variables for this fit, the current polynomial order is used for each variable. This enables 
you to select the order once and set it for the rest of the variables without displaying the second dialog.
 
Weighted
If Shift is pressed when selecting variables for this fit, the current smoothing factor is used for each variable. This enables 
you to select the factor once and set it for the rest of the variables without displaying the second dialog.
 
Pressing esc, Command+Period (Mac), or Ctrl+Period (Windows) stops the calculation of a Weighted curve fit.
 

Opening Recently Opened Files
The File menu contains a Recent Files command that lists the last 20 files that have been opened or saved in 
KaleidaGraph. You can open a listed file by choosing the file name from the submenu.
 

Problems with the Data Window
Only the first column contains data after importing a text file.
Make sure the correct settings are selected for Delimiter and Number in the Text File Input Format dialog. The Number 
setting specifies how many delimiters separate each data value, not the number of characters in the data value.
 
Nothing appears after pasting data copied from KaleidaGraph.
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To copy more than 10,000 cells and paste them into another application, Text Mode must be selected in the Edit menu 
before copying the data. Binary Mode should only be used when moving data from one data window to another in 
KaleidaGraph.
 
Issues importing text files containing localized characters:
You may need to change to a different text encoding in the Text File Input Format dialog.
 
Sorry, the selected data window does not have enough columns to run this script error message.
The Plot Script is pointed to a data window that does not have enough columns to complete the script. The order of 
opening these files is important. Open any data windows before opening the script.
 

Problems with Plots
Some of the markers are not being displayed on the plot.
Choose Plot > Variable Settings. Locate the desired variable and verify that All is selected from the Show Markers pop-
up menu.
 
Color icon is not responding when trying to change the color of the legend text.
By default the color of the legend text is linked to the variable color. To make the text a different color, choose Plot > Text 
Options and clear the Link Text To Variable Color check box.
 
After exporting a plot into another program, the lines are jagged instead of smooth.

If you are copying the image, make sure you use the Copy Graph command and not the Copy Selection
command.

Set the Resolution to 4X Screen or higher.

 
After exporting a plot or layout, the transparent background is lost.
The transparent background can be maintained if you copy the plot to the Clipboard or export in a PNG or TIFF format. 
However if you save it in one of the other formats, the transparent background will be lost.
 
Unable to extract the data or make changes to a saved plot.
The data was not saved with the plot. This can happen if the data was closed prior to saving the plot or if the file type was 
set to KaleidaGraph Picture in the Save dialog.
 
There is no data selected for the plot error message.
The column or selection you are attempting to plot does not contain any data or only contains masked data. Masked cells 
always have a red frame so that they can be easily identified in the data window. The pattern can be removed using the 
Unmask command (Functions menu).
 
Ymin cannot be greater than Ymax error message.

The column or selection you are attempting to plot does not contain any data or only contains masked data. 
Masked cells always have a red frame so that they can be easily identified in the data window. The Unmask
command (Functions menu) can be used to remove the masking.

If you are using a Template plot with fixed minimum limits but auto-scaled maximum limits, the value calculated for 
the maximum may be less than the value set for the minimum. Set the minimum to Auto and try using the 
Template plot again.

 
Text data columns can only be used as the independent plot variable error message.
You are trying to plot one or more Y variables that are formatted as Text in the data window. Use the Column Formatting
command to change the data type from Text to Float or Double.
 
When drawing a line or other object on the plot, only the object handles are visible.
Check the bottom three icons on the toolbox. Either the foreground color is set to white, the pen pattern is set to white or 
None, or the line style is set to None. Any one of these can prevent the object from being visible.
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Unable to choose Template from the Gallery menu.
To use the template feature, a data window must be open and a plot window must be the active window.
 

Problems with Curve Fits
Singular Coefficient Matrix error message
KaleidaGraph could not converge on a solution or it was getting a divide by zero error in the General curve fit. Verify that 
none of the initial guesses are set to 0. Try changing the initial guesses to steer KaleidaGraph away from whatever 
caused the error. You can also try to specify the partial derivatives to point KaleidaGraph in the right direction after each 
iteration.
 
This fit requires the X values to be sorted in ascending order error message.
This error results when you attempt to apply a Smooth, Weighted, Cubic Spline, or Interpolate curve fit to data that does 
not have the independent variable sorted in ascending order. Once the independent variable is sorted using the 
Ascending Sort command (Functions menu), the curve fit can be applied.
 
Syntax error at:
These result when illegal characters or undefined functions are used in a curve fit definition. Some common mistakes 
include using the letter o instead of a zero, having a different number of left and right parentheses, and attempting to call a 
library function that is not defined in the current library. The error message will show a portion of the definition that 
precedes what caused the syntax error.
 
Syntax error in the Macro Library error message.
This error results when the library contains an undefined function. These errors commonly result when opening a saved 
curve fit definition in the library instead of opening it in the General Curve Fit Definition dialog.
 
To return the library to its correct state, choose Macros > Library or Curve Fit > General > Library and open the Library
file (located in the Library folder of the Examples folder). After doing this, make sure you save changes to the Macros 
when quitting KaleidaGraph.
 
Tried to limit the parameter values, but the resulting parameters were outside of the specified limits.
It is possible to get values outside of the limits. During each iteration, KaleidaGraph tries to improve upon the parameter 
values to get the best fit. These new values are not passed through the function to limit their value. The number you are 
seeing is KaleidaGraph’s last best guess at what the value should be. Right now, the only way to avoid this is to replace 
the unknown with a constant.
 
Large error values after applying a General curve fit.
This means that you could get a similar fit using a wide range of values for the parameters. This can happen if you haven't 
collected enough data across a wide range of X values, if the formula is too complicated for your data, or if the formula 
has redundant parameters.
 
Linear Fits on Plots with Log or Semi-Log Scales
When applying a Linear curve fit to data displayed on a log-log or semi-log scale, the curve fit may not appear to be a 
straight line. This is because the divisions along logarithmic axes are not equally spaced. However, it is possible to get the 
appearance of a straight line on plots with either log-log or semi-log scales.
 
You can get the appearance of a straight line on a plot with a log-log scale (both the X and Y axes are logarithmic) by 
applying a Power curve fit to the data. The resulting curve fit will look like a straight line.
 
Getting the appearance of a straight line on a plot with a semi-log scale (either the X or Y axis is logarithmic) depends on 
which axis is logarithmic:

If the X axis is logarithmic (Y axis is linear), applying a Logarithmic curve fit will result in a straight line.
If the Y axis is logarithmic (X axis is linear), applying an Exponential curve fit will result in a straight line.

 

Problems with Formula Entry
Syntax error at:
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This error results when illegal characters or undefined functions are used in a formula. Some common mistakes include 
using the letter "O" instead of a zero, not having the correct number of parentheses and attempting to call a Library 
function when the Library is not currently open. The error message will show a portion of the formula that precedes what 
caused the syntax error.
 
This column does not contain a curve fit error message.
One of the following may be the cause:

The Y column that is specified did not have a curve fit applied to it or a different curve fit was applied to it than the 
one specified in the formula.

The wrong column is specified for the Y column.
You are trying to apply this formula to a saved plot, but you did not extract the data from the graph.

 
After running a formula, the destination column contains incorrect results.
Make sure none of the columns used in the formula (including the destination column) are formatted as Text.
 
Not getting the correct results when typing the results of a curve fit into a formula.
By default, the results of a curve fit are displayed with five significant digits. You can obtain more accuracy by choosing 
Plot > Equation Label Format and increasing the number of digits or decimals. This will make the results of your formula 
more accurate.
 
Another solution is to copy the results of the curve fit to the Calculator. These values are always stored as double 
precision numbers.
 

Problems with the Layout Window
When overlaying two or more plots, they are not transparent.
Activate each of the plots and choose Plot > Axis Options. Click the All tab and verify that Transparent Interior and 
Transparent Background are selected under Colors.
 
This can also happen if the individual cells in the layout have a white fill pattern applied. The fill pattern for each of the 
cells containing a plot should be set to none (N) for the plot to be transparent.
 
Tried to place two plots in the layout window, but only one plot is displayed.
Make sure the first plot is not selected before using the Select Plot command.
 
After exporting a layout, the transparent background is lost.
The transparent background can be maintained if you copy the layout to the Clipboard or export in a PNG or TIFF format. 
However if you save it in one of the other formats, the transparent background will be lost.
 

Other Problems
None of the macros are listed under the Macros menu.
At some point, changes were saved to the default Macros file while this menu was empty. To get the entire list back, 
choose File > Import > Append Macros. Locate and open the Default Macros file (in the Macros folder). All of the 
macros should now be listed in the Macros menu. Remember to save changes to the Macros file before quitting for the 
macros to be available the next time you start KaleidaGraph.
 
Program was working fine before, but now something is strange.
It is possible the default Style file is corrupt. You can test this by quitting KaleidaGraph, renaming this file, and running the 
program. KaleidaGraph does not recognize a renamed Style file and uses its internal defaults.
 
Unknown file version number error message:
You could be trying to open a newer KaleidaGraph file with an older version of the program. Version 5.0 can open any 
KaleidaGraph file, but earlier versions can only open files created by v5.0 if they were exported in an older file format
using the Save As command.
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It is also possible for defective files to display this error message. If the files are stored remotely (flash drive, network 
drive, etc.), you could try copying them to the local computer to see if that helps.
 
Problems opening KaleidaGraph files on another platform.
Check which version of KaleidaGraph is installed. Version 5.0 can open any KaleidaGraph file, but earlier versions can 
only open files created by v5.0 if they were exported in an older file format using the Save As command.
 
Problems opening older KaleidaGraph files.
If you have files that were created in the Mac version prior to OS X, the files will not have any file name extensions. They 
can be added manually or you can try to use the AppleScript converter available on our website.  If the file name 
extension is not added, it will be treated as a text file
 
KaleidaGraph is installed on a server but asks each user to personalize the software.
To have KaleidaGraph installed on a server and not ask each user to personalize the software:

Make sure you are logged in as the administrator of the computer.
Install KaleidaGraph on the server.
Launch the KaleidaGraph application from the server and personalize the software.
Quit out of KaleidaGraph.
Mac version: Move UserInfoV5.xml from the Macintosh HD > Users > (user) > Library > Application Support > 

Synergy Software > KaleidaGraph5.0 folder and KG50License from the Macintosh HD > Users > (user) > 
Library > Preferences > KaleidaGraph Preferences folder and place them in the same folder as the 
KaleidaGraph application.

Windows version: Move UserInfoV5.xml and KG50License from the  \Users\(user)\AppData\Local\Synergy 
Software\KaleidaGraph5.0 directory and place them in the same directory as the KaleidaGraph application.

 

File Errors
Unknown file version number:
You could be trying to open a newer KaleidaGraph file with an older version of the program. Version 5.0 can open any 
KaleidaGraph file, but earlier versions can only open files created by v5.0 if they were exported in an older file format
using the Save As command.
 
It is also possible for defective files to display this error message. If the files are stored remotely (flash drive, network 
drive, etc.), you could try copying them to the local computer to see if that helps.
 
An error occurred while reading the datafile.
If this message appears when trying to open an Excel file, this file may already be open within Excel. You must close the 
file in Excel before opening the file in KaleidaGraph.
 
Bad File Path.
This error appears when the file cannot be found when using the Recent Files command.
 
There was an error in opening the selection.
This error could occur in the Windows version when reading files generated from the Mac version. Look for characters in 
the file name and path that are not valid under Windows.
 

Data Window Errors
Sorry, this transpose requires too many columns.
You are trying to transpose a data selection that requires data columns beyond the 1000 column limit.
 
Both the Title and Data format strings must have the same number of variables.
When using the Special format to import a text file and Read Titles is selected, you must read in the same number of 
column titles as data columns.
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ANOVA Error Messages
Factor B must have at least 2 blocks.
Either this column contains the same value throughout or the values associated with the first group of Factor A are all 
identical.
 
Each cell must have the same number of points.
The number of entries in Factor A are unequal, or the number of entries in Factor B are not equally divided for the groups 
in Factor A, or there are data values missing for the corresponding factors.
 
Using an example of Male and Female for Factor A and Before and After for Factor B:

Factor A contains 8 entries for Male and 8 entries for Female.
Factor B contains 8 entries for Before (4 for Male and 4 for Female) and 8 entries for After (4 for Male and 4 for 

Female).
The dependent column contains the 16 data values that correspond to these conditions.

 
If any one of these is unequal, missing, or masked, this error message is displayed.
If any empty or masked cells are found, the entire row is omitted.
 

Errors When Creating Plots
There is no data selected for the plot.
You are attempting to plot a variable that does not contain any data or only contains masked data in the column or 
selection. Masked cells always have a red frame so that they can be easily identified in the data window.
 
Ymin cannot be greater than Ymax.

The column or selection you are attempting to plot does not contain any data or only contains masked data. 
Masked cells always have a red frame so that they can be easily identified in the data window. The pattern 
can be removed using the Unmask command (Functions menu).

If you are using a Template plot with fixed minimum limits but auto-scaled maximum limits, the value calculated for 
the maximum may be less than the value set for the minimum. Set the minimum to Auto and try using the 
Template plot again.

 
Only one text column may be plotted at a time.
You are trying to create a plot with multiple X variables, but at least one of the columns is formatted as Text. Use the 
Column Formatting command to change the data type from Text to Float or Double.
 
Text data columns can only be used as the independent plot variable.
The Y data is formatted as Text. Use the Column Formatting command to change the data type from Text to Float or 
Double.
 

Curve Fitting Errors
Singular coefficient matrix.
KaleidaGraph could not converge on a solution or it was getting a divide by zero error in the General curve fit. Verify that 
none of the initial guesses are set to 0. Try changing the initial guesses to steer KaleidaGraph away from whatever 
caused the error. You can also try to specify the partial derivatives to point KaleidaGraph in the right direction after each 
iteration.
 
Syntax error in the Macro Library.
This error message means that one of the definitions in the Library contains a syntax error or that a text file was 
inadvertently opened within the Library. If you defined your own constants, variables, or functions, there may be a syntax 
error in the definition, or you may be using a character that is not allowed in the name. It is best to only use letters and 
numbers for the names.
 

To replace the current contents of the Library with the default Macro Library:
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Select the Library command from either the Macros menu or the Curve Fit menu.
Choose File > Open.
Locate and open the Library file within the Library folder and open it.
Click OK or choose File > Close.

 
After doing this, make sure you save the Macros when quitting KaleidaGraph in order for the Library to be saved as part of 
the KG Macros file.
 
This fit requires the X values to be sorted in ascending order error message.
This error results when you attempt to apply a Smooth, Weighted, Cubic Spline or Interpolate curve fit to data which does 
not have the independent variable in ascending order. Once the independent variable is sorted using the Ascending Sort
command (Functions menu), the curve fit can be applied.
 
Sorry, the formula is too long.

The general curve fit definition exceeds the 2000 step limit in the Macro Calculator.
The curve fit definition exceeds the 4096 character limit.

 

Formula Entry Errors
Syntax error at:
This error results when illegal characters or undefined functions are used in a formula. Some common mistakes include 
using the letter "O" instead of a zero, not having the correct number of parentheses and attempting to call a Library 
function when the Library is not currently open. The error message will show a portion of the formula that precedes what 
caused the syntax error.
 
This column does not contain a curve fit.

The Y column that is specified did not have a curve fit applied to it or a different curve fit was applied to it than the 
one specified in the formula.

The wrong column is specified for the Y column.
You are trying to apply this formula to a saved plot, but you did not extract the data from the graph.

 
Sorry, you specified a position that has not been allocated. Please create a row/column before using it.
The formula is attempting to retrieve data from a cell that is outside the range of the current data window. If you are using 
the index() command within the cell() command (for example, cell(index(), 2) = cell(index(), 1) + cell(index()+1, 1)), you 
may need to make an appropriate selection in the data window before running the formula to avoid getting the error.
 
Formula nested too deeply.
You have exceeded the limits of the stack. You have a formula which has more than 24 pending operations. Changing the 
grouping or the order of the calculations can fix this problem.
 
Sorry, this macro definition is too long.
After performing all the necessary Library substitutions, a single formula is more than 4096 characters in length.
 

Plot Script Errors
Sorry, the selected data window does not have enough columns to run this script.
The Plot Script is pointed to a data window that does not have enough columns to complete the script. The order of 
opening these files is important. Open any data windows before opening the script.
 
Too many working directories.
Rename the KG Script file and launch KaleidaGraph again. If the script file was brought over from another machine, save 
a new copy from this machine and try using the new copy.
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Box Plot Definition
Each box encloses 50% of the data with the median value of the variable displayed as a line. The top and bottom of the 
box mark the limits of ± 25% of the variable population. The lines extending from the top and bottom of each box mark the 
minimum and maximum values within the data set that fall within an acceptable range. Any value outside of this range, 
called an outlier, is displayed as an individual point.
 
Note: Outliers are used in the calculations for the Box plot. Removing outliers changes the entire plot. You do not have 

any control over the marker used to represent outliers.
 

 

Median - The data value located halfway between the smallest and largest values.
Upper Quartile (UQ) - The data value located halfway between the median and the largest data value.
Lower Quartile (LQ) - The data value located halfway between the median and the smallest data value.
Interquartile Distance (IQD) - The distance between the Upper and Lower Quartiles (UQ - LQ).
Outliers - Points whose value is either: greater than UQ + 1.5 * IQD or less than LQ - 1.5 * IQD.

 

Statistics Equations
Here are the equations KaleidaGraph uses to calculate the following statistics, where:
n = number of data points

= mean of the data

= current data value (from 1 to n)
 
Mean RMS (Root Mean Square)

Standard Deviation
Standard Error

Variance
Skewness

Kurtosis (Excess Kurtosis)  
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Synergy Software License Agreement
2021 revision This updated license supersedes any previous license issued by Synergy Software.
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This product is published by Synergy Software located at 2457 Perkiomen Ave., Reading, PA 19606-2049 USA -- Phone: 
 (1) 610-779-0522 --  Fax:  (1) 610-370-0548 --  Internet: info@synergy.com -- Website: www.synergy.com
 
IMPORTANT:  READ THIS BEFORE INSTALLING
By installing, copying, or otherwise using this Synergy Software product, you agree to be bound by all the terms and 
conditions of this license agreement. If you do not accept or agree to these terms, do not install, access, or otherwise use 
the software and request a refund within fifteen (15) days from the purchase date.
 
SOFTWARE LICENSE AGREEMENT
Synergy Software grants you a non-exclusive license to use this copy of the program on the following terms:
 
LICENSE
You may:
a. Install and use the program on any single computer dedicated to your sole use, and if desired, install a second copy of 
the program, also for your exclusive use, on a home or portable computer.
b. Or:     Install and use the program from a network server, but only if network monitoring software is employed which 
allows no more than one user per licensed program at any time. The burden of proof for compliance lies with the licensee. 
Shared or networked computer users may not install a second copy of the program on a home or portable computer.
c. Make 1 copy of the program in machine readable form solely for archival purposes, provided that you reproduce all 
proprietary notices on each copy.
 
You may not:
a. Modify, translate, reverse engineer, decompile, disassemble, create derivative works based on, or copy (except for the 
archival copy) the program or the accompanying documentation;
b. Lend, rent, lease, transfer or grant any rights in the program or accompanying documentation in any form to any other 
person without the prior written consent of Synergy Software;
c. Remove any proprietary notices, labels or marks on the program and accompanying documentation.
 
Failure to comply with any of the above restrictions will terminate this license. This license is not a sale. Title and 
copyrights to the program and accompanying documentation and any copies remain with Synergy Software and are 
protected by US and international copyright laws and treaties.
 
USE OF OLDER VERSIONS IF YOU UPGRADED
If you purchase an upgrade from an older version, you may not transfer the license for the older version to another 
computer or to anyone else.
 
LIMITED WARRANTY AND DISCLAIMER
Synergy Software warrants that, for a period of ninety (90) days from the date of purchase, the media on which the 
program is furnished, if any, will be free from defects in materials and workmanship and that the software is properly 
recorded. Synergy Software's entire liability and your exclusive warranty will be to replace the media.
 
Except for the above express limited warranty, Synergy Software and the company's licensor(s) make no warranties or 
conditions expressed, implied, statutory or in any other communication with you, and Synergy Software and the 
company's licensor(s) specifically disclaim any implied warranty or condition of merchantability or fitness for a particular 
purpose. The entire risk as to the quality and performance of the software is borne by you. Some states do not allow the 
exclusion of implied warranties, so the above exclusions may not apply to you. This warranty gives you specific legal 
rights. You may also have other rights which vary from state to state.
 
LIMITATION OF LIABILITY
In no event will Synergy Software and the company's licensor(s) be liable for any damages, lost profit, lost data, loss of 
use, including but not limited to special, incidental, consequential or indirect damages, arising from the use of the 
program, however caused and on any theory of liability, even if Synergy Software and the company's licensor(s) have 
been advised of the possibility of such damages. You acknowledge that the license fee reflects this limitation of liability. 
Some states do not allow the limitation or exclusion of liability for incidental or consequential damages, so the above 
limitation may not apply to you.
 
GENERAL
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This Agreement is the entire agreement. If any provision of this Agreement is held invalid, the remainder of this Agreement 
shall continue in full force and effect.
 

zlib
zlib.h -- interface of the 'zlib' general purpose compression library
version 1.2.6, January 29th, 2012
 
Copyright (C) 1995-2012 Jean-loup Gailly and Mark Adler
 
This software is provided 'as-is', without any express or implied warranty. In no event will the authors be held liable for any 
damages arising from the use of this software.
 
Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it 
and redistribute it freely, subject to the following restrictions:

The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If 
you use this software in a product, an acknowledgment in the product documentation would be appreciated 
but is not required.

Altered source versions must be plainly marked as such, and must not be misrepresented as being the original 
software.

This notice may not be removed or altered from any source distribution.

 
Jean-loup Gailly        Mark Adler
jloup@gzip.org          madler@alumni.caltech.edu
 

Expat
Copyright (c) 1998, 1999, 2000 Thai Open Source Software Center Ltd and Clark Cooper
Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006 Expat maintainers.
 
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated 
documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to 
use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to 
whom the Software is furnished to do so, subject to the following conditions:
 
The above copyright notice and this permission notice shall be included in all copies or substantial portions of the 
Software.
 
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING 
BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND 
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, 
DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING 
FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE 
SOFTWARE.
 

Contact Information
If you have any questions concerning KaleidaGraph, please contact us at:
 
Synergy Software
2457 Perkiomen Avenue
Reading, PA 19606
 
Tel: 610-779-0522
Fax: 610-370-0548
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Internet addresses:
Sales/Upgrades: orders@synergy.com
Technical Support: support@synergy.com
 
Website: www.kaleidagraph.com

www.synergy.com
 

Please take the time to register your program during installation to receive free technical support and upgrade information. 
You can also register by accessing the registration page on our website.
 
Please feel free to check our website periodically for:

Product descriptions
Technical notes
Frequently asked questions
New release information
Maintenance updates
And other topics of interest
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Index
- 70
! 70
!= 70
( ) 70
[ ] 70
* 70
/ 70
&& 70
#CLEAR 202
#CLEARDATA 202
#CLOSE 202
#CLOSE/ALL 202
#CLOSE/OPT 203
#COPY 203
#CUT 204
#DATA 204
#DATA/NOTITLE 204
#DATAFILE 205
#FORMULA 205
#MERGEFILE 206
#METAFILE 206
#METAFILE/OPT 207
#OPEN 207
#PAGE_PRINT 207
#PASTE 208
#PICT 208
#PICT/OPT 208
#PLOT_PRINT 209
#SAVE 209
#SCRIPT 210
#SELECTION 214
#SET_DIRECTORY 214
% 70
^ 70
+ 70
= 70
== 70
|| 70
abs() function 73
Add button 95
adding a background or border to layout 192
adding a curve fit to the master list 168
adding a macro from the calculator 229
adding axis break 109
adding comments 70
adding data to a plot 124
adding drop lines 119
adding empty cells to a layout 191
adding error arcs 183
adding error bars 181
adding error bars from a data column 181

adding labels to data points 182
adding lines to Bar charts 126
adding plots to a layout 191
adding rows and columns 26
adding single-sided error bars 182
adding special characters to text 141
adding subscripts and superscripts 141
adding text error bars 182
adding value labels to Bar plots 126
adding value labels to Histogram plots 125
adding value labels to Pie charts 128
adjusted Alpha value 62
adjusted R^2 value 175
advanced formulas 69
Align tool 134
aligning objects 139
Allowable Error field 156
analysis of variance 42

entering data 53, 45, 53, 46, 46
one way 45, 49, 50
one way repeated measures 53, 56, 57
reference 260
two way 45, 51, 51
two way repeated measures 53, 57, 58

analyzing one sample 43, 43, 44
analyzing repeated measurements 53, 53, 55, 56, 56, 57, 
57, 58, 59
analyzing two or more groups 45, 46, 46, 48, 49, 49, 49, 
50, 51, 51, 52
Anchor Tick field 124
angular axis 127
annotating markers 119
ANOVA 42

entering data 53, 45, 53, 46, 46
one way 45, 49, 50
one way repeated measures 53, 56, 57
reference 260
two way 45, 51, 51
two way repeated measures 53, 57, 58

AppleScript 16
applying a curve fit 152, 152, 153, 153, 153, 154, 154, 
154, 155, 171
Arc tool 132
arcs 132

adding error arcs 183
creating and editing 145

arranging data for group comparison tests 45, 46, 46
arranging data for one sample tests 43
arranging data for plots 96
arranging data for repeated measurements 53, 53
arranging plots in the layout window 192
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Arrow tool 131
arrowheads 143
arrows 143
aspect ratio 191, 243
assigning formulas to function buttons 67
automating KaleidaGraph 197, 200
axes 106

changing position 108, 108, 108, 109, 109, 107
exchanging 112
linking 116, 115
modifying 106
moving 108, 108, 108, 109, 109, 107
offset 108

axis 107
angular 127
hiding 112
linking a second axis 116, 115
position 108, 108, 108, 109, 109, 107
radial 127
removing 112
resizing 122, 122
reversing 112

axis break 109, 110, 110, 111, 111
axis color 112
axis labels 20, 116

editing 140
formatting 116
frequency 116
removing 116
reversing 112

axis limits 106, 136
axis scaling 107
axis thickness 113
axis titles 20, 140
background - adding to a layout 192
background color 121, 147
background color of data window 29
Background Color setting 29
Bar charts 88, 89, 89, 90, 91, 91, 92, 92, 126
Bezier curve tool 133, 145
Bezier curves 145
Bin Data command 125
Binary Mode command 37, 252
binning data 41
Bitmap files 187
Black Column Frame check box 125
Bonferroni test 60, 61, 260
border - adding to a layout 192
Box plot 86, 124, 259
Box tool 132, 144
break 109

axis 110, 111, 111, 109, 110

variable line 32
bubble legend 124
Bubble plot 83, 124
calculating curve fit values 177
calculating statistics 67
calculations with date and time data 68
Calculator commands 227
canceling a curve fit 252
cap width 184
cell 26

entering data into 31
going to a cell 26
using specific cells in formulas 66

cell() function 66, 73
cells - selecting 26
changing axis color 112
changing axis limits 106, 136
changing axis position 107, 108, 108, 108, 109, 109
changing axis scaling 107
changing axis thickness 113
changing cap length 184
changing column width 28
changing data format 37
changing data window background color 29
changing data window font and style 29
changing fill and pen patterns 148
changing foreground and background colors 147
changing grid line color 114
changing grid line style 113
changing grid line thickness 115
changing legend text color 106
changing line styles and widths 148
changing magnification 103, 195
changing markers 117
changing plot color 121
changing row height 29
changing tick mark color 114
changing tick mark interval 114
changing tick mark length 115
changing tick mark thickness 115
changing tick marks 113, 114
Character Map 141
characters - non-keyboard 141
Chi Square 175
choosing a curve fit model 152
choosing a post hoc test 60
choosing a statistical test 42
circles 144
clearing data 37
closing data windows 25
closing plot windows 103
cmax() function 75
cmin() function 75
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CMYK 16
coefficients 174
color 118

axis color 112
box frame 124
curve fit equation 179
drop lines 119
error bars 184
fill pattern 118
grid lines 114
Pie chart frame 128
plot color 121
tick marks 114
variable and curve fit lines 118

Color icon 147
Column Formatting palette 27
column frame 126
column numbers 30, 66
Column Offset field 124
Column plot 91, 126
column titles 37
column width 28
columns 28

adding 26
changing column width 28
changing the data format 37
deleting 26
editing column titles 37
inserting 26
referencing in formulas 66
selecting 26
transposing data 38

comments 70, 201, 219
conditional testing 70
confidence bands 180
confidence limits 60, 61, 63, 64, 175
confidence values 177
constants 220
constraining parameters 172
constraining shape of objects 138, 185
coordinates 134
copying confidence values to data window 177
copying coordinates 134
copying curve fit coefficients 176
copying curve fit values to data window 176
copying data 37
copying layouts 193
copying objects 139
copying plots 187
copying predicted values to data window 177
copying residuals to data window 177
corr() function 73
correlation coefficients 174

cos() function 73
creating arcs 145
creating arrows 143
creating Bezier curves 145
creating circles 144
creating data series 32
creating formula scripts 200
creating formulas 65
creating lines 143
creating new data window 25
creating new layout 191
creating new library 223
creating ovals 144
creating plot script 197
creating plots 79, 79, 80, 80, 81, 81, 82, 83, 83, 84, 84, 
85, 86, 87, 88, 88, 89, 90, 91, 91, 92, 92, 93, 93, 96, 98
creating polygons 144
creating rectangles 144
creating rounded rectangles 144
creating similar plots 98
creating squares 144
creating tables 133
creating text labels 140
csum() function 75
Cubic Spline curve fit 151, 154, 260
curve fit coefficients 173, 176
curve fit definitions 158, 159, 159, 160, 161, 161, 162, 
163, 163, 164, 165, 165, 166, 167, 167

constructing 155
defining in the library 221
entering a custom definition 169
entering the definition 170, 170, 170
multiple independent variables 172

curve fit equation 173
changing format 179
correlation coefficient display 174
displaying 173
editing 179, 173

curve fit functions 76
curve fit lines 178
Curve Fit menu 169, 252
curve fit model 152
curve fit points 179
curve fit references 260
curve fit results 173

Chi Square 175
copying confidence values to data window 177
copying curve fit values to data window 176
copying predicted values to data window 177
copying residuals to data window 177
copying to Calculator 176
copying to Clipboard 176
correlation coefficients 174, 173



KaleidaGraph 5.0 User Guide

Page 267

displaying the equation 173
editing the equation 179, 173
exporting to data window 175
parameter errors 174

curve fitting 171
applying a curve fit 171
Chi Square 175
choosing a model 152
confidence values 177
correlation coefficients 174, 173
defining curve fits in the library 221
displaying only the curve fit 180
displaying the equation 173
editing the equation 173
exporting results 176, 176, 177, 177, 175
extrapolating to the axis limits 179
forcing a Linear fit through the origin 179
increasing the number of curve fit points 179
multiple independent variables 172
obtaining values 177
parameter errors 174
predicted values 177
removing a curve fit 178
residuals 177
setting parameter limits 172
specifying partial derivatives 172
troubleshooting 254
weighting data 171

customizing Bar plots 126
customizing Bubble plots 124
customizing Dot plots 126
customizing Pie charts 128
customizing Polar plots 127
cutting data 37
data 31

arranging 96, 53, 45, 43, 46, 46
binning 41
clearing 37
copying 37
creating a series 32
cutting 37
entering 45, 43, 53, 31, 31, 32
extracting 123
formatting 37
interpolating 68
masking 135, 38, 68
missing values 34, 32, 119
opening 33, 33, 33
pasting 37
plotting 124, 97, 97
printing 40
reorganizing 42
saving 39

selecting subset of data 136
sorting 38
statistics 41
transposing 38
unmasking 38

Data Format field 34
Data Selection tool 135, 135, 136
data window overview 19
data window shortcuts 242
data window toolbar 241
data windows 25

adding rows and columns 26
background color 29
changing column width 28
changing data format 37
changing font and style 29
changing row height 29
clearing data 37
closing 25
column numbers 30
copying confidence values into 177
copying curve fit values into 176
copying data 37
copying predicted values into 177
copying residuals into 177
creating a new data window 25
cutting data 37
deleting rows and columns 26
displaying 25
editing column titles 37
entering data 31, 31, 32
extracting 123
going to a cell 26
hiding 25
inserting rows and columns 26
making selections 26
moving around 25
opening 33
opening text files 33
pasting data 37
plotting 97, 97
printing 40
saving 39
setting defaults 29
splitting 30
switching between Overwrite and Insert Mode 31
transposing data 38
troubleshooting 252

dates 31
entering dates 31
performing date calculations 68
tick mark intervals 114
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DDE 16
debugging a macro 228
default attributes 142

data window 29, 21
legend frame 105
plot layouts 122, 122, 21, 99
shapes 147
tables 133
text labels 142

Define Layout command 21
defining constants in library 220
defining curve fits in the library 170, 221
defining custom General curve fit equation 169
defining General curve fit equation 170, 170, 170
defining mathematical functions 220
defining plot layouts 99, 122, 122
defining structure of text file 34
defining variables in library 219
Degree Mode setting 229
degrees of freedom 44, 48, 50, 51, 57, 58
Delete button 95
deleting items from the layout 195
deleting items in legend 134
deleting objects 139
deleting rows and columns 26
deselecting objects 137
Device Independent Bitmap 186
dialog shortcuts 242
diff() function 73
displaying bars instead of markers 120
displaying column numbers 30
displaying coordinates 134
displaying curve fit coefficients 173
displaying curve fit equation 173
displaying data used to create a plot 123
displaying data windows 25
displaying error arcs 183
displaying grid lines 113
displaying grids in the layout window 195
displaying grids in the plot window 103
displaying layout window 191
displaying only the curve fit 180
displaying only the error bar cap 183
displaying plot windows 103
displaying rulers 103, 195
displaying tick marks 113
Dot plot 87, 126
Double X plot 80
Double XY plot 81
Double Y Bar plot 89, 126
Double Y Column plot 92, 126
Double Y plot 80
dpi 188

Draw Column Frame check box 125
Draw Duplicates as a Line check box 126
drawing shapes 143, 143, 144, 144, 144, 144, 145, 145
drop lines 119
Dunnett test 60, 64, 260
duplicate categories 97
duplicating objects 138
Dynamic Data Exchange 16
EC50 curve fit definitions 161
Edit button 95
Edit Program button 227, 228
Edit String Dialog 243
editing arcs 145
editing arrowheads 143
editing arrows 143
editing axis labels 116, 116, 140
editing axis titles 140
editing Bezier curves 145
editing circles 144
editing column titles 37
editing curve fit equation 173, 179
editing data format 37
editing data on a plot 123
editing display of curve fit lines 178
editing display of variable lines 118
editing grid lines 115
editing keyboard shortcuts 241
editing legend 104, 105, 106
editing lines 143
editing macros 229
editing marker color 117
editing marker size 117
editing marker type 117
editing master curve fit list 168
editing number of markers displayed 117
editing OLE objects 190
editing ovals 144
editing plot color 121
editing plot labels 140
editing plot symbol 117
editing plot titles 140
editing polygons 144
editing rectangles 144
editing rounded rectangles 144
editing squares 144
editing tables 133
editing text labels 140
editing tick mark length 115
editing tick mark thickness 115
editing value labels 140
embedding OLE objects 189, 189, 190
enhanced Metafile images 186
entering column titles 37
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entering custom curve fit equation 169
entering data 31, 31, 32, 43, 45, 53
entering formulas 66
entering Greek symbols 141
Enzyme Kinetics definitions 158
equations 259

Chi Square 175
constructing 155
defining in the library 221, 170
editing 179, 173
entering 169, 170, 170, 170
Friedman test 59
initial conditions 156
Kruskal-Wallis test 52
kurtosis 259
mean 259
multiple independent variables 172
plotting 98
R value 174
rms 259
setting parameter limits 172
skewness 259
standard deviation 259
standard error 259
statistics equations 259
t-test 44, 48
variance 259
Wilcoxon-Mann-Whitney test 49

Eraser tool 134
erf() function 73
erfc() function 73
error arcs 183
error bars 181

adding 181
annotating markers 119
cap length 184
color 184
displaying only the cap 183
error arcs 183
plotting values from a column 181
removing 184
single-sided 182
text error bars 182
thickness 184
X and Y error bars 181

errors 174
Excel files 33
excess kurtosis 259
exchanging axes 112
exchanging files 22
execute() function 77
executing formulas 66
executing macros 39

Exit command 23, 242
exp() function 73
Expand/Collapse button 30, 66
exploded Pie chart 128
Exponential curve fit 151, 153, 260
exponential decay definitions 159
exponential growth definitions 159
exponential rise definitions 160
Export All Curve Fits command 175
exporting curve fit results 175
exporting data 22, 39
exporting graphics 187, 193
exporting layouts 22, 193, 193
exporting plots 22, 186
exporting plots to the Clipboard 187
exporting plots via a script 200
exporting plots without data 186
exporting Script file 200
exporting text files 39
exporting tips 188
expr() function 76
Extract button 20, 98, 124, 194, 195
extracting data 123
extrapolating curve fits 179
F probability 48
F value 48, 50, 51, 57, 58, 175
factorial 70
file formats 186
file name extensions 22
File Settings tab 21
files 33

exchanging 22
opening 33, 33

fill pattern 118, 148
Fill plot 83
filter() function 68
Fisher's LSD test 60, 63, 260
Floating Bar plot 90, 126
Floating Column plot 92, 126
font 29, 140, 142
foreground color 147
formatting axis labels 116
formatting data 37
Formula Entry 65

advanced formulas 69
assigning formulas to function buttons 67
basics 65
calculating statistics 67
curve fit functions 76
entering and executing a formula 66
formula scripting 200, 201
formula structure 65
function description and syntax 70
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interpolating data 68
masking data 68
math functions 73
multi-line formulas 70, 69, 70
obtaining values from a curve fit 177
operators 70
performing date and time calculations 68
referencing columns and memory registers 66
special functions 77
statistics functions 75
troubleshooting 254
using specific cells in formulas 66
variables 73

Formula Entry shortcuts 252
formula scripting 100, 200, 201
formulas 66

advanced 69
assigning to function buttons 67
calculating statistics 67
curve fit functions 76
entering and executing 66
formula structure 65
interpolating data 68
masking data 68
math functions 73
multi-line formulas 70, 69, 70
obtaining values from a curve fit 177
operators 70
performing date and time calculations 68
referencing columns and memory registers 66
special functions 77
statistics functions 75
storing 67
using specific cells in formulas 66
variables 73

fract() function 73
frequency of axis labels 116
Friedman statistic 59
Friedman test 42

entering data 53, 53
interpreting results 59
reference 260
running a test 59

function buttons 67
function description 70
Function plot 94, 98
Gallery menu 252
gap in variable line 119
gen() function 76
General curve fit 171

adding curve fits 168
applying 171

Chi Square 175
constructing equation 155
defining equations in library 221
description 151
entering a custom curve fit equation 169
entering the curve fit equation 170, 170, 170
function description and syntax 70
General Curve Fit Definition dialog 156
initial conditions 156
master curve fit list 168, 168, 168, 169
math functions 73
multiple independent variables 172
operators 70
parameter errors 174
partial derivatives 172
reference 260
removing a curve fit definition 169
results in Macro Calculator 173
setting parameter limits 172
statistics functions 75
using library definitions 170
variables 73
weighting data 171

General Curve Fit Definition Dialog 156
General submenu 168, 169
generating a series 32
generating random numbers 33
graphics 187

exporting 187, 193
importing 185

grayscale images 188
Greek symbols 141
grid line color 114
grid lines 20, 113, 115
grids in layout window 195
grids in plot window 103
Group Layout file 194, 194, 194, 195, 240
Group1 U 49
Group2 U 49
grouped data 42
grouping objects 139
height of row in data window 29
help files 22
Hide Posted Note command 30
hiding axes 112
hiding axis labels 116
hiding data windows 25
hiding grid lines 113
hiding grids 103, 195
hiding plot windows 103
hiding rulers 103, 195
hiding tick marks 113
High/Low plot 81
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Histogram plot 85, 125
Holm test 60, 62, 260
Home button 25
Horizontal Bar plot 88, 126
hyperbola definitions 161
IC50 curve fit definitions 161
Identify tool 134
if-else function 70
Import command 21, 170
Import from file button 34
importing curve fit definitions 170, 170
importing data files 33
importing Excel files 33
importing graphics 185
importing missing data 34
importing plots 185
importing plots into layout window 191
importing Script files 200
importing text files 33
increasing number of curve fit points 179
independent t-test 48
index() function 73
indexed data 42, 45, 46, 53
initial conditions 156
inorm() function 73
inserting axis break 109, 110, 111, 111
inserting OLE objects 189, 190
inserting rows and columns 26
installing 15
int() function 73
interior color 121
interp() function 76
Interpolate curve fit 151, 155, 260
interpolating data 68
interval 114
invcos() function 73
invsin() function 73
invtan() function 73
JPEG files 186, 187, 193
justification 29
Kendall's Concordance 59
keyboard shortcuts 25, 241
Keyboard Viewer 141
KG Layout 240
KG Macros 169, 230, 240
KG Prefs 239
KG Script 241
KG Style 239
Kruskal-Wallis statistic 52
Kruskal-Wallis test 42

entering data 45, 46, 46
interpreting results 52
reference 260

running a test 52
kurtosis equation 259
kurtosis() function 75
labels 140

adding subscripts and superscripts 141
creating 140
editing 140
modifying axis labels 116, 116
setting defaults 142

launching KaleidaGraph 19
layering objects 140
Layout file 194, 194, 194, 195, 240
layout window 191

adding a background or border 192
adding empty cells 191
arranging plots 192
copying 193
creating new layout 191
deleting items 195
displaying 191
exporting 193
grids 195
magnification 195
opening saved layout files 194
overlaying plots 192
placing plots in the layout 191
printing 194
rulers 195
setting plot size and position 191
switching between layouts 195
troubleshooting 255

layout window toolbar 241
Least Squares curve fits 151
legend 104

changing fill and pen patterns 104
changing foreground and background color 104
changing legend text color 106
changing line styles and widths 105
defining in a plot script 198
deleting items in legend 134
editing legend text 106, 105
editing text 140
modifying the legend 104
moving 138
moving text labels 106, 140
order of variables 104, 20
removing frame 105
resizing 138
setting legend frame defaults 105

length of tick marks 115
Levels pop-up menu 124
library 219
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creating new library 223
defining constants 220
defining curve fits 221
defining mathematical functions 220
defining variables 219
importing curve fit definitions 170
loading saved library file 223
overview 219
saving 223
syntax 219

license agreement 260, 262, 262
limits 106

axis limits 106
parameters 172

lin() function 76
Line Color pop-up menu 124
Line plot 79
line style 118

curve fit 178
drop lines 119
legend 105
objects 148
variable 118

line thickness 113, 115, 118, 118, 124, 126, 148, 178, 184
Line Thickness field 124, 125
Line tool 131, 143, 143
line width 118

curve fit 178
drop lines 119
legend 105
objects 148
variable 118, 118

Linear Correlation Coefficient 174
Linear curve fit 151, 152, 179, 260
Linear curve fit statistics 175, 260
linear interpolation 68
linear scaling 107
lines 143

adding to Bar/Column plots 126
creating 143
editing 143

Link Text To Variable Color check box 124
Link To pop-up menu 113, 115, 116
linking axes 115, 116
ln() function 73
log() function 73
Logarithmic curve fit 151, 153, 260
logarithmic definitions 162
logarithmic scaling 107
logr() function 76
Macro Calculator 173, 176, 225, 225, 225, 226, 226, 227, 
227, 228, 229, 229, 230

Macro Calculator commands 230, 230, 231, 231, 232, 
232, 234, 234, 235, 237, 238, 238
macro() function 77
macros 39

adding 229
creating 228
debugging 228
editing 229, 227
executing 39
reordering 229

Macros file 169, 170, 230, 240
saving library 223

Macros menu 229, 229, 229, 230
magnification level 103, 195
major grids 113
major ticks 20, 113, 114, 114
making notes about the data 30
making selections 26, 137
Mann-Whitney test 42

entering data 45, 46, 46
reference 260
results 49
running a test 49

markers 117
annotating 119
displaying as bars 120
number of markers 117
overlaying 121
size 117
thickness 118
type 117
using letters 120

mask() function 68, 77
masking data 38, 68, 135, 135
master curve fit list 168, 168, 168, 169
math functions 73
mathematical functions - defining in library 220
matrix operator 67, 70
Max Size field 124
Maximum field 124
mean difference 44, 48, 60, 61, 61, 62, 63, 63, 64
mean equation 259
mean line 126
mean square 50, 51, 57, 58
mean() function 75
median difference 45, 49, 56
median line 126
median() function 75
memory registers 66
Metafile images 187, 193
Microsoft Excel 33
Minimum field 124
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minor grids 113
minor ticks 20, 113, 114
Missing Data Breaks check box 119
missing data points 32, 34
mod function 70
modifying arrowheads 143
modifying arrows 143
modifying axes 106, 107, 108, 108, 109, 110
modifying axis position 107, 108, 108, 108, 109, 109
modifying plots in group layout 195
moving an axis 107, 108, 108, 108, 109, 109
moving in the data window 25
moving legend 138
moving legend text 106, 140
moving objects 138
moving objects to front/back 140
moving pie slices 128
moving plots 138
moving text labels 138
multi-line formulas 69, 70, 70
multiple comparisons 60, 60, 61, 61, 62, 63, 63, 64
multiple data sets 97
multiple independent variables 172
multiple panes in data window 30
multiple X-Y pairs 97
name() function 77
natural log scaling 107
network install 15, 255
New button 95
nonlinear curve fit 151
nonparametric tests 43, 44, 49, 52, 56, 59
norm() function 73
notes 30
npts() function 75
Object Linking and Embedding 189, 190, 190
objects 138

aligning 139
constraining shape 185, 138
copying 139
deleting 139
deselecting 137
duplicating 138
grouping and ungrouping 139
layering 140
moving 138
pasting 139
resizing 185, 138
selecting 137
sending up or down 140

obtaining values from a curve fit 177
offset 122, 191
offset axes 107, 108
OLE 189, 190, 190

one sample t-test 43
one way ANOVA 42

entering data 45, 46, 46
interpreting results 50
reference 260
running a test 49

one way repeated measures ANOVA 42
entering data 53, 53
interpreting results 57
reference 260
running a test 56

Open command 21
opening data files 33
opening Excel files 33
opening graphics 185
opening layout files 194
opening library file 223
opening plots 185
opening script files 200
opening text files 33
operators 70
origin 179
outliers 135, 135, 259
Oval tool 132, 144
ovals 144
Overlay Markers command 121
overlaying markers 121
overlaying plots 192
P value 44, 45, 48, 49, 50, 51, 52, 56, 57, 58, 59, 60, 61, 
61, 62, 63, 63, 64, 175
P value method 56
paired t-test 42

entering data 53, 53
running a test 55

parameter errors 174
parameter limits 172
parameters - initial conditions 156
parametric tests 43, 43, 48, 49, 51, 55, 56, 57
partial derivatives 172
Paste w/Titles command 33
pasting 139, 185
PDF files 186, 187
peak definitions 163
pen pattern 148
Percentile plot 86, 124
pi function 73
Pie chart 93, 128
plot scripts 197

creating 197
exporting plots 200
pattern recognition 199
pointing groups to different data windows 199
saving and loading scripts 200
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setting titles and legends 198
using 197

plot symbol 117
plot title 20

adding special characters 141
adding subscripts and superscripts 141
defining in a plot script 198
editing 140
setting defaults 142

plot window overview 20
plot window shortcuts 243
plot window toolbar 241
plot windows 103

changing magnification 103
closing 103
displaying 103
grids 103
hiding 103
importing images into 185
resizing 121, 122, 122
rulers 103

plots 96
adding data 124
adding drop lines 119
adding error arcs 183
adding error bars 181, 182, 182, 181, 181
adding to layout window 191
annotating markers 119
arranging in layout window 192
axis break 110, 111, 111, 109, 110
axis position 108, 108, 108, 109, 109, 107
changing plot color 121
creating 83, 91, 96, 87, 80, 81, 92, 80, 83, 90, 92, 81, 
85, 88, 79, 86, 93, 98, 93, 84, 79, 89, 91, 82, 88, 84
creating text labels 140
curve fitting 168, 180, 178
defining layout 99
displaying coordinates 134
editing text 140
exporting 189, 187, 190, 189, 187, 200
extracting data from a plot 123
modifying axes 112, 113, 112, 112, 116, 115, 106, 112, 
107, 106
modifying axis labels 116, 116
modifying fill patterns 118
modifying grid lines 113, 114, 115
modifying in group layout 195
modifying lines 118, 178
modifying markers 117
modifying the legend 104, 105
modifying tick marks 113, 114, 114, 114, 115, 115
opening 185
overlaying 192

plotting from multiple data sets 97
plotting multiple X-Y pairs 97
printing 185
removing error bars 184
removing outliers 135, 135
resizing 122, 122
saving 186, 186
selecting subset of data 136
similar 98
troubleshooting 253
updating 123
using letters as markers 120

plotting a function 98
plotting additional data 124
plotting confidence bands 180
plotting duplicate categories 97
plotting error values from a data column 181
plotting from multiple data sets 97
plotting missing values 119
plotting multiple X-Y pairs 97
PNG files 186, 187, 193
Polar plot 93, 127
poly() function 76
Polygon tool 132, 144
polygons 144
Polynomial curve fit 151, 152, 260
polynomial definitions 163
position 107

axis 108, 108, 108, 109, 109, 107
axis break 109

position of plots in layout 191
post hoc tests 60, 60, 61, 61, 62, 63, 63, 64
Posted Note 30

data window 30
Formula Entry 200

Posted Note button 30, 69
pow() function 76
Power curve fit 151, 153, 260
power definitions 164
precision 179
predicted values 177
Preferences command 21
printing data 40
printing layouts 194
printing plots 185
printing plots via a plot script 200
Probability plot 84
q test statistic 60, 61, 64
Quit KaleidaGraph command 23, 242
R value 174
R^2 value 174
radial axis 127
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ran() function 33, 73
Random# macro 33
raster images 186
rational definitions 165
raw data 45, 46, 53
reading coordinate values 134
rearranging the master curve fit list 168
Recent Files command 21, 256
rectangles 144
references 260
removing axes 112
removing axis break 110
removing axis labels 116
removing curve fits 169, 178
removing error bars 184
removing frame in Pie chart 128
removing outliers 135, 135
reordering the Macros menu 229
reorganizing grouped data 42
residuals 177
resizing axes 122
resizing legend 138
resizing objects 138, 185
resizing plots 122, 122
resizing Variable Selection Dialog 95
resolution 186, 188, 188
results 175

curve fit 179, 175, 177, 176, 176, 177, 177, 174, 173, 
175, 174, 173
Friedman test 59
Kruskal-Wallis test 52
one way ANOVA 50
one way repeated measures ANOVA 57
single sample t-test 44
two way ANOVA 51
two way repeated measures ANOVA 58
unpaired t-test 48
Wilcoxon matched pairs test 56
Wilcoxon signed rank test 45
Wilcoxon-Mann-Whitney test 49

Reverse Order check box 124
right-mouse button 241
rms equation 259
rms() function 75
Root Mean Square 259
Rounded Rectangle tool 132, 144
rounded rectangles 144
rows 26

adding 26
changing height 29
deleting 26
inserting 26
selecting 26

transposing data 38
RPN programming commands 230, 230, 231, 231, 232, 
232, 234, 234, 235, 237, 238, 238
rsum() function 73
rulers 103, 195
Run mode 228
running sum 73
S test statistic 63
Save to file button 34
saving changes to the Curve Fit menu 169
saving changes to the Macros menu 230
saving data 22, 39
saving graphics 22, 187, 193
saving group layout 194
saving layouts 22, 194
saving library file 223
saving multi-line formulas 70
saving plots 22, 186, 186
saving Script file 200
saving text files 39
Scale pop-up menu 124
scaling 107
Scatter Duplicate Points check box 126
Scatter Overlapping Points check box 126
Scatter plot 79
Scheffe test 60, 63, 260
scientific notation 31
Script file 200, 241
script() function 77
scripting 197, 200
selecting a range of cells 26
selecting a statistical test 42
selecting columns 26
selecting entire data window 26
selecting fill patterns for variables 118
selecting objects 137
selecting rows 26
selecting subset of data 136
selecting variables in the Variable Settings Dialog 117
Selection Arrow 108, 122, 131
sending objects up or down 140
series 32
Set Plot View command 103, 195
setting axis limits 106
setting defaults 21, 29, 99, 105, 122, 122, 133, 142, 147
setting legends in a plot script 198
setting limits on parameters 172
setting plot size and position 191
setting titles in a plot script 198
settings files 239
shapes 143, 143, 144, 144, 144, 144, 145, 145, 147
sharing files 22
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shortcuts 241, 241, 242, 242, 242, 243, 243, 244, 244, 
245, 247, 249, 251, 252, 252, 252
Show Column Numbers check box 19, 66
Show Posted Note command 30
Show Variable Mean check box 126
Show Variable Median check box 126
sigmoidal definitions 165
sin() function 73
single sample t-test 42

entering data 43
interpreting results 44
running a test 43

single-sided error bars 182
Single-Step mode 228
size 191

markers 117
plot size 122, 122, 191

skew() function 75
skewness equation 259
Smooth curve fit 151, 154, 260
smooth() function 76
smoothing curve fits 151
sorting data 38
special characters 141
Special format 34, 35, 36
special functions 77
Specify Partials check box 156
specifying structure of text file 34
spline() function 76
splitting the data window 30
sqrt() function 73
squares 144
Stack Bar plot 89, 126
Stack Column plot 91, 126
standard deviation equation 259
standard error equation 259
standard errors 175
statistical tests 42

analyzing one sample 43, 43, 44
analyzing repeated measurements 53, 59, 56, 55, 57, 
56
analyzing two or more groups 45, 52, 49, 51, 49, 48
choosing 42
entering data 53, 45, 43, 53, 46, 46
interpreting results 59, 52, 50, 57, 44, 51, 58, 56, 45, 49, 
48
nonparametric 43
parametric 43
reference 260

statistics 41
calculating with Formula Entry 67
Linear curve fit 175
transposing 41

viewing column statistics 41
Statistics command 259
statistics equations 259
statistics functions 75
std() function 75
stderr() function 75
Step plot 82
storing formulas 67
Student t command 260
Student-Newman-Keuls test 60, 61, 260
Style file 99, 239
Style icon 148
subscripts 141
sum of Group 1 ranks 49
sum of Group 2 ranks 49
sum of negative ranks 45, 56
sum of positive ranks 45, 56
sum of squares 50, 51, 57, 58
Summary Column plot 88, 126
superscripts 141
SVG files 186, 187
switching between layouts 195
switching between Overwrite and Insert Mode 31
Symbol font 141
symbols 117

thickness 118
syntax 70, 155, 201, 219
system requirements 15
t probability 44, 48
t value 44, 48, 61, 62, 63, 175
t-tests 42

entering data 53, 45, 43, 53, 46, 46
equations 44, 48
interpreting results 44, 48
paired data 53, 55
reference 260
single sample 43, 43
unpaired data 45, 48

Table tool 133, 133
table() function 68, 73, 172
tables 133, 133
tan() function 73
Template plot 94, 99
tests 42

analyzing one sample 43, 43, 44
analyzing repeated measurements 53, 59, 56, 55, 57, 
56
analyzing two or more groups 45, 52, 49, 51, 49, 48
choosing a statistical test 42
entering data 53, 45, 43, 53, 46, 46
interpreting results 59, 52, 50, 57, 44, 51, 58, 56, 45, 49, 
48
nonparametric 43
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parametric 43
text data 32
text error bars 182
Text File Input Format Dialog 35, 36
text files 33

exporting 39
opening 33, 35, 36

text labels 140
adding special characters 141
adding subscripts and superscripts 141
creating 140
editing 106, 105, 140, 116, 115
moving 138
setting defaults 21, 142

Text Mode command 37, 252
Text Options command 21
Text plot 94
Text tool 131, 140, 140, 243
thickness 118

axis 113
box frame 124
column frame 126
error bars 184
grid lines 115
markers 118
tick marks 115
variable lines 118

tick mark appearance 113
tick mark color 114
tick mark interval 114
tick mark length 115
tick mark thickness 115
tick marks 20, 115

number of 114
TIFF files 186, 187, 193
time data 31

entering times 31
performing time calculations 68
tick mark intervals 114

tips for exporting graphics 188
Title Format field 34
titles 140

adding special characters 141
adding subscripts and superscripts 141
defining in a plot script 198
editing 140
setting defaults 142

toolbar 241
toolbox 131, 244, 245, 247, 249, 251
transferring files 22
transposing data 38
transposing statistics 41

troubleshooting 252, 253, 254, 254, 255, 255
Tukey HSD test 60, 60, 260
two way ANOVA 42

entering data 45, 46
interpreting results 51
reference 260
running a test 51

two way repeated measures ANOVA 42
entering data 53, 53
interpreting results 58
reference 260
running a test 57

ungrouping objects 139
uninstalling 15
unmask() function 68, 77
unmasking data 68
unpaired t-test 42

entering data 45, 46, 46
interpreting results 48
running a test 48

updating plotted data 123
Use Locale Aware Sorting option 38
using formula scripts 100
using letters as markers 120
using library 170
using plot scripts 197
using Template plots 99
using the Align tool 139
using the Arc tool 145
using the Bezier curve tool 145
using the Box tool 144
using the Data Selection tool 135, 135, 136
using the Identify tool 134
using the Line tool 143, 143
using the Macro Calculator 225
using the Oval tool 144
using the Polygon tool 144
using the Rounded Rectangle tool 144
using the Special format 34
using the toolbar 241
using the Zoom Selection tool 136
value labels 140

adding 126, 125, 128
editing 140

var() function 75
Variable Offset field 126
Variable Selection Dialog 95
variables 117

defining in library 219
modifying fill patterns 118, 118
modifying lines 118
modifying markers 118, 117
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selecting in the Variable Settings Dialog 117
variables in Formula Entry 73
variance equation 259
vector images 186
viewing column statistics 41
viewing curve fit coefficients 173
viewing curve fit results 173, 173
waveform definitions 166
Weight Data check box 156
Weighted curve fit 151, 154, 260
weighting data 171
wgt() function 76
whiskers 259
width 118

axis break 109
curve fit lines 178
data columns 28
drop lines 119
variable lines 118

Wilcoxon matched pairs test 42
entering data 53, 53
interpreting results 56

reference 260
running a test 56

Wilcoxon signed rank test 42
entering data 43
interpreting results 45
reference 260
running a test 44

Wilcoxon-Mann-Whitney test 42
entering data 45, 46, 46
interpreting results 49
reference 260
running a test 49

Windows BMP files 186, 187, 193
Windows Metafile images 186
X-Y Probability plot 84
yield growth/density definitions 167
Zoom Selection tool 136
zoom setting 20, 103, 195
zooming in on portion of plot 136
zooming in or out of layout window 195
zooming in or out of plot window 103
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